• Not Answered

Stellaris EK-LM4F120XL Launchpad: No ICDI device with USB VID:PID 1cbe:00fd found

I have purchased two identical Stellaris Lauchpad boards with LX4F120H5QR processors, and received them in December 2012. One works without problems, with CCS 5.3 as well as using Energia. The other, on the same computer, I can program in CCS, but can't, however, upload code using Energia, receiving error "No ICDI device with USB VID:PID 1cbe:00fd found!". Checking the Windows' Device Manager, I found that under Properties of the "Stellaris ICDI DFU Device" as well as of the "Stellaris ICDI JTAG/SWD Interface" for the "bad" board there's no event for stellaris_icdi_debug.inf device installation, contrary to the "good" board. Does this mean that the firmware on two boards are different, and the "bad" board doesn't have ICDI programmed in? How could I fix this? Any help and advice is very much appreciated. Thank you

Mac Ha

 

(I have uploaded the text file with the Events from Device Manager, but not sure if they're there...)

4 Replies

  • Hi,

    This can be due to Windows device manager which remembers the first internal ID and does not recognize a second one. Try to use both at the same time: start with the first one, download something and start debugging with CCS. Then insert the second one in another USB socket and try it with Energia - if in this case it is recognized, Windows will ask you to install the device drivers for this second one. Mark the sockets and boards and then use them only with the qualified USB socket.

    Petrei

  • In reply to Petrei:

    Mac Ha,

    After implementing the advice from Petrei, and you are able to determine it is not an issue within Windows Device Manager, then it could be isolated to the board.  Is the power LED coming on? 

    From the description that you have provided, it sounds as if the ICDI firmware is not programmed into the LM4F120 that is acting as the Stellaris ICDI JTAG/SWD interface.  If this end up being the issue, then you will need to return the board to the distributor that you ordered it from.

    Lela

     

  • In reply to Lela Garofolo:

    Hi

    Petrei was right, this is indeed the Windows Device problem! Although the trick of plugging both boards at once didn't work - I've tried even uninstall and reinstall the drivers, but any time Windows said that the drivers are already up to date. However, when I connect the "bad" board into another PC, which never had any Launchpad board connected to, Energia was able to program it without problems! So at least it's not a "bad" board after all. Will try to "hack" Windows to make it work on the other PC now. Thank you for help.

    Mac Ha

  • In reply to Mac Ha Nguyen:

    Hi Mac Ha,

    I had this same issue but uninstalling the drivers and reinstalling them seems to have worked for me. I have 64 bit win7. You may want to try it again.

    Scott