DRV8873-Q1: Overcurrent Detection Function about DRV8873-Q1 Evaluation Board

Part Number: DRV8873-Q1

Dear Expert,


Thank you for your special support everyday.
My customer is considering this product.
I received the following question from the customer.

<Status>
During EVM evaluation,
When changing [Wake] of GUI screen to Disable → Enable,
The motor behaved wrong and the driver was damaged.
Since it is not time when [MotorControls] was set to START,
we also suspect a malfunction of the tool.

<Question>
-Is there timing and conditions for overcurrent detection function not to operate?

-Is there a similar report so far?

Best Regars,
Fukazawa

2 Replies

  • Hi Fukazawa-san,

    Can you provide additional information?

    1) What was this a DRV8873S-Q1EVM or DRV8873H-Q1EVM?
    2) Can you provide a picture of the EVM
    3) What were the GUI settings prior to Disable → Enable?
    4) What is the VM voltage
    5) How did the motor behave wrong?
    6) How was motor configured to operate?
    a) Was the motor connected across both outputs or one output to either VM or GND?

    We had one report of a damaged EVM, but the customer was not able to replicate the scenario.

    Rick Duncan
    Motor Applications Team

  • In reply to Rick Duncan:

    Hi Rick-san,

    I am covering for Fukazawa. He is my colleague.

    1) What was this a DRV8873S-Q1EVM or DRV8873H-Q1EVM?
    They use the DRV8873H-Q1EVM

    2) Can you provide a picture of the EVM
    I asked the customer to take a picture of the EVM

    3) What were the GUI settings prior to Disable → Enable?
    I will explain it as below.

    4) What is the VM voltage
    24V

    5) How did the motor behave wrong?
    The motor do not rotate, but slightly vibration.

    6) How was motor configured to operate?
    One BrushedDC motor is connected between OUT1 and OUT2.
    The specification of the motor : R = 1.58ohm , L=3mH

    I explain the situation of the customer.
    ---------------------------------------------------------------------------------------------------
    At first, they configure the DRV8873H by GUI.
    Operation mode : PWM → PH/EN
    Wake : Disable → Enable
    ITRIP : Enable → Disable ( They do not use the ITRIP function!)
    IN1 Duty Cycle : 0% → 100%
    Slew Rate : 53.2 → 2.6V/us
    Motor Controls : Forward → Reverse

    The customer start the motor
    Motor Control : Stop → Start
    (Perhaps, they change the Output State, too : Disable → Enable)
    Then the motor rotate normally.

    Next, they stop the motor.
    Motor Control : Start → Stop
    Wake : Enable → Disable

    10 seconds past, they start the motor again.
    Wake : Disable → Enable
    (They change only Wake button. They do not change the Motor Control)
    Then the motor do not rotate, but slightly vibration.

    They repeated to change the Wake button : Disable → Enable → Disable → ...... several time.
    Then the DRV8873H burn out. It occur at OUT2 ( 14, 15 pin)
    --------------------------------------------------------------------------------------------------------

    If I get a picture of the EVM, I will let you know.

    Best Regards,
    Naoki Aoyama