This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

OMAP 3630 Android 4.0.1 Harware drivers

Hi,

Please let me know when the hardware drivers will be updated for OMAP 3630 devices to make it working with Android 4.0.1(Ice Cream Sandwich)

  • +1,  

    TI Team, Please update us on this. Thanks.

  • In reply to Seenu SS:

    This is currently being worked on. There is a rebase of the code to the latest kernel needed before the patches can be made public. This is ongoing. Will come back as soon as confirm the target date on this.

  • In reply to Prem Vadapalli:

    Thanks a lot, Mr.Premkumar.

    Eagerly waiting for the drivers :)

  • In reply to Seenu SS:

    You can find the Kernel 3.0 drivers for OMAP3630 at the below location:

    K3.0 branch:

    http://git.omapzoom.org/?p=kernel/omap.git;a=shortlog;h=refs/heads/p-android-omap3-3.0

    This has all the necessary drivers to ensure kernel and UI bringup. There is work ongoing wot validate all MM functionality and more updates will continue to be done on this git. So please monitor the changes on this over the next few weeks.

     

  • In reply to Prem Vadapalli:

    Many Many Thanks for the update sir.

    Will be closely watching for this space for MM functional addition too. Thanks again.

  • In reply to Seenu SS:

    Any news sir for kernel 3.0? Thanks for updating this.. I

  • In reply to dayle sacopanio:

    You may have missed my earlier post with the pointer to the OMAP3 K3.0 drivers. Please check that and let me know if you have any specific queries.

  • In reply to Prem Vadapalli:

    I realize my understanding of this subject is sketchy, at best, but if you'll bear with me...

    I've been working with some developers on a device that currently is limited to the 2.6.32.9 kernel. I know you can't help us get around that specific issue, but we've managed to get Android 4.0.4 running quite well on the device, unfortunately, I believe do to issues related to the kernel and the drivers we can't properly get Renderscript working.

    I believe (perhaps incorrectly), that if we could get SGX binaries compiled binaries to support the 4.0.4 source, but for the 2.6 kernel, we might be able to get things up and running - or maybe we need the libraries to be update to support as such?

    Like I said, my understanding is sketchy, but I figured this would be the best place to ask. If you can figure out what I'm asking, and provide an answer, that would be awesome, thanks!

  • In reply to Malcalevak:

    We need to run 4.0.4 in our device! Many weeks has been passed.. Please make it faster

    Thank you so much

  • In reply to dayle sacopanio:

    Dayle,

    Please clarify your request. The device drivers are available at the link posted above on this thread.

    Prem

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.