This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

UCC28950: Problem with Synchronous Rectifier

Intellectual 865 points

Replies: 17

Views: 474

Part Number: UCC28950

Hello

We are developing DC-DC PSU with input voltage range 600-800VDC and output voltage 60VDC@10А using UCC28950. With asinchronous rectifier system works without problems, but power dissipation is too high.

With sinchronous rectifier we got a problem: when SR starting to work we gets a huge noise on all nets - on output, on control nets and even UCC28950 power input. As result, it kills controller. What can cause it?

Oscillograms with enabled SR:

  1. SR transistors gates with SR enabled before stabilization started

2, 3. Output with asynchronous rectifier without load

4, 5. Output with asynchronous rectifier loaded with 1A

6, 7. Output with SR enabled after stabilization started (load 1A)

With input voltage increasing noise level significantly increasing.
If necessary, we can send project files to the email.

Pic1

Pic2

Pic3

Pic4

Pic5

Pic6

Pic7

Regards,

Roman

  • Hi Roman Zavyalov,
    Please could you send your schematic to my Email address j-leisten@ti.com.
    I am not an expert on this part, but I work with a man who is, and can ask for his help.
    Thanks
    Joe Leisten
  • In reply to Joe Leisten:

    Hello, Joe
    Done. Check your email.

    Regards,

    Roman

  • In reply to Roman Zavyalov:

    any ideas?

    Regards,

    Roman

  • In reply to Roman Zavyalov:

    Hello Roman

    I was out of the office for a week and this is the reason for the delay in getting back to you.

    I'm fairly sure that the problem is that you have swapped the SR drives so that the OUTE and OUTF signals are being delivered to the wrong SR. This will put a short circuit on the transformer and cause destructive high currents.You have been using OUTF to drive VT6 but you should be using OUTE to drive this SR. OUTE should be used to drive VT7. You should be able to check this easily by 'tombstoning' R62 and R63 and wiring the signals to the correct transistors. I marked up part of the Typical Application Diagram to show what I mean.

    Please let me know if this solves the problem.

    regards
    Colin

  • In reply to Colin Gillmor:

    Hello Roman
    There is a typo above, I should have said 'OUTF should be used to drive VT7'

    Regards
    Colin
  • In reply to Colin Gillmor:

    Thanks for your advise. We has swapped pins Out E and Out F, after that output voltage has dropped to zero. After that we additionally swapped primary winding's pins and PSU has started to work. Output voltage noise has significally reduced, but after SR starts to work, VD23-VD26 (1.5KE300CA) has started to heat. If we manually stops SR, they are stops to heat. Also, noise in UCC28950 power cicuit has kept and it tied with input voltage (increasing when input voltage increasing). Any ideas about it?

    Regards,

    Roman

  • In reply to Roman Zavyalov:

    Hello Roman

    I double checked your schematic and my marked up schematic above and my markup is correct. Please change your circuit accordingly.

    Please send me your PCB layout files (Gerber or native files) and I'll review them - you can send them to me at colingillmor@ti.com

    In the meanwhile, I suggest that you go back to diode rectification and we can diagnose and correct whatever is causing this misbehaviour.

    Remove R62 and R63 - this will disable the MOSFET gates and they will behave as diodes.

    Send me a plot showing Pin7 of U3, Pin 5 of U3, Pin 7 of U1 and Pin5 of U1. Please show 5 or 6 cycles across the horizontal axis. This will allow me to be sure that we are delivering the correct signals to the switches.

    I'd also like to see a plot of the OUTA, OUTB, OUTC and OUTD signals at the UCC28950 controller. Please look for dropouts or other defects in these waveforms and send me a plot of whatever you see. The switching pattern from the UCC28950 can be upset by external noise sources, for example an OUTx line running under the IC body will cause problems.

    If you can, it would be useful to see the voltage across the primary of the transformer and at the drains of the SRs. A plot showing VT1 drain, VT3 Drain, VT6 drain and VT7 drain would do this nicely.

    Finally, please try to source some UCC28951 devices. These are a 100% compatible drop-in replacement for the UCC28950 but they work better at high duty cycles. This may or may not be the solution to this particular problem but I'd like you to be in a position to try the newer device if our early checks do not fix the problem.

    Regards

    Colin

  • In reply to Colin Gillmor:

    Hello, Colin

    1. Email with PCB have sent.
    2. UCC28951 have ordered.
    3. Currently we are prepare picture of waveforms.

    Regards,

    Roman

  • In reply to Roman Zavyalov:

    1- OUTA, 2 - OUTB, 3 - OUTC, 4 - OUTD

    1- OUTA, 2 - OUTB, 3 - OUTC, 4 - OUTD

    1- OUTE, 2 - OUTF

    1- OUTE, 2 - OUTF

    Regards,

    Roman

  • In reply to Roman Zavyalov:

    Hello Roman

    Thanks for the added information.

    Plot 1, OUTA,OUTB,OUTC,OUTD looks good, the controller is running at Dmax because Vout is below its setpoint but other than that it is fine.

    Plot2, is labelled the same as Plot 1. I suspect these may be the waveforms at the output of the drivers U3 and U1. If this is the case, then they look ok too – with the same comment about running at Dmax.

    Plot 3 and 4 are labelled OUTE and OUTF. I’m very puzzled by this for two reasons –

    First, OUTE and OUTF should be different and second they should be in antiphase

    I don’t know at which points you took the OUTE and OUTF plots but they are definitely incorrect. I’d suggest you start at the OUTE and OUTF terminals of the UCC28950 and follow the signals along to the SRs.

     

    Here is a plot from a simulation I ran just now – it’s at 100kHz and close to Dmax – so it should give you a good general ideal of what you should be seeing.

    Here is a slide showing more or less the waveforms above but at a lower duty cycle.

    /cfs-file/__key/communityserver-discussions-components-files/196/3823.Waveforms.pptx

    Please check the OUTE/OUTF signals and let me know how you get on.

    Regards

    Colin

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.