This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TPS63070: Power management forum

Prodigy 20 points

Replies: 3

Views: 72

Part Number: TPS63070

Hi!

It is my first time on forum. In new board I used the TPS630701 like the datasheet say to use. I isoled the output. I´m using FDSD0630-H-1R0M=P3 with 1uH inductor from Murata, but it dont initialize. I did a double face PCB. I attached the sch and pcb . I will use 12V for input operation.
For now i´m using a lab source power with 3V and current limited to 100mA. When I turn on the power source I have 10V on output for 3 seconds and the output go to 0V.
I negligentiated the PCB? Ground is insufficient? Capacitors are right?
Someone can help me?

PS.: Sorry for my poor english

Thanks

Fernando Maesso

  • Hi Fernando,

    The schematic looks fine, but the PCB layout should be improved. GND connections in particular, only one via connecting the PGND pin to the bottom layer is not enough. Please check the recommended layout in the datasheet. I recommend connecting the inductor using vias to clear the way for the GND lines on the top layer, as shown in Figure 51 of the datasheet.

    Also, the minimum starting input voltage for the TPS63070 is 3 V. The inrush current during startup is usually above 100 mA. If you turn on current limiting on our power supply, the inrush current will trigger the protection, the power supply will reduce the voltage and the TPS63070 will shut down. Then the power supply voltage will go back to 3 V, the TPS63070 will try to turn on again, an so on, the circuit will oscillate or fail to start.

    For the start, try turning on the TPS63070 with higher input voltage and higher current limit. But for reliable operation, the GND routing needs to be improved.

    Best regards,
    Milos

    ti.com/buckboost

  • Hi Fernando,

    We haven’t heard back so we're assuming this resolves your issue. If not, just post a reply below, or create a new thread if the thread has locked due to time-out.

    Thanks and regards,
    Milos

    ti.com/buckboost

  • In reply to Milos:

    Hi Milos.

      Thank you very much. Another board worked but  I will improve my PCB. 

    Fernando Maesso

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.