This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

BQ78350-R1: The fuel gauge is obviously inaccurate during inductive load?(BQ78350-R1 + bq76930)

Part Number: BQ78350-R1

Dear team,

The BQ78350-R1 + bq76930 manages 9 polymer lithium batteries, and the 9-cell lithium batteries are connected in series. The reference design is basically the bq76930 and bq76940 Evaluation Module, which supplies the servo motor. The drive voltage on the motor side is 24V.

If the load is used (stable absorption of 3A current) for testing, the charge and discharge are very accurate. Now the problem is that when I change the load to servo motor (the starting current of the motor is about 15A and the average current is about 2A), the data in BQ78350-R1 is wrong. For example, there is 60%of the power before the test, but there is still 60% of the power after test. When the customer used BqStudio (TI website download) software + EV2400 interface board to observe BQ78350-R1, found that the power does not change. The charging current sometimes appear, sometimes not, and the average current is only 10~20mA. But after restarting, the battery power is changed from 60% to 40%, which means that the battery is still consumed, but the BQ78350-R1 thinks that the power has not changed.

The following figure is the load end waveform, channel 2 is the motor current diagram, the highest value is about 12A, the kickback is -6A; the channel 1 is the voltage waveform;

Could you please help answer this question?

Thank you very much!

Best Regards,

Sherry

  • Hi Sherry,

    Have you followed the steps to set up the gauging parameters for the BQ78350-R1 (Select the correct ChemID, optimize the CEDV parameters for your battery, modify other critical parametres based on your application)? There is a new app note to help guide these steps here: www.ti.com/.../slua924

    If you have already followed these steps (which are critical for accurate gauging), and you are still seeing this issue, please send me your .gg file and a bqStudio log of the behavior. The .gg file is exported from the Data Memory screen of bqStudio and contains all of your data flash settings. The log file can be collected in bqStudio from the Registers screen.

    Best regards,
    Matt

     

  • In reply to Matt Sunna:

    Hi Matt,

    I'm very glad to receive your reply so quickly!

    I will check it, thank you very much!

    Best Regards,

    Sherry

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.