• TI Thinks Resolved

BQ40Z50-R1: am testing single battery testing of li-ione, when am started for learning cycleprocess am getting the charging issue,it does not charging,current is not limited. please give me the proper settings of voltages and current.am attached a advance

Intellectual 365 points

Replies: 17

Views: 260

Part Number: BQ40Z50-R1

  • Vish

       From your next post, I see you already know to use FET control command to turn on the FET for charging. I think this is probably the reason why you do not see charge current here.

      Please also be noted that your Set Threshold for FD is way to high, please set this low to below or equal to 3000mV, this is the typical setting for this parameter

  • In reply to Steven Yao:

    Thanks for the reply.i will check it.

  • In reply to Divya UK:

    I was checking but its not working,please send a proper settings for charging and discharging.i was attached a gg files for your reference.

  • In reply to vishwaradhya G:

    Hi Vish

        The latest version for bq40z50 is R3.08, I get charging and discharging enabled base on default setting for V3.08. Please give me your email so that I can send the srec and gg file to you. But you still need to configure other parameters per your customer requirement and battery specs, the battery modeling parameters should also be configured appropriately by selecting proper chemical ID and doing the learning cycle.please refer the bq40z50TRM for further detailed steps

  • In reply to Steven Yao:

    Thanks for your reply steven, here is my email id. for my testing purpose i using only single cell icr18650-26f, after successful learning cycle of this single cell,later am testing 2s-2p configaration cell.

    part number=bq40z50-r1

    email id=vishwa.aradhya@cedlabs.in

  • In reply to vishwaradhya G:

    what is pre-charging in this section,i should use pchg-fet in gauging,it is necessary, i am bit confusing with charging fet  and pre charging fet section during settings.

  • In reply to vishwaradhya G:

    The gauge enters PRECHARGE mode if,
    1. Min cell voltage1..4 < Precharge Start Voltage OR
    2. Max cell voltage1..4 < Charging Voltage Low – Charging Voltage Hysteresis and not in CHARGE
    mode
    Depending on the FET Options[PCHG_COMM] settings, the external precharge FET or CHG FET can be
    used in PRECHARGE mode. Setting Precharge Start Voltage and Charging Voltage Low = 0 mV
    disables the precharge function.


    [PCHG_COMM] = 0                          [PCHG_COMM] = 1
    FET USED: external                         precharge FET FET USED: CHG FET


    The bq40z50-R2 device also supports 0-V charging using either an external precharge FET or CHG FET.
    If [PCHG_COMM] = 1, the gauge enables the hardware 0-V charging circuit automatically when the
    battery stack voltage is below the minimum operation voltage of the device (see the bq40z50-R2 1-Series
    to 4-Series Li-Ion Battery Pack Manager data sheet [SLUSCS4] for bq40z50-R2 electrical specifications).

  • In reply to Steven Yao:

    hello steven

    what u given srec file i uploded to bqstudio,it is started charging,am started the learnig cycle,the first step of discharging takes 1 hour and reset bit and rdis bits are set and again i started the next step of learning cycle means charging of cells to full it taking 4-5 hours for charging i think this process is reversed,as i read TRM charging takes 2 hours and discharging takes 5 hours.what i gone wrong please suggest me.

    REGARDS

    Vishwa

  • In reply to vishwaradhya G:

    ra tables uptading in charging mode,it is updated in discharge mode am i right?

  • In reply to vishwaradhya G:

    Is thier any options for setting capacity ratings for charging and discharging in bqstudio.