• Resolved

BQ34Z100: Search new chem ID

Intellectual 405 points

Replies: 9

Views: 141

Part Number: BQ34Z100

Good afternoon!

In the new bqStudio program, my chip is not displayed. It says "Auto Detected Device: 0100_0_06". This is not on the list. What to do? Can I use the old version of the program (0.9.90) to get graphs?

thank

  • Hello Sergey,

    The short answer is yes. I will notify the tools team to make sure it is included in our next bqStudio release.

    The preference is for you to use the latest firmware which can be found on the bq34z100-G1 device page.

  • In reply to Kang Kang:

    Good afternoon!

    If I understand correctly, do you suggest taking the firmware from the new bq34z100-G1 and using it to get a gold file? If I use the old version of bqStudio will I have problems?
    One more question:
    1. If I take the firmware from bq34z100-G1 and train bq34z100-G1 can I then use the result for bq34z100? The question is that we have a batch of boards with bq34z100 and they must be used.
    2. If I use for boards where the bq34z100 is now installed, does the bq34z100-G1 chip need to be redone or is it fully compatible?

    thank

  • In reply to Sergey Popov2:

    Hi Sergey

    Ps update the firmware version on your 0100_0_06 firmware version to the latest. Then you will be able to use bqstudio. Do not use the old firmware for any reason. Link to the newest firwmare below.

    Every thing you do should be around this firmware ..learning cycle, golden file extraction etc

    thanks

    Onyx

  • In reply to Onyx Ahiakwo:

    Good afternoon!

    Thanks so much for the clarification! My last question is: can I program a new file using the old or new version of bqStudio?

    thank

  • In reply to Onyx Ahiakwo:

    Good afternoon!

    I got the correct chemID. Do I understand the next steps correctly?

    1. you need to program the * .srec file
    2. you must select and program the correct chemID
    3. After that, you can save the adjusted * .srec file
     
    After that, conduct training according to the following methodology:

    1. Send an IT Enable (21) command to turn ON FETs. Send a Reset command (41) to disable Ra-table updates.

    2. Discharge to empty

    3. Wait 5 hours

    4. Send IT Enable command to set a DOD0 reference point.

    5. Charge to full

    6. Wait 2 hours Qmax will be learned at this step. You should see VOK turn green after Qmax has learned. You should see Update Status change to a 05.

    7. Discharge at typical low rate of target application (usually C/5 for notebooks) down to Term Voltage. Using low rate will allow to update resistance points at deep states of discharge. Rate of discharge must be higher than C/10 rate, otherwise resistance will not update.

    8. Wait 5 hours for relaxation. You should see Update Status change to a 06 during the rest period.

    9. Repeat steps 5-8 while running EV Software log to verify accuracy.

    After training, we get a file that can be programmed into other microcircuits.
    We carry out calibration.

    Is calibration done before or after training?

    thank

  • In reply to Sergey Popov2:

    Hi Sergey

    your steps seems right for the most part. Calibration is done on the unit you are trying to perform learning on, before doing the learning cycle.

    After you get the golden file and you program on multiple units, you have to calibrate those units to ensure measurement accuracy of V, I, T.

    If you do not want to calibrate each unit, then you need to calibrate 20 units, take the average calibration parameters and then program it on a unit with the golden image and then extract a new golden image which will be used for mass production without calibrating each unit

    thanks

    Onyx

  • In reply to Onyx Ahiakwo:

    Good day!

    We tried to conduct training, but we did not succeed. We have completely discharged the battery. After that, she rested. Next, we went according to the method described above. When the charge starts, the status has changed to 0x04, but the “VOK” bit has not been set (“0” remains). Why? We decided to wait and finish the cycle. But the status remained 0x0VIP1513_BMS_Log.log4.
    What's wrong? What are the installation conditions for the bit "VOK". I remind you: we are using the old bq34z100, but we have flashed it from the new bq34z100-q1.

    thanks

  • In reply to Sergey Popov2:

    Can you attach thee gpc chem report you ran and also attach your log of the learning and gg files

    thanks

    Onyx

  • In reply to Onyx Ahiakwo:

    Good day!

    File for receiving chemID:

    7853.1513-2p.zip

    File received in response:

    8475.1513-2p-report.zip

    We chose chemID - 0201.

    The file prepared for training:

    0100_0_16-bq34z100G1_S.zip

    Unfortunately, there is currently no data obtained after the training cycles. We reprogrammed the chip while experimenting. But we re-set for training.


    thanks