• Resolved

Trouble with EV2300 Driver

Hello,

we are succesfully using the EV2300 to check and set up Battery packs (with a BQ2080/85) for years. Now we have trouble with the USB driver of the EV2300 (perhaps since the last windows security update, but not sure). Reinstallation of the driver fails. I already tried some newer downloads, also the Vista driver for the EV2300. But without succes. We tried this on several PCs under windows 2000 and XP without any succes.

Does anybody know this problem? Is there a fix for this problem available?

Greetings,

Birger Neumann

  • The Problem still exist. Now I found and older installation of XP on a different PC where the driver can be installed and works.

    Does anyone know the reason for the Problem or a fix? I already asked the TI Support but I didn't get a reaction by now.

    Regards,

    Birger Neuman

  • What is the error message when the reinstallation failed? 

    Any error message while loading the EVSW?

  • In reply to Jackie Hui:

    The installation of the Driver with your installer gives no error message, but says 'installation complete'

    If I plug the EV2300 in, it is just a yellow question mark with an yellow exclamation mark (in the windows device manager). Status is 'driver not installed  (code 28)' As I got a german version of windows XP I don't know exactly what the error message would be in english.

    When I try to reinstall the driver with the windows device manager I always get the Error Message 'Harwareinstallation nicht möglich' which means installation impossible. Reason: Software not found.

    I can't get any further than this. What is wrong?

  • In reply to Birger Neumann:

    Birger,

     

    After checking with our tools team, the solution is to reinstall Windows.

    Our tools team had seen this problem in some machine before. Something was corrupted in Windows and in all cases, reinstall the OS fix the problem.

  • In reply to Jackie Hui:

    Hi Birger,


    I have the same problem. Since a couple of times the EV2300 is not longer recognised.

    Before it worked well but now he does not find the driver any longer. It must be something to do with the recognition of the USB-Device.

    I get only "USB Device detected". No name is displayed. So Windows can not associate the driver with the device.

    I tried to erase the Enum-keys in the registry:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\Vid_0451&Pid_2136]
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\Vid_0451&Pid_2136]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_0451&Pid_2136]

    but it did'nt work.


    Did you find a work-around without re-installing Windows?


    The EV2300 works fine on another computer.
    Thanks,

    Matthias

  • Genius 10795 points

    In reply to Matthias Kunze:

    My EV2300 stopped being recognized at one point and I got it to work again just by uninstalling EVSW and reinstalling it.  I'm not sure what that did with the driver or if it was related to the driver but it worked for me.  Try the "Uninstall bq Evaluation Software" in the program folder.

  • In reply to dMax:

    I tried this, but it doesn’t work for me. The EV2300 is recognized as a "USB Device".

    Then the driver installation does not associate the driver with the device:

     

     

    I installed the driver package before....

    Mat

  • In reply to Matthias Kunze:

    Well,

    I solved the problem in quite an easy way: I moved the whole project to somebody with a pc on which it worked fine.

    But I guess that isn't a real solution for everybody. ;-)

    Regards,

    Birger