This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

UCC28251: Switching frequency problem

Part Number: UCC28251

Hello!

I have a problem with switching frequency after power-on. In my circuit Rt = 75KOhm (Fsw = 100KHz), Csoftstart = 100nF.

When I "power-on -> power-off -> power-on immediately" -> Fsw = 50kHz.

When I "power-on -> power-off -> wait  for 15s -> power-on" -> Fsw = 100kHz.

When I "power-on -> power-off -> discharge Csoftstart  immediately -> power-on immediately" ->  Fsw = 100kHz.

What happens with Fsw after fast power cycling?

Thanks.

23 Replies

  • Hi Sergei,

    You can have a look at the page 7 of the datasheet. I think maybe you forget to set the Rsp in your circuit.

    Best regards,

    Wenbin

  • In reply to David Huang33:

    Both SP and PS are connected to VREF.
  • In reply to David Huang33:

    In my circuit EN pin is connected to VREF. I have noticed that when I power cycle the circuit the Csoftstart does not discharge. And when UCC28251 in started while Csoftstart is still charged the Fsw is wrong (50KHz instead of 100Khz). How does Csoftstart influence Fsw?
  • In reply to Sergei Ivanov:

    Hi Sergei,

    SP connect to the VREF mean there is no dead time between the SR mos and the Primary mos.

    I suggest you try add the Rsp.
    according to your question "How does Csoftstart influence Fsw?", I will ask our IC designer. Once I have the answer, I will reply to you.

    Best regards,
    Wenbin,
  • In reply to David Huang33:

    Hello!
    Is there any information about Csoftstart and Fsw?
  • In reply to Sergei Ivanov:

    Sorry, I still get the feedback.
  • In reply to David Huang33:

    sorry, I still do not get the feedback.
  • In reply to David Huang33:

    Hello!
    How soon your IC designer can answer?
    Our development can't wait. We are thinking to reject UCC28251 because of undefined behavior.
  • In reply to Sergei Ivanov:

    Hello!
    I have also determined that Csoftstart is not discharged after powering off the IC although on page 24 it is said that SS pin is pulled to ground when UVLO condition happens.
  • In reply to Sergei Ivanov:

    Hello Sergei,
    can you help scan the waveform for me? including the uvlo process and the ss cap do not discharge with the 50Khz frequency.
    since it is not a new IC, I do not have the evm to do the test.so we have to present as much a possible to our IC designer , or they will unable to find the cause. many thanks.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.