This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

RTOS/66AK2H06: Rebuild SBL

Guru 13540 points

Part Number: 66AK2H06

Tool/software: TI-RTOS

Hi,

I'm using Processor SDK RTOS of K2H and trying to rebuild sbl.
But the following error occur and can't rebuild it.
********************************************************************************
C:\ti\PDK_K2~1\packages\ti\boot\sbl>gmake all BOOTMODE=spi BOARD=evmK2H SOC=K2H
gmake[1]: Entering directory `C:/ti/PDK_K2~1/packages/ti/boot/sbl'
compiling /ti/PDK_K2~1/packages/ti/boot/sbl/board/evmk2h/sbl_main.c ...
Assembler messages:
Fatal error: can't create /ti/PDK_K2~1/packages/ti/boot/sbl/binary/evmk2h/spi/ob
j/sbl_main.o: No such file or directory
gmake[1]: *** [/ti/PDK_K2~1/packages/ti/boot/sbl/binary/evmk2h/spi/obj/sbl_main.
o] Error 1
gmake[1]: Leaving directory `C:/ti/PDK_K2~1/packages/ti/boot/sbl'
gmake: *** [all] Error 2
********************************************************************************

Before rebuilding the sbl, I executed the following steps:
1. Execute setupenv.bat (included in C:\ti\processor_sdk_rtos_k2hk_4_02_00_09)
2. Execute pdksetupenv.bat (included in C:\ti\pdk_k2hk_4_0_8\packages)

Are there any missing steps?

best regards,
g.f.

  • Guru 13540 points

    In reply to Rahul Prabhu:

    Hi Rahul,

    Thank you for the reply.

    I upgraded the SDK version to newest v4_03_00_05 now.
    And I tested rebuilding SBL as steps you attached.
    But the error occur that arm-none-eabi-gcc are not found, please take alook at attached log file.

    I checked the .exe file in "pdk_k2hk_4_0_9\packages\ti\boot\sbl\tools\multicoreImageGen\bin"
    there was the file.

    By the way, I want to test ARM single core boot on EVMK2H.
    Is following steps correct for single core boot?
    1. Generate GPIO_LED sample of SDK by using CCSv7.4 -> .out have been generated
    2. convert the above .out by out2rprc.exe as written in TI wiki
       processors.wiki.ti.com/.../L
      
       place .out file under C:\ti\pdk_k2hk_4_0_9\packages\ti\boot\sbl\tools\out2rprc\bin
       then execute .exe as follow:
       C:\ti\pdk_k2hk_4_0_9\packages\ti\boot\sbl\tools\out2rprc\bin>out2rprc <name>.out app

    3. place above app and MLO(prebuild in pdk) under C:\ti\pdk_k2hk_4_0_9\packages\ti\boot\sbl\tools\flashWriter\spi\bin\evmK2H
       (no modify against "config" file)

    4. execute spi_flashwriter.out from CCS

    5. After step4 are completed successfully, power-down the EVM and change boot dip sw setting
       from no-boot to SPI boot.

    When powering on the EVM after step5, following message have been displayed to terminal,
    and it seems that the execution are stopping at SBL.
    ///////////////////////////////////////////////////
    **** PDK SBL ****
    SBL Revision: 01.00.09.00 (May 16 2018 - 16:53:57)
    Begin parsing user application
    Invalid magic number in Single image header
    Jumping to user application...
    ///////////////////////////////////////////////////

    best regards,
    g.f.

    build_sbl_log.txt

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.