• Resolved

Linux/AM4379: CUSTOM BOARD BOOT-UP

Expert 1085 points

Replies: 6

Views: 217

Part Number: AM4379

Tool/software: Linux

Hi All,

We have custom board with AM4379.

I succeed to boot up our board with following steps 

- Set SYS_BOOT pin for SD Card boot
- Plug Bootable SD Card to board
- Power up board
- Launch selected configuration (@UBUNTU-Host PC w/CCS)
- Connect Target CORTEX-A9 
- Load GEL File idk_am437x.gel (modified gel file . SK_IDK_EVM_DDR3_SDRAM_CONFIG value changed)
- Run initialization Script IDK_EVM
- CPU Reset ---> PC=0 
- Tools > Load Memory > u-boot.bin (@0x80800000 w/32bit)
- set PC to 0x80800000
- Resume

But, when i follow the https://training.ti.com/linux-board-porting-series-module-7-debugging-u-boot-jtag-ccs?cu=399066

- Set SYS_BOOT pin for SD Card boot
- Plug Bootable SD Card to board
- Power up board
-  Launch selected config
- Connect A9
-  Load GEL File idk_am437x.gel (modified gel file . SK_IDK_EVM_DDR3_SDRAM_CONFIG value changed)
-  Run initialization Script IDK_EVM
-  CPU Reset ---> PC=0
- Check CPSR - T value. Not thumb mode ! 
- Load Memory > u-boot-spl.bin > 0x402f4000. 
- Run > Load > Load Symbols > u-boot-spl 
- Set PC 0X402F4000
- Resume

@SerialOutputTerminal
U-Boot SPL 2018.01-00569-gf9c38b91a2-dirty (May 14 2019 - 11:47:55)
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

- Run > Load > Load Program > > u-boot
- Resume

 

After this with steps, board does not boot-up.

Code hang :

"bootstage_error(){Show_boot_stage_progress(-id)}"

What could be the reason for this ?

 

 

Best Regards,

Mehmet