This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

Qt Creator Embedded Debugging Setup not working

following the document Qt Creator Embedded Debugging Setup

After following the steps I get to the section 

Connecting a Linux Device

The Qt is suppose to test the connect, but mine is not successfull and there is no further information if the connection fails.

I get the error:  "SSH connection failure: Connection refused  Device test failed." from QT

I cannot find any help for a SSH connection to my DM8168 evm board.

please someone help

I am using the EZSDK 5_3_01_15

  • Well I guess I missed the fine print at the top of the doc,  DropBear is required,  That's great seeing that the EZSDK doesn't include that, it would be nice if the document goes through how to install that on the evm's file system, to be a consice, efficent, and informative document.

    So how do I get dropbear on my DM8168evm?   anyone?

  • In reply to Jeffrey Dionne:

    Help Help Help Help!

    Some one must know how to help me out there?  wheres the support for your Product TI!

    I think I install Dropbear on the target,  targetfs/bin  well at least thats a director that one web site said to put it.

    but I am still getting the 

    Connecting to host...

    SSH connection failure: Connection refused

    Device test failed.

    when QT creator tries to test the connection.

    I am new to linux, so I am totally lost on what I should do,  not sure why everyone says Linux is so great... it has caused me nothing but frustration and anger.  

    PLEASE IS THERE ANYONE OUT THERE WHO CAN HELP!

  • In reply to Jeffrey Dionne:

    Well since it would seem that I am the only one on the planet that is trying to do this,  I just keep posting info that I find combing the web, in hopes that it might help someone else

    The thing about dropbear is that you have to cross compile it for your target,  this web site was very helpfull,  NOT A TI SITE!

    https://sites.google.com/site/al271828183x/techblog/dropbearhow-tosetupsshserveronembeddedlinuxtargets

    this link seems strange so if you cannot get to it just google the phrase "Dropbear: How-To setup SSH Server on Embedded Linux Targets"

    After following the section near the end for Dropbear,  I actually received a different error message:

    SSH connection failure: Server rejected password.

    Device test failed.

    Which seems contrary to what the original artical I was following:http://processors.wiki.ti.com/index.php/Qt_Creator_Embedded_Debugging_Setup

    which states in the "Connection a linux device" section to leave the password blank!

    I seem slightly closer, back to Google.

  • In reply to Jeffrey Dionne:

    It seems like I am getting a transaction between the server and client but I am getting error message, then the connection fails.

    I start dropbear with -E -s -g

    the server message:

    Child connection from 192.168.1.24:47174
    [1423] Dec 09 15:11:03 Exit before auth (user 'root', 1 fails): Disconnect received

    client message:

    SSH connection failure: Server rejected password.

    If I disabled using a password, and the client doesn't send a password, why do I get a password error?  This is so frustrating, I hope I get this solved soon I need to get some real work done.

  • In reply to Jeffrey Dionne:

    I finally got past the section in the original article step by step I was following. :)

    The problem with the intitial test of the ssh connect was that I had to create a password for the evm root login?

    Not sure if it was dropbear not working even when I gave the arguments -s -g or if QT creator is just a little wierd and really wants a value in the password field for the connection.

    At any rate the original article is incorrect and I am not sure how they got it to work as described.

    FYI to set a password:

    after logging in to the target just type: passwd

    hopefully the rest of the instruction goes smoothly, this section took me 3 days just to get working.

  • In reply to Jeffrey Dionne:

    I got to the end of the Document I have been following and ran debug mode...nothing happened, Qt got stuck in build mode. I had to exit the app

    Happened to notice on the terminal window were I launched QT a error message:

    Unexpected extended data 'sh: /usr/libexec/sftp-server: not found
    ' of type 1 on SFTP channel.
    Remote SFTP service exited with exit code 127

    The document doesn't mention setting up SFTP, what is SFTP and were should it be installed

    Hello TI this is your docuemnt, its  incomplete and to many errors.  Following it doesn't not get me a debug environment its be 5 days trying to get this to work.

    Any one else do this before and know what SFTP is and where it should be installed?   another day Googleing :(

  • In reply to Jeffrey Dionne:

    Hi Jeffrey,

    I will update the wiki page to cover supported platforms so others will be aware. This wiki page has been tested against the am335x, am35x, am37x, and am180x.  It looks like EZSDK for the 816 is missing the sftp-server and maybe more. We utilize an automated build system.  I checked this system to find that the sftp-server is built from the open-ssh package: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-5.6p1.tar.gz

    Then there is an addtional patch : openssh-5.2-sftp-server-nolibcrypto.patch

    which is used to modify the makefile to generate the sftp-server.

    You can find that patch here: 

    git://arago-project.org/git/arago-oe-dev.git

    it is located under the directory: arago-oe-dev/recipes/openssh/openssh-5.6p1

    If this post resolves your issue, please click on the verified answer.

    Regards,

    Jeff L

  • In reply to Jeff L:

    Thanks for the reply.

    But being really new to linux, I don't understand what info your are giving me?

    should I download the ftp file your pointing to?  Then what do I do with it? I am not sure what that is.

    The patch you mentioned is for the ftp file I downloaded?

    Also I am not sure what to do with the git line? If I type that in I just get an error

  • In reply to Jeffrey Dionne:

    Jeffrey,

    I didn't realize you were new to Linux.  I was trying to point you to the necessary steps to install the components you needed.  There may be another alternative for you.

    You can use ethernet to NFS mount your filesystem. So your EVM's filesystem can be located on your Host LInux development machine.  Then you could use QT creator to build your project right inside the filesystem.  The only difference may be that you need to manually start and run the QT binaries once you create them, so that would be one extra step for you. You could start the newly created QT programs using your minicom console and launch them command line.

    There is a setup script (setup.sh) that comes in the root directory of our EZSDK on your host machine. If you run it, It will allow you to automatically create all the files and u-boot parameters needed to NFS boot your filesystem rather than using the SD card.

    If this post resolves your issue, please click on the verified answer.

    Regards,

    Jeff L

  • In reply to Jeff L:

    Hi

    So I downloaded the OpenSSH, but when I try to compile it I get an error that zlib is not installed.

    So I tried downloading that and compiling that, but it doesn't seem to install correctly for embedded linux because I keep getting errors about it when I compile OpenSSH.

    Can someone provide guidance on how to get these app compiled and installed for the DM8168?  I have been searching for days on google and can't find anything that helps me.

    From what I understand OpenSSH needs to be installed on the target to provided SFTP support because that's what QT creator uses to transfer files, is this correct or is there an alternative?  I really need to be able to debug the app I am working on, it increasly hard to debug and app with out break points and other debug windows.  

    Some out out there must have done this before?

    Thanx for the replies.

    FYI   I have been developing for Linux only for a few months, so please be as detailed as possible.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.