• TI Thinks Resolved

OPT8241-CDK-EVM: Using the EEPROM programmer with OPT8241 EVM invalidates the firmware

Part Number: OPT8241-CDK-EVM

Hello,

I just wanted to inform you what happens if you try to update the OPT9221 firmware on the OPT8241 EVM using Windows 10 and the TI EEPROM Programmer.

Software used:

  • Windows 10
  • VoxelViewer 0.9.6
  • Firmware to flash: OPT9221_Fw_0v29

Procedure

  • Connect and power the camera
  • Start VoxelViewer
  • Connects to the camera, streaming works
  • Start EEPROM programmer from file menu
  • Select device and correct firmware (OPT9221_0v29.tie)
  • Click Download
  • Wait for the window to show the 'done' message
  • Power-cycle the camera
  • Result: Chipset led stays off, camera does not stream anymore.
  • Repair: Use a Windows 7 PC, follow the exact same procedure, camera works again.

The behavior is reproducable. So, in short:

Situation: Upgrading the TI kit using a Windows 10 PC will invalidate the firmware. (Note: The device can be recovered!)
Effect: The chipset LED does not light up anymore and you won’t get any readings from the depth camera anymore.
Solution: Connect the kit to a Windows 7 PC and use that one to re-flash the firmware. Devices with invalid firmware can be recovered, as long as they still communicate via USB (which is usually the case, as the FX2 firmware remains untouched).

  • Hi Thilo,

    We will check on Windows 10 PCs - could you confirm if your Windows 7 PC was the same model as the Windows 10 one? If possible, could you let me know the model number of the Windows 10 PC you used? (We suspect the issue might be due to the USB controller rather than the OS version).

    Thanks,
    Anand
  • In reply to Anand Gadiyar:

    Hi Anand,

    here are the details as requested:

    PC where FW upgrade fails PC where FW upgrade works
    Model HP ZBook 15 HP ZBook 15
    OS Windows 10 x64 Windows 7 x64
    OS version 1511 (Build 10586.839) 6.1 (Build 7601)
    CPU Intel Core i7-4800MQ Intel Core i7-4800MQ
    RAM 32 GB 8 GB

    By the way, I also tried it on a Windows 10 desktop PC and got the same error.

    Best regards,

    Thilo