IWR1443BOOST: DCA1000EVM---adc_data_Raw_0.bin size differs

Part Number: IWR1443BOOST

Hello

 

I am currently using IWR1443 with DCA1000evm to collect raw data from Ethernet port. I was trying to control mmwave studio by matlab script which originated from mmwave studio user guide. However, the file ``adc_data_Raw_0.bin`` that I obtained using lua script is different from the same binary file that I obtained through clicking buttons of mmwave studio manually. Here, I upload the snapshot and the lua script.

Fig.1 binary file that I obtained through clicking buttons of mmwave studio

 

Fig.2 binary file that I obtained using lua script

 

It can be seen that the file size in Fig.1 is about 64KB while the size in Fig.2 is 65KB.

Then error info appears if I run packetrecordzerofill.exe to adc_data_Raw_0.bin of Fig.2.

For binary file of Fig.1, packetrecordzerofill.exe works fine.

I would like to know if there is any mistake on my lua script. 

Thank you.

 

 

Lua script

ar1.SOPControl(2)
RSTD.Sleep(20)
ar1.Connect(12,115200,1000)
RSTD.Sleep(20)
ar1.DownloadBSSFw("C:\\ti\\mmwave_studio_01_00_00_00\\rf_eval_firmware\\radarss\\xwr12xx_xwr14xx_radarss_ES2.0.bin")
WriteToLog("BSS FW Download Success\n", "green")
RSTD.Sleep(20)
ar1.DownloadMSSFw("C:\\ti\\mmwave_studio_01_00_00_00\\rf_eval_firmware\\masterss\\xwr12xx_xwr14xx_masterss_ES2.0.bin")
WriteToLog("MSS FW Download Success\n", "green")
RSTD.Sleep(20)
ar1.PowerOn(0, 1000, 0, 0)
WriteToLog("Power On Success\n", "green")
RSTD.Sleep(20)
ar1.RfEnable()
WriteToLog("RF Enable Success\n", "green")
RSTD.Sleep(20)
ar1.ChanNAdcConfig(1, 0, 0, 1, 0, 0, 0, 2, 2, 0)
WriteToLog("ChanNAdcConfig Success\n", "green")
RSTD.Sleep(20)
ar1.LPModConfig(0, 0)
WriteToLog("Regualar mode Cfg Success\n", "green")
RSTD.Sleep(20)
ar1.RfInit()
WriteToLog("RfInit Success\n", "green")
RSTD.Sleep(20)
ar1.DataPathConfig(513, 1216644097, 0)
WriteToLog("DataPathConfig Success\n", "green")
RSTD.Sleep(20)
ar1.LvdsClkConfig(1, 1)
WriteToLog("LvdsClkConfig Success\n", "green")
RSTD.Sleep(20)
ar1.LVDSLaneConfig(0, 1, 0, 0, 0, 1, 0, 0)
WriteToLog("LVDSLaneConfig Success\n", "green")
RSTD.Sleep(20)
ar1.ProfileConfig(0, 77, 7, 7, 212.8, 0, 0, 0, 0, 0, 0, 18.298, 1, 1024, 5000, 0, 0, 40)
WriteToLog("ProfileConfig Success\n", "green")
RSTD.Sleep(20)
ar1.ChirpConfig(0, 0, 0, 0, 0, 0, 0, 1, 0, 0)
WriteToLog("ChirpConfig Success\n", "green")
RSTD.Sleep(20)
ar1.ChirpConfig(0, 0, 0, 0, 0, 0, 0, 1, 0, 0)
WriteToLog("ChirpConfig Success\n", "green")
RSTD.Sleep(20)
ar1.FrameConfig(0, 0, 1, 4, 1, 0, 1)
WriteToLog("FrameConfig Success\n", "green")
RSTD.Sleep(20)
ar1.SelectCaptureDevice("DCA1000")
WriteToLog("SelectCaptureDevice Success\n", "green")
RSTD.Sleep(20)
--DATA CAPTURE CARD API
ar1.CaptureCardConfig_EthInit("192.168.33.30", "192.168.33.180", "12:34:56:78:90:12", 4096, 4098)
WriteToLog("CaptureCardConfig_EthInit Success\n", "green")
RSTD.Sleep(20)
ar1.CaptureCardConfig_Mode(1, 1, 1, 2, 3, 30)
WriteToLog("CaptureCardConfig_Mode Success\n", "green")
RSTD.Sleep(20)
ar1.CaptureCardConfig_PacketDelay(25)
WriteToLog("CaptureCardConfig_PacketDelay Success\n", "green")
RSTD.Sleep(20)
--Start Record ADC data
ar1.CaptureCardConfig_StartRecord("C:\\ti\\mmwave_studio_01_00_00_00\\mmWaveStudio\\PostProc\\adc_data.bin", 1)
--WriteToLog("ARM Start \n", "green")
RSTD.Sleep(20)
--Trigger frame
ar1.StartFrame()
--WriteToLog("Frame Start \n", "green")
RSTD.Sleep(2000)
-- Stop Recording
ar1.CaptureCardConfig_StopRecord()
--WriteToLog("Frame Start \n", "green")
RSTD.Sleep(20)

 

3 Replies