• TI Thinks Resolved

LMP91000: Keeping sensor polarized in Standby mode

Intellectual 895 points

Replies: 5

Views: 60

Part Number: LMP91000

Hello,

The STANDBY mode is supposed to keep the sensor polarized in between measurements so that when it is time to measure the sensor does not require any time to stabilize.

However I noticed looking at the voltage difference between C1 and C2 that the sensor still takes some time to stabilize. About 5 seconds for a CO sensor.

It seems that this is due to the TIA power on sequence which draws current through the feedback loop and Rg directly from the sensor itself, thus disturbing its polarization. The sensor require then some time to stabilize.

So is there any way not to disturb the sensor when going from the STANDBY mode to the 3-LEAD mode (ie when powering up the TIA) ?

It would be helpfull if Ti  could provide some details on the internal process of turning the TIA on and off when we transition from STANDBY mode to 3_LEAD mode and vice versa

Best regards.

Frederic 

  • Hi Frederic,

    We're looking into this and will get back to you shortly.

    thanks,

    Ren

  • In reply to Ren Schackmann:

    Hi Ren,

    Just to illustrate the issue, I attach the herebelow curves showing the voltage between C1 and C2 (C1 is taken after an OPAMP follower buffer).

    1. In blue you have 1.5s measurements at 5s interval (50s total) duration. You can clearly see the spikes when transitionning from STANDBY mode to 3-LEAD mode. I had to limit the scale of the Y axis but the spike goes up to 1.2V correspopnding to saturation. After the spike you can see the signal going down.

    2. In Orange the LMP is kept in 3-LEAD mode all the time for the same 50s. You can see the same spike on the first measurement then the stabilization phase which takes about 10s.

    So you could answer that I should wait for 10s in 3-LEAD mode after the transition from STANDBY but for I guess this would not be optimized for 30s measurement period.

    I guess that the STANDBY mode was designed so that the sensor is kept polarized by A1 and all its pin should see the same conditions in both modes (same voltage and same impedance).

    However it seems that some glitches happen during the transition phase which modifies the conditions (on the Working electrode I guess) and destabilize the sensor due to its highly capacitive nature.

    Thanks for your support.

  • In reply to Frederic Griffe:

    Hi Frederic,

    In Standby mode, the TIA is off and A1 stays on. I would say it is normal for some activity to occur on the TIA's output pin as it powers on. Is there some further misunderstanding?

    thanks,

    ren

  • In reply to Ren Schackmann:

    The standby mode is supposed to keep the sensor polarized so that when the TAI is powered back on, the sensor does not spend too much time to stabilize (as opposed to the deep sleep mode).

    But when comparing the permanent 3-LEAD mode and STANDBY mode (see curves) this is not the case. The sensor is being disturbed and takes about 10s to reach a stable value.

    I am try to find a solution to minimize this disturbance and therefore optimize sensor stabilization time and reduce energy consumption.

    On the datasheet is is written that  "For power savings, the transimpedance amplifier can be turned off and instead a load impedance equivalent to the TIA’s inputs impedance is switched in."

    Could you provide some more details on the transition process to STANDBY mode.

    Kind regards.

    Frederic

  • In reply to Frederic Griffe:

    Hi Frederic,

    The Standby feature you've described is intended to be a workaround for the characteristics of the sensor. I don't have information for all sensor types, but it's likely your sensor will have poor behavior over a longer period of time (than the TIA timing discussed) if it is not kept biased. From this perspective, the TIA timing is a minor time cost and inconvenience. 

    thanks,

    Ren