• Resolved

DCA1000EVM: a problem was encountered while attempting to add the driver - FTDI driver

Prodigy 40 points

Replies: 5

Views: 152

Part Number: DCA1000EVM

Hi. I have been using the DCA-1000EVM board for a week or so now.

Everything has been working perfectly fine, but I needed to change the test environment, so I moved the board to a new computer and tried setting up the board again.

I did everything same as I did before, but this time the board started to malfunction, with the message, a problem was encountered while attempting to add the driver.

After a few trials, I connected the board back to the original setup computer, but it seems like the board is not working on the original computer as well (with the same message, and FTDI not being recognized.)

Is there a possibility that the FTDI chip was damaged by some reason? (There was no physical damage to it.)

Or, maybe if it is the problem with the board, is there a way for me to perhaps reset the DCA1000EVM board completely?

Thank you.

  • Hello Kangmin,

    Could you provide more details on what you see in the PC's device manager COM ports when you power up the DCA1000 and connect it to the PC? Could you share the snapshot of the device manager with this condition?



  • In reply to Vivek Dham:

    Here are the info that you might need (I have been going through the Q&A section, and maybe the REV is the problem with the last image?)

    Sorry for the language issue. But the error message is the same as the title. If there is anything more that you might need, please tell me.

  • In reply to Vivek Dham:

    I have actually looked at the following link: https://e2e.ti.com/support/sensors/f/1023/t/615197#pi320995=1

    It seems like you have provided a fix for the ftdi driver with similar issue: the REV issue.

    Apparently, the ftdi driver provided at the link is not for the DCA1000EVM, and doesn't seem to work for me.

    Because of this, I actually tried re-installing the mmwave studio, but it actually gives me an error message while trying to install the ftdi driver again.

    It will be very helpful if you could provide a similar fix for the DCA1000EVM. Thank you.

  • In reply to Kangmin Bae:


    The drivers are the same for DCA1000. Did you unintall the driver and try to install it again?



  • In reply to Vivek Dham:

    Thank you very much for your tip.

    The fact that the drivers are the same for DCA1000 actually helped me out.

    I have tried deleting and installing the driver for multiple times, but it never worked.

    However, when I tried to get the linked FTDI driver updated, I got the error message "The hash for the file is not present in the specified catalog file." instead of the message that I used to get, which was " a problem was encountered while attempting to add the driver ".

    After searching a while for the problem, I found a way to disable device driver signing, and was able to force-update the driver with the provided one.

    Here is the link in case anyone is interested in how I did it. Only option 2 worked for me.

    In case anyone is having similar issue, please do make sure that the overriding driver is the correct driver. I only did this because Vivek Dham confirmed that the FTDI at link was the same one.

    To Vivek Dham, thank you so much for your help.

    You really saved me from much trouble.

    Regards, Kangmin Bae