This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/F28M36H33B2: Ti Cloud Agent not connecting with Gui Composer

Intellectual 690 points

Replies: 13

Views: 5328

Part Number: F28M36H33B2

Tool/software: Code Composer Studio

I connot get the new Cloud based Gui Composer to connect to my device and run the Gui directly from the cloud using the TI Cloud Agent Bridge. I am able to create my Gui and then export it as a CCS Desktop View, copy it into the folder and run the application. But this is quite a hassle while I'm still busy developing and testing the Gui. So I have configured an XDS device under the Target Communication Settings in CCS GUI Composer Cloud so that I can program my device and run the Gui from the Cloud Gui composer. When I then try to connect from the Target Communication Settings dialog it just hangs with "Connecting to TI Cloud Agent..." message. I tried to find the TICloudAgent.log file to add it here but I could fine any such file under the path "ti/node/logs/TICloudAgent.log". I'm using Spectrum Digital XDS 200 Debug probe and the Blackhawk XDS 560, does the Cloud agent support these emulators or does it only work with the TI XDS emulators? 

13 Replies

  • In reply to AndyW:

    node.bat file contents:

    @echo off
    set PATH=%~dp0\util;%PATH%
    reg Query "HKLM\Hardware\Description\System\CentralProcessor\0" | find /i "x86" > NUL && set OS_BIT_SIZE=32||set OS_BIT_SIZE=64
    C:\Users\asmit\TICloudAgent/node C:\Users\asmit\TICloudAgent/src/installer/cli.js --installer ticloudagent__2 (1).exe --quiet true

    node.bat output after execution:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\asmit>cd TICloudAgent

    C:\Users\asmit\TICloudAgent>node.bat
    no valid command line parameter passed


    C:\Users\asmit\TICloudAgent>

  • Genius 13880 points

    In reply to Albert Smit:

    Thank you Albert.

    A couple of other items that will help track this down:

    • You already added lines to enable logging in ticloudagent.bat.  From a Windows command prompt, could you run this file from the command line and post both the log file and console output here:

    C:\Users\asmit\TICloudAgent>ticloudagent.bat

    • Regarding this issue from an earlier reply
      • It does not work from CCS cloud as well. If I go to Target > Connect COM port, it says: "Opening COM port failed. The project does not have Target Type". I don't know where to set the target type.

    The reason you see this message is the IDE was unable to determine the target type from the selected project. If the project you select in your workspace has a supported target configuration, it should be able to find a configuration.  Just to prove whether it is working elsewhere, you could create a project for a different device (say a 28027) and try the same thing.

    • Regarding the supported debug probes mentioned earlier.  We do not have support for 560-class debug probes in CCS cloud. XDS200 class probes should work though.

  • In reply to AndyW:

    output of ticloudagent.bat:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\asmit>cd TICloudAgent

    C:\Users\asmit\TICloudAgent>ticloudagent
    ▲ {"port":56395,"version":"4.2"}

    log file attached.log_ticld.log

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.