This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CCS/TMS570LC4357: XDS110 Not Connecting, Unable to flash code to device

Part Number: TMS570LC4357

Tool/software: Code Composer Studio

Hello,

I am trying to figure out how to flash the Project1_LAUNCHXL2_570LC43 code onto the Hercules chip given in the title, but I am having trouble with performing the configuration properly and getting the XDS110 to connect.

Here is the link I've been using to perform the configuration: http://processors.wiki.ti.com/index.php/LAUNCHXL2_TMS57012:_Project_1 

On step 1,

the debug mode with the configuration file as told, I have errors with the project, and after proceeding with errors, this message shows up:

Error connecting to the target:
(Error -260 @ 0x0)
An attempt to connect to the XDS110 failed.
The cause may be one or more of: no XDS110 is connected, invalid
firmware update, invalid XDS110 serial number, or faulty USB
cable. The firmware and serial number may be updated using the
xdsdfu utility found in the .../ccs_base/common/uscif/xds110
directory of your installation. View the ReadMe.txt file there
for instructions.
(Emulation package 7.0.188.0)


What exactly am I doing wrong? Thank you!

Sincerely,

Patrick

  • Guru 130210 points
    Patrick,

    The explanation of this error is shown at:
    software-dl.ti.com/.../ccsv7_debugging_jtag_connectivity_issues.html

    This basically indicates you are having problems between the host PC and the board. Try the suggestions in the section "Hardware checklist" of the link above as well.

    In addition to the troubleshooting tips above, can you check if you have the XDS110 drivers properly instantiated in the Windows control panel?

    Hope this helps,
    Rafael

    When posting, click on the link Insert Code, Attach Files and more... to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "This resolved my issue".

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.