This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

CCS: Code Composer Studio™ forum

Prodigy 150 points

Replies: 7

Views: 325

Tool/software: Code Composer Studio

When I follow the guide CC3200 SimpleLink Wi-Fi and IoT Solution With MCU LaunchPad Getting Started Guide, I get to the step where I do the first debug and get the following error, cannot connect to target and 

Cortex_M4_0: Error connecting to the target. I provided info below. If there is anymore information I can provide please let me know specifically would help. 

-i'm running windows 10

- CCS6.0.1.00039_win32

-cc3200 launchpad xl

- tera

-uniflash

-service pack as seen below

  • Hello Kris,

    Please, install CCS 8.3 which is the latest. 
    When installing CCS, you need to select and install a debug probe support valid for your LaunchPad.

    Best regards,
    Tom

    If I had answered to your question, please mark this post as Resolved.

  • In reply to Tomasz Kocon:

    How would I go about installing a debug probe support valid for Launchpad, would it be in the app center or the install software tab? Also. do I need to install rtos in the app center as in the user guide, becuase i'm not seeing it pop up in the app center? 

    "When installing CCS, you need to select and install a debug probe support valid for your LaunchPad"

  • In reply to Kris Weber:

    In case of CC32xx LPs you need to have support for TI XDS debug probes.

    During an installation of CCS8.x you should see screen like below:

    Please, ensure that a needed debug probe would be installed.

    Best regards,
    Tom

    If I had answered to your question, please mark this post as Resolved.

  • In reply to Kris Weber:

    Kris Weber
    Also. do I need to install rtos in the app center as in the user guide, becuase i'm not seeing it pop up in the app center? 

    Products, like TI-RTOS, you can install using View -> Resource Explorer. 

    Best regards,
    Tom

    If I had answered to your question, please mark this post as Resolved.

  • In reply to Tomasz Kocon:

    In reference to the menu for selecting the Debug Probe, the following menu opens with the following options, does this look correct?

  • In reply to Kris Weber:

    Your menu shows 1.4 GB as install size.
    Is it CCS 6.0?

    Best regards,
    Tom

    If I had answered to your question, please mark this post as Resolved.

  • Guru 148155 points

    In reply to Tomasz Kocon:

    Hi,

    I am not sure if you were able to find your way through the CCS setup to your CC3200-LAUNCHXL board. In case negative, you have to use the configuration shown in the reference below to properly setup it in your target configuration file.
    software-dl.ti.com/.../appnote-common_target_configurations.html

    If you are a bit confused about the overall process of configuring CCS using a target configuration file, please refer to our user's guide at:
    software-dl.ti.com/.../ccs_debug-main.html

    That should help you overcome the initial connect error, which will allow you to debug your board.

    Hope this helps,
    Rafael

    When posting, click on the link Insert Code, Attach Files and more... to attach images, files or use nice formatting.

    If my reply answers your question please click on the green button "This resolved my issue".

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.