This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

[FAQ] CCS: Trouble building and/or running TI-RTOS projects on MSP430

Guru 167790 points

Replies: 1

Views: 170

Tool/software: Code Composer Studio

I am having trouble building and/or running TI-RTOS for MSP430 example projects with specific versions of CCS. 

____________________________________________________________________________

Please click This Resolved My Issue if the reply answers your question.

Explore Code Composer Studio documentation and resources using online Resource Explorer
Track a known bug with SDOWP. Enter the bug id in the "Find Record ID" box

  • Guru 167790 points

    TI-RTOS for MSP430 is not compatible with latest versions of CCS, Compiler and XDCtools. Please see Known Issues linked from the TI-RTOS download page

    For best compatibility, we recommend using the versions mentioned in the TI-RTOS Release Notes:
    CCS 6.1.3
    XDCTools 3.32.00.06

    If you are using a newer CCS version, the minimum requirement is to use MSP430 Compiler tools v16.x.x.LTS. To install a specific compiler version, follow the procedure described here: http://software-dl.ti.com/ccs/esd/documents/ccs_compiler-updates.html


    One or more of these symptoms may be exhibited when using TI-RTOS for MSP430 with newer CCS/compiler then the versions mentioned in the Release Notes:

    1) Projects build without errors but do not halt at main() and do not execute correctly when loaded to the target. This can happen with compiler tools 18.1.x.LTS (up to 18.1.6), and 18.12.x.LTS (up to 18.12.3).
    Solution: Use compiler tools 16.x.x.LTS

    2) Projects report a linker error at build time:
    error #10458-D: No specialization routine chosen for '_auto_init', referenced from '.text:_isr:_c_int00:boot.ae430X<boot.oe430X>'.
    This can happen with compiler tools 18.1.7.LTS and higher, and 18.12.4.LTS and higher
    Solution: Use compiler tools 16.x.x.LTS

    3) With MSP430FRxx devices and CCSv7 and higher, code gets stuck in Hwi54:
    __interrupt Void ti_sysbios_family_msp430_Hwi54(Void)
    {
    while(1){};
    }
    This is due to known defect TIRTOS-1077
    Solution: Disable the MPU setting for the project as described in the defect details link.

    4) No Log output in the RTOS Analyzer Live Session window for instrumentation examples.
    Solution: Try the workaround suggested for TIRTOS-1077 or use CCSv6.

    ____________________________________________________________________________

    Please click This Resolved My Issue if the reply answers your question.

    Explore Code Composer Studio documentation and resources using online Resource Explorer
    Track a known bug with SDOWP. Enter the bug id in the "Find Record ID" box

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.