This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

[FAQ] TINA/Spice: How to Run PSpice and/or TINA-TI models provided by TI?

Mastermind 39180 points

Replies: 1

Views: 3699

Tool/software: TINA-TI or Spice Models

How to Run PSpice and/or TINA-TI models provided by TI?

Nikhil Gupta | Product Folder Modeling                                                                                                                                                    

All TI Spice Models can be found here | New to TINA-TI? Its a free spice simulator! Try out this short Video Training Series

 

  • TINA-TI MODELS

    In order to find a TINA-TI model for a device, please check the product folder for that device and look under the "Tools and Software" tab. Alternately, you can find all available models from TI through the link in this FAQ page.

    In general you will find 2 files related to TINA-TI in the product folders - TINA-TI Spice Model (TSM) and TINA-TI Reference Design (TSC). 

    TSM is the TINA-TI Spice Macro. This is essentially the model for the device. In order to use this in TINA-TI, you can open a new schematic in TINA-TI (File --> New or "Cntl + N" shortcut), then click on Insert --> Macro and point to the TSM file. This will place the spice model in your TINA-TI schematic. After this you can draw the circuit around this model and simulate it.

    However, TI provides a much more easy way to get started with the simulations by providing the TINA-TI  Reference Design (TSC). This is a schematic containing the spice model (TSM) plus a reference design around that model with all simulation parameters already setup for best accuracy and simulation speed. All you have to do to see typical performance is to run the simulation (from "Analysis" in the Menu bar). If you need to make tweaks to the design, this offers a very easy and convenient way to do so rather than drawing up the entire circuit manually.

    TINA-TI DOWNLOAD

    You can download TINA-TI by clicking here.


     

    PSPICE MODELS

    Many PSpice models for Power related devices from TI are encrypted. This means that they can only be opened and run in PSpice Versions 15.7 and above since encryption in PSpice was only supported from 15.7 onward. Encrypted models can not be run in versions of PSpice older than 15.7. Some PSpice models from TI can be found unencrypted as well. In this case you may be able to run it in older versions of PSpice, but note that some older versions had node limitations so the nodes in the model may exceed that limitation.

    HOW TO RUN 

    In order to run the models in PSpice, please download the model to your local computer and unzip the file. In most cases, you should find 4 files (.DSN, .OPJ, .LIB and .OLB) and a sub folder which contains the test bench setup.

    .DSN is the Design File

    .OPJ is the Project File

    .LIB contains the model (could be encrypted or unencrypted)

    .OLB is the model symbol file.

    In order to open this project in PSpice, please open up "Design Entry CIS" from your directory where you have installed Cadence Allegro PSpice. This will open the Schematic Capture tool for you. Next go to menu bar on the top and click on "File" --> "Open" --> "Project...". You will get a popup. From here, navigate to the unzipped model folder and point to the .OPJ file, then click on the "Open" button. This should open the PSpice project for you. This project will contain an application schematic along with the model and simulation profiles all ready to go, so all you have to do at this point is hit the "Run PSpice" button. Alternately, you can go to the menu on the top, click on "PSpice" --> "Run". The third alternate is to use the keyboard shortcut "F11" to run the simulation.


    QUESTIONS

    If you have any questions about running models provided by TI, please search the E2E community first. There is a high probability that the question has already been answered. In case your issue still persists, please feel free to post your questions to the E2E community forum.


    Nikhil Gupta | Product Folder Modeling                                                                                                                                                    

    All TI Spice Models can be found here | New to TINA-TI? Its a free spice simulator! Try out this short Video Training Series

     

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.