This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

[FAQ] TINA/Spice: How do I avoid convergence issues when TI models are imported into SIMetrix?

Mastermind 39180 points

Replies: 1

Views: 640

Tool/software: TINA-TI or Spice Models

How do I avoid convergence issues when TI models are imported into SIMetrix?

Nikhil Gupta | Product Folder Modeling                                                                                                                                                    

All TI Spice Models can be found here | New to TINA-TI? Its a free spice simulator! Try out this short Video Training Series

 

  • Unencrypted PSpice model import into SIMetrix

    Prerequisites:

    (1)    Please make sure that you are using the latest version of SIMetrix (8.20 and above) since it has several PSpice model import and compatibility enhancements over the older versions.

    (2)    Also, please ensure that you are importing the unencrypted model into SIMetrix. Models encrypted in other tools like PSpice and TINA-TI cannot be imported into SIMetrix. For more information on this topic, please see this FAQ: https://e2e.ti.com/support/tools/sim-hw-system-design/f/234/t/692613

    Import guidelines

    While the following instructions cannot guarantee that all circuits will work, it has been found to work for a majority of applications that we have tested. Following these best practices should be the starting point for any PSpice model import into SIMetrix.

    1.  Please ensure that the PSpice compatibility option has been set in your environment to either 1 or 2
      1. Select menu File | Options | General…
      2. Click on the Miscellaneous tab
      3. See PSpice compatibility level in Simulator compatibility group.
        1. ‘1’ is the regular setting and makes most things compatible with PSpice except for the MOSFET Level 1,2,3 capacitance model.
        2. ‘2’ makes the MOSFET capacitance model compatible as well.
    2. Set Simulation Parameters – Part 1
      1. Select Simulator | Choose Analysis | Transient Tab | Advanced Options…
      2. Set Max time step to 20n. Higher values can be used but can lead to faster simulation times at the cost of lower accuracy and missed switching pulses for switching circuits
      3. Note: DO NOT use the “Fast Spice” option with TI models as these have been known to cause issues.
    3. Set Simulation Parameters – Part 2
      1. Switch to the “Options” tab (Select Simulator | Choose Analysis | Options)
      2. Change Current Tolerance to 10n
      3. Change Voltage Tolerance to 10u
    4. As a best practice, while building up the application around the model, try to replicate the schematic available from TI (in PSpice and TINA-TI) first and get it simulating in SIMetrix. Once this works properly, then modify it for your end application needs. This will help you get to the bottom of potential issues that you might encounter – i.e. help decipher if any seen issues are coming from the TI model itself or from the import process into SIMetrix.

    Nikhil Gupta | Product Folder Modeling                                                                                                                                                    

    All TI Spice Models can be found here | New to TINA-TI? Its a free spice simulator! Try out this short Video Training Series

     

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.