This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

WEBENCH® Tools/BQ40Z50: bq40z50 cycle count 65535 changed

Prodigy 130 points

Replies: 9

Views: 140

Part Number: BQ40Z50

Tool/software: WEBENCH® Design Tools

Dear TI members,

Good day.

I used BQ40z50 IC. (Default srec is bq40z50R3_v3_09_build_73)

When we make a pack, and we're running a Charging and discharging test, However, the Remtimealarm changes from 10 to 375. (Setting value : 10)
And the cycle count soon changes to 65535.
However, if We see Log status at this time, an error seems to occur.
So, I wonder. As above, the reason why RemtimeAlarm changes and the reason why Cycle count changes.
Is it a communication error or a problem setting the GG file? When an communication error occurs, are these values likely to change suddenly?

Please check.

Thanks.

  • In reply to kim gwang:

    I see the 2 items in the attached log file is good, I think it is not the gg file you extracted from the bad device.

    Or are those weird data occurs permanently or only in transient?

    if it is only in transient, than it probable is caused by communication issue.

    When you charge and discharge the data, do you log the data with bqStudio? Do you see any other error in the registers?

  • In reply to kim gwang:

    Good morning!

    Thank you for your effort.

    It`s Export data.

    Only two occurred in 60 packs.In addition, the changed values continue to no change.
    Also, there is no writing in the facility, only reading. I think it's a communication problem.
    If this communication problem causes the wrong cycle count to be changed to 65535?

    Please check.

    Thanks.

  • In reply to kim gwang:

    When you charge and discharge the data, do you log the data with bqStudio? Do you see any other error in the registers?

    : Yes, right. it`s bqstudio log data. There is no special error message. However, the values have been changed. (Remaning time alarm and Cycle count ...etc)

  • In reply to kim gwang:

    Hi, Kim

        Do you have further more detail information on how that 2 packs had its cycle count goes to 65525? Such as :

        1: Have you able to see other values between 0 and 65535 for these or other packs?

        2: Do you observe this when the status transitioned from relax to discharge or charge? Or charge and discharge status just switched rapidly for multiple times when you connect or disconnect the load or charger? Or such thing happened before you see the 65535 cycle count?

        3: Do these 2 packs both have corrupted data at same flash location?

        4: Can you somehow replicate this issue?  

  • In reply to Steven Yao:

    Hi, Steven,

    Good morning,

    Thank you for your effort.

        1: Have you able to see other values between 0 and 65535 for these or other packs?

        : No, Just only 65535.

        2: Do you observe this when the status transitioned from relax to discharge or charge? Or charge and discharge status just switched rapidly for multiple times when you connect or disconnect the load or charger? Or such thing happened before you see the 65535 cycle count?

        : It changes as soon as one cycle charge and one cycle discharge. (3.2A Charging ~ 6.4A Discharging completed. And It`s change 0 -> 65535)

        3: Do these 2 packs both have corrupted data at same flash location? 

        : Yes

        4: Can you somehow replicate this issue?  

       : It`s some difficult.

    And Can you tell me your email? Because I want to share charging and Discharing NG log data. (Cycle count)

    However, We can`t upload this site. Please help.

    Thanks.

       

  • In reply to Steven Yao:

    Hi, Steven yao,

    Good afternoon,

    Okay please check my mail. 

    mail name : Reply:: WEBENCH® Tools/BQ40Z50: bq40z50 cycle count 65535 changed. (bjmoon@powerlogics.co.kr)

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.