This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

wilink8 wl18modgb driver

Guru 11260 points

Replies: 14

Views: 2654

Hi,

Is there a back port version for wl18modgb driver available for 2.6.37 (or any thing closer ) ?

Thanks,

--Prabhakar Lad

  • Hi Prabhakar,

    Which platform?

    Regards,
    Gigi Joseph.

  • In reply to Joseph Gigi:

    Hi Joseph,

    We have a custom board on dm8148, which has this chip,(since TI has no releases after 2.6.37 for this we need to back port).

    Thanks,

    --Prabhakar Lad

  • In reply to Prabhakar Lad:

    Hi Prabhakar,

    Let me check and get back on this.

    Regards,
    Gigi Joseph.

  • Ping...
  • In reply to Prabhakar Lad:

    Hi Prabhakar,

    I have replied by e-mail.
    Please confirm.

    Regards,
    Gigi Joseph.
  • In reply to Joseph Gigi:

    Hi Joseph,

    We need the same Wilink 8 driver for 2.6.37 based on DM3730

    Could you provide source code ?

    Regards,
    Agusti
  • In reply to Agusti Fontquerni Gorchs:

    Hi Agusti,

    Sent you a mail...

    Regards,
    Gigi Joseph.
  • In reply to Joseph Gigi:

    Hi Gigi, after compile the wilik8 for 2.6.37 following this guide:
    processors.wiki.ti.com/index.php
    We have the below message during boot.
    Any clue about it?
    Best Regards
    Eduard Gavin

    [ 6.143829] cfg80211: Calling CRDA to update world regulatory domain
    [ 6.540405] wlcore: wl18xx driver version: ol_r8.a6.02
    [ 6.913757] wlcore: wl18xx HW: RDL 2, 1857 MIMO, PG 2.2 (ROM 0x11)
    [ 6.958282] wlcore: loaded
    [ 6.961181] wlcore: driver version: ol_r8.a6.02
    [ 6.965881] wlcore: timestamp: Tue Apr 14 11:44:43 2015
    [ 7.155334] mcp251x spi1.0: MCP251x didn't enter in conf mode after reset
    [ 7.163024] mcp251x spi1.0: Probe failed
    [ 7.167144] mcp251x spi1.0: probe failed
    [ 7.253448] Bluetooth: Core ver 2.15
    [ 7.257263] NET: Registered protocol family 31
    [ 7.261901] Bluetooth: HCI device and connection manager initialized
    [ 7.268524] Bluetooth: HCI socket layer initialized
    [ 7.297149] Bluetooth: L2CAP ver 2.15
    [ 7.300964] Bluetooth: L2CAP socket layer initialized
    [ 7.320098] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [ 7.357513] Bluetooth: RFCOMM TTY layer initialized
    [ 7.362640] Bluetooth: RFCOMM socket layer initialized
    [ 7.368011] Bluetooth: RFCOMM ver 1.11
    [ 12.640289] net eth0: SMSC911x/921x identified at 0xdb084000, IRQ: 201
    [ 13.151916] wlcore: PHY firmware version: Rev 8.2.0.0.168
    [ 13.245483] wlcore: firmware booted (Rev 8.6.0.0.5)
    [ 13.253265] wlcore: ERROR command execute failure 14
    [ 13.258453] ------------[ cut here ]------------
    [ 13.263305] WARNING: at /home/linux1204/ipnc-v3.5.0/Source/ti_tools/wifi-driver-files/work_space_R8_A6_02/compat-wireless/drivers/net/wireless/ti/wlcore/main.c:818 wl12xx_queue_recovery_work+0x20)
    [ 13.282867] Modules linked in: rfcomm hidp l2cap bluetooth wl18xx wlcore mac80211 cfg80211 option mcp251x usb_wwan ads7846 wlcore_sdio can_dev usbserial omap_wdt twl4030_wdt compat
    [ 13.299713] [<c004855c>] (unwind_backtrace+0x0/0x118) from [<c006ca3c>] (warn_slowpath_common+0x4c/0x64)
    [ 13.309600] [<c006ca3c>] (warn_slowpath_common+0x4c/0x64) from [<c006ca6c>] (warn_slowpath_null+0x18/0x1c)
    [ 13.319702] [<c006ca6c>] (warn_slowpath_null+0x18/0x1c) from [<bf11368c>] (wl12xx_queue_recovery_work+0x20/0x68 [wlcore])
    [ 13.331146] [<bf11368c>] (wl12xx_queue_recovery_work+0x20/0x68 [wlcore]) from [<bf115d8c>] (wlcore_cmd_send_failsafe+0x39c/0x3b8 [wlcore])
    [ 13.344146] [<bf115d8c>] (wlcore_cmd_send_failsafe+0x39c/0x3b8 [wlcore]) from [<bf116e7c>] (wlcore_cmd_configure_failsafe+0x6c/0x94 [wlcore])
    [ 13.357421] [<bf116e7c>] (wlcore_cmd_configure_failsafe+0x6c/0x94 [wlcore]) from [<bf116eb4>] (wl1271_cmd_configure+0x10/0x18 [wlcore])
    [ 13.370178] [<bf116eb4>] (wl1271_cmd_configure+0x10/0x18 [wlcore]) from [<bf11d074>] (wl1271_acx_group_address_tbl+0x94/0xcc [wlcore])
    [ 13.382812] [<bf11d074>] (wl1271_acx_group_address_tbl+0x94/0xcc [wlcore]) from [<bf120954>] (wl1271_init_vif_specific+0x108/0x358 [wlcore])
    [ 13.395996] [<bf120954>] (wl1271_init_vif_specific+0x108/0x358 [wlcore]) from [<bf112764>] (wl1271_op_add_interface+0x694/0x7b4 [wlcore])
    [ 13.408996] [<bf112764>] (wl1271_op_add_interface+0x694/0x7b4 [wlcore]) from [<bf0bc238>] (ieee80211_do_open+0x344/0x7cc [mac80211])
    [ 13.421478] [<bf0bc238>] (ieee80211_do_open+0x344/0x7cc [mac80211]) from [<c038c370>] (__dev_open+0x9c/0xf4)
    [ 13.431732] [<c038c370>] (__dev_open+0x9c/0xf4) from [<c038c590>] (__dev_change_flags+0x8c/0x110)
    [ 13.440979] [<c038c590>] (__dev_change_flags+0x8c/0x110) from [<c038c680>] (dev_change_flags+0x10/0x44)
    [ 13.450775] [<c038c680>] (dev_change_flags+0x10/0x44) from [<c03d44ac>] (devinet_ioctl+0x2b0/0x65c)
    [ 13.460235] [<c03d44ac>] (devinet_ioctl+0x2b0/0x65c) from [<c037b4f0>] (sock_ioctl+0x1ec/0x240)
    [ 13.469299] [<c037b4f0>] (sock_ioctl+0x1ec/0x240) from [<c00d5094>] (do_vfs_ioctl+0x4c4/0x538)
    [ 13.478271] [<c00d5094>] (do_vfs_ioctl+0x4c4/0x538) from [<c00d5154>] (sys_ioctl+0x4c/0x6c)
    [ 13.486999] [<c00d5154>] (sys_ioctl+0x4c/0x6c) from [<c0043ac0>] (ret_fast_syscall+0x0/0x30)
    [ 13.495788] ---[ end trace 2d5153c348f8cc62 ]---
    [ 13.500610] wlcore: WARNING CONFIGURE command NOK
    [ 13.505493] wlcore: WARNING failed to set group addr table: -5
    [ 15.399810] wlcore: ERROR timeout waiting for the hardware to complete initialization
    [ 17.290649] wlcore: ERROR timeout waiting for the hardware to complete initialization
    [ 19.181304] wlcore: ERROR timeout waiting for the hardware to complete initialization
    [ 19.190460] wlcore: ERROR firmware boot failed despite 3 retries
  • In reply to Eduard Gavin:

    Hi,

    The firmware version does not look to be correct.
    Can you show me the "lsmod" results?

    Regards,
    Gigi Joseph.
  • In reply to Joseph Gigi:

    Hi Gigi, thanks for your quick answer, lsmod and modinfo below.
    Best Regards
    Eduard

    root@igep00x0:~# lsmod
    Module Size Used by
    iptable_nat 3737 0
    nf_nat 13550 1 iptable_nat
    rfcomm 48596 0
    hidp 13311 0
    l2cap 48004 4 rfcomm,hidp
    bluetooth 67150 3 rfcomm,hidp,l2cap
    wl18xx 58330 0
    wlcore 170509 1 wl18xx
    mac80211 285192 2 wl18xx,wlcore
    cfg80211 160415 3 wl18xx,wlcore,mac80211
    option 13044 0
    mcp251x 8198 0
    usb_wwan 7163 1 option
    ads7846 9080 0
    wlcore_sdio 4204 0
    can_dev 6052 1 mcp251x
    usbserial 23850 2 option,usb_wwan
    omap_wdt 3183 0
    twl4030_wdt 2631 0
    compat 9946 5 wl18xx,wlcore,mac80211,cfg80211,wlcore_sdio

    root@igep00x0:~# modinfo wlcore
    filename: /lib/modules/2.6.37+/updates/drivers/net/wireless/ti/wlcore/wlcore.ko
    author: Juuso Oikarinen <juuso.oikarinen@nokia.com>
    author: Luciano Coelho <coelho@ti.com>
    license: GPL
    depends: cfg80211,mac80211,compat
    vermagic: 2.6.37+ mod_unload ARMv7
    parm: debug_level:wl12xx debugging level (uint)
    parm: fwlog:FW logger options: continuous, ondemand, dbgpins or disable (charp)
    parm: fwlog_mem_blocks:fwlog mem_blocks (int)
    parm: bug_on_recovery:BUG() on fw recovery (int)
    parm: no_recovery:Prevent HW recovery. FW will remain stuck. (int)

    root@igep00x0:~# modinfo wl18xx
    filename: /lib/modules/2.6.37+/updates/drivers/net/wireless/ti/wl18xx/wl18xx.ko
    firmware: ti-connectivity/wl18xx-fw-mc.bin
    author: Luciano Coelho <coelho@ti.com>
    license: GPL v2
    alias: platform:wl18xx
    depends: wlcore,mac80211,compat,cfg80211
    vermagic: 2.6.37+ mod_unload ARMv7
    parm: ht_mode:Force HT mode: wide or siso20 (charp)
    parm: board_type:Board type: fpga, hdk (default), evb, com8 or dvp (charp)
    parm: checksum:Enable TCP checksum: boolean (defaults to false) (bool)
    parm: dc2dc:External DC2DC: u8 (defaults to 0) (int)
    parm: n_antennas_2:Number of installed 2.4GHz antennas: 1 (default) or 2 (int)
    parm: n_antennas_5:Number of installed 5GHz antennas: 1 (default) or 2 (int)
    parm: low_band_component:Low band component: u8 (default is 0x01) (int)
    parm: low_band_component_type:Low band component type: u8 (default is 0x05 or 0x06 depending on the board_type) (int)
    parm: high_band_component:High band component: u8, (default is 0x01) (int)
    parm: high_band_component_type:High band component type: u8 (default is 0x09) (int)
    parm: pwr_limit_reference_11_abg:Power limit reference: u8 (default is 0xc8) (int)
    parm: num_rx_desc:int
    parm: num_rx_desc_param:Number of Rx descriptors: u8 (default is 32)
    root@igep00x0:~#

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.