• Resolved

MSP430BT5190 + PAN1323 - Works with XT1CLK and not REFOCLK?


I have designed my own custom board to interface with the PAN1323ETU, however, I did not add an external crystal oscillator to source the ACLK. I was not careful enough and I did not realized that the EtherMind SDK sample uses the external crystal. I thought an easy solution would be to change the clock initialization and use REFOCLK instead to feed the ACLK pin. REFOCLK runs at the same frequency as the crystal oscillator and I checked this by directly checking pin 11.0 on the development board.

When I use the REFOCLK as the ACLK source, the Bluetooth fails to turn on and hangs in the following line inside the BT_UART_ISR:

#pragma vector=BT_UART_VECTOR
__interrupt void BT_UART_ISR(void)





Basically it waits for the CTS (P1.3) to go low but it never does. As soon as I change the ACLK source to the external crystal everything works. I was able to replicate this problem which I saw in my custom board in the development board. Additionally, this topic also claims to have tried to use a PWM to drive the Bluetooth slow clock unsuccessfully http://e2e.ti.com/support/low_power_rf/f/660/t/125986.aspx. He implies to have use an oscillator to drive the clock (most likely an external crystal). I don't understand why it works with one and not the other. I understand the accuracy of the crystal to be much better, but is that really the cause of the problem?

EDIT: I have found on the PAN1323ETU design guide the following about the requirements of the slow clock:

The slow clock's frequency accuracy must be 32.768 kHz +/- 250 ppm for Bluetooth
usage (according to the Bluetooth specification).

I cannot find the ppm spec for the REFOCLK to compare to the previous statement. I have also tried using an external function generator to generate a clock at the same frequency with no success. Could the code be hard coded to only work with XT1CLK?

Thanks in advance,


  • Adrian,

    If MSP430_CTS is not going low during initialization, it indicates that the PAN13xx is not powering up correctly. Given your feedback, I think that your clock is not meeting the specs. Please note that the PAN13xx checks the slow clock accuracy during initialization in order to power up. The source does not have to be ACLK. It could be an external clock as long as it meets the requirements.


  • In reply to Miguel:


    Thank you for your response. Yes, apparently the internal 32.768kHz clock does not meet the specs. As soon as I used an external crystal it all worked.