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Chapter 1: Introduction to PSpice

1. Download PSPICE software 16.0 

2. There are TWO DISTINCT tools that one need to remember about PSpice tools: 

a. Design Entry CIS

This tool is the primary environment where we will work PSpice modeling on such as creating schematics, test benches and creating the analysis options such ac small signal analysis, transient and other type of electrical analysis
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When being asked for a selection of tools within Design Entry CIS, choose “Allegro Design Entry CIS”
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b. Model Editor

This tool is used to create “symbol” of certain part / netlist for the FIRST time only. The editing of the “symbol” such as customizing the symbol, the pin name and other things can be done  from Design Entry CIS.
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3. On the next chapters, we will learn on how to use these two tools above in real small example, Low Pass Filter. 
Chapter 2: Running Simulation in Pspice without creating symbol
1. On this section, we will run an example on how to run ac small signal analysis on Low Pass Filter on Pspice environment

2. Open Design Entry CIS or Allegro Design Entry CIS as shown on previous chapter

3. Once, the environment is open, go to File -> New -> Project
[image: image4.png]i3 Allegro Design Entry CIS
View Toos Edi_Options Window fielp

[ tew Erogct

pen Design

B save Ctrks Library
Saveas. L Fle
veriog Fie

Bk pidei =
TextFie

prnt. cri+p
Print Setup.

Import Design.
Export Design,

Bom)
ou





4. Fill out the name of the project as “THS1234” or “the part name” in real modeling work. Then click ok. 
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5. Click on “Create a blank project”. Then click ok. 
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6. By now, you should something as shown on the following picture
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7. Click on the “+” sign on the left of .\ths1234.dsn to see location of the SCHEMATIC1: PAGE1
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8. Now, let’s draw a low pass filter on this “PAGE1” together with source stimulus. Click on Place -> Part to add components such as R, C, VAC and GND.
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9. Type “R” for resistor in the “Part” Box and press “Enter” and then move the cursor to the schematic window to place the component into the schematic. If you can’t find this component, after putting the word “R” into the “Part” Box, click on the button called “Part Search”. Then click “ok” or click “Add library” or whatever the set of next instructions needed to have the “R” added to the component lists
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10. Repeat the step above for “C” the capacitor, “VAC” the small signal voltage source
11. Finally we want to add the ground to the schematic by going to Place -> Ground. Once the window for selection opened, click on 0/CAPSYM so that it will show ground with “0” beneath the symbol. Then click “ok”. 

WARNING: It is very important to choose the ground symbol with “0” sign beneath the symbol. If we choose the ground symbol WITHOUT “0” and put it on the schematic, Pspice will not recognize the ground as 0V. The consequence of doing this is that when we run the simulation, our let’s say VDC=5V will not show as 5V rather it will show as some other voltages since it does not reference to GND = 0V.
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12. Wire the “R”, “C”, “VAC” and “0V GND” up so that it will look like low pass filter test fixture. Also explore Edit-> Rotate and Edit-> Mirror to move around the components. For the sake of fun, change the dc voltage of the VAC to 5V. 
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13. Once the schematic is done, we want to create the simulations state or for most people familiar with ICFB Cadence it is called Analog Artist State. In this case, we want to create both dc operating point simulation and also ac small signal analysis. 
14. To create the simulation state, we go to Pspice -> New Simulation Profile. Name the first state as “op” or any other name.  Then click “Create”
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15. Once the new window opened, change the Analysis type accordingly. In this case we want to choose “Bias Point” for the operating point simulation. Then click ok. 
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16. The step above should create the “op” simulation state. We can verify it as shown on the following figure
[image: image19.png]@i} = [BIX] (/- scremsTict : pacen)

Anslog or Mixed A/D

. Hierarchy

= 3 Deson Resouees w1
= B hstzanden W
= (3 SCHEMATICL @
1 p
S R

# £ Design Cache
3 Library
£ outputs
= £ Pspice Resources
€3 Tnclude Fies
£ Model braries

- 3 sk s
P SCHEMATICL-0p
€3 Stimus Fies





17. At this point, let’s try to run simulation by pressing “F11” or going to Pspice -> Run. By now we should be able to see the operating points (currents and voltages) on the schematic as shown on the following figure. If the operating points do not show up, go to Pspice -> Bias Points -> Enable or Enable Bias Point Display 
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18. Now let’s try to create “ac” state to run small signal analysis by following steps shown above. 
WARNING: For most part Pspice recognize suffix “k” for kilo, “G” for Gigahertz. However, for Megahertz, Pspice does not use “M” rather “MEG”
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19. Once we’re done with simulation by pressing “F11”. The Simulation/Waveform window should open
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20. To plot the output response of the low pass filter, go to Trace -> Add Trace. Click on DB() first, then click on the node V(C1:2). Make sure the expression is showing up on the “Trace Expression” box as shown on the following figure. Then click “ok”
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21. The output plot should show as shown on the following figure
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22. To name the node between Resistor and Capacitor as “Vout”, we can go to Place -> Net Alias. Then click over your mouse to the net line on the schematic. 
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23. To switch back and forth between the simulation states or to activate a specific simulation state, right click on the simulation profiles as shown on the following figure and click on “Make Active”. Once it is activated, we should see the state highlighted with red color instead of green. Then we can use “F11” to run simulation. 
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24. If we accidentally close the simulation/waveform window, we can reopen it without rerunning simulation by pressing F12 or go to Pspice -> View Simulation Results
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Chapter 3: Running Simulation in Pspice with part symbol creation (from a netlist)
1. Now let’s assume that the Resistor and Capacitor of the previous exercise are in fact an IC so called THS1234. We will run simulation on this THS1234. 
2. Let’s copy paste the SCHEMATIC1 into a new schematic called SCHEMATIC2 to preparing the test bench for THS1234. 

3. Right click on .\ths1234.dsn as shown on the following figure. Then click ok. Right click on the PAGE1 of SCHEMATIC1 and click on copy.
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4. Right click on PAGE1 of SCHEMATIC1 and click on copy 
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5. Paste that PAGE1 of SCHEMATIC1 into SCHEMATIC2.
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6. Open up the PAGE1 of this new SCHEMATIC2. Since we will no longer need PAGE1 of SCHEMATIC1, please close that window. 
7. Modify the PAGE1 of SCHEMATIC2 which is the test bench for soon to be THS1234 by deleting the resistor, the capacitor and the wire in between the resistor and the capacitor as shown on the following figure. We will eventually put the symbol of THS1234 in between the voltage source and ground pin. 
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8. Now let’s create THS1234 netlist. Open an empty text editor, type the following netlist and save it as THS1234.lib. In reality, Pspice does not really care if you want to name it THS1234.txt or THS1234.lib. However, our standard modeling procedure called for .lib file as our netlist
.SUBCKT THS1234 1 2 3
R1 1 2 1k

C1 2 3 1p

.ENDS
9. Now let’s create the symbol of this netlist THS1234.lib by opening up the “Model Editor” as shown on step 2.b of Chapter 1 of this tutorial. The new window will open as shown on the following figure. Then go to File-> Open -> THS1234.lib
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10. If it has not been already highlighted, click on THS1234 on the Models List window. 
11. Now go to File -> Export to Capture Part Library as shown below. Then if new window open, simply click ok. 
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12. Now you should see THS1234.OLB on the same folder as you created THS1234.LIB. This THS1234.OLB is the symbol. 

13. To run simulation properly we will be needing two things: the symbol (THS1234.OLB) and the netlist (THS1234.LIB) 

14. Now, let’s put the symbol into the schematic by first including this THS1234.OLB file as shown on the following figure. 
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15. Once it is included in that “Library” folder, then place THS1234 symbol/part by going to Place -> Part, typing THS1234 on the “part” box, and clicking enter. Put the THS1234 symbol/part into the SCHEMATIC2 and wire them up so that it will end up as the following figure. 
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16. Now, we’re done with including the symbol into the schematic. Next step is to include the netlist (THS1234.LIB) into a simulation state (or for those who are familiar with ICFB cadence it’s also called analog artist state). 

17. As shown on Chapter 2 of this tutorial, let’s create a simulation state called “ac” for SCHEMATIC2. However, before we do this, we need to activate the SCHEMATIC2 instead of SCHEMATIC1 as shown on the following figure. Choose “Make Root”.
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18. A new window will most likely come out when we click “Make Root”. If this is the case, click on Save Design. Now, SCHEMATIC2 is activated. We know it is activated because right now it is in the very top of the hierarchy within .\ths1234.dsn. That is to say SCHEMATIC1 is beneath SCHEMATIC2 as shown on the following figure.
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19. Let’s open PAGE1 of SCHEMATIC2. Then create a simulation state called “ac”, configure the analysis type as shown before on Chapter 2 as AC Sweep/Noise and fill out the start frequency, end frequency and points per decade. 
20. Now, we will be including the THS1234.LIB netlist by going into the Configuration Files tab within this simulation state and choose Library on the Category section as shown in the following figure
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21. Click on the Browse button and look for THS1234.LIB. Once we click ok, click “Add to Design” button and we should see the THS1234.LIB included in the Configured files section within this Configure Files tab as shown on the following figure.
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22. Once we’re done with editing this simulation state, then we’re pretty much done and ready to run simulation by pressing “F11”. 
23. Since we have already included the netlist into the simulation state, we can also edit the .lib directly (assuming we don’t change the pin out names) as shown on the following figure
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Chapter 4: Running Simulation in Pspice with part symbol creation (from a schematic)

1. Now let’s assume that we don’t have THS1234.LIB netlist. Rather, we have a schematic view called THS1234 that consists of R, C and the port information. We then want to create a symbol from this schematic, place the symbol on a test bench and run simulation. 

2. Let’s create a new schematic called SCHEMATIC3 and copy the PAGE1 of SCHEMATIC2 into this SCHEMATIC3 which is the test bench for THS1234 schematic. Open the PAGE1 of this SCHEMATIC3 and delete the THS1234 symbol that are created from THS1234.OLB and THS1234.LIB on chapter 3 of this tutorial

3. Create a new schematic called THS1234 and put a new page into this THS1234 schematic called PAGE1 as shown on the following figure
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4. Open this PAGE1 of THS1234 schematic by double clicking it. Close any other opened pages from other schematics. 

5. Once a new window is open, place the resistor and capacitor into this PAGE1 of THS1234 and wire them up accordingly
6. Now let’s place the port by going into Place -> Hierarchical Port as shown on the following figure 
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7. Once a new window is opened, use whichever port we want to use; however, for our case, we can use PORTRIGHT-R and PORTLEFT-L to do most of the job. Place the port into the nodes of the R and C network and rename the value of this port into Vin, Vout and Vbottom so that in the end our schematic will be as shown on the following figure



[image: image43.png]Abattom




8. Now, let’s go back into our test bench for THS1234 schematic which is the PAGE1 of SCHEMATIC3. Open this SCHEMATIC3 and let’s instantiate THS1234 into this test bench by selecting Place -> Hierarchal Block 
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9. A new window should show up. Fill out the blank on this new window as shown in the following figure and then click ok. Once we click ok, then move over our mouse into PAGE1 of SCHEMATIC3 and by using our left click of the mouse draw a rectangle to create our symbol. This step will NOT ONLY create our symbol BUT ALSO directly place the symbol into our test bench.
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10. Now, we’re ready to hook up the wires into this symbol so that it will be shown as the following figure to complete our test bench
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11. Now, we’re ready to run the simulation, but as usual, before hand we have to create a simulation state. Once, this is done, we click “F11” to run the simulation.
WARNING: If you are having difficulties in running simulation on this final step and also perhaps having difficulties in even creating the simulation state for SCHEMATIC3 test bench, this is probably because you forget to “Make Root” of SCHEMATIC3 so that it will show up in the very top of the .\ths1234.dsn hierarchy. This step is described in Chapter 3 step 17 and 18. 
