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TI Designs: TIDM-1011
Tamagawa T-Format Absolute-Encoder Master Interface
Reference Design for C2000™ MCUs

Description
C2000™ microcontroller (MCU) Position Manager
technology offers an integrated solution to interface to
the most popular digital- and analog-position sensors,
which eliminates the necessity for external field-
programmable gate arrays (FPGAs) or application-
specific integrated circuits (ASICs). The Position
Manager BoosterPack™ is a flexible, cost-effective
platform intended for evaluating various encoder
interfaces and is designed to work with multiple C2000
MCU LaunchPad™ development kits. The software of
this reference design specifically targets
implementation of the T-Format, which is a digital,
bidirectional interface for position encoders. The highly
optimized and easy-to-use software library and
examples included in this reference design enable T-
Format, position-encoder operation using the Position
Manager BoosterPack.

Resources

TIDM-1011 Design Folder
LAUNCHXL-F28379D Tools Folder
SN65HVD78 Product Folder
TLV702 Product Folder
TPS22918-Q1 Product Folder

ASK Our E2E™ Experts

Features
• Flexible, Low-Voltage, BoosterPack Evaluation

Platform for Position-Encoder Interfaces
• Integrated MCU Solution for T-Format Without

Additional FPGA Requirements
• Easy Interface T-Format Commands Through

Driver Functions and Data Structure Provided by
Library

• Library Support for Unpacking Received Data and
Optimized Cyclic Redundancy Check (CRC)
Algorithm

• Supports Clock Frequency up to 2.5 MBPS and
Verified Operation up to 100-m Cable Length

• Includes Evaluation Software Example Showcasing
T-Format Software Library

Applications
• Industrial
• Motor Drives

An IMPORTANT NOTICE at the end of this TI reference design addresses authorized use, intellectual property matters and other
important disclaimers and information.
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http://www.ti.com/product/TPS22918-Q1
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http://www.ti.com/lsds/ti/applications/industrial/overview.page
http://www.ti.com/lsds/ti/applications/industrial/motor-drives/overview.page
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1 System Description
Industrial drives, like servo drives, require accurate, highly-reliable, and low-latency position feedback. T-
Format, from Tamagawa, is designed for serial transfer of digital data between linear, rotary, or angle
encoders, touch probes, accelerometers, and the subsequent electronics, such as numerical controls,
servo amplifiers, and programmable-logic controllers. T-Format is a pure-serial, digital interface based on
the RS-485 standard. The interface transmits position values or additional physical quantities and also
allows reading and writing of the internal memory of the encoder. The transmitted-data types include
absolute position, turns, temperature, parameters, diagnostics, and so on. Mode commands that the
subsequent electronics, often referred to as the T-Format master, send to the encoder select the
transmitted-data types. The TIDM-1011 device acts as a T-Format master and provides the subsequent
electronics to interface a T-Format encoder with the F28379D LaunchPad.

Figure 1 shows a T-format encoder interfaced to a F28379D LaunchPad.

Figure 1. Industrial Servo Drive With T-Format Position Encoder Interface

The position encoder with T-Format connects to the TIDM-1011 device through a single, 4-wire, shielded
cable. The four wires used for communication include two wires for DATA+ and DATA–, which are
transmitted in differential format, and two wires for Up and Un, which are used for the encoder-power
supply and ground.

The C2000, Position Manager, T-Format (PM_tformat) library from TI provides support for implementing
the T-Format interface in subsequent electronics. The library comprises the software portion of the TIDM-
1011 device. The T-Format Library features an integrated MCU solution for the T-Format interface that
meets the Tamagawa, T-Format, digital-interface protocol requirements. The library can support up to 2.5-
MBPS clock frequency, independent of cable length – verified up to 100 m. This support is due to the
integrated cable-propagation, delay-compensation algorithm, which is user configurable. The driver
functions and data structure provided by the library allow other commands to easily be used. The library
also uses an efficient and optimized CRC algorithm for both position and data CRC calculations with the
capability of unpacking the received data and reversing the position data that is incorporated into library
functions. This library solution is tuned for position control applications where position information is
obtained from encoders every control cycle with better control of modular functions and timing.

Note these several key concepts while using the T-Format Library. The library only supports the basic
interface drivers for commands defined in the T-Format specification. All the higher-level application
software must be developed by users using the basic interface provided by this library. Clock frequency
for the T-Format Clock is limited to a fixed value of 2.5 MBPS. This limitation applies irrespective of the
cable length and encoder type. For any additional functionality or encoder use not specified in this
reference design, contact the TI support team or refer to the TI E2E™ community.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDUE74
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1.1 Key System Specifications

(1) The time of the encoder connected to the TIDM-1011 device determines the current limit of this supply. TI recommends a
generic, bench-top, adjustable, power supply with an adjustable current limit.

Table 1. Key System Specifications

PARAMETER SPECIFICATIONS DETAILS
Input voltage 5 V (1) Section 3.2.1.1

Output voltage (encoder) 5 V Section 3.2.1.1
Protocol supported T-Format Tamagawa

Frequency (encoder interface) Approximately 2.5 MBPS Section 2.3.2
Encoder bits T-Format protocol standard Tamagawa
CPU cycles — Section 2.3.3.2

Maximum cable length (tested) 100 m —

2 System Overview

2.1 Block Diagram

Figure 2. TIDM-1011 System Block Diagram

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDUE74
https://www.tamagawa-seiki.com/
https://www.tamagawa-seiki.com/
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2.2 Highlighted Products

2.2.1 LAUNCHXL-F28379D
This development kit is based on the Delfino™ TMS320F28379D MCU, which provides 800 MIPS of total
system performance between dual, 200-MHz, C28x CPUs and dual, 200-MHz, real-time-control
coprocessors (CLA). This powerful MCU contains 1MB of onboard flash and includes highly-differentiated
peripherals, such as 16-bit or 12-bit analog-to-digital converters (ADCs), comparators, 12-bit digital-to-
analog converters (DACs), delta-sigma sinc filters, HRPWMs, eCAPs, eQEPs, CANs, and more.

2.2.2 SN65HVD78
The SN65HVD78 device combines a differential driver and a differential receiver, which operate from a
single, 3.3-V power supply. The differential outputs of the driver and the differential inputs of the receiver
are internally connected to form a bus port suitable for half-duplex (two-wire bus) communication. These
devices feature a wide, common-mode voltage range, which makes the devices suitable for multipoint
applications over long cable runs.

2.2.3 TLV702
The TLV702 series of low-dropout (LDO) linear regulators are low-quiescent current devices with excellent
line and load-transient performance. All device versions have thermal shutdown and current limit for
safety. The devices regulate to specified accuracy with no output load.

2.2.4 TPS22918-Q1
The TPS22918-Q1 is a single-channel load switch, with configurable rise time and configurable quick-
output discharge. The device contains an N-channel MOSFET that can support a maximum-continuous
current of 2 A. The switch is controlled by an on and off input, which can interface directly with low-voltage
control signals.

2.3 Design Considerations

2.3.1 TIDM-1011 Board Implementation
The TIDM-1011 board is identical to the Position Manager BoosterPack (BOOSTXL-POSMGR), which
means the TIDM-1011 board can interface with several other position-encoder types. The board is fully
populated by default for future compatibility. This reference design focuses on the T-Format, and the
hardware blocks not mentioned can be ignored. Software support for the other types of position-encoder
interfaces will be the subject of future reference designs. Table 2 lists the connectors on the TIDM-1011
and BOOSTXL-POSMGR devices and their functions.

Table 2. TIDM-1011 Board and BOOSTXL-POSMGR Connectors

CONNECTOR DESCRIPTION RELEVANT TI DESIGNS AND
HARDWARE

Abs-Enc-1 (J7) T-Format and other absolute encoders TIDM-1011, BOOSTXL-POSMGR
Abs-Enc-2 (J8) T-Format and other absolute encoders Future TID and BOOSTXL-POSMGR

Abs-Enc-2 Breakout (J10) Allows two absolute encoders at site two
using jumpers

Future TID and BOOSTXL-POSMGR

SinCos (J14) SinCos encoder Future TID and BOOSTXL-POSMGR
Resolver (J14 and J15) Resolver interface with 15-V excitation

circuitry
Future TID and BOOSTXL-POSMGR

PTO (J17) Pulse-train output Future TID and BOOSTXL-POSMGR
J1, J3 and J4, J2 BoosterPack connector All designs, BOOSTXL-POSMGR

J6 5-V DC supply input All designs, BOOSTXL-POSMGR
J16 15-V DC resolver excitation input Future TID and BOOSTXL-POSMGR

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDUE74


Site 1 (J1 J3 + J4 J2)

x� x1 T-Format or other Absolute Encoder 
and PTO

x� x2 T-Format or other Absolute Encoder 
(simultaneously)

x� x1 PTO

x� x1 Resolver and PTO

x� x1 Absolute SinCos (Channels C and D, 
requires two BOOSTXL-POSMGR)

Site 2 (J5 J7 + J8 J6)

x� X1 SinCos Encoder

x� x1 T-Format or other Absolute Encoder 
and PTO

x� x1 Resolver and PTO

x� x1 PTO

x� x1 Absolute SinCos (Channels A, B, I, 
requires two BOOSTXL-POSMGR)
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Figure 3 shows the encoder support on each site of the LaunchPad.

Figure 3. TIDM-1011 Board and BOOSTXL-POSMGR Encoder Support

2.3.2 PM T-Format Master Details
This section provides a brief overview of how the T-Format interface is implemented on TMS320F28379D
devices. By design, the TIDM-1011 device works with multiple, C2000, LaunchPad development kits. This
reference design focuses on the F28379D LaunchPad as the main example.

Communication over a T-Format interface is primarily achieved by the following components:
• CPU (C28x)
• Configurable logic block (CLB)
• Serial peripheral interface (SPI)
• Device interconnects (XBARs)

While the SPI performs the encoder-data transmit and receive functions, CLB controls clock generation.
The CLB module can only be accessed through library functions provided in the PM T-Format Library and
is not otherwise configurable by users. The following functions are implemented inside the CLB module:
• Identify the critical delay between the clock edges sent to the encoder and the received data
• Monitor the data coming from the encoder through SPISIMO and poll for the start pulse
• Measure the propagation delay at a specific interval, as required by the interface
• Configure the block and adjust the propagation delay through software

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDUE74
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Figure 4 shows how the T-Format transaction works in the system.

Figure 4. T-Format Implementation Diagram Inside TMS320F28379D

For every T-Format transaction initiated using the PM T-Format Library command the following occurs.
• The CPU configures the SPITXFIFO signal with the command and other data required for transmission

to the encoder, as per the specific requirements of the current T-Format command.
• The CPU sets up the CLB to generate clocks for the encoder and SPI.
• The number of clock pulses and edge placement for these two clocks is different and precisely

controlled by the CLB, as configured by CPU software for the current T-Format command.
• The CLB also generates the direction-control signal for the data-line transceiver. This signal is required

to change the direction of the data line, to receive data from the encoder after sending the mode
command.

• The CLB monitors the SPISIMO signal (as necessary), which detects the start pulse and adjusts the
phase of the receive clock accordingly.

• The CPU configures the CLB to generate continuous clocking for the encoder while waiting for the start
pulse from the encoder.

• The CPU configures the CLB to generate a predefined number of clock pulses needed for the SPI (as
per the current command requirements), and continuous clocking for the SPI is disabled while waiting
for the start pulse from the encoder.

• The CLB also provides hooks to perform cable propagation-delay compensation using library functions.

http://www.ti.com
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Table 3 lists the full MCU resource use.

Table 3. TIDM-1011 MCU Resource Requirements

RESOURCE NAME TYPE PURPOSE USE RESTRICTIONS
DEDICATED RESOURCES

GPIO7 I/O SPI clock generated by the
MCU

I/O dedicated for T-Format
implementation

EPWM4 I/O Internal for clock generation EPWM4 dedicated for T-Format
implementation

Input XBAR (INPUTXBAR1) Module, I/O Connected to SPISIMO of the
corresponding SPI instance

INPUTXBAR1 is used for
implementation. The remaining inputs

are available for application use.
Output XBAR

(OUTPUTXBAR1)
Module, I/O Bring out T-Format TxEn

(direction control) signal on
GPIO32 using OUTPUT1 of

Output XBAR

OUTPUT1 is used for implementation.
The remaining outputs are available for

application use.

CONFIGURABLE RESOURCES
SPI Module and I/Os One SPI instance to emulate

T-Format interface (SPIB on
LaunchPad)

Any instance of SPI can be chosen –
module and corresponding I/Os are

dedicated for T-Format
PwrCtl I/O For encoder power control Can choose any I/O power control.

GPIO32 is used for T-Format
implementation and example projects.

TxEn I/O Direction control on data GPIO34 is used for T-Format
implementation and example projects.
Users can choose any GPIO with an

OUTPUTXBAR1 mux option.
SHARED RESOURCES

CPU and Memory Module Check CPU and memory use
for various functions

Application to ensure enough CPU
cycles and memory are allocated

2.3.3 PM T-Format Software Library
The PM T-Format Library provides a host of commands and functions for interfacing C2000 devices with
T-Format position encoders. This section provides some documentation on the library and describes the
commands and functions the library offers. If the latest version of controlSUITE™ is installed, the library is
in the following directory:
C:\ti\controlSUITE\development_kits\BOOSTXL_POSMGR

Software delivered on controlSUITE for the TIDM-1011 device uses the previously mentioned hardware
resources. The Position Manager BoosterPack is expected to be plugged onto site 2, as shown in
Figure 11.

The following subdirectory structure is used:
<base>\Doc Documentation
<base>\Float Contains implementation of the library and corresponding include file
<base>\examples Example using T-Format library

NOTE: The software example included with the TIDM-1011 devices handles properly configuring
and including the T-Format Library in the CCS project. To learn how to use the library for
other applications, see the Position Manager T-Format Library Module User's Guide.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDUE74
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2.3.3.1 PM T-Format Library Commands
Details of the T-Format protocol and commands supported in different modes can be obtained from
Tamagawa. Table 4 lists the commands supported by the T-Format Library.

Table 4. T-Format Commands Supported

COMMAND DESCRIPTION
DATAID0 Data readout
DATAID1 Data readout
DATAID2 Data readout
DATAID3 Data readout
DATAID6 Writing to EEPROM
DATAID7 Reset
DATAID8 Reset
DATAIDD Reading from EEPROM
DATAIDC Reset

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDUE74
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2.3.3.2 PM T-Format Library Functions
The PM T-Format Library consists of the following functions, which enable the user to interface with T-
Format encoders. Table 5 lists the functions existing in the T-Format Library and a summary of cycles
taken for execution.

Detailed explanations of each function are available at the end of Section 2.3.3.4.

Table 5. T-Format Library Functions

NAME DESCRIPTION CPU
CYCLES

TYPE

PM_tformat_generateCRCTable This function generates a table of 256 entries for a given CRC
polynomial (polynomial) with a specified number of bits (nBits).

Generated tables are stored at the address specified by pTable.

30226 Initialization
time

PM_tformat_getCrc To get the CRC of each byte, calculate the n-bit CRC of a
message buffer using the lookup table. Use this function to

calculate CRC of the position data.

220 Run time

PM_tformat_setupCommand Set up an SPI and other modules, for a given command to be
transmitted. All of the transactions must start with this command.

This function call sets up the peripherals for the upcoming T-
Format transfer, but the call does not actually perform any

transfer or activity on the T-Format interface. This function call
populates the sdata array of TFORMAT_DATA_STRUCT with

the data to be transmitted to the encoder.

1160 Run time

PM_tformat_receiveData Function for unpacking and populating the T-Format data
structure with the data received from the encoder. This function
is called when the data from the encoder is available in the SPI

data buffer and transferred to the rdata array of
TFORMAT_DATA_STRUCT. Upon the function call, received
data is unpacked, as per the current command, and unpacked

results are stored accordingly.

500 Run time

PM_tformat_startOperation This function initiates the T-Format transfer to be called after
PM_tformat_setupCommand. This function performs the T-

Format transaction set up by previous commands. The setup
and start operation are separate function calls. The user can set
up the T-Format transfer and start the actual transfer using this

function call, as necessary, at a different time.

46 Run time

PM_tformat_setupPeriph Setup for SPI, CLB, and other interconnect XBARs for T-Format
are performed with this function during system initialization. This
function must be called after every system reset. No T-Format
transactions is performed until the setup peripheral function is

called.

8822 Initialization
time

PM_tformat_setFreq This function sets the T-Format clock frequency. T-Format
transfers typically start low frequency during initialization and

switch to higher frequency during on runtime.

220 Initialization
time

http://www.ti.com
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2.3.3.3 PM T-Format Library Data Structures
The PM T-Format Library defines the T-Format data structure handle as follows:

Object definition:
typedef struct { // bit descriptions

uint32_t controlField;
uint32_t statusField;
uint16_t dataField0;
uint16_t dataField1;
uint16_t dataField2;
uint16_t dataField3;
uint16_t dataField4;
uint16_t dataField5;
uint16_t dataField6;
uint16_t dataField7;
uint16_t crc;
uint16_t eepromAddress;
uint16_t eepromWrDtata;
uint16_t eepromRdDtata;
volatile struct SPI_REGS *spi;
uint32_t sdata[16]; //send data buffer
uint32_t rdata[16]; //receive data buffer
uint16_t dataReady;
uint16_t fifo_level;
uint32_t rxPkts[3];

} TFORMAT_DATA_STRUCT;

MODULE ELEMENT NAME DESCRIPTION TYPE
controlField Control Field (CF) received from encoder 16 bits
statusField Status Field (SF) received from encoder 16 bits
dataField0 Data Field 0 (DF0) received from encoder 16 bits
dataField1 Data Field 1 (DF1) received from encoder 16 bits
dataField2 Data Field 2 (DF2) received from encoder 16 bits
dataField3 Data Field 3 (DF3) received from encoder 16 bits
dataField4 Data Field 4 (DF4) received from encoder 16 bits
dataField5 Data Field 5 (DF5) received from encoder 16 bits
dataField6 Data Field 6 (DF6) received from encoder 16 bits
dataField7 Data Field 7 (DF7) received from encoder 16 bits

crc CRC Field 7 received from encoder (CRC) 16 bits
eepromAddress EEPROM address for read write accesses (ADF) 16 bits
eepromWrDtata EEPROM write data for write accesses (EDF) 16 bits
eepromRdDtata EEPROM read data received in read accesses (EDF) 16 bits

spi SPI instance used for T-Format implementation Pointer to Spi*Regs
sdata Internal variables used by library – for debug purposes Array of 32-bit, unsigned integers
rdata Internal variables used by library – for debug purposes Array of 32-bit, unsigned integers

dataReady Flag indicating dataReady – set by the
PM_tformat_receiveData function, cleared by the

PM_tformat_setupCommand function

0 or 1

fifo_level Internal variables used by library – for debug purposes Maximum value 8
rxPkts Received data in packed 32-bit packets 32 bits

http://www.ti.com
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2.3.3.4 PM T-Format Library Function Details
PM_tformat_generateCRCTable
Description:

This function generates a table of 256 entries for a given CRC polynomial (polynomial) with a specified
number of bits (nBits). Generated tables are stored at the address specified by pTable.

Definition:
void PM_tformat_generateCRCTable(uint16_t nBits, uint16_t polynomial, uint16_t *pTable)

Parameters:

INPUT RETURN
nBits Number of bits of the given polynomial

Nonepolynomial Polynomial used for CRC calculations
pTable Pointer to the table where the CRC table

values are stored

Use:
#define NBITS_POLY1 8
#define POLY1 0x01
#define SIZEOFTABLE 256
uint16_t tformatCRCtable[SIZEOFTABLE];

// Generate table for poly 1
PM_tformat_generateCRCTable(

NBITS_POLY1,
POLY1,
tformatCRCtable);

http://www.ti.com
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PM_tformat_getCrc
Description:

Calculate CRC of a message buffer by using the lookup table, to get the CRC of each byte.

Definition:
uint32_t PM_tformat_getCrc (uint16_t input_crc_accum, uint16_t nBitsData, uint16_t nBitsPoly,
uint16_t * msg, uint16_t *crc_table, uint16_t rxLen)

Parameters:

INPUT
input_crc_accum Initial CRC value (seed) for CRC calculation

nBitsData Number of bits of data for which the CRC needs are calculated
nBitsPoly Number of bits of polynomial used for CRC computations

msg Pointer to the data on which CRC is computed
crc_table Pointer to the table where the CRC table values are stored

rxLen Number of bytes of data for CRC calculation
crc n-bit CRC value calculated

Use:

Define t-format data structure during initialization.

TFORMAT_DATA_STRUCT tformatData;

Example code:
crcResult = PM_tformat_getCRC( 0, // Initial seed

nBits, // number of bits of data
NBITS_POLY1, // polynomial bits
(uint16_t *)& tformatData.rxPkts, // Pointer to data array
tformatCRCtable, // CRC table with polynomial
4); // number of bytes

http://www.ti.com
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PM_tformat_setupCommand
Description:

Set up an SPI and other modules for a given command to be transmitted. All the transactions must start
with this command. This function call sets up the peripherals for the upcoming transfer, but does not
actually perform any transfer or activity on the interface. This function call populates the sdata array of
TFORMAT_DATA_STRUCT, with the data to be transmitted to the encoder.

Definition:
void Val = PM_tformat_setupCommand (uint16_t dataID, uint16_t eepromAddr, uint16_t eepromData,
uint16_t crc);

Parameters:

INPUT RETURN
dataID Mode command for the transfer

to be done

Val

If incorrect, command value is
passed to this function, which

would return zero. For all other
cases function returns a value of

one.

eepromAddr EEPROM address, depending
on the mode command for the

read or write address
eepromData EEPROM data, depending on

the mode command for write
access

crc CRC value to be sent to the
encoder in case of EEPROM

accesses

Use:

Example code:
Val = PM_tformat_setupCommand (DATAIDD, address, 0, crcResult); PM_tformat_startOperation();
while (tformatData.dataReady != 1) {}
retval1 = PM_tformat_receiveData(DATAIDD);
crcResult = PM_tformat_getCRC(0, 32, 8, (uint16_t *)&tformatData.rxPkts, tformatCRCtable, 4);
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PM_tformat_receiveData
Description:

Function for unpacking and populating the T-Format data structure with the data received from the
encoder. This function is called when the data from the encoder is available in the SPI data buffer and
transferred to the rdata array of TFORMAT_DATA_STRUCT. Upon the function call, received data is
unpacked, as per the current command, and unpacked results are stored accordingly.

NOTE: The format for transfer of position values varies in length, depending on the encoder model.
The encoder transmits the position value with the LSB first. For further details, see the
encoder documentation provided by the manufacturer.

Definition:
uint16_t PM_tformat_receiveData (uint16_t dataID);

Parameters:

INPUT RETURN

dataID

Mode command for the T-
Format transfer is done. This

function must be called with the
same mode command that was

used to initiate the transfer.

val

If the incorrect command value is
passed to this function, it returns

zero. For all other cases, the
function returns a value of one.

Use:

Example code:
retval1 = PM_tformat_setupCommand (DATAID3, 0, 0, 0); PM_tformat_startOperation();
while (tformatData.dataReady != 1) {}
retval1 = PM_tformat_receiveData(DATAID3);
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PM_tformat_startOperation
Description:

This function initiates the transfer to the encoder. This function must only be called after
PM_tformat_setupCommand. Therefore, the PM_tformat_startOperation function starts the transaction
that was set up earlier by PM_tformat_setupCommand. The setup and start operation are separate
function calls. Users can set up the transfer when needed and start the actual transfer using this function
call, as needed, at a different time.

Definition:
void PM_tformat_startOperation(void);

Parameters:

INPUT RETURN
None None

Use:

Example code:
retval1 = PM_tformat_setupCommand (DATAIDD, address, 0, crcResult); PM_tformat_startOperation();
while (tformatData.dataReady != 1) {}
retval1 = PM_tformat_receiveData(DATAIDD);

This function clears the tformatData.dataReady flag zero when called. This flag must subsequently be set
by the SPI interrupt service routine when the data is received from the encoder. Users can poll for this flag
to know if the data from the encoder is successfully received after the PM_tformat_startOperation function
call.
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PM_tformat_setupPeriph
Description:

Setup for SPI, CLB, and other interconnect XBARs for T-Format are performed with this function during
system initialization. This function must be called after every system reset. No T-Format transactions are
performed until the set-up peripheral function is called.

Definition:
void PM_tformat_setupPeriph (void);

Parameters:

INPUT RETURN
None None

Use:

Example code:
tformatData.spi = &SpibRegs;
PM_tformat_setupPeriph();

The PM T-Format library uses an instance of SPI for communication. For proper initialization, the SPI
instance must be set in tformatData.spi before calling this function, as previously shown.
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PM_tformat_setFreq
Description:

This function sets the T-Format clock frequency. The T-Format transactions occur at a fixed data rate of
2.5 MBPS.

Definition:
void PM_tformat_setFreq(uint32_t Freq_us);
Data Rate = SYSCLK/(4* Freq_us)

Parameters:

INPUT RETURN

—
Freq_us: A clock divider for the system clock

sets T-Format Clock Frequency =
SYSCLK/(4*Freq_us)

None

Use:

Example code:
PM_tformat_setFreq(TFORMAT_FREQ_DIVIDER);
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3 Hardware, Software, Testing Requirements, and Test Results

3.1 Required Hardware and Software

3.1.1 Hardware
This section describes the hardware specifics of the TIDM-1011 device and how to get started with the T-
Format Library in CCS.

To experiment with the TIDM-1011 device, the following components are required:
• TIDM-1011 EVM board
• External, 5-V, DC power supply (see Table 1)
• F28379D LaunchPad development kit (LAUNCHXL-F28379D)
• USB-B to A cable
• T-Format Encoder from Tamagawa (for example, TS5700N8501)
• 4-pin cable from Tamagawa – length as required by the application (maximum 100 m)
• Custom adapter to connect Tamagawa, 4-position, female-terminated cable to wire leads adapter
• PC with CCS (CCS v6 or greater) installed
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3.1.1.1 TIDM-1011 Jumper Configuration
Figure 5 shows the jumper configuration for TIDM-1011 board.

Figure 5. TIDM-1011/Position Manager BoosterPack Jumper Configuration
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Table 6 lists the jumper configuration for the TIDM-1011 board.

(1) This configuration requires providing an external power source to J6, as shown in Figure 5.
(2) This jumper is for a future reference design.

Table 6. TIDM-1011 Board Jumper Details

JUMPER FUNCTION POSITION
J5 TIDM-1011, 5-V, power-plane source

selection
External (1)

J9 Abs-Enc-1, master-slave mode selection Master (2)

J11 Sine-Cosine, encoder-A signal enable Open
J12 Sine-Cosine, encoder-B signal enable Open[3]
J13 Sine-Cosine, encoder-index signal enable Open[3]

3.1.2 Software
This section describes how to configure the software environment for the F28379D LaunchPad.

3.1.2.1 Installing Code Composer Studio™ and controlSUITE™
1. Install CCS v6.x or later, if it is not already on the PC.
2. Go to http://www.ti.com/controlsuite and run the controlSUITE installer. Allow the installer to download

and update any automatically-checked software for the C2000.
3. After installation, see Section 2.3.3 for more information on the T-Format Library.

3.1.2.2 Configuring CCS for F28379D LaunchPad™
1. Open CCS. This document assumes that version 6 or later is used.
2. When CCS opens, the workspace launcher may ask users to select a workspace location. The

workspace is a location on the hard drive where all the user settings for the IDE (which projects are
open), what configuration is selected, and so forth are saved. This workspace can be anywhere on the
disk. The following location mentioned is just for reference.
1. Click the Browse… button.
2. Create the following path by making new folders as necessary:

C:\c2000 projects\CCSv6_workspaces\PM_tformat_eval_workspace

3. Uncheck the box that says Use this as the default and do not ask again.
4. Click the OK button.

A Getting Started tab opens with links to various tasks from creating a new project, importing an
existing project, and watching a tutorial on CCS. Users can close the Getting Started tab, and go to
next step. CCS is configured to know which MCU the program is connecting to. This configuration is
done by setting up the Target Configuration.

3. A new configuration file can be set by clicking View → Target Configuration. This procedure opens the
Target Configuration window (see Figure 6).

4. In this window, click on the icon. Name the new configuration file depending on the target device. If
the Use shared location checkbox is checked, then this configuration file can be stored in a common
location by CCS for use by other projects as well. Then, click Finish.
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This step opens a new tab, as shown in Figure 6.
5. Select and enter the following options:

a. Connection – Texas Instruments XDS100v2 USB Emulator or Texas Instruments XDS100v2 USB
Debug Probe

b. Device – C2000 MCU on the control card, for example, TMS320F28379D
c. Click the Save button and close.

Figure 6. Configuring New Target Configuration

6. Click View → Target Configurations.
7. In the User Defined section, find the file that was created in Steps 6 and 7. Right-click on this file, and

select Set as Default. To use the configuration file supplied with the project:
1. Click View → Target Configurations
2. Expand Projects → PM_tformat_systemtest.
3. Right-click on the xds100v2_F2837x.ccxml and Set as Default files.

This tab also allows users to reuse the existing target configurations and links them to specific projects.
8. Add the PM T-Format evaluation example project into the current workspace by clicking Project →

Import CCS Project.
9. Select the project by browsing to C:\ti\controlSUITE\development_kits\BOOSTXL_POSMGR (see

Figure 7).
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Figure 7. Adding PM T-Format Example Project to Workspace

10. If there are multiple projects in this directory, choose the projects to import and then click the Finish
button. This action copies all of the selected projects into the workspace.

11. Assuming this is the first-use of CCS, xds100v2-F2837x should have been set as the default target
configuration. Verify this setting by viewing the xds100v2-f2837x.ccxml file in the expanded project
structure and observe an Active or Default status written next to file. By going to View → Target
Configurations, the user can edit existing target configurations or change the default or active
configuration. The user can also link a target configuration to a project in the workspace by right-
clicking on the target configuration name and selecting Link to Project.

12. The project can be configured to create code and run in either Flash or RAM. Either of the two can be
selected, however, RAM configuration is used most of the time for lab experiments and Flash
configuration for production. As shown in Figure 8, right-click on an individual project and select Active
Build Configuration → CPU1_RAM configuration.

Figure 8. Selecting F2837x_ RAM Configuration
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3.1.2.3 Using PM_tformat Library in New or Existing Project

NOTE: Users with an existing project in CCS can skip Step 1.

1. Create a new project by going to File → New → CCS Project. Under target, choose the device
TMS320F28379D. Name the project and select a project template. Then, click finish.

2. Include the T-Format library in {ProjectName}-Includes.h.
#include "PM_tformat_Include.h"

3. Add the PM_tformat library path in the include paths under Project Properties → Build → C2000
Compiler → Include Options. Path for the library:
C:\ti\controlSUITE\libs\app_libs\position_manager\v1_00_00_00\tformat\Float\lib (see Figure 9).

Figure 9. Compiler Options for Project Using PM T-Format Library

NOTE: The exact location may vary, depending on where controlSUITE is installed and which other
libraries the project is using.
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4. Figure 10 shows how to add the PM T-Format Library to Linker Options in a CCS Project

Figure 10. Adding PM T-Format Library to Linker Options in CCS Project

5. Initialization steps: The following steps are needed for initialization and proper functioning of the T-
Format library functions. For more details, see the examples provided with the library.
1. Create and add the module structure to {ProjectName}-Main.c.

TFORMAT_DATA_STRUCT tformatData; //PM tformat data structure

2. Define the frequency of the clock divider.
#define TFORMAT_FREQ_DIVIDER 20

3. Set the SPI instance to be used for communication. For use on the F28379D LaunchPad, the SPI
instance must be set to SpiB, and the SpiB receive FIFO interrupt must be enabled.

tformatData.spi = &SpibRegs;
PieVectTable.SPIB_RX_INT = &spiRxFifoIsr;
PieCtrlRegs.PIECTRL.bit.ENPIE = 1; //Enable PIE block PieCtrlRegs.PIEIER6.bit.INTx3 = 1;
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// Enable PIE Group 6, INT 9
IER = 0x20; // Enable CPU INT6
EINT;

NOTE: Alternatively, users can also poll for the Interrupt Flag and not necessarily use interrupt.
Ensure the SPIRXFIFO contents are copied into tformatData.rdata after the flag is set.
This step must be executed before calling the PM_tformat_receiveData function. Also,
the interrupt flag must be cleared to get the SPI ready for the next T-Format transaction.
for (i=0;i<=tformatData.fifo_level;i++){tformatData.rdata[i]=
tformatData.spi->SPIRXBUF;}
tformatData.spi->SPIFFRX.bit.RXFFINTCLR=1; // Clear Interrupt flag

4. Enable clocks to EPWM instances 1, 2, 3 and 4.
tformatData.spi = &SpibRegs;
PM_tformat_setupPeriph();

5. Initialize and set up peripheral configuration by calling the PM_tformat_setupPeriph function.
tformatData.spi = &SpibRegs;
PM_tformat_setupPeriph();

6. Set up GPIOs needed for configuration, which is required for the F28379D LaunchPad. The GPIOs
used for SPI must be changed based on the chosen SPI instance. GPIO6, GPIO7, and GPIO34
must always be configured.

GpioCtrlRegs.GPAMUX1.bit.GPIO6 = 1; // Configure GPIO6 as SPI Clk master
GpioCtrlRegs.GPAGMUX2.bit.GPIO24 = 1;
GpioCtrlRegs.GPAGMUX2.bit.GPIO25 = 1;
GpioCtrlRegs.GPAGMUX2.bit.GPIO26 = 1;
GpioCtrlRegs.GPAGMUX2.bit.GPIO27 = 1;
GpioCtrlRegs.GPAMUX2.bit.GPIO24 = 2; // Configure GPIO24 as SPISIMOB
GpioCtrlRegs.GPAMUX2.bit.GPIO25 = 2; // Configure GPIO25 as SPISOMIB
GpioCtrlRegs.GPAMUX2.bit.GPIO26 = 2; // Configure GPIO26 as SPICLKB
GpioCtrlRegs.GPAMUX2.bit.GPIO27 = 2; // Configure GPIO27 as SPISTEB
GpioCtrlRegs.GPAQSEL2.bit.GPIO24 = 3; // Asynch input GPIO24 (SPISIMOB)
GpioCtrlRegs.GPAQSEL2.bit.GPIO25 = 3; // Asynch input GPIO25 (SPISOMIB)
GpioCtrlRegs.GPAQSEL2.bit.GPIO26 = 3; // Asynch input GPIO26 (SPICLKB)
GpioCtrlRegs.GPAQSEL2.bit.GPIO27 = 3; // Asynch input GPIO27 (SPISTEB)
GpioCtrlRegs.GPBMUX1.bit.GPIO34 = 1; // Configure GPIO34 as TxEN
GpioCtrlRegs.GPBDIR.bit.GPIO32 = 1; // Configure GPIO32 as Pwr Ctl

7. Set up XBAR, shown as follows. The GPIOs used for the SPI must be changed based on the
chosen SPI instance.

//SPISIMOB on GPIO24 connected to CLB4 i/p 1 via XTRIP and CLB X-Bars
//XTRIP1 is used inside the CLB for monitoring received data from Encoder.

InputXbarRegs.INPUT1SELECT = 24; // GPTRIP XBAR TRIP1 -> GPIO24

8. Initialize CRC-related object and table generation:
//CRC tables to be used for CRC calculations
uint16_t table1[SIZEOFTABLE];

// Generate table for poly 1 and generated tables are placed in
tformatCRCtable(NBITS_POLY1, POLY1, tformatCRCtable);

-- Constants are defined in PM_tformat_Include.h as below.
#define NBITS_POLY1 8
#define POLY1 0x01
#define SIZEOFTABLE 256

9. Turn the power ON. The GPIO used for power control can be changed based on the hardware.
GPIO32 is used for power control on the F28379D LaunchPad.

// Power up 5v supply through GPIO32
GpioDataRegs.GPBDAT.bit.GPIO32 = 1;
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3.2 Testing and Results

3.2.1 Test Setup

3.2.1.1 Hardware Configuration
1. Ensure that the jumper configuration of the TIDM-1011 device is as described in Table 6.
2. Connect the TIDM-1011 device to the LaunchPad using the BoosterPack connector (J1 to J3 and J4 to

J2). Ensure the TIDM-1011 device is connected to site two of the LaunchPad, as shown in Figure 11.

Figure 11. Position Manager BoosterPack Connected to Site Two of LaunchPad™

3. Connect the USB cable to the LaunchPad.
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4. Set up the connection to the encoder.
1. Prepare an adapter to connect the Tamagawa cable to the T-Format interface using a 8-position

female to wire the leads adapter (see the BOM for the header used for the encoder connector, J7).
2. Insert the header of the adaptor, created in the previous step, to connect to Abs-Enc-1 (J7). The

female end of the Tamagawa cable connects to the encoder. Figure 12 shows the pinout of J7.

Figure 12. Abs-Enc-1 (J7) Pinout on TIDM-1011 Board

5. Supply 5-V DC and GND to J6, as shown in Figure 5. The board should now look like Figure 13. LED
D18 should be lit, which shows that the board has power.

Figure 13. Position Manager BoosterPack Powered On and Connected to Tamagawa Encoder
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3.2.2 Test Results
This section describes how to run the software example and detail the results in CCS. Figure 14 shows
the software flow diagram for this project.

Figure 14. Software Flow Diagram for Example Project PM_tformat_systemtest
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3.2.2.1 Building and Loading Project
1. Open the tformat.h file and ensure that TFORMAT_FREQ_DIVIDER is set as needed; save this file.

For more details, see the C2000 Position Manager T-Format Library Module User's Guide.
2. Right-click on the Project Name and select Rebuild Project, then watch the Console window. Any

errors in the project are displayed in the Console window.

3. On successful completion of the build, click the Debug button , (located in the top-left side of the
screen).

4. The following window may pop up, requesting that users select which of the two CPUs (in F28379x) to
connect to (see Figure 15), if it is the first time that the project is used. Select CPU1 by clicking the box
next to it.

Figure 15. Selecting the CPU(s) to Connect

The IDE automatically connects to the target, loads the output file into the device, and changes to the
Debug perspective.

5. Click Tools → Debugger Options → Program / Memory Load Options. Users can enable the debugger
to reset the processor each time it reloads the program by checking Reset the target on program load
or restart and clicking Remember My Settings, to make this setting permanent.

6. Click on the Enable silicon real-time mode button , which auto selects the Enable polite real-time
mode button .
This option allows users to edit and view variables in real time. Do not reset the CPU without disabling
these real-time options.

7. Select YES to enable debug events if a message box appears. This action sets bit 1, the debug enable
mask (DGBM) bit, of the status register 1 (ST1) to 0. When the DGBM bit is set to 0, memory and
register values can be passed to the host processor for updating the debugger windows.
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3.2.2.2 Setting Up Watch Window and Graphs
1. Click View → Expressions on the menu bar to open a watch window, to view the variables being used

in the project.
2. Add variables to the watch window, as shown in Figure 16. The window uses the number format

associated with the variables during declaration. Users can select a desired number format for the
variable by right-clicking on it and choosing. Configure the expressions window as shown in Figure 16.

Figure 16. Configuring Expressions Window

Alternately, a group of variables can be imported into the Expressions window, by:
1. Right-clicking in the Expressions Window and clicking Import.
2. Browse to the .txt file containing these variables.
3. Browse to the root directory of the project and pick PM_tformat_systemtest_VAR.txt, and then click
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OK to import the variables shown.
4. Click on the Continuous Refresh button , in the watch window.

This action enables the window to run in real-time mode. By clicking the down arrow in this watch window,
users can select Customize Continuous Refresh Interval and edit the refresh rate of the watch window.
Choosing too fast an interval may affect performance.

3.2.2.3 Running Code
1. Run the code by pressing the Run button , in the Debug tab.

The project should run and the values in the watch window should continuously update. The following
are screen captures of typical CCS perspectives while using this project. Users may want to resize the
windows according to their preference.

2. Once complete, reset the processor (Run → Reset → CPU Reset) , and terminate the debug
session by clicking (Run → Terminate) . This halts the program and disconnects Code Composer
Studio from the MCU.

3. As the encoder sends the position information, observe the same in the watch window, turns variables.
4. If the encoder is not mounted on a spinning Motor, users can manually rotate the encoder shaft and

observe the position changing in the watch window.
5. It is not necessary to terminate the debug session each time code is change or ran. Instead, follow this

procedure:
1. After rebuilding the project, (Run → Reset → CPU Reset) , (Run → Restart) , and enable

real-time options.
2. Once complete, disable real-time options and reset the CPU.
3. Terminate the project if the target device or the configuration is changed (Ram to flash or flash to

Ram) and before shutting down CCS.
6. Customize the project to meet your encoder and application requirements. Change the encoder type in

the encoder.h file.
7. Modify the example code as needed and perform tests with different cable lengths.

3.2.2.4 Cable Length Validation
Table 7 lists tests with various types of encoders; cable length tests are performed. Tests include basic
command-set exercising and reading-position values, with additional data if applicable.

(1) Cable lengths up to 100 m have also been tested with some of the encoders.

Table 7. Cable Length Test Report

ENCODER NAME TYPE RESOLUTION
(BITS)

CABLE LENGTH (1)

(m)
MAXIMUM T-

FORMAT CLOCK
TEST RESULT

TS5643N100 Rotary 17 bits 70 m 2.5 MBPS Pass
TS5700N8501 Rotary 24 bits 70 m 2.5 MBPS Pass
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4 Design Files
To download the design files, see the product page at TIDM-1011.

5 Software Files
See Section 3.1.2.3.

6 Related Documentation

1. Texas Instruments, Position Manager T-Format Library Module, user's guide
2. Texas Instruments, Using Position Manager T-Format Library on IDDK Hardware and Software, user's

guide
3. Texas Instruments, C2000 DesignDRIVE, software for Industrial Drives and Motor Control
4. Texas Instruments, C2000 Position Manager SinCos Library, user's guide

6.1 Trademarks
C2000, BoosterPack, E2E, Delfino, controlSUITE are trademarks of Texas Instruments.
LaunchPad is a trademark of Texas Instruments Incorporated.
All other trademarks are the property of their respective owners.

7 Terminology
C28x— Refers to devices with the C28x CPU core

CLB— Configurable logic block

Position Manager BoosterPack — Future EVM for interfacing with various position encoders. The TIDM-
1011 board is identical to the Position Manager BoosterPack EVM (see Section 2.3.1)

CRC— Cyclic redundancy check

T-Format— T-Format specification of the encoder interface protocol by Tamagawa

Subsequent Electronics— T-Format Master implementation

PM— Position Manager – foundational hardware and software on C28x devices for position encoder
interfaces

PM_tformat— Prefix used for all the library functions

SPI— Serial peripheral interface

8 About the Authors
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Engineer.
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other intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information
regarding or referencing third-party products or services does not constitute a license to use such products or services, or a warranty or
endorsement thereof. Use of TI Resources may require a license from a third party under the patents or other intellectual property of the
third party, or a license from TI under the patents or other intellectual property of TI.
TI RESOURCES ARE PROVIDED “AS IS” AND WITH ALL FAULTS. TI DISCLAIMS ALL OTHER WARRANTIES OR
REPRESENTATIONS, EXPRESS OR IMPLIED, REGARDING TI RESOURCES OR USE THEREOF, INCLUDING BUT NOT LIMITED TO
ACCURACY OR COMPLETENESS, TITLE, ANY EPIDEMIC FAILURE WARRANTY AND ANY IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT OF ANY THIRD PARTY INTELLECTUAL
PROPERTY RIGHTS.
TI SHALL NOT BE LIABLE FOR AND SHALL NOT DEFEND OR INDEMNIFY YOU AGAINST ANY CLAIM, INCLUDING BUT NOT
LIMITED TO ANY INFRINGEMENT CLAIM THAT RELATES TO OR IS BASED ON ANY COMBINATION OF PRODUCTS EVEN IF
DESCRIBED IN TI RESOURCES OR OTHERWISE. IN NO EVENT SHALL TI BE LIABLE FOR ANY ACTUAL, DIRECT, SPECIAL,
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compliance with the terms and provisions of this Notice.
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