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FMP Demo

See Also

Demo Overview
This demo allows users to evaluate TI's CC256x Bluetooth device by using the PAN1323EMK kit and the MSP-EXP430F5438 board. The CC256x+MSP430 Bluetooth sample applications are

provided to enable a rich out-of-box experience to the user. These applications allow the user to use a console to send Bluetooth commands, setup a Bluetooth Device to accept connections,

connect to a remote Bluetooth device, and communicate over Bluetooth.

Requirements

CC256xQFNEM (http://www.ti.com/tool/cc256xqfnem)

Hardware

https://processors.wiki.ti.com/index.php/File:SS1MSP430ClientServer.jpg
http://www.ti.com/tool/cc256xqfnem
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MSP-EXP430F5438 Experimenter Board (http://www.ti.com/tool/msp-exp430f5438)

Note 1: For downloading the sample demos to the EVM, you require MSP430 USB Debugging Interface (http://www.ti.com/tool/msp-fet430uif). This needs to be purchased separately.

Note 2: Hardware depends on the application, specific demos will have detailed hardware configurations. But all the APPS should work with the hardware listed above.

CC256x+MSP430 Bluetooth Software - Contains the Sample Applications - Download (http://www.ti.com/tool/tibluetoothstack-sdk)
Lite FET-Pro430 Tool - To flash the example code in the MSP430 chip - Download (http://www.elprotronic.com/download.html)

Hardware Setup

a) Connect the CC256x board PAN1323ETU (http://www.panasonic.com/industrial/electronic-components/rf-modules/bluetooth/pan1323etu.aspx)onto the
MSP-EXP430F5438 board (http://www.ti.com/tool/msp-exp430f5438) using the RF1/RF2 connectors (RF EVM connectors)

b) Place the included jumper block on RF3 connector.

c) Make sure that JP1, JP2, JP3, JP4 and JP5 are as shown in the picture below.

d) Make sure the other default jumper configuration remains on your MSP-EXP430F5438 board

Software

MSP430F5438 Experimenter’s Board

http://www.ti.com/tool/msp-exp430f5438
http://www.ti.com/tool/msp-fet430uif
http://www.ti.com/tool/tibluetoothstack-sdk
http://www.elprotronic.com/download.html
http://www.panasonic.com/industrial/electronic-components/rf-modules/bluetooth/pan1323etu.aspx
http://www.ti.com/tool/msp-exp430f5438
https://processors.wiki.ti.com/index.php/File:SS1MSP430Board.jpg
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a) On Windows-7, please run the windows applications in administrator mode.

b) Connect the RF256xT Target Board to the USB board. The picture below shows the connected boards.

EZ430-RF256x

https://processors.wiki.ti.com/index.php/File:SS1MSP430Board.jpg
https://processors.wiki.ti.com/index.php/File:EZE-430_Editable.png
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a) Connect the CC256x board PAN1323ETU (http://www.panasonic.com/industrial/electronic-components/rf-modules/bluetooth/pan1323etu.aspx)onto the
MSP-EXP430F5529 board (http://www.ti.com/tool/msp-exp430f5529) using the RF1/RF2 connectors (RF EVM connectors)

b) Remove the JP3 Jumper.

c) In J12, make sure Pin 3 to Pin 4 (P1.0 to P2.0), Pin 5 to Pin 6 (P4.4 to P4.0), Pin 7 to Pin 8 (P4.5 to P4.6), Pin 9 to Pin 10 (P4.7 to P2.4) are connected as
shown in the picture.

d) Make sure the other default jumper configuration remains on your MSP-EXP430F5529 board

MSP430F5529 Experimenter’s Board

https://processors.wiki.ti.com/index.php/File:EZE-430_Editable.png
http://www.panasonic.com/industrial/electronic-components/rf-modules/bluetooth/pan1323etu.aspx
http://www.ti.com/tool/msp-exp430f5529
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To use the CC256XB module, the patch CC256XB.h has to be included. To make sure this patch is included, in BTPSVend.C add a line

#define __SUPPORT_CC256XB_PATCH__

This will make sure that the CC256XB patch is loaded and the CC256XB module can be used without issues.

CC256XB Information

https://processors.wiki.ti.com/index.php/File:MSP4305529_Editable.png
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Software Setup

The Bluetooth SDK can be downloaded from here (http://www.ti.com/tool/tibluetoothstack-sdk). You will be prompted for a TI login when you try to download the SDK. If you don't already have

a TI login you will be asked to create one. After creating a TI login you will need to complete the export approval form. After completing the form a request will be submitted to TI for approval.

After the request is approved you will see a confirmation on the next page and be provided with a link to download the software. Click the "Download" button to start the download.

After the download completes run the setup file (e.g. CC256x_MSP430_Bluetopia_SDK_vx_x_Setup.exe). The setup process will ask you to accept the TI Bluetooth Stack Clickwrap License

Agreement. After accepting the license agreement the SDK will be installed to "C:\TI\Connectivity\CC256X BT\CC256x MSP430 Bluetopia SDK\". The SDK can be accessed using Start /

Programs / Texas Instruments / CC256x MSP430 Bluetopia SDK v x.x.

You now have access to sample applications' source code as well as binaries to flash directly to your MSP430 board.

Customers can use MSP430 Flasher with MSP430DLLV3 after updating the firmware of FET430 USB Emulator. For instructions visit MSP430 FET430 setup

You can use the included batch file Flash_CC256x_MSP430_Bluetopia.bat to flash the software The flashing tool (MSP430Flasher.exe) and documentation (MSP430Flasher_Doc.pdf) are

available under Tools folder at the install location.

Once MSP430Flasher tool is ready to flash the code, you can use the included batch file or the shortcut Flash_CC256x_MSP430_Bluetopia.bat to flash the BR/EDR SPP sample application to the

board.

All the demo apps have support for EZ430. Here is the software configurations for the demos:

a) Go to TI's_Bluetooth_Stack_Version-Number_MSP430\MSP430_Experimentor\Samples. Here you will see a list of samples.

b) Select the demo that you want to load on the device. For our example we will use SPPDemo

c) Navigate to Projects->IAR and select SPPDemo.eww . The IDE should open.

Downloading and Installing the Software

Flashing the Bluetooth Code

Platform Specific

EZ430

IAR

http://www.ti.com/tool/tibluetoothstack-sdk
https://processors.wiki.ti.com/index.php/MSP_Debug_Stack#Upgrade_process_to_MSP430.DLLv3


11/10/21, 7:33 PM CC256x MSP430 TI Bluetooth Stack - Texas Instruments Wiki

https://processors.wiki.ti.com/index.php/CC256x_MSP430_TI_Bluetooth_Stack 8/22

d) In the workspace tab, the configurations to load the device should be present. From the dropdown menu, select either debug or release configurations for
EZE-430. In our case we select, Debug-EZE 430.

e) Select download and debug(make sure that the EZE-430 device is conencted) by either clicking on the Play icon or selecting Project->Download and
Debug.

f) Let the IDE debug and load the software on the device. This may take 5-10 minutes. Once it is done debugging, click on the X on the IDE to stop
debugging.

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-1.png
https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-2.png
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g) The software is now ready to use. To begin using the profile disconnect and reconnect the EZE-430 after flashing.

a) Open Code Composer Studio 5. Select File->Switch Workspace. Navigate to the folder where the TI's Bluetooth Stack Samples are located and make a
new folder for the workspace.

CCS

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-3.png
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CCS will now exit and reload the software. Each time you load a project it is preferable to create a new workspace for it.

b) Select Project-> Import Existing CCS Eclipse project. In the select Auto search directory point to the TI's_Bluetooth_Stack_Version-
Number_MSP430\MSP430_Experimentor\Samples folder. CCS will recognize all available profiles. Select all profiles and hit finish. (If you prefer you can
selectively load the profiles you want).

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-4.png
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c) The projects should load on the left in Project Explorer. Click on the profile that you want to load. By default it should select the Debug, MSP 430
configuration for the profile. To change the configuration, right click on the profile-> Build Configurations -> Set Active. Select either the debug or release
configuration for EZE-430.

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-5.png
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d) To begin flashing the device, select from the toolbar  -> Debug as -> Code composer session. Let the IDE debug and load the software on the
device. This may take 5-10 minutes. Once it is done debugging, click on the stop button on the IDE to stop debugging.

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-6.png
https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-7.png
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e) The software is now ready to use. To begin using the profile disconnect and reconnect the EZE-430 after flashing.

a) Go to TI's_Bluetooth_Stack_Version-Number_MSP430\MSP430_Experimentor\Samples. Here you will see a list of samples.

b) Select the demo that you want to load on the device. For our example we will use SPPDemo

MSP430F5438/MSP430F5529

IAR

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-8.png
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c) Navigate to Projects->IAR and select SPPDemo.eww . The IDE should open.

d) In the workspace tab, the configurations to load the device should be present. From the dropdown menu, select either debug or release configurations for
EZE-430. In our case we select, Debug-MSP430F5438A.

e) Select download and debug(make sure that the MSP430 device is conencted) by either clicking on the Play icon or selecting Project->Download and
Debug.

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-1.png
https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-10.png
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f) Let the IDE debug and load the software on the device. This may take 5-10 minutes. Once it is done debugging, click on the X on the IDE to stop
debugging.

g) The software is now ready to use. To begin using the profile disconnect and reconnect the MSP430 after flashing.

Note: The MSP430F5529 is not supported with CCS due to code size limitations.

a) Open Code Composer Studio 5. Select File->Switch Workspace. Navigate to the folder where the TI’s Bluetooth stack Samples are located and make a
new folder for the workspace.

CCS

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-3.png
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CCS will now exit and reload the software. Each time you load a project it is preferable to create a new workspace for it.

b) Select Project-> Import Existing CCS Eclipse project. In the select Auto search directory point to the TI's_Bluetooth_Stack_Version-
Number_MSP430\MSP430_Experimentor\Samples folder. CCS will recognize all available profiles. Select all profiles and hit finish. (If you prefer you can
selectively load the profiles you want).

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-4.png
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c) The projects should load on the left in Project Explorer. Click on the profile that you want to load. By default it should select the Debug, MSP 430
configuration for the profile. To change the configuration, right click on the profile-> Build Configurations -> Set Active. Select either the debug or release
configuration for MSP430.

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-5.png
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d) To begin flashing the device, select from the toolbar  -> Debug as -> Code composer session. Let the IDE debug and load the software on the
device. This may take 5-10 minutes. Once it is done debugging, click on the stop button on the IDE to stop debugging.

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-9.png
https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-7.png
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e) The software is now ready to use. To begin using the profile disconnect and reconnect the MSP430 after flashing.

Demos

This application shows how to utilize the SPP module and also how handle the different callback events. The application can be used to interface with a remote SPP Client or Server.

Classic Bluetooth Demos

SPP Demo

https://processors.wiki.ti.com/index.php/File:Getting_Started_Guide-SS1-8.png
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For a step by step demonstration on how to run this application visit the SPP Demo Wiki.

The human interface device enables a host to connect and control a HID device.
For a step by step demonstration on how to run this application visit the HID Demo Wiki.

The Assisted Advanced Audio Distribution Profile shows how to send stereo audio over Bluetooth.
For a step by step demonstration on how to run this application for the Sink Role visit the A3DP Demo Sink Wiki

For a step by step demonstration on how to run this application for the Source Role visit the A3DP Demo Source Wiki

The A3DP MultiRoom demo allows us to stream high quality audio to 2 different speakers at the same time.
For a step by step demonstration on how to run the MultiRoom application visit the A3DP MultiRoom Demo Wiki.

The Hands Free Profile shows how to provide remote control and voice connections over Bluetooth to a mobile device. This profile supports the HandsFree Role.
For a step by step demonstration on how to run this application visit the HFP Demo Wiki

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample emulates using SPP over LE using the GATT Profile. This sample acts as a LE Master and LE Slave.
This application also shows how to utilize the SPP module and how to handle the different SPP callback events. This will act as either a SPP Server or SPP Client and exposes the same
command set for SPP as the SPPDemo.
For a step by step demonstration on how to run this application visit the SPP + SPPLE Demo Wiki.

The KeyFobDemo is used to demonstrate button press or accelerometer data over LE.
For a step by step demonstration on how to run this application visit the KeyFob Demo Wiki.

The SPPLE Lite demo is a server-only version of SPP LE where, in addition to supporting the SPP LE protocol, the classic Bluetooth profile SPP is also initialized as a server, and the device
is ready to accept connections over classic Bluetooth (a.k.a. BR/EDR) or Bluetooth Low Energy (BLE).
For a step by step demonstration on how to run this application visit the SPPLE Demo Lite Wiki.

HID Demo

A3DP Demo

A3DP MultiRoom Demo

HFP Demo

Classic BT + BLE Demos

SPP + SPPLE Demo

KeyFob Demo

SPPLE Demo Lite

https://processors.wiki.ti.com/index.php/CC256x_MSP430_TI%27s_Bluetooth_Stack_Basic_SPPDemo_APP
https://processors.wiki.ti.com/index.php/CC256x_MSP430_TI%27s_Bluetooth_Stack_Basic_HIDDemo_APP
https://processors.wiki.ti.com/index.php/CC256x_MSP430_TI%27s_Bluetooth_Stack_Basic_AssistedA2DPSinkDemo_APP
https://processors.wiki.ti.com/index.php/CC256x_MSP430_TI%27s_Bluetooth_Stack_Basic_AssistedA2DPSourceDemo_APP
https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_AssistedA2DPSinkMultiRoomDemo_App
https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_HFPDemo_App
https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_SPPLEDemo_App
https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_KeyFobDemo_App
https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_SPPLEDemo_Lite_App
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This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the Alert Notification Profile (ANP) using the GATT profile. This sample acts as a LE
Master and LE Slave.
For a step by step demonstration on how to run this application visit the ANP Demo Wiki.

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the Heart Rate Monitoring Profile (HRP) using the GATT profile. This sample acts as a
LE Master and LE Slave.
For a step by step demonstration on how to run this application visit the HRP Demo Wiki.

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the Health Thermometer Profile (HTP) using the GATT profile. This sample acts as a LE
Master and LE Slave.
For a step by step demonstration on how to run this application visit the HTP Demo Wiki.

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the Phone Alert Status Profile (PASP) using the GATT profile. This sample acts as a LE
Master and LE Slave.
For a step by step demonstration on how to run this application visit the PASP Demo Wiki.

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the Human Interface Device (HID) using the GATT profile.
For a step by step demonstration on how to run this application visit the HOGP Demo Wiki.
{HOGP Demo Legacy page}.

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the ProXimity Profile(PXP) using the GATT profile. This sample acts as a LE Master and
Slave.
For a step by step demonstration on how to run this application visit the PXP Demo Wiki.

This application shows how to utilize Low Energy (LE) and the GATT profile. This sample implements the Find Me Profile(FMP) using the GATT profile. This sample acts as a LE Master and
Slave.
For a step by step demonstration on how to run this application visit the FMP Demo Wiki.

Bluetooth Low Energy Demos

ANP Demo

HRP Demo

HTP Demo

PASP Demo

HOGP Demo

PXP Demo

FMP Demo

https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_ANPDemo_App
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https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_HOGPDemo_App
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https://processors.wiki.ti.com/index.php/CC256x_TI_Bluetooth_Stack_FMPDemo_App
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