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CC13xx CC26xx Tools Overview
This article gives you an overview of the Tools and kits available for developing on the CC13xx and CC26xx family of devices.

Kits
CC1310DK
CC1310EMK
CC2640R2 LaunchPad
CC2650DK
CC2650STK
CC2650 LaunchPad
CC1350 LaunchPad
CC1310 LaunchPad

Software Tools
SmartRF Studio 7
Sensor Controller Studio
SmartRF Flash Programmer 2
Uniflash

IDEs and Compilers
Code Composer Studio
IAR Embedded Workbench for ARM
GCC/GDB

Debuggers
XDS100v3
XDS110
XDS200
IAR I-Jet
Segger J-Link
CC-DEVPACK-DEBUG

Production Programmers
Tips & Tricks

XDS100v3
XDS110

CC-DEBUG-DEVPACK + SensorTag 2.0
Using IAR 7.40.2 with XDS110 and CC26xx
Using CCS v6.1 with XDS110 and CC13xx/CC26xx
Using 2-wire / cJTAG with CCS

Adding device support to CCS Uniflash 3.1
Using CC13xx/CC26xx in MDK-ARM with Segger J-Link

Platform for firmware development
RF performance reference design
2x CC1310EM-7XD-7793
2x SmartRF06EB

Get CC1310DK (http://www.ti.com/tool/cc1310dk)

RF performance reference design
Compatible with SmartRF06EB
2x CC1310EM-7XD-7793
2x Pulse W5017 antennas

Get CC1310EMK (http://www.ti.com/tool/cc1310emk)

Contents
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CC1310DK CC1310EMK
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XDS110 debugger included on board
RF performance reference design
Primary kit for BLE development with the SIMPLELINK-CC2640R2-SDK (http://www.ti.com/tool/SIMPLELINK-CC2640R2-SDK)
Bluetooth 5 Ready

Get LAUNCHXL-CC2640R2 (http://www.ti.com/tool/launchxl-cc2640r2)

Platform for firmware development
RF performance reference design
2x CC2650EM-7ID
2x SmartRF06EB

Get CC2650DK (http://www.ti.com/tool/cc2650dk)

Sensor kit for app developers
iOS and Android apps available
Contains CC2650 BLE SensorTag
IoT enabled

Get CC2650STK (http://www.ti.com/tool/cc2650stk)

XDS110 debugger included on board
RF performance reference design
Note: TI recommends CC2640R2F LaunchPad (http://www.ti.com/tool/launchxl-cc2640r2)for BLE development
IoT and multi-protocol enabled

Get LAUNCHXL-CC2650 (http://www.ti.com/tool/launchxl-cc2650)

XDS110 debugger included on board
RF performance reference design
Dual-band Wireless MCU
Supported in the BLE-Stack (http://www.ti.com/ble-stack) SDK
IoT enabled

Get LAUNCHXL-CC1350 (http://www.ti.com/tool/launchxl-cc1350)

XDS110 debugger included on board
RF performance reference design
Sub
IoT enabled 
 

Get LAUNCHXL-CC1310 (http://www.ti.com/tool/launchxl-cc1310)

All LaunchPad and SmartRF06 kits featured above can be used as a standalone JTAG debugger / programmer to custom boards with CC26xx / CC13xx wireless MUCs. Refer to
the LaunchPad procedure in Application Note SWRA534 (http://www.ti.com/lit/pdf/swra534).

CC2650DK CC2650STK

CC2650 LaunchPad

CC1350 LaunchPad CC1310 LaunchPad
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This section covers the software tools available for the CC13xx/CC26xx device family.

What is SmartRF Studio?
SmartRF Studio is a PC application that helps designers of radio systems to easily evaluate the RF-IC at an early stage in the
design process.

Can be used in combination with several development kits for Texas Instruments’ CCxxxx RF-ICs.
Test functions for sending and receiving radio packets, continuous wave transmit and receive.
Evaluate RF performance on custom boards by wiring it to a supported evaluation board or debugger.
Can also be used without any hardware, but then only to generate, edit and export radio configuration settings. 

Get SmartRF Studio 7 (http://www.ti.com/tool/smartrftm-studio)

What is Sensor Controller Studio?
Sensor Controller Studio provides a development environment for the CC26xx/CC13xx Sensor Controller. The Sensor
Controller is a proprietary, power-optimized CPU located in the CC26xx/CC13xx AUX domain, which can perform simple
background tasks autonomously and independent of the System CPU state.

Allows for Sensor Controller task algorithms to be implemented using a C-like programming language
Outputs a Sensor Controller Interface driver, which incorporates the generated Sensor Controller machine code and
associated definitions
Allows for rapid development by using the integrated Sensor Controller task testing and debugging functionality. This
allows for live visualization of sensor data and algorithm verification.

Get Sensor Controller Studio (http://www.ti.com/tool/sensor-controller-studio)

What is SmartRF Flash Programmer 2?
SmartRF Flash Programmer 2 is a PC application for JTAG programming TI CC13x0 & CC26x0 ARM devices.

Graphical User Interface (GUI) and Command Line Interface (CLI) versions.
Features: Edit secondary MAC addresses, program multiple files.
Supports cJTAG/JTAG interface and CC13xx/CC26xx serial bootloader
Please note JTAG programming of CC13x2 and CC26x2 devices is not supported. Please use Uniflash

Get SmartRF Flash Programmer 2 (http://www.ti.com/tool/flash-programmer)

What is Uniflash?
Uniflash is a standalone flash programmer with Windows, Mac and Linux desktop support

Graphical User Interface (GUI) and Command Line Interface (CLI) versions.
Uniflash 4.x has built-in support for CC13xx/CC26xx devices (for CCS Uniflash 3.1, see here)

Get Uniflash (http://processors.wiki.ti.com/index.php/Category:CCS_UniFlash)

This section covers IDEs and compilers supported for the CC13xx/CC26xx device family. Refer to the SDK documentation for the supported IDE and compiler versions.

Software Tools

SmartRF Studio 7

Sensor Controller Studio

SmartRF Flash Programmer 2

Uniflash

IDEs and Compilers
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Integrated development environment with project management tools and editor
Code Composer Studio (CCS) 6.1 has built-in support for the CC13xx/CC26xx device family (CCS 6.0.1 support via in-app
updates)
Best support for XDS debuggers; XDS100v3, XDS110 and XDS200
High integration with TI-RTOS with support for TI-RTOS Object View
Use CCS for free - A free, unlimited code size license will be generated that supports working with attached low cost
XDS100v3/XDS110 equipped debug probes from TI or TI development kits with an on board debug probe.  
This includes the CC2650DK (XDS100v3), CC13xx/CC26xx LaunchPads & the Debugger DevPack (XDS110) for the
CC2650 SensorTag. CCS v7 and later can be used for free without the need of an attached TI development kit / probe.
See the CCS Licensing Wiki for more details.

More about Code Composer Studio (http://www.ti.com/ccs)

Integrated development environment with project management tools and editor
IAR EWARM 7.30.3 and up has built-in support for the CC13xx/CC26xx device family
Broad debugger support, supporting XDS100v3, XDS110, XDS200, IAR I-Jet and Segger J-Link
Integrated development environment with project management tools and editor
RTOS plugin available for TI-RTOS

More about IAR EWARM (https://www.iar.com/iar-embedded-workbench/partners/texas-instruments/ti-wireless/)

GNU Compiler Collection (GCC) and GNU Project Debugger (GDB) support is documented in an application note using CGG
ARM Embedded.

Basic support
Application note Using GCC/GDB with CC26xx/CC13xx (http://www.ti.com/lit/swra446)
Not supported for developing BLE-Stack applications

More about GCC ARM Embedded (https://launchpad.net/gcc-arm-embedded)

This section covers the debuggers that support the CC13xx/CC26xx device family.

Code Composer Studio

IAR Embedded Workbench for ARM

GCC/GDB

Debuggers
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Integrated on SmartRF06EB (http://www.ti.com/tool/smartrf06ebk)
Stand-alone version from Spectrum Digital (http://www.spectrumdigital.com/product_info.php?products_id=251)
Supported in CCS and IAR
2-pin cJTAG and 4-pin JTAG
Low-cost

More about XDS100v3 (http://processors.wiki.ti.com/index.php/XDS100)

Faster download speeds than XDS100v3
On board debugger for CC13xx and CC26xx LaunchPads
Functions as a standalone debugger for CC26xx/CC13xx custom boards
2-pin cJTAG and 4-pin JTAG
SWO trace support
Supported in IAR and CCS 6.1+

More about XDS110 (http://processors.wiki.ti.com/index.php/XDS110)

Stand-alone version from Spectrum Digital (http://www.spectrumdigital.com/product_info.php?&products_id=261)
Supported in CCS and IAR
2-pin cJTAG and 4-pin JTAG
SWO trace support
Faster download speeds than XDS110

More about XDS200 (http://processors.wiki.ti.com/index.php/XDS200)

XDS100v3

XDS110

XDS200

IAR I-Jet
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Supported in IAR
2-pin cJTAG and 4-pin JTAG
SWO trace support

More about IAR I-Jet (https://www.iar.com/iar-embedded-workbench/add-ons-and-integrations/in-circuit-debugging-probes/)

Supported in IAR and CCS
4-pin JTAG
Requires v6.00g or later of the jLink drivers (https://www.segger.com/jlink-software.html)

More about Segger J-Link (https://www.segger.com/jlink-debug-probes.html)

Integrated XDS110
Debugger DevPack for the CC2650STK SensorTag
Not recommended for custom board programming or debugging
No Vsense or level shifters

More about Debugger DevPack (http://www.ti.com/tool/cc-devpack-debug)

Note: ICDI based debuggers, such as found on TM4C LaunchPads, are not compatible with CC13xx/CC26xx devices
Note: XDS100v2 is not compatible with CC13xx/CC26xx devices

There are several production programming solutions available for the CC26xx and CC13xx devices. Please refer to e.g.

Elprotronic (http://www.elprotronic.com)
Elnec (http://www.elnec.com)
BPM Microsystems (http://www.bpmmicro.com)

How to setup XDS100v3 (Olimex) to be able to run example project UartEcho with CC2650/CC2640 on a custom board or SensorTag (TI E2E) (https://e2e.ti.com/support/wireless_c
onnectivity/f/538/t/448029)

When using the CC-DEBUG-DEVPACK (XDS110 debugger) with the SensorTag 2.0 (CC2650STK), make sure the SensorTag battery is mounted before attaching USB.

If you power up a CC-DEBUG-DEVPACK (Debugger DevPack) when connected to a SensorTag without battery (or a weak battery), it will boot in "firmware upgrade mode" in the

Windows Control Panel. The Debugger DevPack cannot be used to debug or program CC26xx in "firmware upgrade mode." If this mode occurs, disconnect USB, remove & re-insert a

fresh battery into the SensorTag, then re-attach USB to the Debugger DevPack. The battery can then be removed once the Debugger DevPack is powered up correctly.

This section applies to IAR EWARM 7.40.2. EWARM 7.40.3 has built-in support for XDS110 (last updated 2015-08-19).

IAR 7.40.2+ has built-in support for XDS110 debugger that works together with CC13xx/CC26xx devices. To enable XDS110 support, follow the below steps.

1. Install the included XDS Emulation Software Package on your computer (Important: use "Run as administrator" on Win7)

1. It is recommended to use the default installation directory
2. Configure your IAR project to use XDS110 debugger

1. Project > Options > Debugger: Select "TI XDS" as the Debugger driver
2. Project > Options > Debugger > TI XDS:

1. Select "TI XDS110 Emulator" from drop down menu.
3. Click OK to save settings.

Segger J-Link CC-DEVPACK-DEBUG

Production Programmers

Tips & Tricks

XDS100v3

XDS110

CC-DEBUG-DEVPACK + SensorTag 2.0

Using IAR 7.40.2 with XDS110 and CC26xx
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4. Repeat for each project in the Workspace.
3. Connect your XDS110 debugger to your CC26xx target and make sure both are powered up.

You should be able to download and debug your CC26xx project using XDS110.

CCS v6.1 supports XDS110 when the latest updates are applied. Refer to the Debug_DevPack_User_Guide for the setup procedure.

To use the XDS110 in cJTAG (2-wire) mode, please make sure your XDS110 firmware and CC26xx Device Support in CCS are up-to-date. Most CC26xx/CC13xx SDKs, including BLE-

Stack v2.2.0, by default configure CCS to support cJTAG mode. If you are using an older SDK that does not configure XDS110 for cJTAG, you can configure CCS according to the

procedure in this E2E post (https://e2e.ti.com/support/wireless_connectivity/bluetooth_low_energy/f/538/p/410451/1971482#1971482).

This section applies to CCS Uniflash 3.1. It is recommended to upgrade to Uniflash v3.3 or later (last updated 2015-08-19)

CCS Uniflash 3.1 does not have built-in support for CC13xx and CC26xx devices. Follow the below steps to add device support to CCS Uniflash 3.1.

1. Open CCS Uniflash
2. Addding software site

1. Go to Help > Install New Software ...
2. Click "Available Software Sites" in the upper right corner
3. Click Add ...
4. The actual URL to be filled in the 'location' dialog is dependent on CCS version:

1. Name: CC2xxx Device Support Updates
2. Location: http://software-dl.ti.com/dsps/dsps_public_sw/sdo_ccstudio/smartrf/CCSv6

5. Click OK twice to get back to the main window of Uniflash
3. Go to Help > Check for Updates
4. If updates are available, they will appear in the list of updates.
5. Follow the Wizard to complete the update

This article describes how: Using Keil MDK-ARM with CC13xx/CC26xx
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