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Introduction

This User's Guide describes the TI Bluetooth logger tool used to trace log messages and protocol transactions captured from the TX_DBG pin of the CC256x device. The logger tool provides

visibility into the inner data and states of the Bluetooth controller as well as information on the remote device transactions.

Hardware Requirements

The TX_DBG pin on the CC256x should be accessible. It is a 1.8V UART pin on the CC256x. To connect to the computer's serial port, a level shifter and UART-to-USB converter is needed such as
the TTL-232RG-VREG1V8-WE (http://www.digikey.com/product-search/en?pv493=313&FV=£ff40018%2Cfff804dc&mnonly=0&newproducts=0&ColumnSort=0&page=1&quantity=0&ptm=0&{f

id=o&pageSize=25).

Once the Hardware is connected, the serial port for the TX_DBG will be enumerated on the PC.

= i.e. the COM13 in the following example represents the serial port connected to the TX_DBG pin of the CC256x.
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Software Requirements

The Logger tool is part of the Wireless Tools package which can be found here (http://www.ti.com/tool/wilink-bt_wifi-wireless_tools). Download and install Wireless Tools to install Logger.

After you have successfully installed Logger tool without any errors, the Logger tool can be used to connect to the CC256x device.
Download supporting files (XML and ILI) for the CC256x device. The latest ILI and XML files can be downloaded along with the service pack.

= CC256xB-BT-SP: Download link for CC256xB, CC2564MODN and CC2564MODA (http://www.ti.com/tool/cc256xb-bt-sp)

= CC256xC-BT-SP: Download link for CC256xC (http://www.ti.com/tool/cc256xc-bt-sp)
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1. Open the Logger application.

o Note: While capturing the CC256x logger data, it is best to start capturing before the CC256x initializes. Moreover, it is also required to capture both BT Logger and

HCI/LMP viewer traces to ensure that all the relevant log traces will be recorded in the logs.

BT Logger Traces

2. From the menu bar of the main working window, click on the view->Settings... (Alt+F7).

W Untitled - Logger 5.0 - Not Connected

&f Settings...

Alt+F7 I

File Edit Bookmarks/Comments View Help

=D

‘.ﬂ?:

| B Automatic Seroll
Show All ltems

@ Show Date
@ Show Time
@ Show Relative Time

| @ Refresh
& Clear Screen

Switch Previous View

v Toolbar
v Status Bar
-4 Stay On Top

F5

Ctrl+Tab

Port

File Mame

Line | Information

|Auto Save ----

|View: <None>

|Logs: 0/ 0

The Logger Settings dialog box will pop up.
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Logger Settings

*
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3. Select the BT Logger 1 under the Installed Ports list and click on Setup... button.
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4. The Setup Dialog Box will pop up. Select the COM port that is connected to the TX_DBG pin of the CC256x.
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4 Note: Make sure the COM port number is less than 50. If not, change the COM port number to a lower value from the control panel. Reference (http://www.sealevel.

com/support/article/AA-00441/0/How-to-change-asynchronous-serial-COM-port-assignments-in-Windows-Device-Manager.html)

5. Setup the COM port for the following settings and click OK.
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6. Under the Mapping Files section of the Setup Dialog Box, click on Add File... and select the appropriate ili file for the CC256x device.
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Cancel ok

4 Note: Make sure that only one ili file is checked.

7. Click OK to apply the changes to the Setup Dialog Box for BT Logger port. Next, configure the HCI/LMP Viewer.

HCI/LMP viewer Traces

8. In the View->Settings window, select the HCI/LMP viewer 1 under the Installed Ports and Click on Setup....
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. Setup the TX_DBG COM port with the same settings used in step 4.
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, Note: Make sure only one XML file is selected.

11. Click OK to apply the changes to the Setup Dialog Box for the HCI/LMP viewer.

12. Make sure that both BT Logger 1 and HCI/LMP viewer 1 ports are checked and the COM port is displayed next to both of them. Click OK to apply changes and close the Logger Settings.
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Capturing the logs

13. After both BT Logger 1 and HCI/LMP viewer 1 ports have been setup with the correct configurations, select View->Show All Items to disable any filters.

W Untitled - Logger 5.0 - Connected (COM13)
File Edit Bookmarks/Comments View Help
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et [ Port | FileMame | Line Information | Local Clock | Network Clock | Host
Show All [tems
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[HCI/LMP viewer 1 {|BT Logger 1 (COM1[Auto Save ----  [View: <None> [logs: 0/0

igi‘Note: If capturing the logs for a long period of time (i.e. more than an hour), make sure to use the Edit->Auto Save and Clear... option . If the capture file is too large, it may crash the

PC. The Auto Save and Clear option will prevent such a crash. Please refer to the Appendix section below for more details.

14. Power on the Bluetooth device with CC256x. An initialization sequence like the following example will be captured in the Logger window.
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¥ Untitled - Logger 5.0 - Connected (COM13) e m] *
File Edit Bookmarks/Comments View Help
DsEB Xo B@lsH 8 18!
A 2| Level | Time | Port | FileMame | Line| Information | Local Clock | Metwork Clock | Host RS
= 12 & 191421958 +0.. BTLoggerl uart_hci parameters: UartDIV=3, 05=23, 5P=0, MoB=10
i 2 2 BT Logger 1 temperature ;en%ing: temp 17, read 0x23, vbe 0x299397d, slope 0x1f308 @ BT Logger traces
3 3 2 BT Logger 1 Temperature region = 5
z- 4 3 BT Legger 1 In le_rf_init_periodic_calibration
o % 5 BT Logger 1 synch event REG received, module RF_CALIBRATION, msi 0
i 6 5 BT Logger 1 synch crd start instance, module RF_CALIBRATION, msi: 0
& | ] BT Logger 1 synch cmd return event STARTED, module RF_CALIBRATION
7 8 2 BT Logger 1 ORCA Platform
= 9 2 BT Logger 1 Process type: Nominal
i 10 2 BT Logger 1 Chip revision: 7
_9_ n 2 19:14:21.958 BT Logger 1 Detected Clock = 26000000 Hz
10 12 2 19:14:21.958 BT Logger 1 Ref Clock = 26000000 Hz
|| 13 2 19:14:21.958 BT Logger 1 KXTAL wakeup mode is disabled
14 2 19:14:21.958 BT Logger 1 Ref Clock is valid for PLL
15 2 19:14:21.958 BT Logger 1 PLL Clock Qutput is OK .
% 2 19:14:21.958 BT Logger 1 PLL Clack Out = 40000000 Hz HCILMP viewer traces
17 2 19:14:21.958 BT Logger 1 Clock Working mode: PLL Mode
18 2 19:14:21.958 BT Logger 1 ARM Clock = 40000000 Hz, Slow Clock: External
19 2 ] BT Logger 1 OCP Clock = 8000000 Hz
20 4 BT Logger 1 UART HCl baudrate = 113200
21 3 BT Logger 1 Im_lc_get_local_features
22 3 BT Logger 1 Im_lc_set_brest_retran
23 1 HCI/LMP vie... 0%00000028 000000028 HCI|_Reset t—
24 4 HCI/LMP vie... 0%00000028 000000028 i} |-
25 1 HCI/LMP vie... 0x0000002B 0x0000002E HCI_VS_Update_Uart_ HCI Baud... t—
26 4 19:14:22.005 HCI/LMP vie... 0%0000002B 0x0000002B - i |
27 1 19:14:22.005 HCI/LMP vie... 0%0000002C 0x0000002C HCI_VS_Start VS _Lock o—
28 4 19:14:22.005 HCI/LMP vie... 0%0000002C 0x0000002C - |
29 4 19:14:22.021 HCI/LMP vie... (0%0000002E 0x0D00002E B Z— 1
30 4 19:14:22.021 HCI/LMP vie... 0%0000002F 0x0D00002F -———— 0 F
31 4 19:14:22.021 HCI/LMP vie... 0%00000031 000000031 B Z— 1
32 4 19:14:22.021 HCI/LMP vie... 0%00000032 000000032 B Z—
33 4 HCI/LMP vie... (00000034 000000034 B —
4 4 HCI/LMP vie... (%00000035 000000035 B —
35 4 HCI/LMP vie... (00000036 000000036 -t} |-
B 4 HCI/LMP vie... 0%00000038 000000038 i} |-
37 4 HCI/LMP vie... 0%00000039 000000039 i} |-
8 4 HCI/LMP vie... 0x0000003B 0x0000003E i} |-
39 4 HCI/LMP vie... 0x0000003C 0x0000003C i} |-
40 4 HCI/LMP vie... 0%0000003D 0=0000003D - i}
41 4 HCI/LMP vie... 0%0000003E 0x0D00003E e |
42 4 HCI/LMP vie... 0%0000003F 0x0D00003F - |
43 4 19:14:22.036 HCI/LMP vie... 0%00000040 000000040 -——0F
a4 19:14:22.036 HCI/LMP vie... 0%00000041 000000041 HCI_V5_Goto_Address —
45 4 19:14:22.036 HCI/LMP vie... 0%00000041 000000041 B Z—
46 4 19:14:22.036 BT Logger 1 12C doesn't exist !
47 3 19:14:22.036 BT Logger 1 Im_lc_get_local_bd_addr =
an o EERPRCY S oo P O R v
< >
Ready |HCI/LMP viewer 1 [BT Logger 1 (COM1|Auto Save |View: <Mone> |Logs: 635 / 635

15. When all the relevant traces (BT Logger and HCI/LMP viewer) for the instance are captured, use File->Save As... to save the logs as a *.gr file.

Appendix - Auto Save and Clear

& Open..

File = Edit
Ctrl+N
Ctrl+0
Ctrl+5S

Load Workspace...

Save Workspace...

Export All (Ignore Filters)...

Cvmmrt Colartad

W Untitled - Logger 5.0 - Conne

Bockmarks/Commer

When capturing the logs for a long period of time (for example several hours), it is best practice to use the Auto Save and Clear feature of the logger. Doing so prevents a single log file from getting

too large and helps keep the logs organized for a long capture. To setup the Auto Save and Clear, use Edit->Auto Save and Clear... to open the Save and Clear window.
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W Untitled - Logger 5.0 - Connected

File = Edit Bookmarks/Comments

Copy Crl+C @
¥ Delete Delete |

Invert Selection

Find... Ctrl+F
Find Next F3
Find Previous Shift+F3

Set Time Anchor

% Auto Save and Clear...

Open In Editor Ctrl+F4

1n]

After setting up the parameters like below, click OK.

Save And Clear X
ctwate Save And Clear
When logs court reaches 100000

Save the logs in the folder: ]E-\FW_L ogsy J

Filzname Prefix: AutoSave

o Note: When the log capture is complete, save the last log as mentioned in the step 15.

Keystone= C2000=For MAVRK=For
a = For technical fs‘i’?p”éffé . MSP430=For OMAPL1=For ;i?p”é;aé .
support on i i
. . e . the C2000 DaVinci=For ©¢Mmcal  oyiApasx=For tECIMCEl 1ayRK
1. switchcategory:MultiCore=  MultiCore devices, lease technical SUPPOILON 4o pnical support on lease post
please post your p MSP430 OMAP p p For technical support
= For technical support on questions in'the ~ POStyour - support on please post SUPP ort on please post V%4’ please post your
MultiCore devices, please C6000 MultiCore  questions DaVincoplease our OMAP please oUr questions questions at
; ; on The ost your v ost your y on The .
post your questions in the Forum C2000 post y questions on post y questions on MAVRK http://e2e.ti.com.
C6000 MultiCore Forum  u For questions ¢ quesions o The MsP430 32050000 O The omap 1AV Please post only
= For questions related to related to the F,‘,Zgg;’ F oreuma P’I,Za(Zse Forum. Foreum Please Forum. F?)?un(:x comments about the
the BIOS MultiCore SDK BIOS MultiCore ’ Please post ’ Please post : article CC256x
post only  post only post only Please post .
(MCSDK), please use the SDK (MCSDK), comments comments only comments only only Logger User Guide
BIOS Forum gl%:lée':use the about the about the :Zr:ﬂfﬁés about the :Zr:ﬂfﬁés comments here.
Please post only comments related orum article article CC256x article article CC256x article aboutthe 1
to the article CC256x Logger User Please post only CC256x Loqger User CC256x Loqger User CC256x article
Guide here. comments related to the ll.jogger Guide here. Logger User Guide here. Logger User fczssx
article CC256x  Logger - 5" Guide here. Guide here. ~°99¢"
User Guide here Guide User Guide
’ here. here.
Links
Amplifiers & Linear DLP & MEMS Processors Switches & Multiplexers
\\ Audio High-Reliability Temperature Sensors & Control ICs
NG Broadband RF/IF & Digital Radio Interface = ARM Processors Wireless Connectivity
Clocks & Timers Logic = Digital Signal Processors (DSP)
Data Converters Power Management = Microcontrollers (MCU)
= OMAP Applications Processors

Retrieved from "https://processors.wiki.ti.com/index.php?tite=CC256x_Logger_User_Guide&oldid=233625"

This page was last edited on 15 March 2018, at 13:02.

Content is available under Creative Commons Attribution-ShareAlike unless otherwise noted.

8of 8 3/25/2021, 1:40 AM



