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Preface 

Read This First 
 

About This Manual 

This manual describes PurePath Studio GDE operation when used with a 
TLV320AIC3254/TLV320AIC36/TLV320ADC3x01/TLV320TLC2117/TLV320AIC31xx/TLV
320DAC31xx EVM from Texas Instruments. 

How to Use This Manual 

This document contains the following information: 

Overview,  Quick Setup Guide,  System Interfaces 

Related Documentation from Texas Instruments 

The following table contains a list of data manuals that have detailed descriptions of the 
integrated circuits used in conjunction with the AIC PurePath Studio GDE User’s Guide. 
The data manuals can be obtained at the URL http://www.ti.com. 

Table 1-1. Related Documentation from Texas Instruments 
Part Number Literature Number 

TLV320AIC3254 SLAS549 

TLV320AIC36 SBAS387 

TLV320ADC3101 SLAS553A 

TLV320ADC3001 SLAS548A 

TLV320AIC3111 SLAS644B 

TSC2117 SLAS550A 

Additional Documentation 

║ AIC3254 Graphical Development Tool (GDE) (GDE ver. 3.20 or later) 

║ General Application Notes 

 

Trademarks 

PurePath DigitalTM is a trademark of Texas Instruments.
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Chapter 1 

Quick Start 
 

TI's PurePath Studio (Portable Audio) Graphical Development Environment (GDE) is a 
powerful, easy-to-use tool designed specifically to simplify software development for the 
TLV320AIC3254/TLV320AIC36/TLV320ADC3x01/TLV320TLC2117/TLV320AIC31xx/TLV
320DAC31xx families of data converter with a miniDSP.  The GDE consists of a library of 
common audio functions that can be dragged-and-dropped into an audio signal flow, 
graphically connected and assembled to produce a signal processing application. The 
application can then be downloaded to a target device where the audio processing 
functions can be interactively controlled by the GDE.  
 
The GDE permits a miniDSP data converter to be programmed to support the processing 
requirements of a wide number of portable audio processing applications. The 
programming is done graphically using a library of low level and high level audio 
processing components. The GDE audio component library contains functions including a 
digital volume control, mixers, multiplexers, equalization, tone controls, loudness, dynamic 
range compression, bass boost and surround effects.  
 
This release is version 4.1 of the PurePath Studio for Portable Audio converters. If you 
have a request or question please send us a message at aicpps@list.ti.com. 
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1.1 GDE Features 

║ Flexible and easy to use minDSP programming interface 

║ Broad ranges of audio processing components 

║ Easy to use GUIs to support the configuration of complex components   

║ DSP programming experience is not required 

 

 

 

1.2 GDE Software Installation 

The miniDSP data converter is programmed and configured using the PurePath Studio 
Graphical Development Environment (GDE). The GDE permits the user to program the 
miniDSP using predefined signal processing components that are placed and connected 
graphically onto the GDE palette to produce a signal processing application. 

1.2.1 Installation Requirements 

Minimum 

 700 MHz PC 

 512 MB RAM 

 Windows 2000 SP4 or later or  

 .Net Framework 2.0 (SP1 is recommended) 

 1024x768 display with 16 bit color 

 USB Port 

Supported Operationg Systems 

 Windows XP SP1 or later 

 

1.2.2 Installing the GDE Software 

1. If you have not done so already, save the installation program file to temporary 
directory. The PPS GDE installation file will have a name with the following 
format: setup_PurePath_Studio_Portable_Audio_v#.##_build#_rev####.exe and 
can be downloaded from http://pps.ext.ti.com.  

2. From the temporary directory execute the installation program. Follow the 
installation prompts to compete the installation. The installation program will 
install the GDE at %ProgramFiles%\ Texas Instruments Inc\PurePath Studio 
Portable Audio. 
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The GDE installation will include several example process flows and application notes 
which are located in the following subdirectories of the installation path mentioned above. 

 

Example process flows ..\ MyProcessFlows\Example Process Flows 

Application Notes ..\ ApplicationNotes 

The GDE installation program will create a short-cut for the GDE under: 

All Programs→Texas Instruments Inc→PurePath Studio Portable Audio→PurePath 
Studio Portable Audio GDE. 

  

 

1.3 TI EVMs 

The miniDSP data converter family has two types of EVMs, EVM-K and EVM-U. The 
EVM-K  (see Figure 0.1) is a larger two board EVM which allows the user to more easily 
observe signals as well as allow for easier connection of the TI EVM to other hardware. 
EVM-Ks will run directly with the GDE without any additional scripting file. 

The EVM-U (see Figure 0.2) is a smaller form factor the size of a USB thumb driver and is 
only presently available for the TLV320AIC3254. The EVM-U will require that a separate 
scripting file be used in conjunction with the GDE. 

Both EVM will connect to a host PC via a USB connection. This USB connection will be 
use by the GDE to download images to the EVM as well as the control path for the 
miniDSP application. 

 

 

 

Figure 0.1. EVM-K 
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Figure 0.2. EVM-U 

 

 

 

1.4 Programming the TLV320AIC3254 EVM-U 

The rest of this document will illustrate some of the steps that are needed to construct and 
run an application on a miniDSP based data converter. For the purpose of illustration this 
document will discuss the process with regards to the TLV320AIC3254 and the 
TLV320AIC3254 EVM-U. Most of the discussion will apply directly to other miniDSP data 
converters and their respective EVMs. 

1.4.1 The TLV320AIC3254 

The TLV320AIC3254 is a device that contains a stereo ADC, a miniDSP for processing 
the ADC information, digital audio serial interfaces for receiving and transmitting, a 
miniDSP for processing the DAC information, and a stereo DAC.  Figure 0.3 shows a 
simplified illustration of the device. 
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Figure 0.3. a miniDSP data converter Architecture 

 

 

1.4.2 Setting up the GDE for the TLV320AIC3254 EVM-U 

As stated previously, the EVM-U requires that a separate script file which enables the 
analog regulators be loaded by the GDE in order for the EVM to be functional. The EVM-K 
will not require such a script file. 

The EVM-U command file is named AIC3254EVM-U_PPS_GDE.txt and is available on 
the PurePath Studio web page (http://pps.ext.ti.com/). Copy the file to the PPS GDE 
subdirectory ..\MyProcessFlows\.. Rename the file AIC3254EVM-U_PPS_GDE.txt to 
AIC3254EVM-U_PPS_GDE.cfg 

Now it is time to launch the PPS GDE. Select the shortcut at 

All Programs→Texas Instruments Inc→PurePath Studio Portable Audio→PurePath 
Studio Portable Audio GDE. 

This will bring up the GDE. If it is the first time you have open the GDE it may take several 
seconds for the application to fully come up. Once the GDE is up, we can specify the 
command file that will be used everytime the EVM-U is reset. We specify the I2C 
command file to be loaded by the GDE by using the I2C command File Tool (Tools→ I2C 
Command File). 
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Figure 0.4. I2C Command file  

Use the I2C Command file tool to select the AIC3254EVM-U_PPS_GDE.cfg file.  Also 
check the “Execute on reset”.  By checking the “Execute on reset” we ensure that this 
command will be executed whenever the miniDSP code is downloaded to the EVM.   

This configuration will be saved by the GDE until the software is uninstalled or different 
setting is entered in the I2C command file window. 

 

 

 

Figure 0.5. I2C Command file entry 
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1.4.3 Loading  an Existing PurePath Studio Application 

Select File→Open and navigate to the subdirectory ..\MyProcessFlows\Example Process 
Flows\AIC3254_ADC_I2S_VOL_DAC 

Select the process flow AIC3254_ADC_I2S_VOL_DAC.pfw  in the 
AIC3254_ADC_I2S_VOL_DAC subdirectory. 

 

 

Figure 0.6. Loading a Process flow 

 

This will load a process flow that will stream a signal from the ADC or I2S inputs to the 
DAC output. The  

The ADC miniDSP will execute the following processing elements: 

o Stereo 4 x decimator for the ADC 

o Inter-processor port from the ADC miniDSP to the DAC miniDSP 

While the  DAC miniDSP will execute the following processing elements: 

o Inter-processor port from the ADC miniDSP to the DAC miniDSP 

o Stereo Mixer 

o Stereo Volume Control 

o Stereo 8x interpolator for the DAC 
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Figure 0.7. Example Process flow - Mixer 

Figure 0.9 shows the process flow on the palette with the Stereo Mixer selected. The 
properties for the Stereo Mixer are shown in the right hand properties window.  In this 
window you can see that the component is defined as having four input channels and two 
mixed output channels, it is a DAC miniDSP (miniDSP_D) component and that the gains 
for each stereo channel pair are 0.5. 

Figure 0.8 shows the process flow on the palette with the Volume selected. The properties 
for the Volume are shown in the right hand properties window.  In this window you can 
see that the component is defined as having two channels, it is a miniDSP_D component 
and that the gain is  0.0 dB. 
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Figure 0.8 Example Process flow - Volume 

 

To build this process flow we select:  Build→Generate Code 

The status of the code generation will be indicated in the output window below the palette. 
If successful, the output window will terminate the output text with “…Done.” 

 

Figure 0.9. Code Generated 

To download the code into the EVM and start execution, select Build→Download Code.  
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The PurePath Studio will take a minute for the download to occur. When the download is 
complete the palette background will turn light blue and the output window will indicate 
successful download.    

 

Figure 0.10. Code Downloaded 



  

1-12  Portable Audio PurePath Studio Quick Start Users Guide   

At this point the EVM should be streaming audio.   To adjust the component runtime 
parameters, make the changes on the component GUI or in the properties window and 
press the “write state” button ( ).  This will update the parameters in memory. These 
changes will be reflected in the signal processing. 

 

Figure 0.11. Runtime Control 

To exit the run mode select Build→Disconnect. 

1.4.4 Building a PurePath Studio Application From Scratch 

The first step to build an application is to place a framework onto the palette.   

There are three main fixed frameworks that can be selected for the TLV320AIC3254. 
These frameworks have fixed clock rates with a fixed maximum number of cycles.   

Since the EVM as shipped is configured to support a 44.1 kHz sample rate, we will use 
the AIC3254 8x4x framework. This framework supports sample rates of 8 kHz to 48 kHz.  
This framework provides 904 clocks per FS with an 8x interpolator for the DAC output and 
a 4x decimator for the ADC input.  
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Figure 0.12 Selecting a Framework 

 

The default configuration of the GDE is for the AIC3254 to be operated in adaptive mode.  
When the AIC3254 is operated in adaptive mode, half of the coefficient memory is 
accessible via I2C while the other half of the coefficient memory is being used by the 
miniDSP. This configuration will apply to both the minDSP_A on the ADC side as well as 
the miniDSP_D on the DAC side.  

The next step is to select the input and output components, in this case, an interpolator 
and decimator.  
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Figure 0.13. Selecting Input and Output Component 

 

After selecting the input and output components, we select the components that will be 
used for the application. In this case let’s add an AGC component. 

 

Figure 0.14. Selecting a Processing Component 
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Selecting a component followed by a right mouse click brings up a popup menu that 
shows a help selection. Selecting the Help item will bring up the help screen associated 
with the component. The help screen will explains the operation of the component. 

 

Figure 0.15. Component Help File 
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Figure 0.16. Help File 

 

To configure this component we first must configure the design time properties. The 
design time properties can only be changed at design time prior to building the process 
flow. Design time properties will be fixed once the process flow is built and cannot be 
changed at runtime. For the AGC the design time properties are the number of inputs and 
the target processor.  The number of inputs is two since this is a stereo component. The 
target processor is the ADC mini DSP. However we do not need to set this value 
manually.  The GDE will set this parameter when the component is connected to other 
components. 

The Runtime properties of a component can be changed either during the design of the 
process flow or at runtime after the process flow has been built and is executing.   
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Figure 0.17. Configuring a AGC Component  

 

In this case for listening to music we could set the  

ACG Attack time Coefficient to roughly 0.0005  

AGC Decay time Coefficient to roughly 0.00001 

AGC Desired Level to roughly 0.015 
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Figure 0.18. Configuring a AGC  Component cont 

We then add an ADC to DAC miniDSP inter-processor communication port. This 
component will allow data to be transferred from one miniDSP to the other. It also 
provides information to the GDE regarding where components should be executing. 

 

Figure 0.19. Adding a Interprocessor Block 
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After adding the interprocessor component, we can add and configure additional 
processing components that will run on miniDSP_D. In this case we will add a biquad to 
the DAC miniDSP side and configure it to be 5 biquads in series. 

 

 

Figure 0.20. Adding a 5 Element Biquad for Loudspeaker Equalization 

 

A copy of a component can be created by selecting a component and using CTRL-
C/CTRL-V (copy/paste). 

A component can be defined to be an “alias” of another component of the same type by 
selecting the appropriate instance of a component from the “AliaseOf” design property.  
Components that are aliased share coefficients. A change to the coefficients of one of the 
components will affect both. 

Some more complex components will have a custom component GUI associated with the 
components. In order to bring up the custom component GUI, select the component and 
right click. Select custom GUI item. In the case of the biquad components, the right 
mouse click will bring up the popup menu with an item for “Biquad GUI.” 
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Figure 0.21. The Biquad GUI  

 

The biquad GUI will provides an interface to easily define the filter types associated with 
the biquad. 

 

Figure 0.22. The Biquad GUI – Filter Data 
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The biquad GUI will also allow you to check the frequency response of one or all of the 
selected fiters by selecting the “Frequency Response Graph” tab (see Figure 0.23). The 
frequency response can also be adjusted directly from this tab (see Figure 0.24) 

 

Figure 0.23. The Biquad GUI – Frequency Response 
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Figure 0.24. The Biquad GUI – Individual Frequency Response 

 

Selecting “Apply” button on the biquad GUI will send the changes to the biquad filter 
coefficients. 

Next a Volume Control is added and configured. 

 

Figure 0.25. A Volume Component 

After adding the volume control, the process flow can be saved (File→Save As). The 
default location for the new process flow will be the ..\MyProcessFlow subdirectory. 
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Figure 0.26. Save as 

 

 

 

Figure 0.27. Save as 

 

Once saved, we can generate the application by selecting Build→Generate Code. 

The GDE will report the status of the code generation in the Output window. 

 

Figure 0.28. Generate Code. 

The resources window (View→Resource Window) will show what processing resources have 
been used by the application. 

Note because the frameworks sizes are fixed the processor resources will be shown to be 
at 100%  
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Figure 0.29. Resources Used. 

 

The program can be downloaded and executed on the EVM by selecting 
Build→Download Code. Depending on if the process flow must be saved or recompiled 
the download may take a half a minute or so. 

 

Figure 0.30. Run Environment. 

 

At this point the EVM should be streaming audio 

To make a change to one of the runtime parameters, make the desired changes and 
select the “write state” button or wait a few seconds and the GDE will automatically 
generate a “write state”.  The “write state” will update the parameters in memory. These 
changes will be reflected in the signal processing. 



  

1-25  Portable Audio PurePath Studio Quick Start Users Guide   

 

Figure 0.31. Changing Parameters During Run  

 

We could also change the Biquad filter response during run time. Let’s open the Biquad 
GUI, select the frequency tab and zoom in. 

 

 

 

Figure 0.32. Changing Biquad  Parameters During Run. 
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Each of the individual plots can be shown by checking the appropriate checkbox in the 
scrolling checkbox list at the bottome of the Frequency Response Graph dialog. 

 

 

Figure 0.33. Changing Biquad  Parameters During Run. Con. 

 

We can change the filer response by dragging the response and then selecting Apply, 
followed by selecting the write state button on the PurePath window or wait a few seconds 
for the GDE to automatically perform the automatic “write state”. 

To exit the run mode select Build→Disconnect. 

 

 

1.5 Important notes 

 

The MiniDSP architecture is an auto indexing architecture.  If you have a component with 
unused inputs, these inputs will not be zero but will be of some value 

To avoid inputting noise into unused inputs, always terminate an unused input with a 
constant value. The easiest way to do this is to attach a coefficient to data converter to the 
unused input. Set the coefficient value of this component to zero. 
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Figure 0.34. Constant values. 

  

 

Once a process flow is saved, the GDE will automatically save the process flow whenever 
the Generate function is used. If you are modifying a process flow and you wish to retain 
the previous process flow, please save it under a different name before selecting 
Generate.  

 

1.6 Programming the EVM to Support other sample rates 

The EVM is preprogrammed to enumerate as a 44.1 kHz sample rate device on a 
Windows XP PC. If another sample rate is desired, the EVM firmware can be updated by 
a configuration program that is contained in %ProgramFiles%\Texas Instruments 
Inc\PurePath Studio Portable Audio\USBFirmware. This directory contains documentation 
that describes the firmware programming procedure.  Please note – the Echo Canceller 
framework is configured to operate at 8 kHz. However the other PurePath frameworks are 
configured for only 44.1 kHz sampling rate, at the present time.  

To operate the standard frameworks at other sample rates, a script file must be executed 
when PurePath downloads the process flow information into the AIC3254.  These script 
files can be obtained by sending a message to aicpps@list.ti.com 

The script to be loaded is specified using the I2C Tool (Tools→ I2C Command File ). We 
then specify the desired configuration file (in this case configure8kHz.cfg) to load. 

We also enable the enable the “Execute on reset” to cause this configuration file to be 
loaded whenever a build is performed. 
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Figure 0.35. Script file specification 

 

1.7 Advanced Information and Help 

 

For more advanced use of the GDE please refer to GDE online help, GDE Release notes, 
and GDE User Guide. 

 

 

 


