BIOS C6SDK 2.0 Getting Started Guide

Important Note:

The software found on this site is available for download, but is no longer being actively developed or maintained. To help determine which software option is best
Jor you, visit the OMAPL138 SW & HW Comparison (http://processors.wiki.ti.com/index.php/OMAPL138 SW_%26_HW__Comparison) Wiki site
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Introduction

The BIOS C6 Software Development Kit (BIOS C6SDK) provides the core foundational building blocks that facilitate application software development on TI's single core DSPs. The foundational

components include:

= SYS/BIOS which is a light-weight real-time embedded operating system for Tl devices
= Drivers

» Basic networking stack and protocols

= Optimized application-specific and application non-specific algorithm libraries

= Flash and boot utilities

= Demonstrations


http://processors.wiki.ti.com/index.php/OMAPL138_SW_%26_HW_Comparison

The purpose of this guide is to provide more detailed information regarding the software elements and infrastructure provided with BIOS C6SDK. BIOS C6SDK pulls together all the elements into
demonstrable DSP applications and examples for supported EVMs. The objective being to demonstrate device, platform, and software capabilities and functionality as well as provide the user with

instructive examples. The software provided is intended to be used as a reference when starting their development.

. Note: Itis expected the user has gone through the EVM Quick Start Guide provided with their EVM and have booted the out-of-box demonstration

application flashed on the device. Specifically, this Getting Started Guide provides information on installing the BIOS C6 Software Development Kit, loading
the EVM out-of-box demonstration application via JTAG, and running the out-of-box demonstration application. It is expected the user has gone through the
EVM Quick Start Guide provided with their EVM.

By the end of this Getting Started Guide the user should have:

= |nstalled CCS
= |nstalled the BIOS C6SDK Software
= Connected to the EVM via CCS/JTAG

After completing the material in this Getting Started Guide, it is recommended the user continue on to the BIOS C6SDK User’s Guide for additional information on the C6SDK software elements
and to get started with development on the TI DSP using the BIOS C6SDK.

Supported Devices/Platforms

The latest BIOS C6SDK Release supports the following Texas Instrument devices/platforms:

Platform |Supported Devices Supported EVMs
C6748 C6748, OMAPL138 TMS320C6748/OMAP-L138/LCDK (C6000™ L13x/C674x Development Kit )

Getting Started

This section will walk you through installing and using the BIOS Single core C6 Software Development Kit. It is expected that you have gone through the EVM Quick Start Guide for your EVM.
The overall steps are:

1. Make sure your EVM hardware is set up
2. Install Code Composer Studio 5.1.0.09000
3. Install the BIOS C6SDK 2.0

4. Use JTAG to load the application

5. Run the application

Hardware Setup

Follow instructions in one of the links below that correspond to the EVM that you are using

= OMAPL138/TMS320C6748 EVM Hardware Setup (http://support.logicpd.com/downloads/1230/)


https://processors.wiki.ti.com/index.php/BIOS_C6SDK_2.0_User_Guide
http://support.logicpd.com/downloads/1230/

Installing Code Composer Studio

The BIOS-C6SDK 2.0 uses CCS 5.1.0.09000. To install CCS please refer to the instructions provided in the CCSvs Getting Started Guide.

+ Note: When installing Code Composer Studio you can choose to control what is installed. For example, you may not want support for particular devices
and ISA's. If you choose to do a custom installation, the following components must be installed to support the C6SDK:

= SYS/BIOS 6
= XDC
= CG Tools

In Windows 7, install and run CCS/BIOS C6SDK in administrator mode, this will rule out issues with CCS start-up and RTSC component recognition.

Installing the C6 Single core Software Development Kit

To install C6SDK on your PC run the C6SDK installer (bios_c6sdk_<version>_setupwing2.exe). The C6SDK install includes several sub-components, all of which will be installed in the same
location. This location can be chosen using "Destination Folder". It is recommended that you keep the default installation paths for BIOS C6SDK components in "C:\Program Files\Texas
Instruments". For Windows 7 users this path will be "C:\Program Files (x86)\Texas Instruments". Refer to the FAQ section in BIOS C6SDK 2.0 User Guide for auto discovery of components of
BIOS C6SDK through CCSvs.

Once the installation is complete, all the C6SDK components will be installed in the specified installation directory (e.g., C:\Program Files\Texas Instruments\). Each of the directories will be of

following format <component_name>_ <component version>. Please refer to individual components release notes for detailed information on the components or package.

With a typical default install you should see directories similar to the ones below:

bios_6_33_01_25
chsdk_02_00_00_00
dsplib_c674x 3_1_0.0
edma3_lld_02_11 04 01
imglib_c64Px 3.1 0 1
ipc_1_23_05_40
mathlib_c674x 3 011
ndk_2_20_06_35

pdk C6748 2 0.0 0
xdctools 3 23 00 32

Steps to create a CCS Configuration File

1. First time CCSv5 users needs to follow the steps described in GSG:CCSv5 Running for the first time page.
2. The above procedure will open up the CCSv5 GUI.


https://processors.wiki.ti.com/index.php/CCSv5_Getting_Started_Guide
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https://processors.wiki.ti.com/index.php/GSG:CCSv5_Running_for_the_first_time

3. Create a New Target Configuration, by selecting the tab File -> New -> Target Configuration File.

4. Enter a configuration file name (say "evmomapl138_xds510.ccxml") in the file name field, check the Use shared location box and hit finish button (the procedure assumes you are using
Spectrum digital XDS510 USB emulation).

5. Select the connection type as "Spectrum Digital XDS510 USB emulator"” in the drop down list and enter OMAPL138 in the Device search field. Select OMAPL138 and save the file by clicking
Save button."

6. Click View->Target configurations to list the available target configurations. The configuration file (evmomapl138_xds510.ccxml) created above will be under "User Defined" section
. Right click on the configuration file and select Launch Selected Configuration. This will launch the configuration and open the debug view.
8. Most of the development and debugging will require CCSv5. For more information on CCSv5 see the CCSv5 Getting Started Guide page.

~

Running the Demonstration Application

Running Facedetect Demo on EVMC6748

= Ensure that the Hardware is setup as explained in Hardware Setup for Demos in User Guide.
= Open CCSv5.1 and launch the target configuration file for TMS320C6748 or OMAPL138

= Go to Tools -> GEL Files

= Right click inside the GEL Files window and select Load GEL.

= Browse to the pdk_C6748 folder -> gel and select C6748.gel

= The loaded gel file will be in GEL Files window.

= In the Debug window, Right click on "Spectrum Digital XDS510USB Emulator_0/C674X_0 [Non-Project Debug Session]" -> Connect Target (Make sure the EVMC6748/LCDK is ON before
saying Connect Target)

= Make sure DIP switches 5 and 8 of S7 are ON to boot in the emulation mode.

= In the console window, you will find the PLL and DDR frequencies getting set by the GEL file.

= |tis a good practice to reset the CPU by going to Run -> Reset -> CPU Reset

= Now go to Run -> Load -> Load Program

= Browse to c6sdk_02_00_00_00\demos\facedetect\bin{COMPILATION_METHOD}NevmC6748\Release amd open facedetect_evmC6748.out
= Wait until the program is loaded.

= Now run the program by going to Run -> Resume. If your hardware is set up correctly, you should be able to see a box around faces captured by the camera. For best results, stand a few
feet away from the camera and make sure the camera is placed in such a way that your face and the camera are exactly at the same level. This is needed as it is a frontal face detection
demo. Also, for the same reason, make sure your head is not tilted with respect to the camera.

Running Demos on C6748 LCDK

= Connect a mini USB cable at J3 on the UART port on LCDK with the other end going to the host computer at one of its USB ports.

= |f you do not have the driver installed on your PC, you can find it here (http://www.ftdichip.com/Products/ICs/FT232R.htm)

= Now open a serial port terminal like Tera Term (http://logmett.com/index.php?/download/tera-term-479-freeware.html) on the host computer and connect to the appropriate Serial port.
= Set the baud rate to 115200. (To do this in Tera Term, go to Setup -> Serial port and set the Baud rate as 115200 from the drop down menu)

= The C6748 LCDKs have IT_IS_ALL_ABOUT_YOU demo flashed on them by default. So just power on the board and you should be able to see a screen like below in about 10 seconds on
the serial terminal -
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¥ COM4:115200baud - Tera Term VT =™

File Edit Setup Control Window Help

Belect the Demo you want to run
Press 1 for FingerPrint and hit Enter

Press 2 for FaceDetect and hit Enter

( For FaceDetect Demo. make sure a composite camera is connected at J? on composite
video input port and LCD screen is connected at J8 on the UGA connector on LCDK.

m

= Select 1 for FingerPrint or 2 for FaceDetect. Once any demo is selected, the board needs to be rebooted to run another demo.

= Before selecting facedetect, make sure the hardware is setup correctly.

= |f your hardware is set up correctly, you should be able to see a box around faces captured by the camera. For best results, stand a few feet away from the camera and make sure the camera
is placed in such a way that your face and the camera are exactly at the same level. This is needed as it is a frontal face detection demo. Also, for the same reason, make sure your head is
not tilted with respect to the camera.

» [f you select Finger print demo, you should see a screen like below


https://processors.wiki.ti.com/index.php/File:Itsyou1.png

¥ COM4:115200baud - Tera Term VT B
File Edit Setup Control Window Help

AuthenTec Embedded Matching Application
AE API wversion: 7.6

¥You may now perform the following operations:
E> Enroll a new user.

I» Identify against all users in database.

D> Delete all templates in database.

Q> Quit.

E)nroll, I>dentify,. Drelete all or Qlruit:

11

= Type E to enroll a user and press enter.
= Enter the name of the user to be enrolled.
= Enter the finger number to be enrolled. Multiple fingers of the same user can be enrolled as different templates in the database.

= Now swipe the desired finger on the sensor. A video of the swipe sensor usage is available in the c6sdk_02_00_00_00\docs folder. Remember to swipe the finger in the direction going from
the power cord to away from the board or the other way but NOT in the direction going from or to the USB/UART port. You will have to swipe the finger 3-4 times to get a good image of the
finger.

= Once the application finds a good image, it will store the finger image as a template in the database.

= The console should look like below


https://processors.wiki.ti.com/index.php/File:Fingerprint1.png
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¥ COM5:115200baud - Tera Term VT L= ] ) |

File Edit Setup Control Window Help
2> Quit. "

E¥nroll, I)dentify. Dlelete all or QIuit:
E
Enter the name of the user to be enrolled:
user

Enter the finger number to he enrolled <1-18>:
il
Enrolling finger 1 of user (Swipe 12

>»> Please swipe a finger on the sensor

Enrolling finger 1 of user {(Swipe 2>

>»» Please swipe the same finger on the sensor again

Enrolling finger 1 of user (Swipe 32

»»> Please swipe the same finger on the sensor again

Enrolling finger 1 of user (Swipe 4>

>»> Please swipe the same finger on the sensor again

—— Storing finger 1 of user into template B in database.

m

E>nroll, I>dentify. D)elete all or Qluit:
|

.

= You can enroll upto 10 users using the procedure above.

= To identify a fingerprint, type | in the console and hit enter.

= Swipe the finger to be identified.

= |f the fingerprint exists in the database, the application will print the name and finger number of the identified user on the console; otherwise it will say finger did not match.


https://processors.wiki.ti.com/index.php/File:Fingerprint2.png
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File Edit Setup Control Window Help

Enrolling finger 2 of userl <(Swipe 3>

>>> Please swipe the same finger on the sensor again

Enrolling finger 2 of userl <Swipe 4>

>>> Please swipe the same finger on the sensor again

~—— Storing finger 2 of userd into template 1 in database.

E>nroll. I>)dentify,. Dlelete all or Qluit:
1
>>> Please swipe a finger on the sensor

——— This finger matched template #8 in database. bhelonging to finger 1 of user.

1

E)nroll, I>dentify,. Dlelete all or GQruit:
|

L

= You can delete all templates in the database by typing D on the console. It will ask for confirmation in case you select D mistakenly.
= You can stop the demo by selecting Q and can select facedetect demo by resetting the board again.

Technical Support and Product Updates

Technical Support and Forums

For technical discussions and issues, please visit

= C6000&nbsp;Single Core DSP forum: http://e2e.ti.com/support/dsp/tms320c6000_high_performance_dsps/default.aspx (http://e2e.ti.com/support/dsp/tms320c6000 _high_performance_dsp
s/default.aspx)
*BIOS Embedded Software forum: http://e2e.ti.com/support/embedded/f/355.aspx
*Embedded Processors wiki: http://processors.wiki.ti.com

4 Note: When asking for help in the forum you should tag your posts in the Subject with “BIOS C6SDK”, the part number (e.g. “OMAPL138/EVMC6748”) and additionally the component (e.g.
“NDK”).
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) ) ) B , technical technical technical technical technical technical please post your
1. switchcategory:MultiCore= = :Sgéi(ﬁthg:’lcal support on support on supporton  support on supporton  supporton questions at
. : x ) the C2000 DaVincoplease MSP430 OMAP please OMAP please MAVRK http://e2e.ti.com.
For technical support on MultiCore devices, pjoa5e post your please post post your post your  please post Please post only

'L\)Aousltlsgl:? ((qjue:s(t:i?)?spilr? ?r?: p{?:;?oﬁgsi; %ﬁgr post your question§ on your questions on  questions on your _ cor_nments about the
C6000 MultiCore Forum q questions The DaVinci  questions on The OMAP The OMAP  questions  article BIOS C6SDK
on The Forum. Please The MSP430 Forum. Please Forum. on The
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= Microcontrollers (MCU)
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Power Management
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