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LAB 0 Pre-Work

The Pre-Work lab is to be completed
before beginning the rest of the Debugging Tech-
niques with AM5728 labs.

LAB 0.1 Software Installation

The labs presented in this document will require
the installation of 3 software components: CCS,
SYS/BIOS, and XDCTools. If you already have CCS,
SYS/BIOS, and XDCTools installed, ensure that you
have the correct versions.

LAB 0.1.1 Code Composer Studio 8.3.0.00009

Download the CCS installer from http://processors.
wiki.ti.com/index.php/Download_CCS. Once down-
loaded, run the ccs_setup_8.3.0.00009 executable
and follow the installation instructions. It is recom-
mended to not install CCS in the default C:\ti or
~/ti directory. A recommended installation location
would be in a directory that references the specific
version of CCS you are installing (C:\ccs\8.3.0.00009
for example).

Figure 1: In most cases it is okay to continue installation
with anti-virus turned on.

Figure 2: Accept the license agreement and select Next.

Figure 3: Select a new directory to install CCS. The in-
stallation directory will be created by the installer.

Figure 4: The "Sitara AMx Processors" and "TDAx Driver
Assitance & Jacinto DRAx Infotainment SoCs" support
packages need to be installed for this lab.
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Figure 5: Only the TI XDS Debug Probe Support is
needed for this lab unless you are not using a TI XDS110
probe.

LAB 0.1.2 SYS/BIOS 6.75.02.00

SYS/BIOS installers can be downloaded from
http://software-dl.ti.com/dsps/dsps_public_sw/sdo_
sb/targetcontent/sysbios/. Once downloaded,
run the bios_<version> executable and set the
installation directory to C:\ti on Windows or ~/ti on
Linux.

Figure 6: It is recommended to install SYS/BIOS in the
default location (C:\ti on Windows or ~/ti on Linux).

If you wish to install SYS/BIOS in a location other
than C:\ti on Windows or ~/ti on Linux, you will
need to update the CCS product discovery path to
the SYS/BIOS installation directory via the Window-
>Preferences menu option within CCS as shown in
Figure 7.

Figure 7: Add the path of the SYS/BIOS installation to
the product discovery path if SYS/BIOS is installed in a
non-default location.

LAB 0.1.3 XDCTools (3.51.1.18 )

The 3.51.1.18 version of XDCTools is available by
default in the CCS 8.3.0.00009 installation. If you
require a different version of XDCTools, you can
download the package from http://downloads.ti.com/
dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/.
Other tools automatically downloaded with CCS
8.3.0.00009 include:

• GCC: gcc-arm-none-eabi-7-2017-q4-major
(https://developer.arm.com/open-source/
gnu-toolchain/gnu-rm/downloads)

• C6000 CGT: 8.2.5
(http://www.ti.com/tool/download/
C6000-CGT-8-2/8.2.5)

• ARM CGT: 18.1.4
(http://www.ti.com/tool/download/
ARM-CGT-17/18.1.4.LTS)

LAB 0.2 CCS Configuration

After CCS, SYS/BIOS, and XDCTools have been in-
stalled, launch CCS. When prompted to select a
workspace, create a new workspace directory that
will be used for the debug training labs.

3

http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/sysbios/
http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/sysbios/
http://downloads.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/
http://downloads.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/
https://developer.arm.com/open-source/gnu-toolchain/gnu-rm/downloads
https://developer.arm.com/open-source/gnu-toolchain/gnu-rm/downloads
http://www.ti.com/tool/download/C6000-CGT-8-2/8.2.5
http://www.ti.com/tool/download/C6000-CGT-8-2/8.2.5
http://www.ti.com/tool/download/ARM-CGT-17/18.1.4.LTS
http://www.ti.com/tool/download/ARM-CGT-17/18.1.4.LTS


Figure 8: You will be prompted to select a workspace
when launching CCS.

It is highly recommended not to share
workspaces across different versions of CCS. In
a clean CCS installation and workspace, you will
be prompted to install newly discovered products.
When you see the product install prompt, select the
6.75.02.00 version of SYS/BIOS to install and restart
CCS when prompted.

Figure 9: You will be prompted to select a workspace
when launching CCS.

After CCS has restarted, you will need to update
3 components needed for the labs: TI Emulators,
DVT, and Sitara Device Support. The TI Emulators
package contains the software libraries responsible
for communicating with debug probes and debugab-
ble targets. The DVT package contains trace visu-
alization tools. The Sitara Device Support package
includes the support files needed for the AM5728 de-
vice.

To update the components to the necessary ver-
sions, follow the instructions below.

1. In CCS select Window->Preferences->Install/
Update->Available Software Sites.

2. Add the TI Emulators and DVT patch locations
below as available software sites. Note that the

TI Emulators site is platform specific. The links
below are not intended to be opened with a web
browser but will allow the correct components to
be installed via the CCS updater.

• TI Emulators (Windows):
http://downloads.ti.com/emulation/esd/
emupack/int_rel/8.1.0.00003/repo_win32

• TI Emulators (Linux):
http://downloads.ti.com/emulation/esd/
emupack/int_rel/8.1.0.00003/repo_linux

• DVT (all OS):
http://downloads.ti.com/ccs/esd/dvt/dvt_4.
1.0.20190206

Figure 10: Add the DVT and TI Emulators software sites
to pickup necessary patches.

3. After TI Emulators and DVT patch sites have
been added, select “Apply and Close”.

4. Select Help->Check For Updates in CCS

5. A list of software updates will appear. Deselect
ARM and C6000 compiler tools. Ensure that the
following components are selected and that the
version numbers are as specified below. Newer
versions of any of the components will also
be acceptable for this lab.

• TI Emulators - 8.1.0.00003

• DVT - 4.1.0.20190206 (any package with
com.ti.dvt2)

• Shared device support - 1.1.1 (required by
the Sitara Device support)

• Sitara Device support - 1.4.5

6. Proceed with the installation and restart CCS
when prompted.
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LAB 0.3 Hardware Setup

The hardware used for this lab is as follows. Note
that the XDS110 debug probe can be substituted
with any CCS supported debug probe.

• AM572x EVM - http://www.ti.com/tool/
tmdsevm572x

• Texas Instruments XDS110 Debug Probe - http:
//www.ti.com/tool/TMDSEMU110-U

If you do not have access to the hardware, pro-
ceed to LAB 0.4. To prepare the hardware for de-
bugging with CCS:

1. Connect the XDS110 debug probe to the 20-pin
JTAG connector on the AM572x EVM.

2. Connect the XDS110 USB to your machine.

3. Ensure that the lab-provided micro SD card is
fully inserted into the SD card slot.

4. Connect the 12-volt power supply to the
AM572x EVM. At this point you should see one
LED light up on the EVM.

5. Press the S1 button to power on the AM572x
EVM. Another LED should light up.

6. Wait 10 seconds and confirm that both LEDs
are still lit.

7. If one of the LEDs turns off after 10 seconds,
confirm that the SD card is inserted properly
and try again.

To power-cycle the AM572x EVM:

1. Unplug the 12-volt power supply from the EVM
then plug the power supply back in.

2. Press the S1 button to power on the AM572x
EVM.

To power-cycle the XDS110:

1. Unplug the USB cable from the XDS110 debug
probe and plug back in.

2. For more XDS110 information, see <ccs in-
stall>/ccs_base/common/uscif/xds110/
XDS110SupportReadMe.pdf.

If at any point during the labs a step is not
working as expected, the first trouble-shooting
advice is to power-cycle the EVM.

LAB 0.4 Debug Training Installation

1. Run the Debug_Training-1.1 -<OS>-installer
executable.

Figure 11: The Debug Training material can be installed
anywhere.

2. This will install the CCS projects and target con-
figuration needed for the labs.

3. Keep the installation directory handy as you will
be using it when importing the CCS projects
and target configurations into CCS. This debug
training installation directory will be referred to
as <debug training root> in this document.

LAB 0.5 Debug Lab Setup in CCS

The labs will use application code provided by the
Debug Training installer for demonstrating debugging
techniques. To build the lab applications, follow the
steps below.

1. Within CCS, select Project->Import CCS
Projects as shown in 12.

Figure 12: Import the Debug Training lab projects into
your CCS workspace.
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2. Set the "Select search-directory" input box to
the "labs" directory which can be found in <de-
bug training root>.

Figure 13: Import the Debug Training lab projects into
your CCS workspace.

3. Select all projects and click “Finish” button.

4. Build all of the projects in the CCS workspace
via Project->Build All(CTRL + B).

5. In a new, clean environment, the build can take
several minutes.

6. If errors are displayed in the CDT Build Console,
check that all required software was correctly in-
stalled as described in LAB 0.1.

LAB 0.6 Target Configuration

If you are using a supplied AM572x EVM and
XDS110 for the lab, you will need to import the tar-
get configuration created for the this lab using the
following steps.

1. Select View->Target Configurations menu op-
tion in CCS.

2. In the Target Configurations window, right-click
User-Defined and select Import Target Configu-
ration.

Figure 14: Import the target configuration from <debug
training root>/target_config.

3. Point the Open File dialog to
<debug training root>/target_config/
AM572-GPEVM_DebugLab_
XDS110_USB.ccxml and select Open.

4. Select “Link to Files” as the import method so
that the correct GEL files used.

Figure 15: Select Link to files when importing lab-
provided CCXML files.

5. If you have completed the steps in LAB 0.3, you
can test the Target Configuration.

6. To test the Target Configuration, dou-
ble click the AM572-GPEVM_DebugLab_
XDS110_USB.ccxml file in the Target Config-
urations window and select Test Connection
shown in Figure 16.

7. After several seconds, a pop-up dialog will dis-
play with the connection test results as shown
in Figure 17.
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Figure 16: Test the connection to confirm that the lab
hardware is setup correctly.

8. A successful connection test will look similar to
Figure 17.

Figure 17: After several seconds, the Test Connection
console will display the test results.
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LAB 1 Debugging With Breakpoints

The term breakpoint within CCS can be used to describe a set of debug features that extend past the
classical definition of a breakpoint. Breakpoint types are debug feature definitions that are generically
named and used across multiple TI devices. Not all of the breakpoint types described in this section are
actually breakpoints in terms of functionality, however they are all configurable via the Breakpoints view.

Breakpoints can be enabled during an active debug session in the following ways.

1. Breakpoints View

(a) Open the Breakpoints view (View->Breakpoints)

(b) Highlight the core you want to set a breakpoint for.

(c) Right-click anywhere in the Breakpoints view and select a breakpoint type from the dropdown
menu.

Figure 18: Breakpoints can be enabled via CCS View->Breakpoints menu.

2. Source File / Disassembly View

(a) Some breakpoints can be set directly from a source file or disassembly view during an active
debug session.

(b) To set breakpoints from source, you can double-click the blue vertical bar left of the line number.
You can also right-click the desired source line and select a Breakpoint type.

(c) To set breakpoints from the disassembly view, you can double-click left of the address or right-click
the desired line and select a breakpoint type.
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Figure 19: Breakpoints can be enabled directly from the Source or Disassembly views in CCS.

LAB 1.0.1 Breakpoint Types

Breakpoint Type Cortex A15 Cortex M4 TI C66 DSP
Breakpoint Supported Supported Supported
Hardware Breakpoint Supported Supported Supported
Chained Breakpoint Supported
Context Breakpoint Supported
Count Event Supported Supported (via SCTM) Supported
Hardware Watchpoint Supported Supported Supported
Data Access Count Supported
Cross-Triggering Supported
Profile Control Point Supported Supported Supported
Set AEGEVT/External Supported
Watchdog Timer Supported

Table 1: Supported breakpoint types on AM5728 device.

LAB 1.0.2 Breakpoint

Breakpoints in CCS are software breakpoints that are used to generate a debugger response when the
PC register matches the address of a breakpoint’s specified location. The implementation of software
breakpoints is architecture dependent but generally is handled in CCS by replacing or modifying opcodes
in program memory. Software breakpoints in CCS can’t be written in non-volatile memory such as flash.
However, hardware breakpoints can be used in flash memory. An unlimited amount of software breakpoints
can be set within CCS. Breakpoints can also be used for functions other than halting a core. Some debugger
actions that can be triggered from a breakpoint include read/writing to a file, executing GEL expressions,
and controlling profiling features.
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LAB 1.0.3 Hardware Breakpoint

Hardware breakpoints share all of the same features as software breakpoints and offer extended ISA spe-
cific features. There are a limited number of hardware breakpoints per ISA as each hardware breakpoint
requires the use of hardware resources. Note: HW breakpoints are limited to 29-bit address range for
Cortex-M targets. Therefore, one can only set breakpoints in program locations below 0x2000_0000,
which only includes the boot space on this device.

LAB 1.0.4 Chained Breakpoint

A chained breakpoint is a special type of hardware breakpoint that takes two locations as parameters.
The second location specified in a chained breakpoint will only execute the debugger response (i.e. halt
core) after the first location has been matched. Chained breakpoints are useful when you want to trigger a
breakpoint in frequently executed code only after another specified condition has been met.

LAB 1.0.5 Count Event

Count events use hardware resources to count system events such as CPU cycles, cache misses, and
pipeline stalls.

LAB 1.0.6 Hardware Watchpoint

Hardware watchpoints are similar to hardware breakpoints but instead of triggering an action when a PC is
matched, the action will be triggered when a specified memory address range or value is accessed.

LAB 1.0.7 Data Access Count

Data access counts provide a similar functionality as a count event combined with a hardware watchpoint.
When a specified address range or location is accessed, a hardware counter is incremented.

LAB 1.0.8 Cross-Triggering

Cross-triggering is primarily used for Symmetric Multi-Processing (SMP) debugging, however, there are
additional capabilites exposed in the context of the Breakpoint view in CCS. In the case of the A15, a
Cross-Triggering breakpoint allows customized triggering networks to be configured.

LAB 1.0.9 Breakpoints Application

The purpose of the lab activities in this section are to demonstrate use-cases for the different breakpoint
types supported for the AM5728 device. The breakpoints demonstration application is a SYS/BIOS appli-
cation that launches two simple tasks that will work together to fill an external buffer with a ramping toggle
value as shown below.
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Figure 20: The breakpoints application is run in SMP mode for the Cortex A15 and M4 cores where bpTaskFxn1()
and bpTaskFxn2() are executed on separate cores. For C66 DSP cores, both tasks are executed on a single core.

The first task, bpTaskFxn1() is the task that will update the external buffer (externBuf) with the calculated
ramping toggle value that is determined by the shared scale parameter. The second task, bpTaskFxn2() is
responsible for updating the scale factor and wrapping the count loop once a specified number of iterations
have been reached.
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LAB 1.1 Software Breakpoints

In this lab, we will create an A15 SMP group, load
the breakpoints application, and set software break-
points.

LAB 1.1.1 Setup

1. Power-cycle the AM57x EVM as described in
Section LAB 0.3.

2. Launch the AM572-GPEVM_DebugLab_
XDS110_USB.ccxml target configuration by
right-clicking the .ccxml file and selecting
"Launch Selected Configuration".

Figure 21: Debug sessions can be launched from the Tar-
get Configurations window by right-clicking and selecting
"Launch Selected Configuration".

3. Highlight the CortexA15_0 and CortexA15_1
cores by holding CTRL while selecting each
core.

4. Right-click one of the highlighted cores and se-
lect Sync group core(s).

Figure 22: For AM5728, the Cortex A15s, Cortex M4s,
and C66 DSPs can be grouped in a sync group.

5. You should see the SMP confirmation dialog
pop up if the “Do not show this message again”

checkbox has not been previously marked.
Click proceed to continue.

Figure 23: Select "Proceed" on the Sync Group Cores
dialog.

6. Now that the A15 cores have been grouped,
right-click the created group and select “Con-
nect Target” to connect to both A15s.

Figure 24: Example of a sync group created with the Cor-
tex A15 cores.

7. Once the A15s are connected and marked as
“Suspended”, right-click the CortexA15_0 core
and perform a “CPU Reset (SW)” reset using
the reset button in the CCS toolbar as shown in
Figure 25. Repeat the "CPU Reset (SW)" reset
for the CortexA15_1 core.

Figure 25: Reset CortexA15_0 and CortexA15_1 individ-
ually by selecting each core and then selecting reset.

8. Highlight the A15 group and select Run->Load-
>Load Program and point the file browser to the
<debug training root>/labs/breakpoints/build/
a15/Debug/breakpoints_a15_smp.out application.
This will load the application onto both cores.
Both cores will run for a bit and should end up
halted as shown in Figure 26.
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Figure 26: Ensure that CortexA15_0 is halted at main().

LAB 1.1.2 Configure - Set Breakpoint (SW) in
bpTaskFxn1()

1. Open up main.c within the Debug perspective
and navigate to bpTaskFxn1().

2. If main.c is not opened, double-click the main()
entry in the CortexA15_0 call stack.

3. On line 90 of main.c, double-click the blue bar
left of the line numbers to set a software break-
point as show in Figure 27. Note: You can spec-
ify a location with the format of <source file>,
line <line number>.

Figure 27: Breakpoints will show up as a blue dot in the
left column of the source view.

LAB 1.1.3 Observe - Run the cores and observe
the software breakpoint

1. Select the top-level synchronous group contain-
ing the A15 cores.

2. With the A15 synchronous group highlighted,
click the green play arrow in the toolbar to run
both A15 cores as shown in Figure 28.

Figure 28: The A15 cores will run simultaneously when
running in a sync a group.

3. Almost instantly, both cores will halt as a re-
sult of the software breakpoint set in LAB 1.1.2.
There are several observations to be made
here:

• The CortexA15_0 status should be set
to (Suspended – SW Breakpoint). As
the suspended status implies, the Cor-
texA15_0 core is halted because of the
software breakpoint that was set in step
LAB 1.1.2

• The CortexA15_1 status should be set
to (Suspended – Cross-triggering). The
cross-triggering status implies that this
core has halted as the result of an ex-
ternal trigger. In this case, the external
trigger was the halting of CortexA15_0 as
setup from the synchronous group created
in step 1.

• Note the call stack underneath the Cor-
texA15_0 shows bpTaskFxn1() at the top
of the stack as expected. You should also
see that the source line in main.c is high-
lighted where CortexA15_0 is halted.

• To view the source where the Cor-
texA15_1 core is halted, double-click the
top of the call stack underneath the Cor-
texA15_1 core.
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Figure 29: Halted at the software breakpoint set in LAB
1.1.2.

4. The simple task of the breakpoints application is
to generate an array of ramping toggle values in
DDR. To view the content of the ramping toggle
array generated by the breakpoints application,
create an expression (externBuf) in the expres-
sion Window as shown in Figure 30.

Figure 30: Use the Expression window to view the values
of externBuf[].

5. Next, clear the software breakpoint created in
LAB 1.1.2.

(a) To clear the breakpoint, double-click on the
breakpoint in the Source or Disassembly
view.

(b) You can also delete the breakpoint from
the View->Breakpoints menu.

6. Run the grouped A15 cores for a few seconds
and the halt just the CortexA15_1 core by high-
lighting the CortexA15_1 core and selecting the
pause/suspend button from the CCS toolbar.

Figure 31: Halt both cores after for a few seconds then
halt the cores with the pause/suspend button.

7. Observe the statuses of the CortexA15_0 and
CortexA15_1 cores. The CortexA15_1 status
should read “Suspended” due to the user re-
quest to halt. The CortexA15_0 status should
read “Suspended – Cross-triggering” due to the
external halt request from CortexA15_1 .

Figure 32: Cores that are not explicitly halted will display
the reason for the halt next to the core name.

8. Next observe the updated values in externBuf
via the Expressions window. Note: You will
need to highlight a single core for the Expres-
sions window to be valid.

Figure 33: Ensure that a single core is highlighted when
viewing expressions.

9. To graph the values of externBuf, right-click the
externBuf row and select “Graph” as shown in
34.

Figure 34: Right-click an expression and select Graph.
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Figure 35: Graphed value of externBuf[] in CCS.

LAB 1.1.4 Experiment

1. Set a software breakpoint anywhere in bpTask-
Fxn2().

2. Run the A15 group and wait for the A15 cores
to halt.

3. Observe that CortexA15_1 is halted at bpTask-
Fxn2() as shown in Figure 36. Remember that
bpTaskFxn1() is run on the CortexA15_0 core
and bpTaskFxn2() is run on the CortexA15_1
core.

4. Observe the suspended status of both A15
cores and justify the reason for the halt sta-
tuses.

Figure 36: Halted at a software breakpoint in bpTask-
Fxn2().

LAB 1.1.5 Challenge - Create a software break-
point that will print a message to the
console every time the loop counter
is reset in bpTaskFxn2().

1. Hint 1: You will need to update the Debugger
Response->Action in breakpoint properties.

2. Hint 2: GEL APIs and documentation can be
found directly in CCS via Help->Help Contents.
Search for “GEL_TextOut”.

LAB 1.2 Hardware Breakpoints

LAB 1.2.1 Setup

1. Clear any leftover breakpoints that were created
in LAB 1.1 via the Breakpoints view and the Re-

move All Breakpoints button shown in Figure 37.

(a) You might notice that there are multiple
breakpoints (one per core) listed in the
Breakpoints view after only setting one
breakpoint.

(b) This is how the CCS debugger handles
breakpoints within the context of an SMP
group. See http://software-dl.ti.com/ccs/
esd/documents/ccs_smp-debug.html for
more details.

Figure 37: Remove all breakpoints via the Breakpoints
window.

LAB 1.2.2 Configure - Set a hardware break-
point in bpTaskFxn2() where the loop
counter gets reset

1. Right-click line 136 in main.c and select “Hard-
ware Breakpoint” as shown in Figure 38.

Figure 38: Hardware breakpoints can be set from the
source view by right-clicking a line of code.

LAB 1.2.3 Observe

1. Run the sync group cores and observe after
some time that the cores have halted.
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2. Verify that the suspended status for is correct
and justifiable for both cores.

3. Observe that the values in externBuf are as ex-
pected.

LAB 1.2.4 Experiment

1. Configure the hardware breakpoint on line 136
to have a skip count of 4 via the Break-
point Properties (right-click a breakpoint in
source/disassembly view or Breakpoints view)
as shown in Figure 39.

Figure 39: A skip count defines how many times the
breakpoint will be hit and automatically resumed.

2. Set another hardware breakpoint on line 137
in main.c and configure the Debugger Re-
sponse to execute the following GEL function:
GEL_TextOut("Count will be reset.\n ",0,0,0,0,0);

3. After running for ~30 seconds, you should see
four messages print to the console from the
CortexA15_1 context and that the breakpoint
on line 136 has been hit after being skipped 4
times.

4. Also note the suspended status of CortexA15_1
is now “Suspended – HW Breakpoint”.

LAB 1.2.5 Challenge - Determine how many
hardware breakpoints are supported
for each ISA (A15, M4, C66).

1. Hint 1: CCS will not allow you to set more than
the maximum number of hardware breakpoints
supported by the hardware.

2. Hint 2: You do not have to have code loaded
to set hardware breakpoints. You can use the
Breakpoint view to add hardware breakpoints
with a random address.

3. Hint 3: AET stands for Advanced Event Trigger-
ing and is the software stack used underneath
the hood of CCS to program device hardware
for debugging and analysis.
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LAB 1.3 Chanined Breakpoints (C66 only)

LAB 1.3.1 Setup

1. Connect to the C66xx_DSP1 core.

2. Perform a CPU Reset on C66xx_DSP1
and load the <debug training
root>/labs/breakpoints/build/c66/Debug/
breakpoints_c66.out application and verify that
the PC is at main().

3. Ensure that no breakpoints are set via the
Breakpoints view.

LAB 1.3.2 Configure Chained Breakpoint

1. Suppose we are interested in the value of
testVal in bpTaskFxn1() only after the scale has
been updated in bpTaskFxn2().

2. To do this, we can set up a chained breakpoint
with the first location set to “main.c, line 142”
and the second location set to “main.c, line 96”
as shown in Figure 40. Note that chained
breakpoints must be configured from the Break-
point view by right-clicking or selecting the New
Breakpoint icon.

Figure 40: In a chained breakpoint, the application will
halt at the second location only after the first location
breakpoint has been reached.

LAB 1.3.3 Observe

1. Run the C66xx_DSP1 core and wait for the core
to halt.

2. After running, the C66xx_DSP1 core will halt at
the first location only after the second location
has been reached, which is the first time the
scale variable gets updated.

3. Observe that the scale variable is no longer set
to the initial value of zero.

LAB 1.4 Count Event

For this lab, we will set up 2 count events that will
count the following.

1. CPU interrupts on the C66xx_DSP1 core

2. Number of floating point instructions specual-
tively executed on the CortexA15_0 core

LAB 1.4.1 Setup - Execute initialization gel on
CS_DAP_DebugSS

1. If the breakpoints application is already loaded
from LAB 1.2, clear any active breakpoints and
continue to LAB 1.4.2.

2. In order for the hardware to be setup correctly
for this lab, a gel needs to be run on the
CS_DAP_DebugSS core.

3. First, connect to the DAP_DebugSS core.

4. To do so, right-click any core and select the op-
tion to "Show all cores" as shown in Figure 41.

5. Expand non-debuggable cores, right-click
CS_DAP_DebugSS, and select "Connect
Target".
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Figure 41: Non Debuggable Devices are hidden by de-
fault. Right-click any core and select "Show all cores" to
make non debuggable devices visible.

Figure 42: Connecting to the CS_DAP_DebugSS will
cause an initialization gel file to run needed for timer con-
figuration. Note: The CS_DAP_DebugSS core is auto-
matically connected when connecting to A15 cores.

6. Perform a CPU Reset on C66xx_DSP1 and
load the C66 breakpoint application.

7. Ensure that no breakpoints are set via the
Breakpoints view.

LAB 1.4.2 Configure

1. First, we will configure a count event breakpoint
to count CPU interrupts on the C66xx_DSP1
core.

2. Set a breakpoint on “main.c, line 98”, run the
C66xx_DSP1 core, and wait for the breakpoint
to be reached.

Figure 43: Run to line 98 before enabling the count event
breakpoint.

3. Next configure a Count Event breakpoint by
right-clicking in the Breakpoints view and select-
ing “Count Event”.

4. Configure the Count Event breakpoint proper-
ties as shown in Figure 44.
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Figure 44: Count event configuration to profile CPU in-
terrupts. Note: The overflow flag is a read-only field
which indicates that the counter has overflowed. If
the Overflow field is true, you can reset the counter
by right-clicking the Count Event in the Breakpoints
window and selecting "Reset Counter".

LAB 1.4.3 Observe

1. Run the C66xx_DSP1 core until the breakpoint
is reached again.

2. Observe the count value of 5 in the Breakpoints
view as shown in Figure 45.

Figure 45: Count event indicating that 5 interrupts have
happened since the last time the breakpoint on line 98
was hit.

3. The count value of 5 is justifiable as the bpTask-
Fxn1() task is configured to sleep 5 system ticks
(interrupts) before executing and reaching the
breakpoint.

4. Note: If you see an interrupt value other than
5, check the Signal Type setting in breakpoint
properties.

LAB 1.4.4 Experiment

1. Clear all existing breakpoints and load the
breakpoints application onto the CortexA15_0
and CortexA15_1 cores in SMP mode as de-
scribed in LAB 1.1.

2. Set a breakpoint with a location of “main.c, line
98” and run the CortexA15_0 and CortexA15_1
cores until the breakpoint is hit.

3. Create a Count Event breakpoint for the Cor-
texA15_0 and CortexA15_1 cores to count the
number of float instructions speculatively exe-
cuted as shown in Figure 46.
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Figure 46: Count the number of float instructions
specualtively executed.

4. Run the A15 sync group and observe the count
value on halt.

5. Open the Disassembly window to the halted lo-
cation and observe the float instructions that
were executed prior to reaching the breakpoint
as shown in Figure 47.

Figure 47: Count event displaying the number of float
instructions speculatively executed. Note: Only one of
the count events will show a non-zero count because only
the CortexA15_0 core is executing float instructions.

6. Run the CortexA15_0 and CortexA15_1 cores
several times and observe the changing count.

7. Note that the speculative execution of floats
may cause a difference in count values each
run.

LAB 1.4.5 Challege

Count events are also configurable in a more stream-
lined fashion within CCS via the Run->Clock menu
(A15 and C66 only). If enabled in this way, CCS will
create the Count Event breakpoint under the hood
and display a clock icon and count value in the bot-
tom right corner of the debug perspective

1. Profile CPU cycles using a debug clock via the
Run-Clock menu.

Figure 48: The profile clock can be enabled vis the Run
menu in CCS.

Figure 49: The profile clock will show up in the bottom
right-hand corner of CCS.

2. Hint: You can reset the clock count by double
clicking the clock icon in the bottom right hand
corner of the CCS debug perspective.
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LAB 1.5 Hardware Watchpoint

LAB 1.5.1 Setup

1. Clear any leftover breakpoints from LAB 1.4.

2. Perform a CPU Reset on the C66xx_DSP1 and
reload the breakpoint application.

LAB 1.5.2 Configure

1. The hardware watchpoints for C66 and Cor-
texM4 cores support an additional data field
which allows the watchpoint to compare data
values in addition to the address comparison.

2. Since we know how the ramp pattern will be
generated and scaled in the breakpoints appli-
cation, we can wait for the value being written to
externBuf to hit 300, which means the bpTask-
Fxn2() task will have run 3 times and we have
increased the scale by a factor of 3.

3. Navigate to line 98 in main.c, right-click and se-
lect “Run to cursor” as shown in Figure 50.

Figure 50: "Run to cursor" is the shortcut for setting a
breakpoint, running to the breakpoint, and removing the
breakpoint.

4. Once line main.c, line 98 has been reached,
configure a Hardware Watchpoint by right-
clicking testVal on main.c, line 98 and
selecting“Breakpoint->Hardware Watchpoint”.

5. Another method to set the watchpoint is to right-
click the Breakpoints view and enter the symbol
or address into the Location field as shown in
Figure 51

Figure 51: When manually entering a location field for a
hardware watchpoint, CCS can resolve symbols directly
to an address.

6. Right-click the hardware watchpoint in the
Breakpoints view and update the properties as
shown in Figure 52.

Figure 52: "Hardware watchpoint configuration for halt-
ing the C66xx_DSP1 when a value of 0x12c is written to
testVal.

LAB 1.5.3 Observe

1. Run the C66xx_DSP1 core until the core halts.

21



2. Observe the values of scale and testVal by mov-
ing the cursor over the variables in the main.c
source window.

3. As predicted, scale has a value of 3 and testVal
is now 300.

LAB 1.6 Cross Trigger

LAB 1.6.1 Setup

1. If you are connected to the A15 cores, disable
the synchronous group if it is enabled.

2. To disable the synchronous group, right-click
the top level group and select "Ungroup
core(s)".

3. Terminate the debug session, start a new de-
bug session, and connect to both A15s. Do not
create a sync group.

4. Ensure that no breakpoints are set.

5. Run both cores (code does not need to be
loaded).

LAB 1.6.2 Configure

1. Here we will use a Cross Trigger breakpoint to
cause CortexA15_1 to halt when CortexA15_0
halts.

2. Right-click in the Breakpoints view and add a
Cross Trigger breakpoint.

3. Open up the Cross Trigger breakpoint proper-
ties and set the configuration as shown in Fig-
ure 53

Figure 53: Cross Trigger breakpoint configuration to halt
CortexA15_1 when CortexA15_0 halts. Events can be
considered inputs and actions can be thought of as out-
puts. For example, when event A occurs trigger action
B.

4. After closing the Breakpoint properties, enable
the Cross Trigger via the checkbox in the Break-
points view.

LAB 1.6.3 Observe

1. With both cores running and the Cross Trigger
breakpoint enabled, halt the CortexA15_0 core.

2. CortexA15_1 should halt with a suspended sta-
tus of Cross-Triggering.

LAB 1.6.4 Experiment

1. An equivalent and more convenient way to con-
figure the cross trigger shown in steps 1-3 would
be to use global breakpoints. Global break-
points set up the triggering network required to
halt a set of cores that have global breakpoints
enabled. Global breakpoints can be enabled
by right-clicking a core and selecting “Enable
Global Breakpoints” as shown in Figure 54.
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Figure 54: Cores with global breakpoints enabled will halt
when any other core is halted if global breakpoints are
enabled for the initiating core.

2. Clear the cross-trigger breakpoint set in the pre-
vious steps.

3. Enable global breakpoints for both A15s and run
and halt the each core to see that the crosstrig-
ger is observed in both directions. Note that
global breakpoints can be used with all A15,
C66, and M4 cores on AM5728.

4. Next create a new Cross Trigger breakpoint.

5. In the properties observe that Channel 0 is allo-
cated to Global Breakpoints.

6. Similar to hardware breakpoints, cross trigger-
ing channels are a limited resource.
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LAB 2 Processor Trace

Processor trace provides a non-intrusive means of capturing what code was executed during a specified
period of time. ISA specific hardware on the A15 and DSP cores can be programmed to generate trace data
where the data can be captured into an on-chip embedded trace buffer (ETB) or exported via device pins to
a supported debug probe. Once the trace data has been captured, CCS can collect the data from the ETB
or debug probe and decode the information and present it in a human-readable format. See section 39.4
Processor Trace of the TRM 3 for more details.

LAB 2.1 Processor Trace Use-cases

Use-case Cortex A15 Cortex M4 TI C66 DSP
PC Trace Supported Supported
Custom Core Trace Supported Supported
Function Profiling Supported Supported
Code Coverage Supported Supported

Table 2: Supported processor trace use-cases on AM5728.

For the AM5728 device, all of the processor trace use-cases listed in Table 2 are available via the
Tools->Hardware Trace Analyzer menu in CCS.

LAB 2.1.1 PC Trace

PC (program counter) trace is the most basic processor trace use-case. With default settings, PC Trace will
capture the instructions executed on the selected, running core and display the trace in the Trace Viewer
when the core is halted. No additional trigger setup is required in the advanced properties.

LAB 2.1.2 Custom Core Trace

Custom Core Trace is the same as PC trace except there are no pre-configured triggers set up. If you run
Custom Core Trace without setting up advanced properties, no trace data will be captured. Typical trace
trigger actions that need to be set up for Custom Core Trace are:

1. Trace On – Trace is always on (PC Trace uses this trigger action by default)

2. Trace Start – Start trace capture

3. Trace Stop – Stop trace capture

4. Trace In Range – Trace only when PC is within specified address range

5. Don’t Trace In Range – Trace only when PC is not within specified address range

6. Trace Variable – Trace specified data variable and/or range

LAB 2.1.3 Function Profiling

Function profiling configures the hardware similar to PC Trace, but extends some additional analysis settings
for the visualization. When opening Function Profiling, a standard Trace Viewer will open as well as an
additional Function Profiler analyzer to show statistics about the code execution. Note that the Function
Profiler analyzer can also be opened via the Trace Viewer toolbar during a standard PC or Custom Core
Trace session.
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LAB 2.1.4 Code Coverage

Code Coverage is similar to Function Profiling in that the use-case will open a standard Trace Viewer with
PC trace settings as well as an analyzer specific to code coverage data.

LAB 2.1.5 Processor Trace Application

A test application has been provided for the A15 and C66 cores and can be found in the following locations:

• CortexA15_0 : <debug training root>/labs/trace/build/a15/Debug/processor_trace_a15.out

• C66xx_DSP1 : <debug training root>/labs/trace/build/c66/Debug/processor_trace_c66.out

The processor trace application is intended to be run on a single core and will execute a single task,
traceTask(). The traceTask() function will loop continuously, making several function calls which includes
calls to more nested functions.

Figure 55: The processor trace application contains a series of nested function calls that are used to demonstrate
trace capabilities for the AM5728 device.
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LAB 2.2 PC Trace

LAB 2.2.1 Setup

1. Launch a debug session and connect to the
CortexA15_0 core.

2. Perform a CPU Reset (SW) on the CortexA15_0
core.

3. Load the <debug training root>
/labs/trace/build/a15/Debug/
processor_trace_a15.out application.

LAB 2.2.2 Configure

1. Configure PC Trace by first opening the Tools-
>Hardware Trace Analyzer->PC Trace menu
item.

2. Reset the trace configuration to default values
by selecting the red arrow on the bottom left
side of the trace configuration dialog as shown
in Figure 56.

Figure 56: Default PC Trace dialog

3. Verify the Transport Type is set to ETB and click
start.

4. A new Trace Viewer tab should open and
display “Receiver recording trace data. . . ” as
shown in Figure 57.

Figure 57: Trace Viewer with trace enabled

LAB 2.2.3 Observe

1. At this point PC trace is enabled and any in-
structions executed on the CortexA15_0 core
will be recorded in the ETB.

2. Note the various menu items in the Trace Viewer
toolbar. Some notable menu items are labeled
in Figure 58

Figure 58: Important Trace Viewer menu items

3. The default settings for PC trace will configure
trace recording to be synchronized with the ex-
ecution of the core being traced. To verify this,
perform a single step over (F6) with the Cor-
texA15_0 core and observe the contents in the
Trace Viewer.

4. You should see a few records of trace data.
Compare the Program Addresses in the Trace
Viewer records to what is in the current disas-
sembly view for CortexA15_0 .
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Figure 59: The results of tracing a single step with the
CortexA15_0 core.

5. Now run (F8) the core for a few seconds and
halt (ALT + F8).

6. You should see thousands of trace records and
the receiver status should mention buffer full.
Currently for this device, only circular buffer
mode for the ETB is supported. This means that
the ETB buffer will continuously wrap over itself
until trace is stopped and as a result will always
contain only the most recent trace data.

LAB 2.2.4 Experiment

1. You will notice that the majority of trace data
contains internal system calls from SYS/BIOS.
Use the search feature button (Binoculars in
the trace viewer toolbar) to attempt to locate
any of the core_fxn functions in the trace data
by setting the search field to “Source” contains
“core_fxn”.

2. If you are unable to locate core_fxn in the pre-
vious step, the trace window that was captured
did not contain any history of a core_fxn func-
tion execution as the trace data containing that
information has been overwritten. In this case,
trace was most likely captured when the task
was sleeping.

3. Set a breakpoint on the core_fxn3() call inside
of traceTask() and run the CortexA15_0 core
again.

4. Run the core until the breakpoint is hit and scroll
to the very end of the trace data in the Trace
Viewer.

5. You should now see the correct sequence of
function execution up until the breakpoint is hit.

6. There are other means of specifying where in
your program to trace as described in LAB 2.3.
However, if you know exactly where you want to
trace in an application, breakpoints are an easy
way to do so.

LAB 2.2.5 Challenge

1. Using analyzers and breakpoints, plot the func-
tion execution graph of the core_fxn functions
in traceTask() using either the C66 or A15 trace
application.

2. You should be able to capture a view similar to
that shown in Figure 60.

Figure 60: Function Profiling analyzer displaying the
functions executed during trace capture.

LAB 2.3 Custom Core Trace

LAB 2.3.1 Setup

1. Launch a debug session and connect to the
CortexA15_0 core.

2. Load the <debug training root>
/labs/trace/build/a15/Debug/
processor_trace_a15.out application.

3. If CortexA15_0 is already connected and the
trace application is loaded from LAB 2.2, close
the Trace Viewer.

4. Ensure that no breakpoints are set.

LAB 2.3.2 Configure

1. Configure Custom Core Trace by first opening
the Tools->Hardware Trace Analyzer->Custom
Core Trace menu item.
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2. In LAB 2.2, we had to use breakpoints to narrow
down the window of when trace was captured
so that we could see the core_fxn functions in
the trace data.

3. With Custom Core Trace, we can configure 2
trigger actions to capture the core_fxn trace.

4. On the Custom Core Trace Configuration dialog,
select Advanced Settings.

5. Next, use the New Trace Trigger button to add
two trace trigger actions. Note: You can specify
a location with the format of <source file>, line
<line number>.

Figure 61: Select the New Trace Trigger icon to add trace
triggers.

Figure 62: The goal is to trace only functions called be-
tween lines 77 and 81 in main.c.

6. Create a Start Trace trigger on "main.c, line 77".

Figure 63: Specify the line of code where tracing will
start.

7. Create an End Trace trigger on "main.c, line 81".

Figure 64: Specify the line of code where tracing will stop.

8. Once settings are configured, start the trace
session.

LAB 2.3.3 Observe

1. Now trace is configured to only capture at the
start of the first call to core_fxn1() and stop after
core_fxn3() has been executed.

2. Run the core for a few seconds and halt.

3. Use the Code Coverage analyzer (default set-
tings) to view the code coverage statistics for
the trace that was captured.

Figure 65: Code coverage data of the trace application.
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LAB 2.3.4 Experiment

The steps for LAB 2.2 and LAB 2.3 are relevant for
the C66 DSP cores as well. If time permits, experi-
ment with C66 core trace.
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LAB 3 Profiling

There are several use-cases in CCS that aid in profiling system level events such as memory transactions,
cache misses, and pipeline stalls. Below is a table of profiling use-cases available in the CCS.

LAB 3.1 Processor Trace Use-cases

Use-case Cortex A15 Cortex M4 TI C66 DSP
Memory Throughput Analysis Core Independent
Stall Profiling Support Supported
Cache Analysis Supported
Cache View Supported

Table 3: Supported profiling trace use-cases on AM5728. Note: All use-cases except the Cache View are available
via the Tools->Hardware Trace Analyzer menu. Cache View is supported via the View->Other->Debug->Cache menu
item in CCS.

LAB 3.1.1 Profiling Application

A test application has been provided for the A15 and C66 cores and can be found in the following locations:

• CortexA15_0 : <debug training root>/labs/profiling/build/a15/Debug/profiling_a15.out

• C66xx_DSP1 : <debug training root>/labs/profiling/build/c66/Debug/profiling_c66.out

The profiling lab application performs one task to swap two buffers in DDR memory 8 times every millisec-
ond. The two buffers being swapped are located in DDR memory and a temporary holder for swapping the
buffers is held in on-chip memory (OCMC RAM).

Figure 66: The profiling application executes a single task named statsFxn() to swap buffers in DDR memory.
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LAB 3.2 Memory Throughput Analysis

LAB 3.2.1 Setup

1. Launch a debug session and connect to the
CortexA15_0 core.

2. Load the <debug training root>
/labs/profiling/build/a15/Debug/
profiling_trace_a15.out application.

LAB 3.2.2 Configure

1. Open Tools->Hardware Trace Ana-
lyzer>Memory Throughput Analysis.

2. Open Advanced Settings and configure the
trace trigger as shown in Figure 67 and 68.

Figure 67: Modify the Throughput RW EMIF1 trigger
to use MA_MPU_P1 when profiling DDR traffic from the
A15s.

Figure 68: Modify the Throughput RW EMIF2 trigger
to use MA_MPU_P2 when profiling DDR traffic from the
A15s.

3. Click Ok and begin trace capture.

LAB 3.2.3 Observe

1. First notice the two new analyzers that are dis-
played. The same type of setup can also be

configured via the Custom System Trace use-
case. If using Custom System Trace you will
have to manually setup triggers and analyzers.

2. At this point, statistical data is being recording
into the ETB. Since no DDR traffic should be
being generated at this point, the statistical data
will be all zeros.

3. Switch to the Trace Viewer tab and observe that
the buffer is already full. Stop trace collection
using the stop trace button and observe that the
throughput measurement is all zero.

4. Now, run the profiling application on the Cor-
texA15_0 core.

5. If the trace configuration settings are set to
synchronize trace capture with core execution,
trace will have automatically started again and
trace capture will stop when halting the core that
is highlighted. Since the statistics collector trace
capture isn’t tied to a specific core, there is not a
way in hardware to stop trace exactly when the
core halts (not true for C66 and A15 processor
trace). This means that for Memory Throughput
Analysis, halting the core in CCS will first halt
the core then stop trace in separate commands
from your computer to the debug probe to the
target. Thus, the gap between the core halt-
ing and trace halting is enough for the ETB to
wrap and valuable data will be overwritten. To
avoid this, we need to stop trace in the Trace
Viewer before halting the A15 should it need to
be halted.

6. Stop trace via the stop trace button in the Trace
Viewer.

7. Now the data should be non-zero and a graph
should be shown in the Memory Throughput
window as shown in Figure 69
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Figure 69: DDR throughput traffic generated by the pro-
filing application running on the CortexA15_0 core.

LAB 3.2.4 Experiment

1. Capture DDR throughput data from the
C66xx_DSP1 core and corresponding profiling
application.

2. Note: you will need to use EMIF1_SYS and
EMIF2_SYS probes for monitoring DSP/M4 ->
DDR traffic.

LAB 3.2.5 Challenge

1. Observe the data values in the Trace Viewer for
the DSP memory throughput case.

2. Do the values and corresponding graph make
sense for memory throughput?

3. Rationale: Note that in the Memory Throughput
window we will see spikes of traffic across both
EMIFs. This matches the task execution, which
is mostly in an idle state, and then periodically
does a small transfer job. Furthermore, if we
look at the data in the Trace Viewer and add up
for a given spike (i.e. “area under the curve”),
we see that we get just over 64 KB, matching
the task execution for each iteration plus a small
overhead from system calls: 2 buffers read * 4-
bytes per sample * 1024 samples * 8 loop it-
erations + some other minor traffic == 64KB!
(+small delta due to system SW overhead).

LAB 3.3 Average Burst Length

The Average burst length uses some of the same
hardware resources as throughput but in a different
mode.

LAB 3.3.1 Setup

1. Leave profiling applications from LAB 3.2 run-
ning on A15 and DSP cores.

2. Leave Memory Throughput Analysis open. We
will be modifying the use case for measuring av-
erage burst length.

LAB 3.3.2 Configure

1. Open analysis properties and modify the Use
Cases field for both triggers to “Average Burst
Length”.

2. Leave the probes as EMIF1_SYS and
EMIF2_SYS as we will be monitoring DSP-
>DDR traffic first. Additionally, set the Trans-
action Type to Read for both EMIF1_SYS and
EMIF2_SYS.

Figure 70: Set Use Cases to "Average Burst Length" and
Transaction Type to "Read".

3. Apply the trace settings and start trace capture.

LAB 3.3.3 Observe

1. After a few seconds stop trace.

2. Notice the data in the Trace Viewer during the
activity spikes indicate an average burst length
is 64 (0x40) bytes. This matches the architec-
ture of the DSPs L1 cache controller which has
64 byte cache line sizes. This is also true for the
A15s.
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Figure 71: Spikes of average burst length data indicating
64 byte bursts.

LAB 3.3.4 Experiment

1. Repeat steps 2 and 3 with the MA_MPU_P1
and MA_MPU_P2 probes and note the ex-
pected burst length.

LAB 3.4 Average Latency Distribution

Average latency use-cases use statistics collectors
in a similar fashion as the throughput and burst
length use-cases. However, for the AM5728 device,
not all probes available for throughput use-cases are
supported for latency use-cases due to hardware re-
strictions.

LAB 3.4.1 Setup

1. Leave profiling applications from LAB 3.2 and
LAB 3.3 running on the DSP as we will use it for
this lab. The A15 is not needed for this lab.

2. Leave Memory Throughput Analysis open. We
will be modifying the use case for measuring la-
tency statistics.

LAB 3.4.2 Configure

1. The configuration in this lab will measure la-
tency for two paths:

(a) DSP1 MDMA accesses to DDR (via the
DMM module)

(b) DSP1 MDMA accesses to OCMC RAM
bank #2

2. Open analysis properties and modify the first
and second triggers as shown in Figures 72 and
73.

Figure 72: Settings to measure latency distribution for
DSP1 MDMA -> DDR accesses.

Figure 73: Settings to measure latency distribution for
DSP1 MDMA -> OCMC RAM bank #2 accesses.

3. Apply the trace settings and start trace capture.

LAB 3.4.3 Observe

1. After a few seconds stop trace.

2. Once the trace data has loaded, find the spikes
in data activity from the Trace Viewer. Notice
that reads from OCMC take about 1/3 the time
as from DDR. This matches intuition as access
to on-chip memory should in general be faster
than off-chip accesses.
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Figure 74: Average latency distribution for DDR and
OCMC RAM accesses from DSP1 MDMA.

LAB 3.5 Cache View

The Cache View provides a special memory view of
L1 and L2 cache for the DSP cores on the AM5728
device.

LAB 3.5.1 Setup

1. Close the Trace Viewer and any analysis win-
dows if they are still opened from LAB 3.4.

2. Halt C66xx_DSP1 which should still be running
from LAB 3.4.

3. Enable the Cache View by selecting View-
>Other->Debug->Cache

LAB 3.5.2 Configure

1. With the C66xx_DSP1 in focus on the Debug
window and Cache View opened, click on the
+ button in the Cache View to show cache line
details.

Figure 75: Select option to "Show Cache Line Details".

2. Next set a breakpoint in the profiling application
at "main.c, line 85".

Figure 76: Set a breakpoint on the first memcpy in the
statsFxn() task.

3. Run C66xx_DSP1 to the breakpoint.

4. Once halted at the breakpoint, run the core
once more to ensure that all 3 buffers have been
un-cached via the Cache_wbInv() calls.

LAB 3.5.3 Observe

1. Single source step over the first memcpy() on
line 85.

2. Note that array aBuf[], having just been read in
as the source of memcpy(), is fully present in
L1D cache.

3. Since aBuf[] is 4096 bytes long, it occupies 64
L1D cache lines, each of length 64 bytes.

4. aBuf[] is also fully present in L2 cache, occupy-
ing 32 x 128-byte lines.

5. Note that all aBuf[] lines are Valid (V), but not
Dirty (-), since they have only been read.

6. swapBuf[], the destination of the memcpy(), is
also fully present in L2, but not in L1D cache.

7. While L2 operates as a read and write allocate
cache, L1D is read-allocate only.

8. For details, see the TMS320C66x DSP Cache
User Guide 4.
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Figure 77: The cache view after single stepping over line 85 in main.c.

LAB 3.5.4 Experiment

Observe the Cache Biew of aBuf[] after single stepping once more where aBuf[] is being written on line 86.
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LAB 3.6 Cache Analysis

Cache Analysis uses event trace to capture cache
events. In this lab we will configure cache analy-
sis to profile L1D Read Miss cache events on the
C66xx_DSP1 core.

LAB 3.6.1 Setup

Close the Cache View and run the C66xx_DSP1
core to the breakpoint set in LAB 3.5 so that cache
is invalidated again.

LAB 3.6.2 Configure

1. Open Tools->Hardware Trace Analyzer>Cache
Analysis.

2. When the Cache Analysis Configuration dialog
opens, select “L1P Cache Miss Analysis” under
“Data Collection Settings”.

Figure 78: Leave the Type selection as "L1P Cache Miss
Analysis. Note: If the option is missing, select the red ar-
row at the bottom left corner to reset settings to the default
values.

3. Next, open Advanced Settings and configure
Events 1-4 as shown in Figures 79, 80, 81, and
82.

Figure 79: Configuration for Event 1.
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Figure 80: Configuration for Event 2.
Figure 81: Configuration for Event 3.
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Figure 82: Configuration for Event 4.

4. Now apply trace settings and start trace cap-
ture.

LAB 3.6.3 Observe

1. Perform a source step over where aBuf is being
copied to swapBuf on line 85.

2. After the step is complete, trace should have
automatically started/stopped and the Cache
Event Profiler analyzer will be populated.

3. Note that Memory Event 2 Total (L1D Read Miss
Path B) has 64 occurrences. This makes sense
as memcpy() fills L1D in chunks of 64 bytes
(L1D cache lines).

4. Also note that Memory Event 4 Total (Write
Buffer Full Path A & B Totals) has 0 occur-
rences. This is because writes to swapBuf[] are

“absorbed” (w/o stalling the CPU) in the Write
buffer (FIFO) to L2 memory.

Figure 83: Cache Analysis data after single stepping over
line 85.

LAB 3.7 Stall Profiling

Stall Profiling will use event trace to capture stall
events.

LAB 3.7.1 Setup

1. Close the Cache Event Profiler and Trace
Viewer from LAB 3.6

2. Run the C66xx_DSP1 core to the breakpoint set
one line 85 so that cache is invalidated again.

LAB 3.7.2 Configure

1. Open Tools->Hardware Trace Analyzer->Stall
Profiling.

2. Select the red arrow in the bottom left corner of
the dialog to reset configuration to the default
values.

Figure 84: Use the default values for Stall Profiling.
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LAB 3.7.3 Observe

1. Perform a source step over where aBuf is being
copied to swapBuf on line 85.

2. After the step is complete, trace should have au-
tomatically started/stopped and the Stall Cycle
Profiler analyzer will be populated.

3. Observe, in the “memcpy” row:

(a) L1D Read Miss Stalls Total = 3171 cycles
(or thereabouts)

(b) Other Stalls Total = 64

(c) Note that these quantities represent CPU
cycles, whereas the Cache Analysis pro-
filing counts in LAB 3.6 were stall events.

Figure 85: Stall Cycle Profiling for line 85.

4. Switch to the “Trace Viewer - C66xx_DSP1 ”
tab.

5. Use the “Filter” button in the Trace Viewer tool
bar to search for “Pipeline stall” (Use Field ->
Trace Status . . . contains . . . “Pipeline stall”

Figure 86: Pipeline stalls occuring during memcpy().

6. The stalls are primarily associated with load in-
structions, esp. “LDNDW.D2T1” in memcpy()
reading from aBuf[], which is located in external
DDR memory.

7. Notice that after higher initial stalls (first 3
occurrences are each 200 cycles), pipeline

stalls for subsequent load instructions decline
to lower values, as the C66x Data Prefetch sup-
port takes hold. For details, see section 7.5.1
“Data Prefetch Buffer” in the TMS320C66x DSP
CorePac User Guide 5.
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LAB 4 Additional Debugging Tools

1. Debug Server Scripting (DSS): DSS provides means to script debug operations without having to open
CCS. DSS can be especially useful if you need to perform the same debugging operations many times
for a given debug scenario or test bench. DSS API documentation can be found in the root directory of
your CCS installation at <ccs root>/ccs_base/scripting/docs/DS_API/index.html.

2. CToolsTraceScripting: As an extension to DSS, CToolsTraceScripting exposes an API to script
trace capture that is normally available in Hardware Trace Analyzer. CToolsTraceScript-
ing API documentation can be found in the root directory of your CCS installation at <ccs
root>/ccs_base/scripting/docs/CTOOLTRACE_API/index.html.

3. CToolsLib: CToolslib is a set of C libraries that expose APIs to on-chip debugging capabilities. CTool-
sLib can be built into test applications that are run on the target SoC for a fine-grained control of trace
and profiling features. For more information see the CToolsLib wiki 6.

40



5 References

1. A Guide to Debugging With CCS on the DRA7x, TDA2x, and TDA3x Family of Devices - http://www.ti.
com/lit/an/sprac17b/sprac17b.pdf

2. Trace Analyzer User’s Guide - http://www.ti.com/lit/ug/spruhm7b/spruhm7b.pdf

3. AM572x Technical Reference Manual - http://www.ti.com/lit/ug/spruhz6k/spruhz6k.pdf

4. TMS320C66x DSP Cache User Guide - http://www.ti.com/lit/pdf/SPRUGY8

5. TMS320C66x DSP CorePac User Guide - http://www.ti.com/lit/pdf/SPRUGW0

6. CtoolsLib - http://processors.wiki.ti.com/index.php/CToolsLib

41

http://www.ti.com/lit/an/sprac17b/sprac17b.pdf
http://www.ti.com/lit/an/sprac17b/sprac17b.pdf
http://www.ti.com/lit/ug/spruhm7b/spruhm7b.pdf
http://www.ti.com/lit/ug/spruhz6k/spruhz6k.pdf
http://www.ti.com/lit/pdf/SPRUGY8
http://www.ti.com/lit/pdf/SPRUGW0
http://processors.wiki.ti.com/index.php/CToolsLib


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

April 2019 

Important Notice: 


	Pre-Work
	Software Installation
	Code Composer Studio 8.3.0.00009 
	SYS/BIOS 6.75.02.00 
	XDCTools (3.51.1.18 )

	CCS Configuration
	Hardware Setup
	Debug Training Installation
	Debug Lab Setup in CCS
	Target Configuration

	Debugging With Breakpoints
	Breakpoint Types
	Breakpoint
	Hardware Breakpoint
	Chained Breakpoint
	Count Event
	Hardware Watchpoint
	Data Access Count
	Cross-Triggering
	Breakpoints Application

	Software Breakpoints
	Setup
	Configure - Set Breakpoint (SW) in bpTaskFxn1()
	Observe - Run the cores and observe the software breakpoint
	Experiment
	Challenge - Create a software breakpoint that will print a message to the console every time the loop counter is reset in bpTaskFxn2().

	Hardware Breakpoints
	Setup
	Configure - Set a hardware breakpoint in bpTaskFxn2() where the loop counter gets reset
	Observe
	Experiment
	Challenge - Determine how many hardware breakpoints are supported for each ISA (A15, M4, C66).

	Chanined Breakpoints (C66 only)
	Setup
	Configure Chained Breakpoint
	Observe

	Count Event
	Setup - Execute initialization gel on CS_DAP_DebugSS 
	Configure
	Observe
	Experiment
	Challege

	Hardware Watchpoint
	Setup
	Configure
	Observe

	Cross Trigger
	Setup
	Configure
	Observe
	Experiment


	Processor Trace
	Processor Trace Use-cases
	PC Trace
	Custom Core Trace
	Function Profiling
	Code Coverage
	Processor Trace Application

	PC Trace
	Setup
	Configure
	Observe
	Experiment
	Challenge

	Custom Core Trace
	Setup
	Configure
	Observe
	Experiment


	Profiling
	Processor Trace Use-cases
	Profiling Application

	Memory Throughput Analysis
	Setup
	Configure
	Observe
	Experiment
	Challenge

	Average Burst Length
	Setup
	Configure
	Observe
	Experiment

	Average Latency Distribution
	Setup
	Configure
	Observe

	Cache View
	Setup
	Configure
	Observe
	Experiment

	Cache Analysis
	Setup
	Configure
	Observe

	Stall Profiling
	Setup
	Configure
	Observe


	Additional Debugging Tools
	References

