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Abstract 

“In software engineering, tracing involves a specialized use of logging to  

record information about a program's execution.”1 

 

This presentation will look at the software log capabilities in TI-RTOS and see how they can 

be used in conjunction with System Analyzer in CCS to debug an application. Specifically 

we’ll look at the Execution Graph and Duration Analysis to help to understand an 

application’s behavior.  

 

 

 

 
 

1Wikipedia 
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Agenda 
Here’s the high-level view of what we will cover in this presentation: 

1. Stopmode Example 

2. Debugging with System Analyzer 

– Live View 

– Execution Graph 

– Duration Analysis 

3. Logging Concepts 

– What is the Log module? 

– Logger Comparison 

– Diags Mask 

4. Debugging with System Analyzer Post Mortem 

– Runtime Enabling/Disabling Logging 

– Generating a binary file and importing in System Analyzer 

5. Appendix 

– Advanced Topics 
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Stopmode Example: Introduction 

Let’s jump right into using System Analyzer to debug an application. We’ll call this application 

“stopmode” since we’ll use Logger_StopMode as the logging mechanism. We will not focus on the 

mechanics of the logging too much now. We’ll cover it more later. 

The stopmode example has two tasks of different priorities. It also has a button callback that 

generates an exception. We’ll use System Analyzer to explain some delays and find the location of 

the exception. 

The next slides will focus on the following 

– Logging Configuration 

– Exception Handling Overview 

– Application Source Code Description 
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Stopmode Example: Logging Configuration 

Here’s the logging configuration in the app.cfg file. We’ll use the LoggingSetup module. This module 

makes enabling logging easier and gets users up and running faster. We’ll cover this module and more 

advanced capabilities later in this presentation. 

 

• Include LoggingSetup and have two different  

log buffers to manage the different areas in the 

applicaton. Also enable Hwi logging. 

 

• Make sure the kernel has logging enabled. 

 

• Include these modules so we can make Log 

calls in the application. 

 

Also, make sure the following is NOT a predefined compiler setting (SimpleLink CC2640R2 SDK does this in some examples). 

xdc_runtime_Log_DISABLE_ALL 
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Stopmode Example: Exception Handling [cont.] 

When Button0 is pushed an exception will occur. TI-RTOS has several types of exception 

handling options for CortexM devices*: 

• TI-RTOS Enhanced Exception Decoding Handler 

• TI-RTOS “Minimal” Exception Decoding Handler 

• TI-RTOS Spin loop Handler 

• User supplied Handler 

For a detailed overview, please refer to https://training.ti.com/debugging-common-

application-issues-ti-rtos. 

The next slide will show the stopmode application’s exception configuration and source 

code. 

 

 

 

*Refer to the TI-RTOS Kernel documentation for details about the exception handling for your specific device. 
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Stopmode Example: Exception Handling 

Here at the two pieces needed in the example for the exception handling… 

 

• The source code which is responsible for plugging in  
the exception handler function in the app.cfg file.  

 

 

 

• And here’s the function in main_tirtos.c. For now, 

we’re just going to turn on an LED to know that an  

exception has occurred and spin. We’ll add content  

to this function later in the postmortem example. 
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Stopmode Example: Example Description 

Here is the main gist of this very simple application… 

 

- Task1 is a priority 1 (lowest) task which sleeps for 
3 ticks. It uses the UIABenchmark_start/stop 

events. We look at these later in System Analyzer. 

 

 

 

 

- Task2 is a priority 2 which burns some CPU to  

simulate some real action and then sleeps for 

6 ticks. 

 

 

- When pushed, Button0 causes an exception! 
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Stopmode Example: Running the Example 

The example uses the MSP-EXP432P401R LaunchPad* and following software: 
- CCS 7.3.0 

- SimpleLink MSP432 v1.40.01.00 

- XDCtools 3.50.02.20   

- Compiler ARM version 16.9.4.LTS 

 

• Please build, load, and run the example.  

• After 5 or 10 seconds, hit Button0 to cause the exception. You should see 
Board_GPIO_LED0  come on. 

• Now let’s go use System Analyzer to help determine what happened… 

 

 

 

 
* We’ll use a MSP-EXP432P401R LaunchPad as a concrete example, but the concepts and the code is exactly the same  

   for all devices (minus pontentially the asm call to generate the exception).  
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Stopmode Example: But first let’s confirm we have Log records 

A quick way to make sure there are Log records is to open Tools->ROV->LoggerStopMode-

>Records. You should see records in both areas.  

 

 

 

 

 

 

 

 

 

 
We use the term “Main” for non-kernel code. For example the Log_write1() in task1 will 

go into the “Main” logger. To be more exact, xdc.runtime.Main is used for all non-XDC 

modules.  
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Stopmode Example: Start System Analyzer 

Let’s open the Execution Graph now…. 

1. Tools->RTOS Analyzer->Execution Analysis. Note: RTOS Analyzer 

 may have to initialize the first time. 

 

2. Select “Start” 

 

 

 

 

 

 

 

 

 

 

 
Please note: RTOS Analyzer is closely related to System Analyzer. For this presentation, we might use the term 

System Analyzer in a generic manner to mean either System Analyzer or RTOS Analyzer. 
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Stopmode Example: Live Session View 

System Analyzer should display the Log records in the “Live Session” window.  

 

 

 

 

 

 

 

Look at the last record and we see that the GPIO_hwiIntFxn() was the last thing running. 

When we look at the GPIO callback function, it makes sense we crashed. 
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Stopmode Example: Execution Graph 

You can see that task2 runs before task1 when they are lined up (every 6 ticks) 

since it is higher priority.  

 

 

 

 

 

 

Note: Swi logging is not included to reduce the number of records. If it was 

enabled, you see the Clock tick Swi run after the Timer Hwi (instead of Idle task). 

Please refer to the appendix to see how to get an execution graph over a longer 

period. 
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Stopmode Example: Duration Summary 
You can select Duration View the drop-down. 

 

 

Remember the UIABenchmark events in Task1…  

 

 

 

 

This is measuring the Task_sleep duration. You can see the max/min/avg in the Duration Summary. 

 

 

 

Why are the Min and Max so different? 
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Stopmode Example: Duration Summary [cont.] 
Remember Task1 is lower priority than Task2. Task1 sleeps for 3 ticks and Task2 sleeps for 6 

ticks. So every 6 ticks, both tasks will wake up. Since Task2 is higher priority, it will run first. 

Therefore Task1’s execution is delayed. This can easily be seen in the Execution Graph. 

 

 

 

 

 

 

 

Let’s look under the covers to see how we got all of this… 
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Task1 is delayed so the duration is longer Task2 was delayed so the duration is shorter 



Logging Concepts: Introduction 

TI-RTOS includes a Log module to aid in the generation of software log records. The goals 

of the Log module are 

- Minimal runtime intrusion on the application (e.g. no ASCII management on the target). 

- Usable by middleware software 

- Able to compile out the Log API calls 

- Can easily disable/enable logging during runtime 

- Can be used in runtime and post mortem analysis 

- Portable across all devices 

 

When a Log API (e.g. Log_printN or Log_writeN) is called, a Log record is generated. 

Please note the Log record is relatively small (e.g. 20-64 bytes). It is up to a host tool to 

decode the binary data. The next slide will show this in more detail. 
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Logging Concepts: Log Records 

Let’s look at the result of a couple Log API calls. 

Log_print2(Diags_USER1, "counter1 = %d (0x%x)", counter, counter); 

Log_write1(UIABenchmark_start, (IArg)"task1 sleep time"); 

These calls will generate two Log records in the internal  

LoggerStopMode buffer. 

Then here are the decoded  records in CCS 

 

 

 

And ROV 
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Logging Concepts: Loggers 

The Log module allows the application to select the underlying logger. There are several different 

types of loggers in TI-RTOS. This allows a software engineer to pick the one most optimal for their 

environment (comparison on the next slide). 

 

 

 

 

A logger is plugged a module via the common$.logger field in the .cfg file. For example  
Defaults.common$.logger = LoggerStopMode.create(loggerStopModeParams); 

Task.common$.logger     = LoggerMin.create(loggerMinParams); 

These lines plug in a LoggerMin instance for the Task module and all other modules will use the 

LoggerStopMode logger. Note: unless explicitly set, modules inherit from Defaults. 

Note: LoggingSetup creates and assigns loggers automatically for you. 
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Logging Concepts: Logger Comparison 

Here’s a comparison of the most commonly used loggers in the UIA product (or in the kernel/ti/uia 

directories in the SimpleLink SDK). 

 

 

 

 

 

 

 

 

 

 

For more details, please refer to the spruh43X.pdf document in the UIA or SimpleLink products. 
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Loggers Description Typical Use Cases 

LoggerStopmode Log records are stored in internal RAM buffer(s) JTAG is connected and can halt the target. 

LoggerMin Log records are stored in an internal RAM buffer. 

Similar to LoggerStopmode but less features. 

JTAG is connected and can halt the target. 

Post mortem analysis. 

LoggerIdle Log records are sent over UART or USBin the 

SYS/BIOS Idle Task. 

No JTAG and/or prefer not to stop the 

target. 

LoggerStreamer2 Log records are stored in a buffer supplied by the 

application. 

Application wants to “own” the 

management of the Log record buffers. 

LoggerRunMode 

(JTAG) 

Log Records are uploaded over real-time JTAG. 

Available on C64+ and C66x targets only. 

JTAG connected and cannot stop the 

target. 

LoggerRunMode 

(Ethernet) 

Events uploaded through ServiceMgr user-

pluggable transport function. 

Multi-core devices 



Logging Concepts: Diags Mask 

Too many log records is a common problem when logging. All Log calls have a “Diags” mask 

associated with it. For example: 

Log_print2(Diags_USER1, "counter1 = %d (0x%x)", counter, counter); 

The use of the Diags mask allows the Log call to be  

- Compiled in or out 

- Enabled/disabled during runtime 

For example in the .cfg file, you can tell the TI-RTOS Task module to include the USER1 and not 

include USER2 Log calls. 

Task.common$.diags_USER1 = xdc.module("xdc.runtime.Diags").ALWAYS_ON; 

Task.common$.diags_USER2 = xdc.module("xdc.runtime.Diags").ALWAYS_OFF; 

For the Task module, USER1 is used for high-level records (e.g. context switch) while USER2 is 

used for more detailed events (e.g. when a task calls Task_exit). 

You can refer to the TI-RTOS cdoc for each modules usage of the Diags mask. The Diags module 

is also discussed here: http://rtsc.eclipse.org/cdoc-tip/xdc/runtime/Diags.html 
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Logging Concepts: Pre-Defined Events 

The application can use pre-defined events also. For example the application uses 

UIABenchmark_start/UIABenchmark_stop events.  

As we saw earlier, Duration Analysis will use these events to form all the stats. 

How to use these pre-defined events is detailed in spruh43X.pdf in the UIA or SimpleLink 

products. More information is in the cdoc for each of the events also. 
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Logging Concepts: LoggingSetup 

As stated before, the most common logging features can be 

set via LoggingSetup. LoggingSetup does many of the 

actions under the covers. For example 

- Creates the requested logger instances 

- Sets up module’s common$.logger. 

- Sets up module’s common$.diags_XYZ 

To the right is the graphical view of LoggingSetup 

configurations. 
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Post Mortem Example: Overview 

We are going to have the same basic application, but show how the Log records can be written to 

non-volatile memory that can be retrieved and analyzed later. In the postmortem example, we’ll 

write the Log records to flash in the exception handler via the NVS module. 

We are use LoggerMin instead of LoggerStopMode. LoggerMin has an API that can be used to 

retrieve all the Log records. Also it only manages a single buffer. Having one buffer simplifies the 

application code when writing the records to flash memory. 

In this example, we’ll set the Main logging to be disabled at boot, but can be enabled later by 

pushing Button1. 

23 



Post Mortem Example: LoggerMin 

Instead of using LoggingSetup, we’re going to manual configure the loggers. This gives us more control on exact 

configuration we want.  

• First remove (or comment out) all LoggingSetup  

lines in the .cfg 

• Make sure the kernel has logging enabled*. 

 

• Include these modules so we can make Log 

calls in the application*. 

 

• Create a LoggerMin logger and plug into all the  

modules. The minus 16 is described later. 

 

• Enable Main. Task and Hwi modules to log records. 

For Main, we’re allowing runtime control. 

 

• These are needed to support runtime control 

of enabling/disabling logging. 

 

* Same as the stopmode example 
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Post Mortem Example: Enabling Logging 

Below is the code that will enable the Diags_USER1 and Diags_ANALYSIS diags mask for the 

application (e.g. the Log_print2 in Task2 and Log_write1 in Task1). 

 

 

 

 

 

This is possible because we used Diags.RUNTIME_OFF in the previous slide. 

Using this approach allows you to programmatically enable/disable logging. This can reduce the 

amount of Log records generated.  

The downside is that each Log API will have an additional if check. When you use 

Diags.ALWAYS_ON, the generated Log code is more optimized. 
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Post Mortem Example: NVS module 

The SimpleLink SDKs include a NVS (Non-Volatile Storage) driver. We’ll use this 

module to store the Log records into flash on the MSP432.  

The APIs used are 

- NVS_erase(): to clear out data from a previous run 

- NVS_write(): to store the Log records into flash 

Depending on your device, you may need to store the Log records via a different 

mechanism. Basically, you need to place the Log records somewhere that can be 

easily retrieved. Note: the writing of the Log records to flash in our example is 

occurring in the exception handler, so interrupts are disabled.  

The NVS module manages a 4096 block of flash by default in the MSP432 

examples in the SimpleLink SDK. We’ll use the default. 

The NVS module is detailed in 
<SimpleLink_install_dir>/docs/tidrivers/doxygen/html/index.html  
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Post Mortem Example: Exception Handler 
The exception handler in the postMortem example is expanded to read 

the Log records and write them to non-volatile memory.  

 

 

 

• Buffer to hold the read Log records 

 

 

• Open NVS module and erase the contents of the flash. 

 

• Get the contents of the LoggerMin and place them in a buffer. 

 

 

 

• Add the UIAPackect_Hdr onto the front of the buffer. It’s 16 bytes 

long. This is why we made the Log buffer size 2048 – 16 in the 

app.cfg file. 

 

 

 

• Write the Log Records to Flash 
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Post Mortem Example: Running the Example 

• Please build, load, and run the postmortem example.  

• You can halt the target now and look in ROV to see that the Main logs are not being 

recorded. 

 

 

 

 

• Resume the target and press Button1 (and confirm Board_GPIO_LED1  comes on) and 

then halt the target. Now you’ll see the Main Log records. 

 

 

 

 

 

• After 5 or 10 seconds, hit Button0 to cause the exception. You should see 
Board_GPIO_LED0  come on. 
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Post Mortem Example: Saving Log Records to a File in CCS 

Now the Log records are in flash, you can retrieve them and save 

them to a binary file.  

For this case, simply attach CCS and look at the flash memory that 

NVS manages. Select the “Save Memory” and specify the 

destination file name (must be systemAnalyzerData.bin!). Then hit 

“Next>” and specify the address and size (below is the size of the 

NVS flash region). 
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Post Mortem Example: Creating a .usmxml file…do only once! 

System Analyzer needs to know about the application since the debugger may not be 

attached when looking at the binary file. This step needs to be done once. To make it easier, 

make sure the debugger knows that the postMortem application is loaded. 

 

 

 

Open Tools->System Analyzer->Open File->Open Binary file and  

1. Click the Custom UIA Config 

2. Select the “Create UIA Config File” button. 

Next slide… 
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Post Mortem Example: Creating a .usmxml file…do only once! [cont.] 

Now save this to a file (e.g. C:\training\ExceptionAnalysis\DefaultSession.usmxml). 

 

 

 

 

 

 

This file contains information about the application (.e.g. .out file location, .xml file locations, etc.).  
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Post Mortem Example: Opening the Binary File in CCS 

In CCS, open Tools->System Analyzer->Open File->Open Binary file. Note: the debugger 

does not need to be attached!  

 

- Enter the folder name where the  

systemAnalyzerData.bin is located 

- Click the Custom button 

- Enter the .usmxml file 

- Hit “Start” 

 

 

Now you have the Log records and you 

can open Execution Graph and  

Duration Analysis the same was as before. 
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Appendix: Why have multiple loggers? 

LoggingSetup by default will create three loggers: 

– SYS/BIOS 

– CPU Load 

– Main (i.e. application) 

This is done to guarantee that one area does not flood all the other modules. For example, if 

there are lots of kernel Log records, the application Log records will not be over-written.  
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Appendix: Longer periods in execution graph 

On memory constrained devices, we generally keep the log buffers small. Of course this 

potentially causes wrapping to occur in the loggers since the smaller the buffer, the fewer records 

it holds. Here’s a few ways to handle this. 

1. Make the log buffers bigger if you have the memory. For devices like C66xx, we’ve seen log 

buffers set to 1MB! 

2. Use Diags_setMask() to enable/disable logging accordingly. So basically only log during 

regions you are interested in. 

3. Carefully use the Diags mask to only enable Log records you are interested in. 

4. Disable timestamps in the Log records. This will result in a smaller Log record so more can fit 

in a buffer. You’ll lose the time reference in the execution graph but you’ll still get the order. 

You can also move to 32-bit timestamp instead of 64-bit. 

5. For loggers that are directly read by System Analyzer (e.g. LoggerStopMode), you can just 

several breakpoints. Since System Analyzer will read at each breakpoint, you might be able to 

avoid buffer wraps. 
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Appendix: Examples Enhancements 

The example’s CortexM exception handler function is passed in the exception stack and LR 
register. We could have added Log_printN statements in myExceptionHandler() that 

would have aided in figuring out the problem also.  

 

 

 

 

 

 

 

For examples of decoding the exception stack for CortexM devices, look at the 
Hwi_excHandlerMin() or Hwi_excHandlerMax() functions in 

ti\sysbios\family\arm\m3\Hwi.c. 
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Appendix: Examples Enhancements [cont.] 

The postMortem example uses a 2048 byte buffer to retrieve the Log records from 

LoggerMin. A buffer is needed since the order of the Log records in LoggerMin’s internal 

buffer is not know (e.g. a wrap could have occurred). The LoggerMin_getContents() API 

manages that and places the Log records into the passed in buffer accordingly. 

 

 

Instead of using a dedicated 2048 byte buffer, the application could have reused a different 

buffer. For example we could have reused the stack to the tasks for retrieving the Log 

records. You’re in the exception handler already…those task are not going to be running 

anyway… 
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Appendix: LoggerStreamer2 

LoggerStreamer2 can be used instead of LoggerMin also for the post mortem case. If you 

are interested in the code for this, please ask for it on e2e.ti.com and we’ll send you a copy.  
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Appendix: Bugs 
During the write-up, a few bugs were found. 

1. The execution graph does not show the last GPIO Hwi starting icon. I believe it 

is there, but the border is hiding it. Sometimes it barely peeks out! 

 

 

 

2. If you select “Duration Analysis” in the Tools->System Analyzer, it does not 

recognize that UIABenchmarks was enabled in the .cfg. Ignore the warning 

and the Duration view still works. 

3. LoggerMin graphical configuration is incorrect. 

Bug tickets have been opened and will be addressed in a future release. 
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