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Module 1
Lab 1: Running Code on the LaunchPad using CCS
(Appendix)

Lab 1: Running Code on the LaunchPad using CCS	

1.10 Appendix: CCS Tips and Tricks
In this additional section, we will cover some tips and tricks on the following areas.
Training material for Code Composer Studio v7 is now integrated into Resource Explorer inside CCS or dev.ti.com. Under the the Development Tools -> Integrated Development Environments -> Code Composer Studio section, you can explore all of the training material available for CCS including workshops, training modules and videos. Please see the CCSv7 Training page for more details.
General
· Workspaces
· Views
· Perspectives
· Windows
· Installing Plug-ins
Projects
· Editor Tips
· Indexer
1.10.1 Workspaces
The Workspace is the Main working folder for CCS. It contains information to manage all the projects defined to it. It is the default location of any new projects created. User preferences, custom perspectives, cached data for plug-ins, etc are all stored in the workspace. For flexibility, multiple workspaces can be maintained. Only one can be active within each CCS instance. The same workspace cannot be shared by multiple running instances of CCS. It is not recommended to share workspaces amongst users, such as a networked file location. 
Multiple Users: Keep separate workspaces for each user on a shared machine
· Custom preferences, layouts, etc will be maintained on a per user basis
· Each user can be working on specific project(s) that would only be applicable to a their workspace
Project Organization: Break up all your CCS projects into separate workspaces for better maintenance
· A workspace for each software release
· A workspace for each module/feature of a release
Performance: The larger the contents of the workspace (number of open projects), the greater the impact on performance of CCS
· Good idea to periodically clean your workspace for best CCS (Eclipse) performance and stability as sometimes the workspace folder can get corrupted
· To clean workspace, either:
· Delete the .metadata folder in workspace folder
· Use a new workspace folder
· Before cleaning, save current workspace settings so they can be imported into the new workspace
· Save settings:  File->Export...->General->Preferences->To preference file 
· Import Settings: File->Import...->General->Preferences->From preference file
· Any projects will have to be re-imported after cleaning the workspace
1.10.2 Views
A view is a special tabbed window that provides resources within CCS. You can go to the View menu on the tool bar to access these if they are not visible. Access a variety of resources from the Getting Started page. Access software packages, code examples, and documentation from the Resource Explorer page. Access a variety of plug-ins and compilers from the CCS App Center page.  Use the History view to compare the current source file against any previous version or replace it with any previous version. Terminal can connect to a remote target (development board) via a serial port or over TCP/IP using the TELNET or SSH protocol. 
To open a new view go to the View menu, which lists the most commonly used views with CCS, but there are many useful hidden views. To access views that are not listed select “Other…” in the View menu. 
1.10.3 Perspectives
A perspective is how the windows are displayed in CCS. Simple perspective combines just the most common features of the CCS Edit and CCS Debug perspectives, simplifying the environment for new users and avoiding perspective switching when starting a debug session
Open the Simple perspective from the Getting Started page.
1.10.4 Windows
[image: ]
Double-clicking on the title bar of a window will maximize the window. Double-clicking again will restore it to its previous size. Fast-view windows are great for windows you use infrequently but need a lot of space when you do use them
The window that has focus is indicated by a blue border and heading[image: ]
You can customize the menu items and toolbars in your perspective. Right click on the toolbar and select Customize Perspective
[image: C:\Users\keesio\Dropbox\Work\Munich2013\1-04-TipsAndTricks\ss\03.png]
Key bindings are possible in CCS and are part of the general preferences that can be exported to a preferences file and imported. All key bindings can be viewed and modified: Window -> Preferences -> General -> Keys
1.10.5 Installing Plug-ins
Eclipse plug-ins are available through CCS App Center. Find additional Eclipse plug-ins from within CCS with the Eclipse Marketplace go to Help -> Eclipse Marketplace… and select popular 3rd party additions to the IDE.  Use the Eclipse Update Manager to install plug-ins if the plug-in update site is already known. Help -> Install New Software for new 
updates to install (specify remote site (URL) or local site (directory) )
Many plug-ins can be simply downloaded as an archive and copied into the .\ccsv6\eclipse\dropins folder manually. 
[image: C:\Users\keesio\Dropbox\Work\Munich2013\1-04-TipsAndTricks\ss\07.png]
1.10.6 Source code editor
[image: ]
Advanced editor features include Code Completion, Navigation (back to last edit button, go to definition, go to declaration), Code Folding (collapse functions), Variable Highlighting (Highlighting a variable in the editor will highlight all instances of the variable in the editor), 
Right-click in the editor margin to:
· Toggle line numbers in the editor margin
· Enable/Disable code Folding
· Enable/Disable Quick Diff
Open editor Preferences… to access more options to configure: Content Assist (Code Completion), Folding, Syntax Coloring, Hovers (Cursor "hover over" behavior), Typing behavior
1.10.7 Indexer
The C/C++ Indexer creates a database of source and 
header files of the project by parsing all of the files of the projects open in the workspace. Configure the Indexer: Window -> Preferences -> C/C++ -> Indexer
If you don’t use the CCS editor or don’t need the advanced editor features, it is recommended to turn off the indexer. The indexer can use a decent amount of system resources as it scans the file system, causing CCS to appear sluggish in larger workspaces. It is enabled by default. 
[image: C:\Users\keesio\Dropbox\Work\Munich2013\1-04-TipsAndTricks\ss\11.png]
If the indexer or advanced editor features don’t appear to be working properly you can rebuild the indexer. Right-click on a project and select
Index -> Rebuild to rebuild the indexed database for that project. 
1.10.8 Portable projects and project sharing

Often in software development you will need to split the workload between multiple developers or you need to do code reviews. This means we need a way to share our work from the IDE environment. It is not just a simple copy of the main C files but often involves having the correct configuration and support files linked and included as well. 

There are two ways to export and share your projects. Simple project sharing or linked file project sharing. You can refer to the TI wiki for additional information. 

Simple sharing
This method assumes that all source/header files are contained within the project folder and the whole folder including all the files can be shared. To share such projects:
· zip up the entire project folder and share with other user
· user who receives the project can unzip the file and import the project into their workspace using "Project->Import Existing CCS Eclipse Project" and select the project folder

Linked File sharing
The approach we are going to use here is similar to simply zipping up your project and sending that zip to another user. However this method works well even when you have linked (or referenced) files that are located outside of the project folder.
The method described here does not handle every case and if it does not work for you then you will want to take a look at the other alternatives described by the Portable Projects topic.

Here we discuss how you can export a project and give it to other users. This will give you an idea of how to structure your project and how to use the export and import features. 

In this example all the files are located within the project directory structure. If in your project you are using linked files this method can still work. What will happen is when you create the archive the export tool will include the linked resources in your archive file. When you import that archive into a workspace on a different PC it will extract the files from the archive and place them in the same location on the new PC.

These instructions cover how to archive your project on the source computer.
1. File -> Export
2. Expand "General" and select "Archive File". Click "Next"
3. The dialog that appears allows you to select which projects you wish to export to the archive. When you select a project it will show you on the right hand side all of the items it is going to export. Check the box beside the project to indicate that you want to archive it.
4. Recent versions of CCS have a check box titled Resolve and export linked resources. If your project has any linked files, then check this box.
5. Specify a name for your archive and select either zip or tar, then click "Finish"
6. You now have a zip file on your computer containing the project. Not only did it copy in the files that are physically located in your project directory but it also copied in your linked/referenced resources.

A video is available to show you a real example: https://youtu.be/kCBLL-4eq3E


These instructions cover how to import the project from the archive. What happens is that it will import the project into your workspace. For linked/referenced resources it will copy those files from the archive in place then at the same path where they were located on the original computer.
1. Project -> Import Existing CCS/CCE Eclipse Project
2. Change the radio button selection at the top to "Select archive file"
3. Browse to and select your archive file
4. It will list all of the projects found in the archive. They are all selected by default. Select the ones you want and click "Finish"
5. The project is now in your workspace

If you are creating example projects to provide to other users there are some guidelines that you can follow to make it easier for other users to be able to use your examples.
1. If possible include all of your source files in the project directory or in sub-directories under the project directory. This removes the issue of having to deal with linked files.
2. Include a readme.txt or similar file in the project that describes the purpose of the example as well as how to import it using the import from archive feature described in this topic. This file should also describe any special build options that are set.
3. If the project is designed to work with a specific development board that has onboard emulation consider including a target configuration file (.ccxml) in the project so that users can simply hit the bug button to build it and launch a debug session without having to setup the debugger.
4. Don't duplicate files that already exist in the CCS installation in your project. For these files reference them using some of the standard macros like: ${CCS_INSTALL_ROOT}
5. Export your project to an archive and share the zip (or tar if Linux).

This section covers use cases that can cause this method to fail and where you may need to perform extra steps
· The original project had file locations defined with variables. This common when someone tried to create the original project as a portable project. You will need to update the definition of these variables to match the location on your computer. 
· Do this from Windows -> Preferences. Expand General -> Workspace -> Linked Resources. 
· Select the variable and click the Edit button to change the value. 
· Once you have defined the variables you will need to delete the project from your workspace and import it again so that the import tool will copy the files in the archive to the correct location. 
· Alternative you could manually copy the files from the archive to the specified locations but it is easier to just redo the import. 
· Note that if there is a macro.ini file in the project when you do the import it may request to overwrite your definitions, say no.
· StellarisWare and ControlSuite projects both use variables.
· If header files are not in the project either physically in the project or added via linked resources then they will not be included in the archive.

The first step in solving a complicated problem is to break it into pieces. 

Sample code: Program 4_2
int32_t errors;
void Program4_2(void){
  scenario_t result,truth;
  int i,j,k;
  int32_t left, right, center; // sensor readings 
  errors = 0;
  for(i=0; i<18; i++){
    left = CornerCases[i];
    for(j=0; j<18; j++){
      center = CornerCases[j];
      for(k=0; k<18; k++){
        right = CornerCases[k];
        result = Classify(left,center,right); // yours 
        truth = Solution(left,center,right);  // correct 
        if(result != truth){
          errors++;
        }
      }
    }
  }
  while(1){
  }
}


1.11 Appendix: XDS110 Debugger and EnergyTrace

In this additional section, we will cover the debugger available with the MSP432 LaunchPad development kit. The built in debugger is an important feature that makes the LaunchPad attractive for our robot. 

1.11.1 XDS110 

The XDS110 is the latest entry level debug probe (emulators) for TI embedded processors. Designed to be a complete solution that delivers JTAG and SWD connectivity at a low cost, the XDS110 is the debug probe of choice for entry-level debugging of TI microcontrollers, processors and SimpleLink devices.

The XDS110 replaces the XDS100 technology and is the first debug probe that supports all TI devices with JTAG, cJTAG and SWD/SWO debug port in a single product. Also, both Core Processor and System Trace are available for all ARM and DSP devices that support Embedded Trace Buffer (ETB).

The XDS110 is also the first of the XDS family of debug probes to feature EnergyTrace for MSP432 and its add-on module EnergyTrace HDR (to be available in the future) for wireless connectivity devices. EnergyTrace is a technology that allows measuring the true Energy and Power consumption of the target board and it can measure up to 75mA natively and up to 800mA with the add-on module. As an added flexibility, the same physical connection for EnergyTrace also features one UART port and four GPIOs for total hardware control.

The XDS110 is designed to replace the aging XDS100 family of JTAG debuggers with higher JTAG and cJTAG data throughput, added support for ARM Serial Wire debug modes at the same cost.

Following the trend for space reduction on modern TI development boards, the XDS110 features a standard TI 20-pin connector as the primary JTAG connectivity to the target. In addition to that, all variants feature modular target configuration adapters for TI and ARM standard JTAG headers (the offer of adapters varies per model).

The XDS110 family supports the traditional IEEE1149.1 (JTAG) as well as IEEE1149.7 (cJTAG) and ARM Serial Wire Debug (SWD)/Serial Wire Output (SWO) and operates with interface levels of +1.8V up to +3.6V.

IEEE1149.7 or Compact JTAG (cJTAG) is a major improvement over the traditional JTAG, as it supports all its features while using only two pins, and is available in selected TI wireless connectivity microcontrollers.

Serial Wire Debug (SWD) is a debug mode that uses two pins (JTAG uses four) and transfers data at a higher clock rate when compared to JTAG. Serial Wire Output (SWO) adds one more pin that allows performing simple Trace operations on selected Cortex M4 microcontrollers.

The XDS110 supports either USB2.0 Full Speed (11Mbps) or High Speed (480Mbps) connection to the host.

The XDS110 family is fully compatible with TI’s Code Composer Studio IDE. This combination gives a complete hardware development environment which includes an Integrated Debug Environment, Compiler, and full hardware debugging and Trace capability on selected TI microcontrollers, processors and wireless connectivity microcontrollers.

1.11.2 EnergyTrace

EnergyTrace highlights
· Supports three modes of operation:
· ET: Energy profiling only
· ET+: Energy profiling + Program Counter trace
· ET++: Energy profiling + Program Counter trace + Peripheral state (not supported in MSP432)
· EnergyTrace measurements exported via a USB bulk endpoint - i.e., independent on having an active CCS debug session or connection to the device core.
· Electrical specifications:
· Accuracy: ± 2% ± 500nA, Condition: I < 25mA, VBUS = 5V constant during and after calibration
· Accuracy: ± 5% ± 500nA Condition: I > 25mA & I < 75mA, VBUS = 5V constant during and after calibration
· Maximum current: 100mA
· Fixed voltage for energy and power calculations: 3.3V

How does it work?
MSP432 allows the debugger to control the power transitions of the device and read the power status using bits in the Debug Access Port (DAP) CTRL/STAT register. 

CCS has 3 modes in which the core can be run:
1. Run : Run with debug control for active debugging. In this mode power transitions are disallowed by the debugger and it sets the CSYSPWRUPREQ bit.
2. Free run : Run without debug control. In this mode the debugger clears the CSYSPWRUPREQ bit. But JTAG is still active in this mode as DAP is still connected.
3. Low power run : Run with debug control and allow core to transition power levels. In this mode the debugger clear the CSYSPWRUPREQ bit and JTAG is still active.

ET+ mode and Code profiling:
To be able to obtain code profile, the Program Counter is sampled by reading the PCSR (PC Sampling Register). The PCSR is a memory mapped register in the DWT debug module of Cortex M cores and can be accessed via the AHB AP. When MSP432 is allowed to enter low power state (during CCS Free Run and Low Power run), the AHB AP is powered down by the MSP432 PCM and accessing it hangs the bus. This makes polling for the PCSR an unsafe operation in the Free run and LP Run modes. As a result the only information returned during a Free/LP run is the device status as active or low power. Code profiling is not performed. For code profiling the regular run option must be selected from CCS. 

Difference between MSP430 and MSP432.
In MSP430 devices since the MSP430 is the only core, on a Free Run, JTAG is disabled. In the MSP432 device, the Cortex M core sits under a DAP. So even though Free Run is issued from the core, the DAP is still connected and so JTAG cannot be disabled. For obtaining true power measurements MSP430 used the Free Run mode. As this is not possible for MSP432, a new mode was created called ET-only mode. In this mode ET is launched without a debug session and allows true power measurements. More details can be found in the EnergyTrace ET-Only Mode section below. 

Using EnergyTrace
As mentioned before, EnergyTrace can be invoked during a CCS active debug session (ET on a debug session, where both ET and ET+ modes are available), or by itself (ET-only mode, where only ET mode is available).
EnergyTrace (ET and ET+) on a Debug Session
Two modes are available when ET is invoked during a debug session: ET and ET+. 

1. Open CCS, select a workspace and, before anything, make sure that EnergyTrace is enabled and the selected connection is XDS110. For that, go to menu Window --> Preferences, navigate to the EnergyTrace settings and check the settings as shown below (click to expand):
[image: Energy Trace main options.PNG]


2. Launch a debug session and load the code to the target device.
before launching a debug session, a target configuration file for the MSP432 Launchpad has to be created using the target configuration editor. Make sure to select the following options:
Texas Instruments XDS110 USB Debug Probe for the Connection field
MSP432P401R for the Device or Board field
Note: for details on how to create this file, check this reference.

3. The EnergyTrace view should show up with three tabs: 
[image: Main tab]
[image: Power tab] 
[image: Energy tab] 


4. Resume the code execution (F8). After 10 seconds (configurable via the stopwatch icon [image: ET Stopwatch icon.PNG]), the EnergyTrace view should show up with the measurements and graphs as shown below - the actual measurements depend on your code:
[image: Measurements] 
[image: Power graph] 
[image: Energy graph]
Note: Click on the small floppy disk icon [image: ET Save icon.PNG] if you desire to save the data for future comparison.

5. To see the device actually going to the deep sleep, suspend the core (Alt+F8), Restart (menu Run --> Restart) and issue a Free run (menu Run --> Free Run). The results shown below demonstrate this scenario where the minimum current is a fraction of the value obtained previously: 
[image: Measurements]
[image: Power graph] 
[image: Energy graph] 


6. If needed, the results can be compared with the previous run by clicking on the small folder icon [image: ET load icon.PNG] and browse to the previously saved file. The differences are showcased in the three tabs as shown below:

[image: Measurements] 
[image: Power graph] 
[image: Energy graph]


7. To verify the device actually going to the power transition, EnergyTrace plus (ET+) is required. Click on the ET+ switch icon [image: ET plus icon.PNG], which will show an extra tab called States. 

8. Click on the tab EnergyTrace+™ profile, Suspend the target, Restart and Free Run. After 10 seconds the ET+ views will be updated showing the CPU states: 

[image: Measurements] 
[image: Power graph] 
[image: Energy graph] 
[image: States graph] 

EnergyTrace ET-Only Mode
As seen in the previous section, despite free running and entering the deep sleep mode, the device's JTAG circuitry still consumes some extra power. To prevent this, a debug session cannot be used and therefore ET-only mode will yield the most accurate power consumption measurement. 

1. Make sure the device is running free, then terminate the debug session (Ctrl+F2). 

2. Click on the small EnergyTrace icon [image: ET only icon.PNG] on the top toolbar and, after CCS switches to the CCS perspective, the EnergyTrace ET-only mode view will be shown. 

3. Click on the small Play icon [image: ET only play icon.PNG] and wait until the 10 seconds are finished. The display will show the measurements without the JTAG circuitry involved. 
[image: Measurements] 
[image: Power graph] 
[image: Energy graph] 

4. Notice the much smaller power measurements obtained this time. These results can also be compared with the previously saved results. 

One More Look at ET+
One additional aspect of EnergyTrace+ is its capability to show the power consumed by each function in a system. 

1. With the EnergyTrace project open, select the FP_run build configuration: right-click on the project, select Build Configurations --> Set Active. 

2. Launch a debug session and the Energy Trace view should open. Click on the ET+ switch icon [image: ET plus icon.PNG] and set the total run time to 30s by clicking on the small arrow near the stopwatch icon [image: ET Stopwatch icon.PNG]. 
3. Put the target to resume (F8) and wait until the 30s have passed. You should get the energy details separated by function as shown below:
[image: ET plus fxn profile.PNG]










image1.png
T CCS ot - S UA Tutorl s - Code Conporer S
Fie G View Novgete PrjectRunScigts Window Tl
[=}d $e i i@ iCo-D- 5 % CCsDebug (17
2 Project Explorer 27 2% 7 Z 0| [ mainc 22| [ ttoriallac

5 helocout i e

+ 15 hell_cputand2

& hello_cpuand /7 Configure the target's,
+ & hllo_cputands startup();

B mimon 6678 7+ fun the tutorial selected by the tutd
+ & SAUA Tworld e (eutoriatonese < $)(
" s uiten(tutorialoaze) (
+ B Incudes Case 1: tutorial 1A(
. 2% tutorkal 100}
3% twtorial a0 breok;
& et Case 31 tutorisl 100); bresk;
@ minc 5
(@ woiisc totardatohaze =

17 The folloving label provides an a
= script uses %o sat o breakpotnt.

£ ttorsLIAD  void
£ tutor 180 vod
F tora 1C0  void
4 tutora 100  void
@ tuoriaPhase vlstic int
i stanup0:void

o mainlypcd
o sl
butlding torget: SAUIA Tutortsl 1.out”





image2.png
= || 4B Scripting Consold
DT Build Console [SA_UIA Tutorial 1] Initializing ...|
o) BEIE B e
o g, e
xml_link_info="SA_UIA_Tutorial_1_linkInfo.xml" i
sodel -0 "Sh_UTA_Tutorial 1.out”

s>

= Jtutorialla.obj” *./main.obj" -
<Linking>
*Finished building target: SA_UIA Tutorial 1.out' D





image3.png
Tool Bar Visibilty | Mena Visibilty | Command Groups Availabilty | Shortcuts|

Select the command groups that you want to see added to the current perspective (CCS Edit). The details field identifies which menu
tems and)/or toolbar items are added to the perspective by the selected command group.

Avalable command groups: Menubar details Toolbar detals:
JovaScipt Element Creation = + Bl Run 2 bounch
JovaScrpt Navigation @ run 35 Debug SA_UIA TutoriaL 1 (aheady
JavaScript Open Actions %, Debug © Runs.
JavaScript Search E"" ;":‘"'Y
Keyboard Shortcuts Run Configurations.
e g Debug History
Make Actions D e
Openfiles Debug Configurations..
Profle

I71_Profile. =
« 0 D i D

o J o ]





image4.png
Available Software
Check the items that you wish to install.

Work with:  http://e-pri-c.sf.net/updates
Find more software by working with the *Availsble Softuware Sites” preferences.

[typefittertex

Name Version

B eic o546

ludes the basic EPIC (Eclipse Perl Integration) ~
components. -

Mo
Show only thelaest versions of available software ] Hide items that are already installed
Group tems by category What s slready installed?

Show only software appliczble to target environment

Contact all update sites during nstall to find required software

@ P (e |





image5.png
+ CCS comes with an excellent, feature rich editor

B © oo [ e = 0)[Eowine 3| B % R o %~ =0
B o modem
206
o o redcosh
248 o sinetabh
213 constllation: struct POINTI)
250 /* read next data, convert to constellation points, and add noise */ @ g Modembata: struct MODEM PARAMETE
251% void ReadNextData(void)[] 4 © TEST
457 /* convert data to constellation points and add noise */ o itlong
void ReadConstellation(void) o jilong
259 ® gttt TEST
Addiossesignal() o Sinelookuplint): it
o CosineLookup(int): int
© Modulation(int, int, int) : int
0 cint(25s] | ©  ShapingFilter(int", int) : void
© OutputBuffer: int [32] ©  ModemTransmitter(int, int") : void
© Qdelay : int [255] © Initialize(void) : void
© SymbolClock : int [32] o ReadNextData(void): void
© cNoise : POINT [1] © ReadConstellation(void) : void
© cPeints:POINT 1] o AddNoiseSignalvoid): void
© carerfreq int ® aiinil)
© dataSymbols: int 1] o main(vid): void
© noiselevel:int
© phase:int
© samplesPerBaud it -
< i v

Press Ctrl-Space’to show Default Proposals

E




image6.png
» General
4 C/Ces
Appearance
» Autotools
» Build





image7.png
5 Preferences el
type fitertext EnergyTrace™ Technology GrDv v
g EnergyTrace™ technology enables enclog eneray measurement to determine

4 Code Composer Studio.
4 Advnced Tools
Disk Usage
EnergyTrace™ Technology.
Source Line Reference.
Trace Viewer
> Build
> Debug
> Grace
» RTSC
Energia
> Help
> Install/Update.
> JavaScript
> Model Validation
> Remote Systems
> Run/Debug
> Team
Terminal

the energy consumption of an application. This feature s available for all
devices with selected debuggers.

EnergyTrace+™ technology in addition supports an energy-based code:
analysi tool that is useful for measuring and viewing the applications energy.
profile and correlating with the devices CPU state and optimizing it for
ultra-low power consumption. This feature s available on MSP432 devices and
selected debuggers. Please check the "CCS for MSP432 User's Guide’ for
details.

EnergyTrace++™technology in addition supports an enhanced energy-based
code and peripheral analysis tool that is useful for measuring and viewing the.
applications energy profile and correlating with the devices CPU and peripheral
states and optimizing it for ultra-low power consumption. This feature is

ailable on selected MSP430 devices and selected debuggers. Please check the.
'CCS for MSP430 User's Guide” for details.

nable Auto-Launch on target connect

EnergyTrace

catye
Cell capacity (méhy [220

ot

Peak current - continuous (m&) | 0.0

Target lifetime (days) w0

{

P——
Comecton X050

Device MSPa32

Valtage (mv) [30000

advanced setfings





image8.png
12 EnergyTrace™ Technology 51 |l Power v Energy. Olp-IVIEeE-H=0
EnergyTrace™ Profile
‘Name Live e
4 System

Tme  0sec

Energy  000m)





image9.png
EnergyTrac





image10.png
EnergyTrac

100000
80000

Time ()





image11.png




image12.png
O EnergyTrace™ Technology 31 fix Power v Energy

ol-WME=

~W =8

EnergyTrace™ Profile

Name Live
4 System
Time  10sec
Energy 4016 m)
4 Power
Mean 4,016 mW
Min 3908 mW
Max 4727 mW
4 Voltage
Mean 3300V
4 Current
Mean 1,217 mA
Min  1188mA
Max  1432mA

Battery Life CR2032:6,8 day (est)





image13.png




image14.png
EnergyTrace™





image15.png




image16.png
O EnergyTrace™ Technology 31 fix Power v Energy

ole-I@

- =0

EnergyTrace™ Profile

Name Live
4 System
Time  10sec
Energy  3123m)
4 Power
Mean 3,526 mW
Min 0518 mW
Max 4,486 mW
4 Voltage
Mean 3300V
4 Current
Mean 1,068 mA
Min  0157mA
Max  1359mA

Battery Life CR2032:88 day (est)





image17.png
er 52 | Energ





image18.png
EnergyTrace™ Technology [ P





image19.png




image20.png
O EnergyTrace™ Technology 1 | fix Power v Energy
Reference: EnergyTrace 2014 10 13 151826

Olo-WME=E=-H=10

EnergyTrace™ Profile

Name
4 System

Time
Energy
4 Power

Mean

Min

Max

4 Voltage

Mean

4 Current

Mean

Min

Max

Battery Life CR2032:88 day (est)

Live

10sec
13m

3524 mW
0518 mw
4486 mW

330V
1068 mA

0157 mA
1359 mA

Delta (%) Reference E

123
867

51

123
867

51
26

10sec
4016 m)

4016 mw
3908 mW
4727 mW

330V

1207 mA
1184 mA
1422 mA
CRAOI:68day (est)

] ’





image21.png
EnergyTrace™





image22.png




image23.png




image24.png
12 EnergyTrace™ Technology £ [ Power [ Energy [ St =g

olt-Mue &= -0

EnergyTrace+™ Profile

ey Runtime (%) Energy (%)
System 100 o

4 CPU
ActiveMode e 671 e 01
4 Low Power Mode B 298 <o)

LPMx — 298 59





image25.png
EnergyTrace™ Technolog er 53 |l Energy [ States





image26.png




image27.png
* mPower Mode
AM
LPMx





image28.png




image29.png




image30.png
12 EnergyTrace™ Technology 52 | Power [ Energy O | B € ~

EnergyTrace™ Profile

Name Live
4 System
Time  10sec
Energy 070
4 Power
Mean 0,070 mW
Min 0067 mW
Max 0071 mW
4 Voltage
Mean 3300V
4 Current
Mean 0021 mA
Min 0020 mA
Max 0021 mA

Battery Life CR2032:390,5 day (est)





image31.png




image32.png
Showing




image33.png
O EnergyTrace™ Technology 37 | fix Power v Energy [ States

olg-VEHe

EnergyTrace+™ Profile
Name
System
4 CPU
4 Active Mode
funch
funcs
funcz
funcs
funco
funcl
funcs
func2
funcl
funco
Low Power Mode

Runtime (%)
100

10
u5
77

77

77

77

77

77

76

76

75

65

00

Energy (%)
100

g

u5
77

77

77

77

77

77

76

76

76

65

00





