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Preface
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Introduction

Trademarks
DLP is a registered trademark of Texas Instruments.
Konica Minolta is a registered trademark of Konica Minolta.
Cheetah is a trademark of Total Phase.
Total Phase is a registered trademark of Total Phase.
All other trademarks are the property of their respective owners.

Purpose and Scope
This document explains the functionality of the DLPC120 Automotive Control Program. This program is
compatible with DLP® technology for automotive head-up display systems using the DLP3030-Q1 chipset.

The DLPC120 Automotive Control Program provides a PC interface to control a DLP3030-Q1 based head-
up display (HUD) system. Functionality includes:
• Setting output brightness
• Displaying and modifying an image or test pattern
• Reprogramming configuration and calibration software
• Interfacing with a color meter to measure brightness output and perform calibration

This guide uses the TI DLP3030PGUQ1EVM as an example hardware system, but can be used with any
system using the full DLP3030-Q1 chipset.

The following sections are meant for new users:
• LED Driver Board Connections
• Software Requirements and Installation
• Quick Start – Instructions for displaying and dimming an image

The Control Program Tabs section explains the full functionality of the various menus in the Automotive
Control Program.

Terms and Abbreviations

Abbreviations Description
ACP Automotive Control Program
ASIC DLPC120 Controller for the DMD
HUD Head-Up Display
EVM Evaluation Module

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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References
The following documents can be found on www.ti.com/mysecuresoftware in the DLP Automotive Head-up
Display Documentation and Piccolo Control Software section.

Document Number Document Name
1. DLPU066 DLP3030-Q1 RGB LED Calibration for Automotive Display
2. DLPU057 DLP3030-Q1 Head-Up Display (HUD) Piccolo SPI User's Guide
3. 2514132 DLPC120 and LED Driver Board Schematics
4. DLPU064 DLP3030-Q1 Picture Generation Unit EVM DLP3030PGUQ1EVM User's Guide
5. DLPU061 Piccolo Software Programmer’s Guide for the DLPC120 ASIC
6. DLPA084 LED Driver for DLP3030-Q1 Displays Application Note
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Chapter 1
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LED Driver Board Connections

1.1 LED Driver Board Connections
Figure 1-1 shows the connectors on the DLP HUD LED driver board and all of its connectors. The Piccolo
MCU JTAG Connector and SPI Communication connector are used for programming the system. The
Type A HDMI connector is used for displaying external video. For instructions on how to connect the LED
driver board to the rest of the EVM, please refer to the DLP3030-Q1 Picture Generation Unit EVM
DLP3030PGUQ1EVM User's Guide.

Figure 1-1. LED Driver Board Connections

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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Software Installation and Setup

2.1 Software Installation and Setup
This section describes the software components of the DLP3030PGUQ1EVM and how to download and
install them.

Access to www.ti.com/mysecuresoftware is necessary to download software. For login credentials, please
contact a TI applications engineer.

2.2 Software Components
Table 2-1 lists all of the software components for the EVM, their location, and their purpose. The following
sections explain how to download and install the software.

Table 2-1. Software Components

Software Location Purpose
Automotive Control Program and

Cheetah™ Drivers PC Used to control the EVM.

Piccolo Bootloader Piccolo Flash Sector A Allows reprogramming of Piccolo main
application via SPI connector.

Piccolo Main Application Piccolo Flash Sector B+C Handles DLPC120 initialization routine and
dimming commands.

Configuration File Piccolo Flash Sector D Defines the functionality available on
application flash of the DLPC120.

Calibration File Piccolo Flash Sector D Contains look up table used by Piccolo to
maintain color point with dimming range.

DLPC120 Application Flash Image Application Flash Provides all of the commands necessary for
the DLPC120 to perform actions.

2.3 Automotive Control Program and Total Phase® Cheetah™ Software Installation
The Automotive Control Program and Total Phase Cheetah software are necessary to control the EVM.
Follow the procedure below to download and install the Automotive Control Program and Total Phase
Cheetah Drivers.

Note: The Total Phase Cheetah drivers and cheetah.dll are not distributed by Texas Instruments. Login
credentials must be created for www.totalphase.com in order to download the required software.
1. Install Automotive Control Program (ACP).

• Login to www.ti.com/mysecuresoftware
• Click “Access” on DLP Auto HUD Gen 1.5 - DLPC120 Automotive Control Program (Object)

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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• Download the latest version of the Automotive Control Program (ACP) from the Automotive Control
Software Section:

• Run setup.exe
• Follow instructions to completion

2. Install Cheetah drivers.
• Download and install USB drivers for the Cheetah from: www.totalphase.com/products/usb-drivers-

windows
• Note: The installation program should be “Run as administrator” by right-clicking

3. Download and Copy cheetah.dll.
• Download Flash Center software from: www.totalphase.com/products/flash-center
• From the downloaded folder, copy cheetah.dll
• Paste cheetah.dll file into ACP installation directory:

C:\Program Files (x86)\Texas Instruments\DLPC120 Automotive Control Program 1.4.1.XX
• This file is used by the ACP and the Total Phase Cheetah to communicate via SPI protocol with

the DLP3030PGUQ1EVM.

2.4 Konica Minolta® CA-SDK Installation (Optional)
The Konica Minolta CA-SDK is only necessary for system calibration and color point and brightness
analysis. All new EVMs are calibrated before shipping, therefore, this SDK is not necessary for properly
displaying an image with the DLP HUD EVM. However, if using a custom hardware and optics design, the
system will need calibration for proper operation and a Konica Minotla CA-210 or CA-310 and CA-SDK will
be needed.

The CA-SDK can be downloaded from the following link:

www.konicaminolta.com/instruments/download/software/display/ca-sdk/agree.html

2.5 Piccolo Software
Note: The following software is only needed to reprogram the HUD EVM for debug and development
purposes. All new EVMs are programmed with the latest Piccolo software before being shipped.
1. Download Piccolo Software.

• Note: Piccolo Software is available in two versions:
– Evaluation Software: Requires click-wrap license. Only binary code. Good for evaluation

purposes
– Source Code: Requires signed software license agreement. Good for development and debug

purposes.
– For more details, please contact a TI applications engineer

• Login to www.ti.com/mysecuresoftware
• Click “Access” on the appropriate product directory

– Evaluation Software:

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
http://www.totalphase.com/products/usb-drivers-windows
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http://www.konicaminolta.com/instruments/download/software/display/ca-sdk/agree.html


Piccolo Software www.ti.com

10 DLPU059–March 2018
Submit Documentation Feedback

Copyright © 2018, Texas Instruments Incorporated

Software Installation and Setup

TI Information — Selective Disclosure

• Download DLP HUD Piccolo Software Version 0.21(74) or higher
• Download DLP HUD Piccolo Bootloader Version 0.1(6) or higher

2. Download and install Code Composer Studio or Uniflash:
• Uniflash: TI command line programmer that is used by the Automotive Control Program to

program the Piccolo flash.
– Download Link: www.ti.com/tool/uniflash

• Code Composer Studio: Interactive Development Environment (IDE) for Texas Instruments
MCUs.
– Includes uniflash installation
– Allows user to view and modify Piccolo source code
– Download Link: www.ti.com/tool/ccstudio

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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Chapter 3
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Quick Start

3.1 Quick Start
This section explains how to connect a PC to the DLP HUD EVM and display images or videos. For kit
assembly instructions, please see the DLP3030-Q1 Combiner HUD EVM DLP3030CHUDQ1EVM User's
Guide (DLPU065).

Follow these steps to display an image:
1. Install the Automotive Control Program and Cheetah Drivers as described in Section 2.3 above.
2. Connect an HDMI cable from the PC to the Type A HDMI Connector on the LED Driver Board. See

Chapter 1, LED Driver Board Connections to locate the HDMI connector.
3. Connect the Cheetah USB adapter from the PC to the SPI Communication Connector on the LED

Driver Board. See Chapter 1, LED Driver Board Connections to locate the SPI connector.
4. Open the Automotive Control Program (ACP).

5. Click Connect as shown in the image above. The “System Not Connected” box will turn to “System On”
or the SPI protocol menu shown in Step 6 will be displayed.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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6. If the SPI Protocol menu is displayed, select Cheetah SPI. Note: This menu is only displayed the first
time ACP is used.

7. Click OK.

8. Navigate to System Control > Display Mode and Command Lists from the menu on the left.

http://www.ti.com
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9. Select an external video resolution, splash image, or test pattern to display. The EVM is configured to
operate with an external video resolution of 864 × 480.
• Note: Please see Section 3.2, External Video Troubleshooting for additional help.

10. Navigate to System Control > Dimming Control.
11. Change Backlight to adjust brightness. Backlight value range is 0 to 65535. Backlight 700 to 1000 is

recommended for indoor settings.

3.2 External Video Troubleshooting
This section describes the most common issues with displaying external video and the solutions to those
problems. Table 3-1 lists the most common external video issues and the sections with the solutions. For
help with issues not described here, please contact a TI applications engineer.

Table 3-1. Common External Video Issues

Section Error
Section 3.2.1 Blank screen is displayed on EVM
Section 3.2.2 Image is flipped
Section 3.2.3 PC resolution is changed when EVM is connected

3.2.1 Blank screen is displayed on EVM
The most common reasons for a blank image on the EVM are the following:
1. The HDMI cable is not connected properly.

• Solution: Check HDMI connection. Make sure HDMI cable is properly installed in the PC and the
EVM.

2. The PC’s external monitor setting is in the “Computer Only Mode.”
• Solution: Press “Windows + P”, then select “Extend” as shown in the image below:

http://www.ti.com
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3.2.2 Image is flipped
The HUD EVM contains commands to flip the image. Follow the instructions below to flip the image.

1. From the Automotive Control Program, press (Ctrl + Alt + M), or navigate to System Control >
Display Mode and Command Lists from the navigation pane on the left side of the window.

2. In the Command Lists section, select Flip from the Type drop-down menu.
3. From the Lists Drop Down menu, select a flip type. The flip is applied immediately when it is selected.

Select the one that is appropriate.

3.2.3 PC resolution is changed when EVM is connected
If the PC is trying to duplicate the image on the EVM and the monitor, then the PC resolution can be
changed. To fix this, change the PC’s external monitor setting to extend:
• Press “Windows + P”, then select “Extend” as shown in the image below:

http://www.ti.com
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Control Program Tabs

4.1 Control Program Tabs
The Automotive Control Program has several tabs that can be access from the left side of the window.
The tabs are organized for functionality into the following categories:
• Connection: Shows system status and information
• System Configuration: Used for programming and calibrating the system
• Calibration and Configuration file: Used for viewing, selecting, modifying, and programming

calibration and config files
• System Control: Used for display, dimming, and other system controls
• Utilities: System debug and characterization tools
• Personalized Tabs: User created tabs for easy access to functions

The following sections explain each tab in detail.

4.2 Connection
The connection tab controls connection to a HUD EVM, displays information about the status and software
of the EVM, and controls connection to a light meter.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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1. System Connection: Displays the connection status of the PC to the Cheetah. Click
Connect/Disconnect to connect or disconnect from the Cheetah. Click the settings button to modify
protocol.

2. System ON/OFF: Shows system state. Click to change state between ON/OFF. State is UNKNOWN
when the cheetah or the EVM are disconnected from the PC.

3. Piccolo-ASIC I2C Clock Rate: Allows selection of I2C communication rate between Piccolo and
DLPC120. Only 400 kHz should be used.Software Status: Shows status of the current software. Click
"Read Status" to update status.

4. Software Status: Shows status of the current software. Click "Read Status" to update status.

http://www.ti.com
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5. Light Meter Connection: Click Connect to connect to the CA-210 or other compatible light meters.
• Averaging Mode: Determines how many measurements the CA-210 takes internally. AUTO

setting is recommended.
• Max Luminance: Maximum brightness allowed by the light meter.

6. System Information: Lists system software versions and Built-In Self-Test (BIST) results. Click “Read
System Info” to update.

4.3 System Configuration
The system configuration tab is used to load software onto a DLP HUD EVM. The Piccolo and the
DLPC120 Application Flash can be programmed from this menu.

4.3.1 Program Piccolo Flash
The tabs in this section are used for programming the Piccolo flash using SPI or JTAG. The bootloader
must be programmed using JTAG as described in Section 5.2, Programming Piccolo Bootloader. The
Piccolo Main application can be programmed using JTAG or it can be programmed using SPI as
described in Section 5.3, Programming Piccolo Main Application. Programming the Piccolo main
application using SPI is recommended.

4.3.1.1 Program Piccolo SW—Cheetah SPI
This tab allows the user to program the Piccolo’s main application as shown in Section 5.3. The main
application is provided in a (.hex) format in the Debug directory of the Piccolo main application project on
www.ti.com/mysecuresoftware. See Section 2.5 for help with downloading the Piccolo software.

The Piccolo main application can be loaded using this menu only if the bootloader is already loaded on
the system, and the system is in bootloader mode. The bootloader can be loaded using JTAG as shown in
Section 5.2. The system can be changed to bootloader mode using this menu.

http://www.ti.com
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1. Bootloader Settings File: Stores settings required to program the Piccolo. Default file is provided with
Automotive Control Program. Do not modify unless required.

2. Piccolo Main Application (.hex): Piccolo Main Application. Provided with Piccolo Main Application
software release on www.ti.com/mysecuresoftware . Click Browse to select file for programming

3. System mode and State: Displays and changes state of the system between Bootloader and
Application Mode.
• Bootloader Mode: Allows update of Piccolo main application via SPI
• Application Mode: Normal operation mode for EVM
• Get Mode: gets the updated status of the system mode
• Toggle Mode: used to switch between bootlader mode and application mode

4. Program: Click to program selected Piccolo Main Application to EVM.
5. Settings: Piccolo programming settings.

• Flash Erase Wait Time: wait time between erase of each Piccolo flash sector
• Packet Size: size of packets written to Piccolo Flash

4.3.1.2 Program Piccolo SW—JTAG, Uniflash
This page allows programming the Piccolo Flash—bootloader or main application—using a JTAG emulator
and Uniflash as shown in Section 5.2.

Uniflash is a command line programmer for TI target devices. It is part of the Code Composer Studio
installations for versions 5.4 or higher. It is also available for free from the following location:

http://www.ti.com
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• Uniflash Download Link: www.ti.com/tool/uniflash

1. Program: Section for selecting the files used to program the Piccolo flash and to program the Piccolo
flash.
• Target Config File: File that specifies which JTAG emulator is being used for programming the

Piccolo. Two files are provided with the Piccolo software projects—one for XDS100 and one for
XDS510.

• Uniflash.bat Executable: TI command line programmer executable. Provided with Code
Composer Studio version 5.4 or higher. Also available as standalone tool from
www.ti.com/tool/uniflash.

• Piccolo.out File: Compiled C code for Piccolo bootloader or main application. Provided in Debug
directory of software project

2. Command Line Log: Log to display programming log. Used for debug purposes if necessary.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059
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3. Sectors to Erase: Determines which sectors to erase before programming:
• Sector A: Bootloader
• Sector B and C: Piccolo Main Application
• Sector D: Piccolo Calibration and Configuration file

4.3.2 Program ASIC Flash
This tab allows programming the SPI Application Flash on the EVM as shown in Section 5.5.

To program the application flash, the Cheetah SPI adapter needs a direct connection to the application
flash. This can be done on the EVM by clicking the Switch SPI bus button on this page. This disconnects
the Cheetah from the Piccolo and connects it to the application flash. Note: The EVM must be restarted to
reconnect to the Piccolo.

http://www.ti.com
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1. Browse and select config or flash binary file.
2. SPI flash mode indicator.
3. Actions for SPI flash memory.
4. Target Flash Device Information: Used for selecting, detecting, and viewing information about the

target SPI flash.
• Target Device: Drop Down menu to select from list of flash devices
• Auto Detect: Click to automatically detect flash device
• Load Parts File: Click to Load Flash device XML if Auto Detect cannot successfully detect the part
• Selected Device Information: Information about the selected flash device

1. Override Max Bit Rate: Click to manually set Max Bit Rate
2. Advanced>> / << Button:Click to switch between Advanced and Simple view of flash device

information.
5. Binary View: Displays binary data of selected file.

http://www.ti.com
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4.4 Calibration and Config File
The calibration (cal) and configuration (config or .cfg) file are stored in the Piccolo’s flash in sector D. The
config file contains data about the system’s capabilities, such as its display modes. The cal file contains
information used for dimming.

This section allows browsing, editing, and programming of the cal and config file as shown in Section 5.4.
The calibration wizard can be used to generate a new cal file. See the DLP HUD Calibration Guide to
learn how to generate a new calibration file.

4.4.1 Calibration File

1. Browse: Click to open a saved calibration file.
2. Recent Calibration Files: Click a file name to open a recently saved cal file.

3. Read Only View: Shows contents of the opened calibration file in a read-only view.
4. Print/Print Preview: Click to print or preview a printed cal file.
5. Contents: Click Links to jump to content in the cal file.

http://www.ti.com
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6. File Creation Details: This tab shows information about how and when the cal file was generated.
7. Calibration ID: This ID is automatically generated when the cal file is created. It needs to be updated

when changes are made to the cal file. Click “Generate” to update.

http://www.ti.com
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8. Defaults Tab: This Tab is used to set the default settings of the cal file. These settings are used by
the EVM at startup if the calibration file is programmed on it.

9. Defaults Section: Sets the initial system state at power-on.
• Backlight: Default brightness of the system (0-65535)
• Base Temperature: Temperature table to be used if temperature compensation is disabled
• PWM Period: Period of PWMs used to generate LED target levels
• Master ON: Determines if system should start up in Master On/Off mode

10. Feature Enable/Disable:
• Temperature Compensation: Adjusts LED PWMs based on temperature. Only recommended if

system has been calibrated across operating temperature range.
• VAC: Digital Dimming function for use at low brightness levels. The backlight value for VAC enable

is defined in the calibration tables
• Voltage Monitoring: Turn on/off voltage monitoring at startup.

11. Default Dimming LUT/CMT: This section selects the default dimming table and gamma to use.This
section is automatically populated by calibration.

http://www.ti.com
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12. Calibration Tables: This tab shows calibration look up tables used by the Piccolo to set LED PWMs.
Calibration temperatures for all temperatures can be viewed from this tab.

13. Temperature Data:
• Temperature: Lists all the temperatures for which calibration tables are stored
• VAC Mode Switch Backlight: Sets backlight at which digital dimming should be used if enabled
• Calibrated: Shows whether the stored calibration data was generated from a calibration procedure

or not
14. Add Transition Temperature: Adds all necessary tables for transition temperatures if they are not

already present in the cal file. Note: This is needed for DLP3030-Q1 operation.
15. Calibration Data for Selected Temperature: Dimming table for the selected temperature.
16. Show additional information: Displays informational auto-calibration results in the calibration table,

such as calibration targets and errors.
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17. Right Click the rows in the calibration tables or the temperature table for additional options.

18. Other: Input the photodiode sensor gains available on the LED driver. TI EVM has 1x, 4x, 8x, and
16x.
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19. Charts: This menu creates various plots for the data in the calibration file.
20. Select the plot to display.
21. Select the temperatures, backlight value range and scale to display.
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22. Binary Data: Click “View Cal Binary Data” to view the binary data stored in the cal file.

23. This page shows the calibration log if it is available in the cal file’s directory with the same name as
the cal file.

24. Errors/Warnings: This page shows any errors or warning in the cal file.
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4.4.2 Config File

1. Browse: Click to open a saved config file.
2. Recent Calibration Files: Click a file name to open a recently saved config file.

3. Read Only View: Shows contents of the opened config file in a read-only view.
4. Print/Print Preview: Click to print or preview a printed config file.
5. Contents: Click the links to jump to content in the config file.
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6. Defaults: This tab is for viewing and modifying the command lists that are run at startup. See
Section 4.4.2.1, Modifying Default Command Lists for instructions.

7. Click buttons to add, delete, or reorder commands lists to be run at startup. Command lists are run in
order from top to bottom.

8. Shows the command lists that will be run at startup. Command lists are run in order from top to bottom.

9. Errors/Warnings: This tab shows the Errors and Warnings in the config file.
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10. The DLPC120 App Flash data can be viewed and saved from this tab. Click View ASIC Flash Data or
Save ASIC Flash file to view or save the flash data.

11. Click Program ASIC Flash to jump to ASIC Flash Programming tab .

4.4.2.1 Modifying Default Command Lists
This section shows how to select which command lists to run at start-up.

To add a new command list, navigate to the Defaults page on the Calibration and Config File>Config
File tab. Then, follow these steps:

1. Click Button to add Command List.
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2. Select the command list(s) to run at start-up.
3. Click OK.

4. Select Command lists and use arrows to reorder as desired. Command lists are run in order from top
to bottom.

5. Click Verify to check for errors. Errors and Warning will be displayed in the Error/Warnings tab.
6. Click Save or Save As to Save file.
7. Program calibration and config file as shown in Section 5.4.

• Note: Updating DLPC120 App. Flash is not required.
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4.4.3 Program Calibration Data (Cheetah SPI)
This tab has the following functions:
• Programing the selected cal and config file to the EVM. See Section 5.4 for more details.
• Viewing the Memory Map of the calibration data
• Changing Programming settings
• Viewing Calibration Binary
• Viewing DLPC120 Flash Build Information

1. Click Verify and Program to program selected calibration and configuration file to Piccolo.

2. This tab is for checking the memory map of the combined calibration and the configuration data.
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3. Adjust the programming settings from this section. If the wait time is too short, programming may fail.
4. Shows Approximate time to Program based on settings.

5. Click Read Cal Data from Piccolo to read the data currently stored on the EVM.

6. Click to read information about the DLPC120 Flash build stored within the config file.

4.4.4 Iterative Calibration
Use of the calibration procedure is described in DLP3030-Q1 RGB LED Calibration for Automotive Display
(DLPU059).

4.5 System Control
This section of the ACP is used for controlling the EVM. It is divided into the following sections:
• Dimming Control: Change the brightness level of the system and take measurements with a light
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meter
• Display Mode and Command Lists: Change Display Modes or run commands lists from the config

file
• Temperature Compensation: Read DMD temperature, enable/disable temperature compensation,

modify TMP411 parameters
• DMD and Heater Control: Modify DMD drive strength and DMD heater PWM parameters

4.5.1 Dimming Control

1. Dimming Control: This section is used to control the brightness of the EVM. It allows control of
individual LEDs or all LEDs at once.

2. Color Point Measurements: This section works with a light meter to provide color point and
brightness measurements in the CIE 1931 color space. Light meters compatible with the Konica
Minolta CA-210 SDK are supported.

4.5.1.1 Dimming—Normal and Calibration Mode
The dimming of the EVM can be controlled in two modes:
• Normal Mode: Used for normal operation. LEDs, DMD sequence, and sensor gain are automatically

adjusted based on backlight value and the currently programmed calibration data.
• Calibration Mode: Used for debugging/calibration purposes. Allows independent control of LEDs,

DMD sequence, and sensor gain.
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The mode can be controlled from the System Mode drop-down menu.

4.5.1.1.1 Normal Mode
In Normal Mode, input a backlight value (0 – 65535) to adjust the system brightness. Individual LEDs,
sequences, and sensor gain will automatically adjust based on the backlight value. The calibration file
stored on the system is used to determine individual LED levels.

1. Backlight: Backlight value range is 0 to 65535. Dimming Parameters are determined by Backlight
value.

2. Click Set or press “Enter” to update Dimming Parameters based on Backlight value.
3. Click Get to view the system’s current backlight value and Dimming Parameters.

4.5.1.1.2 Calibration Mode
In calibration, the Dimming Parameters can be individually adjusted.
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http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059


1 2

3

1

2 3

www.ti.com System Control

37DLPU059–March 2018
Submit Documentation Feedback

Copyright © 2018, Texas Instruments Incorporated

Control Program Tabs

TI Information — Selective Disclosure

1. Dimming Parameters: system parameters that affect brightness and color point.
1. PWMs: Target levels for the LEDs and Current Limit:

1. Red/Green/Blue: Optical feedback level for LEDs. Enter value from 0 to 59418
2. Current Limit: Sets current limit for LEDs. 0 to 61166

2. Sensor Gain: Determines gain on the photo feedback sensor circuit. Higher gain results in lower
brightness.

3. LDC Index: Determines LED and DMD duty cycle and operation Mode. In general, lower LDC
results in higher brightness.

2. Click Set or press “Enter” to apply the Dimming Parameters.
3. Click Get to update the system’s Dimming Parameters.

4.5.1.2 Brightness and Color Point Measurements
The Color Point Measurements section is used for measuring system brightness and color point.

1. Click New Connection to Connect to the light meter.
2. Click Measure, Save, or Clear to take, save, clear measurements.
3. Measurement Results: Shows measurement results:

1. Normal/Calibration Mode: Shows the mode in which the measurement was taken.
2. Red/Green/Blue: Shows the PWM of the LEDs when the measurement was taken.
3. Y/x/y: CIE 1931 brightness and color point measurements.
4. LDC Index: LDC index of measurement.
5. Gain: Optical Feedback Gain.
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4.5.2 Display Mode and Command Lists
This tab changes the display mode of the system and also runs various other command lists that are
available in the config file.

1. Click Refresh Available Lists to read the command list data stored on the connected Piccolo and
update the drop down menus on the page.

2. Display Mode: Menus to select the display mode.
1. External Video: Select resolution from drop down menu to put system in external video mode and

display selected resolution.
2. Splash: Select an image from the config file to display.
3. Test Pattern: Select a test pattern from the DLPC120 to display.

3. Sequence Table and Gamma Selection: Change the sequence table or Gamma.
1. Note: This section is only available in Calibration Mode. The gamma or sequence update is not

completed until the system is changed back to normal mode. Change the system mode from
System Control > Dimming Control tab.

4. Command Lists: Runs commands from the config file.
1. Type: Select command list category first. Example: Flip, or Dither.
2. Lists: Select the command list to run. The command list is run immediately when it is selected.

5. Bezel Offset: Adjust image location on the DMD.
1. Vertical Offset: Image vertical position adjustment.
2. Horizontal Offset: Image horizontal position adjustment.

4.5.3 Temperature Compensation
This tab controls the temperature compensation parameters used by the Piccolo software. For an
explanation how temperature compensation works, see Piccolo Software Programmer’s Guide for the
DLPC120 ASIC (DLPU061).
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1. Enable Compensation: Determines whether LED PWMs should be adjusted based on temperature or
not.

2. Temperature used for Compensation: Displays the temperature that is currently being used for
temperature compensation.

3. Low Pass Filter Coefficients: Software low pass filter coefficients that can be used for temperature
compensation.

4. Measurement Mode:
1. User Selected Temperature: Allows user to set system temperature used by the Piccolo in order

to set LED PWMs. For Debug purposes only.
2. DMD temperature measured via TMP411: Makes Piccolo software use measured DMD

temperature.
1. Measurement Frequency: Rate for Piccolo software to read DMD temperature from TMP411.

5. DMD Array Temperature: DMD temperature from TMP411. Click Get to update.
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4.5.4 DMD and Heater Control

1. DMD Drive Strength: Select the drive strength of the DMD from the drop-down menu.
2. Heater PWM Control: Select Frequency and Duty Cycle of DMD Heater PWM. Note: Use of the

heater is not needed for full operation. The DLP3030-Q1 DMD will function without the heater enabled
over the full –40°C to 105°C operating temperature range. Duty cycle should be left at 0%.

4.6 Utilities
This section of the ACP contains utilities for debug and characterization purposes.

4.6.1 Communication
These tabs are used for communicating with the EVM.

4.6.1.1 ASIC Registers
This section allows the user to write values directly to DLPC120 registers. A list of all available DLPC120
registers can be found in the Help menu. Press Ctrl + F1 to display the help menu.

1. Register Read/Write: Set or get ASIC register value:
1. Get: Type ASIC Register address into Address, then press Get.
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2. Set: Type ASIC Address and Data, then press Set.
2. Smart Edit: This field lets you read/write individual register fields. Press Set after editing field to

update register.
• Bits: Shows the bits of the register for the specified field
• Value: Value of the bit field
• Description: Description of the bit field
• Reset: Default value at DLPC120 reset

3. Register Dumps: View/Save the register actions.

4.6.1.2 Piccolo SPI Command
This section is for sending raw SPI commands to the EVM and then reading the response of the EVM. It
can be used for debugging or learning purposes.
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1. Command ID + Read: Enter the ID of the command and select whether it is a read or write command.
See DLP3030-Q1 Head-Up Display (HUD) Piccolo SPI User's Guide (DLPU057) for more information.

2. Length/Read Length: Specifies the length or the read or write command automatically.
3. Data: Input data to send here. One byte per line.
4. Read Data: Displays the data read from the system in case of a read command.
5. Click Send to send command.
6. Response: Displays system response to SPI command.

4.6.1.3 SPI Command Log
This section of the ACP is for viewing a log of the SPI commands.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059


4

5

6

1 2

3

www.ti.com Utilities

43DLPU059–March 2018
Submit Documentation Feedback

Copyright © 2018, Texas Instruments Incorporated

Control Program Tabs

TI Information — Selective Disclosure

1. Logging Options:
• Log to File: Determines whether SPI commands should be stored in a log file
• Log to Screen: Determines if SPI commands should be displayed in the Log tab

2. Click Browse to select a log file.
3. Log: shows the SPI commands that have been sent if the Log to Screen option is selected.

4. Click to Decode the log that is selected in the Decode data source section.
5. Select which log to decode.
6. Filter data to decode by time.
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7. Decoded SPI commands.

4.6.2 Lua Scripting
This section is used to write and execute scripts in order to automate system functions.

The scripting language used for this section is Lua 5.1. To learn more about Lua, visit:
• www.lua.org/start.html
• www.lua.org/manual/5.1

The ACP includes many DLP HUD specific Lua functions. These are described in the Help section of the
Lua Scripting tab as shown in step 12 below.
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1. Click to Open script file.
2. Click to Refresh script file.
3. Click to Close script file.
4. Click to Save script. Click drop down menu to Save As or Save Log.
5. Click to Clear Script.
6. Play, Pause, or Stop script execution.
7. Displays script execution state and line no.
8. Enable GUI updates during execution—highlights code lines during execution.
9. Script Editor: write/edit scripts here.
10. Script Log: Errors and printed messages are displayed here.
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11. Recent Files: Shows recent Lua files.

12. Help: Shows HUD specific Lua functions. Click any function to see example code.

4.6.3 Color/Brightness Characterization
The tabs in this section are used for characterizing the systems color and brightness.

4.6.3.1 Dimming Characterization
This section is used to measure the brightness of the system as the backlight value is changed.
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4.6.3.2 LED Characteristics
This tab is used to create plots of LED Brightness vs PWM. It can be used for debugging and calibration
purposes.

1. Delay Between Measurements: Delay in between the measurements taken by the CA-210.
2. ND Filter percentage
3. LED / Image settings: Settings for image when taking measurements.

• LDC Index: LED sequence and operation mode to be measured
• Sensor gain: optical feedback amplifier gain
• Current Limit: LED driver current limit
• Use user pattern setup: Uses image displayed by user. Otherwise, a white pattern is used.

4. Light Meter: Connect to a light meter.
5. Load/Save: Load or Save measurement settings.
6. PWM settings:

• Enable: Select whether to measure an LED or not
• From: minimum PWM to measure
• To: Max PWM to measure
• Increment: Increment between PWM values
• Fine Increment: For development use only. Set to 50.
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• Weighted: For development use only. Do not check.
• Num Points weighted: For development use only
• Max Difference in slope: For development use only

7. Load / Save Measurements: Load or Save measurement results.
8. Plot Characteristics: Click to start measuring and plotting data.
9. Operating Range Result: Determines max and min usable PWM. This feature is still under test.
10. Compute Operating range: Computes operating range from data. This feature is still under test.

11. LED Curve: This page shows the measured LED Brightness vs PWM data.
12. Curves to view: Select which LED’s data to view and whether to view weighted data or raw data.
13. Select the grid lines to display.
14. LED Data: LED data. Click and drag to zoom in.
15. Click here to zoom out.
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16. Red/Green/Blue LED Data: This section shows the measured LED data in table form.

4.7 Errors
This section describes the error tab and common errors. Section 4.7.1 describes the Error Tab and its
functionality. Error! Reference source not found. shows common errors and the section they are
described in.

Table 4-1. Common Errors

Section Error
6.6.2 ERROR: Timed out waiting for response
6.6.3 Device not Available for Use
6.6.4 ERROR: Invalid Command
6.6.5 Error taking CA-210 Measurement
6.6.6 Cal/Config file programming fails

4.7.1 Error Tab
The error tab is located at the bottom of the ACP window. Its functionality described below.

1. Select whether the error menu should be shown when an error occurs.
2. Click to hide the error menu. Warning: If “Display when Error Occurs” is deselected, the error menu

will not pop when an error occurs after it is hidden.
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3. Clear currently displayed errors.
4. Error timestamp and description.
5. Click here to display error menu when it is hidden.

4.7.2 ERROR: Timed out waiting for response
This error occurs because the connection to the HUD EVM was lost. This could be for several reasons:
• The Cheetah is not connected to the EVM
• The PC entered sleep mode
• The EVM was restarted

Follow these steps to resolve the error:
1. Make sure the Cheetah is connected on the EVM.
2. Make sure the EVM is powered up.
3. From the Connection tab Click Disconnect and then press Connect.

4.7.3 Device not Available for Use
This error occurs because there are multiple ACP windows open or another program is trying to use the
Cheetah. Close any additional ACP windows and any other applications that are trying to use the
Cheetah.

4.7.4 ERROR: Invalid Command
This error occurs because the command sent by Automotive Control Program was not recognized by the
EVM.

The SPI command may not be in the Piccolo software for the following reasons:
1. Piccolo software is old and does not contain SPI command handler.
2. ACP is old. Command is no longer included in Piccolo Software.

4.7.5 Error taking CA-210 Measurement
This error occurs when the brightness is too high for the CA-210 to measure. To fix this error add an ND
filter in front of the CA-210 probe, or move the CA-210 probe further away from the light source.

4.7.6 Cal/Config file programming fails
This error can occur because the wait time between the writes of the flash sectors is too short. Increase
this setting from the Calibration and Config File > Program Calibration Data tab as shown below:
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Chapter 5
DLPU059–March 2018

Reprogramming the EVM

5.1 Reprogramming the EVM
This section explains how to reprogram the DLP HUD EVM. All new EVMs are programmed, and do not
need to be reprogrammed until a new software release becomes available in the future. EVMs sold with
optics are also calibrated.

EVMs may need to be reprogrammed for evaluation and debug purposes. Table 5-1 describes the
protocol and reasons for reprogramming any software on the EVM.

Table 5-1. Software Reprogramming

Software Programming Protocol Reason for reprogramming
Piccolo Bootloader JTAG The bootloader will not require frequent updates. It may need to

be updated if bugs are found in the current version or additional
functionality is added.

Piccolo Main Application SPI (with bootlader)
JTAG

TI provides occasional new releases of Piccolo main application
for added functionality.

Configuration File SPI Can be updated to reconfigure system capabilities such as test
patterns, splash images, video resolutions, and DMD
sequences.
Contact TI applications engineer for new configuration file.

Calibration File SPI Needs to be updated when system is recalibrated.
DLPC120 Application Flash SPI Needs to be updated at the same time as Configuration file

Figure 5-1 shows the recommended software reprogramming flow chart. Not all steps of this
reprogramming need to be completed. To determine when software needs to be reprogrammed, refer to
Table 5-1. Reprogramming does not need to be done in the following order. However, the recommended
order is the most time efficient way to reprogram software. Please make sure that all the software
installation is complete before beginning this procedure.

Figure 5-1. Software Reprogramming Flow Chart

5.2 Programming Piccolo Bootloader

The bootloader allows the main application of the Piccolo to be programmed using the Piccolo SPI
connector. It will very rarely need to be upgraded.

This section requires an XDS100 or XDS510LC USB to JTAG emulator.

Follow these instructions to program the bootloader:
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1. From the navigation pane, go to System Configuration > Programming–Piccolo Flash > Program
Piccolo SW (JTAG, UniFlash).

2. Switch to Settings Tab and select sectors A, B, and C to erase.
• Selecting sector D will also erase the calibration and configuration data that are currently stored in

the Piccolo Flash.

3. Connect an XDS100v2 or XDS510lc to a USB port on the PC and the JTAG connector, H1, on the
HUD EVM LED Driver board.

4. Load the correct target configuration file:
• Target configuration files are included in the bootloader software project in the following location:

– \HUD_Piccolo_Bootloader_SW_Release_V0.1(6)\Target Config Files\
• The Piccolo SW project comes with two target configuration files as shown in Table 5-2

Table 5-2. Target Configuration FilesCommon Errors

Programming Device Target Configuration File
XDS510LC XDS510LC_F28023.ccxml
XDS100 XDS100_F28023.ccxml

5. Load Uniflash.bat file. Included in the following location if Code Composer Studio is installed:
• Location: <CCS Installation path>\ ccs_base\scripting\examples\uniflash\cmdLine\uniflash.bat

6. Load Piccolo Bootloader .out file:
• Location: \HUD_Piccolo_Bootloader_SW_Release_V0.1(6)\Bootloader Code Binary\

7. Click “Start Programming.”
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8. When complete, the following prompt will be displayed. Click “OK.”

5.3 Programming Piccolo Main Application

The main application of the Piccolo controls initialization, communication with the external host and the
ASIC, and dimming. This section describes how to program the main application using SPI.

This section requires the Total Phase Cheetah and the SPI adapter cable included with the EVM.

Follow these instructions to program the main application of the Piccolo:

1. Connect Cheetah Adapter to USB port on PC and SPI connector, J10, on the EVM.
2. Navigate to Program Piccolo SW (Cheetah SPI).

3. Under Bootloader Settings File, click Browse and select Bootloader Settings file.
• Default location: C:\Program Files (x86)\Texas Instruments\DLPC120 Automotive Control

Program 1.4.1.XX\Settings\Xmls\BootloaderSettings.xml
4. Under Piccolo Main Application, click Browse and select main application (.hex) file:

• Default location: \HUD_Piccolo_SW_Release_V0.18(67)\Application Code Binary\
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5. Click Program.
6. When complete, click close on the prompt window shown below:

7. Reset the system by turning the power “off” and then “on” again. The system will be in application
mode when it restarts.

5.4 Programming Calibration and Configuration File

The configuration file informs the Piccolo about the commands available in the application flash memory
and their addresses. The calibration file contains the look-up tables used by the Piccolo to perform
dimming operations.

The calibration and configuration file are programmed into sector D of the Piccolo as a combined binary.
For more details, see the Piccolo Software Programmer’s Guide for the DLPC120 ASIC (DLPU061).

This section describes how to program the calibration and configuration file using SPI:

1. Navigate to Calibration and Config File > Calibration File.
2. Browse and select a calibration file or select one from the list of recent files.

3. Navigate to Calibration and Config File > Config File.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059


8

5

6

7

Programming Calibration and Configuration File www.ti.com

56 DLPU059–March 2018
Submit Documentation Feedback

Copyright © 2018, Texas Instruments Incorporated

Reprogramming the EVM

TI Information — Selective Disclosure

4. Browse and select a configuration file or select one from the list of recent files.

5. Navigate to Calibration and Config File > Program Calibration Data (Cheetah SPI).
6. Connect Cheetah Adapter to USB port on PC and SPI port on EVM.
7. Click Verify and Program.

8. The error message shown above will appear. Since we have not programmed the Flash yet, we expect
this error. Press “Yes.”
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9. Once programming is complete, power cycle the system. When the system restarts it will use the
newly programmed calibration and configuration data.

10. Click Close.

5.5 Programming Application Flash

The application flash memory connected to the DLPC120 contains the commands necessary for the
DLPC120’s initialization and much of its other functionality. The flash image version loaded on the
application flash must match the configuration file version loaded on the Piccolo.

This section requires the Total Phase Cheetah and the SPI adapter cable included with the EVM.

Follow these instructions to Program the SPI Flash:

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=DLPU059


4

5

2

3

Programming Application Flash www.ti.com

58 DLPU059–March 2018
Submit Documentation Feedback

Copyright © 2018, Texas Instruments Incorporated

Reprogramming the EVM

TI Information — Selective Disclosure

1. Connect Cheetah Adapter to USB port on PC and SPI port on EVM.

2. Navigate to System Configuration > Programming – ASIC Flash > SPI Flash Program (Cheetah SPI).
3. Click Switch SPI Bus.

4. Click Browse and select .cfg file that is programmed on the Piccolo.
5. Click Erase + Program + Verify.
6. When programming is complete, power cycle the system.
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