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B J5i %% DevPack for SimpleLink SensorTag Debugger
(CC-DEVPACK-DEBUG)

Description

The Debugger DevPack adds debug capability to your SensorTag. Plug it into the SensorTag DevPack expansion header and debug your SensorTag with Code
Composer Studio or AR ARM development environments. The Debugger DevPack includes a FREE license of Code Composer Studio that is tied to the DevPack.

The Debugger DevPack includes a USB power connection, making it easy to power your SensorTag during debugging. Alternatively, simply connect it to a USB
power supply if your sensor application requires permanent power. It also includes traces for three Grove connectors to make it easy to add support for any of the 100s
of Grove sensors and actuators.

The Debugger DevPack is a small form-factor XDS110 debugger. It can an be used with IAR and CCS.

How To Setup A Development Environment For The CC2650STK SensorTag

There is a lot of information on TI’s website on how to get your CC2650 Sensortag ready to connect to a development environment which is quite overwhelming.
There are still a few bugs in the software which the SensorTag team is working on. In the mean time, this guide will help you get setup with a development
environment for the CC2650STK.

Warning: The binary/hex file that is generated with TI’s code used in this write-up has a bug and it will not work with TI’s Android application, due to a versioning
error. Read the end of this article for a workaround.

1. Required Hardware:

e CC2650STK Sensortag
e SensorTag DevPack( CC-DEVPACK-DEBUG )

2. Required Software

e The latest Code Composer Studio
o Ifyou already have CCS, make sure you update to the latest version via Help->Check for updates.
o CCS switches to a free version once you have the Debug DevPack connected.
e TI-RTOS for SimpleLink and TI-ARM compiler
o The above two can be downloaded from TI’s application center from within CCS.
o Goto Help->CCS App Center
o Under Code Composer Studio Add-Ons, you should see the following. Install them:

TI-RTOS

for SimpleLink™

TI-RTOS for SimpleL... TI ARM Compiler

ozm [

o
o BLE-STACK2
o Remember to download BLE-STACK?2, not BLE-STACK.
o Install the stack using recommended settings. On my machine it defaults to c:\ti\simplelink

3. Connecting Your SensorTag Hardware

This is kind of tricky. There are two ways to go about this.
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3.1 Connecting the Tag directly to the Debug Devpack

Separate your SensorTag into its different parts, so that you only have the main Tag PCB. Now align the SensorTag 10 pin connector and the 20-pin SKIN connector as
shown below. Do NOT remove the battery! The LED should stay on when you connect the USB cable to the PC.

Warning: It is highly recommended not to leave the Debug DevPack connected to the SensorTag without the USB cable as it can damage the Debug Devpack pins,
with the coin cell inserted.

It is not recommended to use the Debug DevPack without the USB power attached due to the risk of powering the Debugger from the coin cell battery on
the SensorTag. The SensorTag battery voltage will be disconnected from the Debug DevPack power supply but there is a risk that the 1/O from the CC2650
will power the MCU on the debugger: The following 1/O DevPack signals are connected to the MCU on the DevPack

T

3.2Breaking the rear cover tab

Another way to connect the SensorTag2 while it is in it’s casing is by breaking the tab on the rear cover. There seems to be a few places where you can cut the tab off.
For my setup, I went the above route.

BREAK TAB

http://goods.ruten.com.tw/item/show?21309249087500 2/6



2/6/2018 BRINE-G1 NO.1 A B 49us

Once the USB cable is connected, the hardware drivers get installed if Step 2 was followed correctly. The Device Manager should show the following XDS110
413" Ports (COM 8LLPT)

7 XDSL10 Class Application/User UART (COMLO)

devi H ?’ XD5110 Class Auxiliary Data Port (COMI11)
CVICECS. * wm _

-

Note that if you do not have the coin cell inserted into the SensorTag, the Debug DevPack comes up as a DFU or “Stellaris Device Firmware Upgrade” for upgrading
the TivaC on the Debug DevPack

4B Stellaris Device Firmware Upgrade
] L, Stellaris Device Firmware Upgrade

4.Loading Demo Code On The SensorTag
The fun part!

¢ Open Code Composer Studio and select a workspace

% Workspace Launcher EETR X

Select a workspace

Code Composer Studio stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

LWLl ELORRE: Working HUB-42\Repos\ github\CC2650 SensorTag - Browse...

[] Use this as the default and do not ask again

[ ok ][ cancl

o 2
* Goto File->TI Resource Explorer. On the left panel you should see BLE-Stack for SimpleLink wireless MCUs
' TIResource Explorer &3

:.enter search keyword | Address:

Devices: [All "] Topics: I.All -

1> f# BLE-Stack for SimpleLink wireless MCUs
. MSPWare PP g
(4

. H3 TLRTOS for SimpleLink Wireless MCUs \Qﬁp.. Tl Resource Exp'orer

. i TivaWare_C_Series-21171
A place to browse examples, documentation, and online content.

S 1 O
¢ Expanding “BLE-Stack for SimpleLink wireless MCUs” should give you a list as shown below. Select SensorTagApp and click ” Import the example project
into CCS”
' Tl Resource Explorer i3
Packages: Devices: |All '-'l Topics: IALl -
:...'?”t.er SEaeh-keywond | {{dess:
a4 {5 BLE-Stack for SimpleLink wireless MCUs
4 ) CC2640F128
» 6 Dacumentation - SensorTag App
@ Download Bluetooth Smart SDK .
@ E2E Forum SensorTag Application Project
4 ) Projects :

3 ﬁ Glucose Collector

» ) Glucose Sensor

@) HID Emulsted Keyboard These are the steps to import the project, build the project, and debug the project.

I ) Host Test

i @ KeyFob Demo Step 10 g Import the example project into CCS

4 () SensorTag ) - o _ _ o

s Click on the link above to import the project. The imported project is available in the F
= SensorTagApp s : : et d
e the imported source files. To modify source code, double clicks on the source file witt
= SensorTagStack
° ¥ @ SensorTag Quickstart Cloud Step 2: & Build the imported project

o Perform the same step for the SensorTagStack project. On import you should see the two projects on the left panel.Now, all that is needed is the SensorTagApp
project. The SensorTagStack project is provided if you are brave enough to make changes to the Bluetooth Low Energy stack. TI separated these two to make it
modular and ease development.
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[ Project Explorer 50
Pl 'f';' SensorTag [Active - FlashROM]

3 -t';b Binaries

[+ i Includes

I+ [py Application

» [y Board

I+ (&g Drivers

[+ (= FlashROM

b 2 ICall

+ (i ICallBLE

I R Include

I+ [Zy PROFILES

I (B Startup

> (= targetConfigs

- By TOOLS
P .Seﬁ_sérTa_gE.ntack'

i+ i Includes

(z=- FlashROM

[+ = HAL

[ (2= ICallBLE

|+ (2= INCLUDE

> (= LB

> (= OSAL

|» (= PROFILES

|+ [ Startup

> (= targetConfigs

b = TOOLS
o

» Right click the SensorTagApp project and click build. It will take some time to build the first time. On completion, you should see a “Build Finished” output.

5.Debugging the SensorTag
Debug can be started by clicking the “bug” drop down and selecting Debug as->Code Composer Debug Session.
The first time you try to debug the SensorTag, a XDS100 error will pop up.
Error connecting to the target: (Error -151 @ 0x0) One of the FTDI driver functions used during the connect returned bad status or an error. The cause

may be one or more of: invalid XDS100 serial number, blank XDS100 EEPROM, missing FTDI drivers, faulty USB cable. Use the xds100serial command-
in the ‘common/uscif” folder to verify the XDS100 can be located. (Emulation package 5.1.641.0)

<+ Texas Instruments XD5100v3 USB Debug Probe/IcePick € LB &

I"' '-I Error connecting to the target: -
A " (Error -151 @ 0x0)

One of the FTDI driver functions used during

the connect returned bad status or an error.

The cause may be one or more of: invalid XD5100 serial number,

blank ¥D5100 EEPROM, missing FTDI drivers, faulty USB cable.

Use the xds100serial command-line utility in the 'common/uscif'

folder to verify the XD5100 can be located.

(Emulation package 5.1.641.0)

o] i

This is due to the fact the stock SensorTagApp project was setup to use the XDS100 debugger, but the debug DevPack comes with the XDS110. This will need to be
changed as shown below.

o Right click the SensorTag project and click properties.
s Select “General” and change the Connection from “Texas Instruments XDS100v3 USB Debug Probe” to “Texas Instruments XDS110 USB Debug Probe”
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¥ Praperties for SensorTag - ) - == ==
type filter tet | | General &S -
1+ Resource
General
4 Build Configuration: |FlashROM [ Active ] | [ Manage Configurations...
4 ARM Compiler
Proceszor Options
Optimization E Main (Bl RTSC|
Include Options
MISRA-C:2004 Device
ULP Advisar Family | ARM il
[+ Advanced Options i = —
4 ARM Linker Variant <celect or type filter taxt> » |CC2650F1L28 -
Basic Options Connection: (applies to whole project)
File Search Path ——
i+ Advanced Options Stellaris In-Circuit Debug Interface
" ARM Hex Utility [Disabled] Advaneed =i Texas Instruments XD5100v2 USB Debug Probe
[l  XDCtools i Texas Instruments XDS100v3 USB Debug Probe (Default]
Debug RCLLIERRS T s Instruments XDS110 USE Debug Probe | More..
Texas Instruments X052 USE Debug Probe |
Qutput type Texas Instruments XDS2woc USE Onboard Debug Probe
Texas Instruments XDS560 Debug Probe
Qutput formi Tigae Instruments XDSS60 Debug Probe, 2-Pin JJTAG with External Converter
Device endi Texas Instrumients XDS560 Debug Probe, 20-pin Rew-D Cable
FVIEs SRCIR | ART Connection
Linker command file: * | Browse.
Runtime support library: <automatic> v Browse..,
7\
?) Show advanced settings oK | | Canezl
o i

o Click ok and try debugging again. This time your code should breakpoint at main().
' TIResource Explorer [€] main.c &2

54 #include “bleUserConfig.h”

55

56 // BLE user defined configuration

57 bleUserCfg_t user@Cfg = BLE_USER_CFG;
58

50 #endif // USE_DEFAULT_USER_CFG

68

51 #ifdef FEATURE_OAD

62 extern uint32_t _ vector_table;

63 #endif //FEATURE_OAD

PIN_init(BoardGpioInitTable);

// Enable iCache prefetching
VIMSConfigure(VIMS_BASE, TRUE, TRUE);

Kl G i Ehi

Please note that although you have code burned onto the CC2650 SensorTag and are excited to try it with TI’s Android application, the application will error out. This
is due to a version check bug as described here. The good news is that you can restore the SensorTag to factory by either of the following two ways:

o Pressing the two user buttons for six seconds and release to hear a beep...OR

s Programming the CC2640_SmartRF_SensorTag.hex file which can be found under: C:\ti\simplelink\ble cc26xx_2 00_00_42893\Accessories\HexFiles

o This firmware can be downloaded via the SmartRF Flash programmer-2
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® SmartRF Flash Programmer 2 - Texas Instruments A e B

Smart ™Flash Programmer 2 e 151

Connected devices: i i MAC Address

4 XD5110, XDS-00000000
Flash image(s)

@ Single  C:pisimplelinivble_ccZ6xx_2_00_00_42B83/Accessories/HexFiles/CC2640_SmartRF_SensorTaghex +

EEiakmer fonti e

() Muttiple ‘ || Disable [] KeepC
_Flash lock

| Write protect pages

| Lock debug interfac

Actions Hide opﬁnns<«] Secondary MAC Addr

f Erase f Pro fl Verify
H Erase B Program Bl verity Flash Address EEE 80z

| Retain secondary &

Flash Address BLE: 0xt

| Retain secondary E

™
© Al unprotected pages o e @ Pages filed with

@ Pages in image
Exclude pages in image filed @ Pages
® Speciicpages: [N | ® win [ o« | -

Erase all unprotected pages, Program entire source image, \Verify with readback and compare °

A Status Clear

State: Normal access
Flash size: 128 KB
Ram size: 20 KB
Chip revision: 2.2 E
Package size: Tx7

Hope you liked this how-to. If you have any questions
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