This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

PGA309EVM-USB: Win10 software not connecting

Part Number: PGA309EVM-USB


last week I have received my PGA309EVM board. However I am really struggling to bring this thing to work on my Win10 64bit machine. I´ve seen some other related topics here with people having the same or similar issue.


I´ve connected the external 9V Power Supply before plugging in the USB cable. µC; 3.3V; Vcc LEDs are on, Vdut LED is off

When starting the software it says "Check your hardware connection and re-boot the software".

It seems like the Windows 10 Device Manager doesn´t recognize the device:

What I have tried to fix the issue so far:

  • doublechecked the jumper settings like they are suggested in the other thread mentioned above
  • reinstalled the software with administrator privileges
  • installed the software on a different Win10 PC with the same result

Any suggestions how can I approach this? Is this a problem with the Win10 drivers?



  • Hi Max,

    I had very similar issues when I first started using the board, where it wouldn't install the USB driver to interface with the board. In my case I found out it was because the board shipped with the WP and EE jumpers set in the wrong locations. These are JMP3 and JMP10, and they should be set to WP_On and EE_On. Once I changed them, and some other settings (I can't recall exactly which ones, but I had to move a few jumpers so that the configuration perfectly matched with the below picture) it worked for me. For reference, I am using Windows 10 Pro.

    Are you running the executable as an administrator? Did you install it in the default Program Files (x86) folder or somewhere else?

    I will also note that over time there have been a few instances where the board was suddenly no longer recognized. I could fix it by powering everything down, rebooting my laptop, powering the EVM back up and then reconnecting the USB cable.

    Just to verify, you are using the Rev C code from this link, correct?



  • Hi Jon,

    I just came back to office today and changed nothing since friday. I checked the jumpers again but everything seems to be fine, so I tried again.

    I don´t know why, but Windows now chooses the correct driver and the software detects the board as well. Maybe there are some weird things going on with a Windows update?

    However now I can continue my work with my sensors again. Thanks a lot for your time


  • Hi Max,

    Interesting, well I'm glad that it is working now! Windows can certainly be a fickle beast. Feel free to reach out again if you have any other issues with the system.