This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Hints and or suggestions in the use of the INA322 (circuit doing a few strange things)

Other Parts Discussed in Thread: INA322, MSP430F5342

 I've been having some strange issues with the following circuit

We are using a 0 REFERENCE voltage (in the real circuit as well) and in no place it mentions "thou shalt not ground reference" however is this an issue with the INA322? The circuit doesn't work consistently between ones we had made.


The LTSPICE simulation seems to hint REF wants to NOT be ground (again not explicitly stated in the Data sheet however).

I appreciate a bit of feedback on this.

Stephen

  • Hi Stephen,

    I think the issue here starts at the output of the second op amp in the chain, A2:

    In the equation for the output voltage of A2, input common-mode drops out, and the output voltage is:

    VOA2=5VDIFF+VREF (given on page 10 of the datasheet)

    Where VDIFF is the input differential voltage. If VREF is equal to zero, and VDIFF is equal to zero, then ideally the output of A2 would be 0V. But this cannot happen because 0V is the negative supply rail of the amplifier. So the output of A2 gets as close to ground as possible, but this is still potentially several above ground (and will vary from part to part). This saturation voltage of A2 represents an error voltage that is then amplified by A3.

    By adding a small reference voltage, it prevents the output of A2 from ever saturating at the negative power supply rail and contributing an additional error. 

  • That would explain the long convergence time in the spice simulations with an odd output value unless I place a reference offset.

    What is the rail to rail swing on A2 is it like A3 which is 50mv (25mv 'typical)?  So this would indicate a minimum of ~60mv reference offset needed correct? That would require an opamp to drive it because of the

    Fortunately we are within the common mode range at least (by 300mv roughly).


    Thanks for your feedback much to think about.

  • Back again, after some analysis and a sudden strange output change, here comes the big question. (heh)


    Page 11 of the data sheet discuses the input protection for the amps, is their any output protection? As it appears one of the transistors has failed shorted on the A3. The device although powered and receiving a signal (the difference between Vin- and Vin+ is always positive it cannot go negative (hence the original schematic showed a 3 resistor divider type circuit).  The output of A3 is very close to ground it will lift from ground slightly with enough difference on the inputs but it "floats" around  0.0005V their are more than 1 of the 10 boards we built that had this issue. A 3rd board had to have some work on it and it came back with this condition. The output goes directly input an MSP430F5342 P6.4/A5/pin 2 and I'm pretty sure it's not the msp430.

    Is it possible for the output transistor to be shorted or opened by static? I noticed the inputs had protection but no mention of the output transistors.


    Thanks much appreciated.

  • If you lift the INA322 output pin of the PCB (so it is not connected to the input of the MSP430) does the output remain at the negative rail? This would eliminate the MSP430 from the debug process. 

    All pins of the IC will have ESD protection devices but these devices are intended to protect the IC during shipping and assembly and are not intended to withstand large discharges. Ensure that your technicians and engineers are using proper ESD mitigation techniques when working on the PCBs, (wrist straps, surface mats, etc.).