This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

INA220EVM: USB Communication Error

Part Number: INA220EVM
Other Parts Discussed in Thread: INA220

I purchased an INA220EVM and am having exactly the problem described in the manual (SBOU079–July 2009 INA220 Evaluation Module) on page 14 but the suggested fixes are not working for me.

The usb user interface appears to have installed correctly and I can see what I think is that interface in the device manager.  I plugged in power first.

I'm running Windows 7 Enterprise in 64bit mode.  Service Pack 1.  I changed the compatibility setting for the EVM software to several other obvious choices like Windows XP (Service Pack 3) and Windows 7 and I tried the compatibility trouble shooter.

I had downloaded the latest application code (sboc297).

Any suggestions?

  • Hello Chuck,

    Thank you for using the TI forums. I will be looking into your problem. For your information, there is a second revision for the User's Guide which can be found here: Is your problem the one that is on page 16 of that document? When did you buy your EVM? What letters are on your board at the bottom for "6492886 BOM" and "6492889 PCA"?

  • I bought the board (Sales Order 166869850) for a project last summer but it wasn't delivered in time to put to use.  So it has been on the shelf since receiving it about 9/14/16.

    The number on the bottom of the INA220 board is 6509589 BOM A.. Is this a serial number on the paper tag: 4461000005?  The DIG Platform says 6492886 BOM C and 6492889 PCA C, serial number 4256400002, tested 03/22/2016.

    I downloaded everything from the web: User Guide SBOU079B–July 2009–Revised May 2016; INA220 Source Code; INA220EVM Software  I uninstalled what I had and started over.

    I still get the USB communications error described on page 16 of the User Guide.

  • I've tried supply voltages from 6 to 8.75V. I've tried powering from USB but neither the board nor my laptop liked that.

    I've tried alternative USB ports on my laptop. I can see on the device manager when I connect and disconnect to the board (HID compliant device and USB-input device).
  • I tried all possible combinations of "set address" with same error.
  • After USB communications error one can Try Again but you get a dialog box saying "Check connections to DAQ EVM" and then one that says "Invalid calibration information."
  • Hello Chuck,

    After you saw “Invalid calibration information” were you able to move forward past the error in the program? If not, we have another solution that may work for you. If you are interested you can email me directly.

  • Okay, that was tricky. In desperation I checked "Use Legacy Address" despite the directions in the video that say that is only applicable to boards prior to 3/1/08. My board says it was tested 3/22/2016. I had previously tried all possible values of USB addressing in the jumpers.

    NOW MY INA220EVM IS RESPONDING CORRECTLY! Please consider this issue closed.
  • Chuck,

    I am glad that you figured out the problem!