This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

OPA857EVM-978: No output from board in test or photodiode mode.

Part Number: OPA857EVM-978
Other Parts Discussed in Thread: OPA857

The first time I tested this board I was unable to get it functioning properly.

I spoke with a representative of TI yesterday regarding this issue and was advised to post here to determine if the board is defective as I suspect it is.

The evaluation board is intended to be used in conjunction with a photodiode for detecting 30 uA current pulses with a pulse width of 40 ns. The photodiode I am testing the amplifier with is a properly  functioning silicon photodiode that I've independently verified with a 520 nm 40 ns laser pulse and a scope.

I've tested the board in test mode and in photodiode mode. I would like to use it in photodiode mode. My test connections are as follows according to section 5.2 Photodiode Mode and referring to Figure 5. Pulse Response Test Circuit as outlined in manual TIDUBX71 - April 2016:


TEST_IN = +VCC (equivalent to +VS)

Anode of photodiode connected to IN

Cathode of photodiode connected to VAPD

VAPD at ground (i.e. for photovoltaic mode)

VCC = 3.3 V (positive supply)

GROUND = 0V (negative supply)

J6 set to 20 kOhm position.

I've attached an image showing the jumper configurations on the board for photodiode mode.

I've noticed that the power supply sources 0.09 A at 3.3V which seems a bit high for the OPA. The rep seemed to think this may indicate a defective board. 

Please advise on how to proceed.



  • Hi Andre,

    you have wired the photodiode improperly. Because the IN pin of OPA857 is sitting on 1.83V the cathode of photodiode must not be connected to GND!


  • Hi Kai,

    I've tried that, and every other combination I could think of.

    It doesn't matter whether or not I connect the cathode to GND, 1.83V (photovoltaic mode) or > 1.83 V (photodiode mode), there is no output from the amplifier. I even tried driving a simple capacitor with a sine wave to see some amplification at the output and again there is no signal.

  • Hi Andre,

    can you carefully measure the voltages between each solder pad of C7 and GND?

  • Hi Andre,

    Were you able to resolve this issue? If the supply current drawn from the EVM is ~90mA then it is very likely that the part has become defective. Also, as Kai mentioned, the cathode of the photodiode needs to be connected to a higher bias voltage than 1.83V.

    Would it be possible for you talk to the TI representative and replace the existing board with a newer evaluation board?

    Also, when you are measuring the output, are you recording at the J3 SMA connector?

    Best Regards,