This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

INA229_239EVM: The plots on the "results data" section are always zero

Part Number: INA229
Other Parts Discussed in Thread: INA228

I am working on INA229EVM and I am able to see data in "register map" section in GUI; However, there is no data in "results data" section. Everything is zero on the plots. Also in the manual it says that we have to select CS3 in the EVM1 SW in "results data" section. But the options showing for SW1 and SW2 are GND, Vs, SDA, and SCL. I cannot see CS1, CS2, CS3, CS4. I tried " link to Regmap", but it didn't work. 

  • Hello Parisa,

    Can you check that you are using the latest user's guide and GUI?

    Currently the latest User's Guide is:

    The latest GUI can be found here:

    Note for the GUI, the link on the tool page currently goes to version 1.0.0, I'm in the process of getting that fixed to point to all versions like the link above.  Currently, the newest version is 1.0.1.

    SC3 is only still needed if using the old GUI, or if using SENS064A EVMs. Note that if using SENS064A EVMs, then you'll use CS3 on the EVM, but CS1 in the GUI.  (If set to CS3, the GUI will automatically put CS1 for you in the box).  If you have a revision B EVM, then this is not important.

    If using only 1 EVM, then the GUI/firmware should automatically detect the correct EVM and switch setting and populate the drop down boxes accordingly (on GUI refresh). Then, to see data in the plots, you just need to click the "COLLECT DATA" button.

    I see a couple other problems though. If the GUI is showing you SW1 and SW2, then it thinks you have an I2C EVM....   This would be hardware ID SENS063. Does your EVM say SESN064? A or B?

    There are a few things you can check for this. First, connect the EVM to the MCU board, and then power it on (or reset the MCU board). Then launch the GUI and close the dialog.

    1. On the home tab in the upper left, do you see "DEVICE CONNECTED"? with a green indicator light? 
      1. If so, what device does it say is connected? (If you have an INA229EVM, then it will say INA229).
      2. You should also see "Hardware Connected." in the bottom left corner.
    2. On the register map page, what do you see for the DEVICE_ID register?
      1. Should be 0x229X, most likely 0x2291.

  • Hi Mitch,

    Thanks for your reply. I tried GUI v1.0.1, but I had the same issue. My EVM is SENS064B and device ID is 0x229.

    When I connect my device to the laptop, GUI does not automatically detect it and gives the following error:

    "No SCB controller detected"

    So I go to Options->serial port to connect it and it only has one option :

    "COM6 (type error: cannot read properly 'dev-name' of undefined)"

    Also in the home page it doesn't specifically show INA229, it shows :

    "Device connected 


  • Hello Parisa

    If you see "INA228_229_237_238_239", then it is probably says "Device Disconnected" instead of "Device Connected". So, I'm guessing it was red, not green.  However, this looks like a driver issue.

    Make sure that you download and install the driver as an administrator. It can be found here:  (You may have already done this, the problem is associating the drivers)

    It is looks like your drivers are not linked properly to the device.  Click on the FAQ link that shows up on the window when you see "No SCB controller detected". For convenience, this is the link:

    Follow the steps outlined in this FAQ to associate the drivers with the device.  Note that you may have to do this 3 times, once for each driver listed in step 8.

  • Parisa,

    One more note after running through this myself.  When having driver issues, it may be easier to manually put the device into DFU mode (per User's Guides instructions), then make sure the driver is connected.  For example, after you enter DFU mode, you should see a device in device manager called "TIVA Device Firmware Update", if not, then use the instructions from the FAQ to link the unknown device with "boot_usb.inf".

    Once you see "TIVA Device Firmware Update", open up the GUI and go to File -> Program Device....  Then everything should work properly. 

  • Thank you. I tried updating the driver based on the FAQ page. It still didn't work, but I programed the device manually  based on the instructions in the user guide and it solved the issue. 

    Note: From the beginning, my device was connected and I was able to read data in "register map" section, while it was showing connected "INA228_229_237_238_239".

    Thanks for your help. 

  • Parisa,

    Glad it is working for you!  Thanks for the clarification, that is interesting that you were able to read registers and it say connected while saying "INA228_229_237_238_239".