Due to the U.S. Thanksgiving holiday, please expect delayed responses during the week of 11/22.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

OPA657: Importing pspice model into project design

Part Number: OPA657

Hello all,

I am facing difficulty in using pspice model for OPA657 in my simulations using pspice for ti. What I did was download pspice model for OPA657 available in the technical documents section of the project page and tried to generate a part using the .lib file. But ended up having the following error

ERROR(ORPSIM-15108): Subcircuit OPA657 used by X_U2 is undefined

Am clearly missing something here and trying to figure out what am doing wrong.

Any pointers from expert users are welcome.

thank you,

SK

  • Hi SK,

    Since you downloaded the model from TI, you shouldn't need to use the 3rd party symbol generation procedure. You can just unzip/extract the zip folder, drag and drop the OPJ file for the OPA657 into your schematic window. Click place part button, and you'll see the OLB file in your design cache, which you can drag onto your schematic.



    Please let me know if you still have issues.


    Best,

    Sam

  • Hi Sam,

    Thanks for the valuable pointer. I followed your recommended work around by dragging and dropping the .opj file of OPA657 into my work schematic. This allowed me to directly place part OPA657 into my schematic from add part option and use it. But still when I run the following error pops out.

    ERROR(ORPSIM-15108): Subcircuit OPA657 used by X_U1 is undefined.

    I am very much clear of the importing the .opj file (thanks for your tip), but unaware whats the reason for the error.

    thanks,

    SK

  • Hello all,

    Found a working solution from this link here. What I found after my struggle with the error was .lib file has to be shown to the simulator while creating/editing the simulation profile so that the simulator zeroes on to the correct library file for the component used/imported (in this case OPA657).

    Hope this helps or saves some newbie like me in future.

    Expert users please add your valuable comments, so that I can improvise if my understanding is wrong.

    regards,

    SK

  • Hi SK,

    It should show up there in under Design Cache when you drag it in. Not sure why that's not behaving, but I'm glad you got it to work.


    Best,

    Sam