This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

Error on CCS 5.2 + Ubuntu 12.04 + LM3S8962 evb

Prodigy 10 points

Replies: 4

Views: 10388


 I have succesfully installed and licensed CCS 5.2 on my Ubuntu 12.04 laptop.

I have connected a LM3S8962 evaluation board to my laptop, then I started 

CC2 5.2 and: 

Project -> Import Existing CCS/CCE Eclipse Project.

In the search-directory box, I browsed to StellarisWare/boards/ek-lm3s8962/blinky

but I get the following error:

File connections\Stellaris_ICDI_Connection.xml does not exist. Was included by file /home/user/CodeComposerStudio/workspace_5.2/blinky/target_config.ccxml 

Any ideas on how to solve this problem?

Thanks in advance,

Francesco Brasini.

  • We are still working on support for Stellaris in Linux.  First of all, aside from that error, did your project import okay?  You probably have the red "X" by the target configuration file but otherwise all the files are there, and you should be able to successfully build the project?

    The target configuration file has windows style path separators so that is one reason you are getting an error.  We are fixing the path separators in the next StellarisWare release.  However, that file is not actually present because we do not yet have good support for Stellaris ICDI on linux.  We have been able to make it work, but it does not always work on all systems and we have not been able to debug the reason for this yet but it has something to do with USB drivers.

    So, I would like to say that if you want to use CCS on Linux with Stellaris boards, we highly recommend that you use an XDS100v2(ARM).  This works well:

    If you want to try and get the ICDI direct connection working, you are welcome to do that and we will try to help but may not be successful.  If you want to do that then you need to create a file with the following contents:

    <?xml version="1.0"?>
    <connection id="Stellaris In-Circuit Debug Interface" class="31040">
        <connectionType Type="LM_ICDI"/>
        <property Type="hiddenfield" Value="No" id="dataFileRequired"/>

    Name this file "Stellaris_ICDI_Connection.xml"

    And place it in the path (relative to where you installed ccs):


    Good luck.

  • In reply to Stellaris Joe:

    Thank you for the tip. Following it, I was able to add the "Stellaris In Circuit Interface" as the connection option of my LM4F232 project. However, it still did not work and I had to do some tweaks to get it working. I wrote them here, in case anyone may find them useful.

    First of all, although CCS graphical environment kept complaining about target being missing, I noticed some warnings in the text console regarding and not being found on the system. was indeed not on my system, so I downloaded it from FTDI web page ( I copied the "i386" binary to my /usr/lib folder and then created a symbolic link to it, also in /usr/lib:

    sudo ln -s

    libusb-1.0 was already instaled on my system (Ubuntu 10.04), but is was named as "", so I also created a symbolic link to it in /lib:

    cd /lib

    sudo ln -s

    CCS still wasn't working, and now it complained about the target's clock, but again, in the console there were some warning now regarding the permissions of the device file placed in "/dev/bus/usb/...." folder. So I added this to one of the existing udev rule files.


    And now, apparently, it works!

  • In reply to Jose Manuel Cano Garcia:

    I can confirm that Jose Manuel's solution works ok in a Ubuntu 11.10 64 bits SO. However, you must use i386 "" instead of 64 bits one, as it doens't work with the later. It's probably due to CCS is a 32 bits program.

  • In reply to Ignacio Herrero:

    I tried Jose's solution while working on a ubuntu 12.04 64bits environment for my Stellaris Evalbot which is based on Lm3S9B92 but It didn't work completely. To make it work in 12.04 64, not only has to be the i386 version, (like Ignacio mentioned above,) but also the file Although I'm not sure if it helped, I also used the i386 versions of,, and since these files were causing errors as well.

    I got all the necessary i386 versions from And used them to replace the 64bit versions existing in /lib/ (for, /usr/lib (for,, and /usr/lib/gtk-2.0/2.10.0/menuproxies/ (for After that, I was able to load blinky onto the board.

    If you do that like I did, then I'd recommend to restore the 64bit files after finishing working with ccs since the i386 versions could break other programs (so far no program has broken though).

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.