This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

PCM1808: Reference voltage is zero. Bad part?

Part Number: PCM1808
Other Parts Discussed in Thread: PCM5102, TEST

I purchased a couple break out boards that have a PCM1808 and a few resistors and capacitors. 

Each channel has in input filter consisting a series 0.1 uF capacitor, a series 10 kohm resistor, and a shunt 360 pF capacitor to ground.

I am providing it with +5 volts (measured as +5.027 volts at pin 3)

and +3.3 volts (measured as +3.32 at pin 4).

Operating in slave mode.

System clock at 3,072,000 Hz from an ESP32 processor.

Left/right clock at 12,000 Hz from the ESP32 processor,

Bit clock at 768,000 Hz from the ESP32 processor.

First board worked for a few hours.  Then both channels stopped working.  The DOUT line was always low. Turned system on and off, left channel does not work, right channel works for 

a minute and then stops working (all zeros out from both channels).  Then right channel comes back.  Input signal is fixed 750 Hz 500 mv p-p sine wave.  ESP32 transfers

serial data to a PCM5102 and recreated data goes up and down in level over of a period of several minutes. 

Scope image of data out of the PCM1808 shows that the measured level is going up and down 

over a period of many seconds.  By this I mean that the right channel data value is going positive and negative at 750 Hz, but the number of

active data bits can be seen to vary up and down.  As if the signal level is going up and down many dB.

The Vref always measures within a few millivolts of 5.027 / 2 on this board.  DC voltage at right input pin is close to 2.5 volts. 

DC voltage at left input pin is 2.28 volts.  Input capacitors are ceramic, and measure as open circuits.

With breakout board removed from test rig and no power applied, the resistance from Vref to ground is several megaohms, difficult to measure accurately because

there is a 10 uF bypass capacitor on the Vref line.  Resistance from the input pins to ground also measures in the megaohms.

Does the behavior of the first board indicate a clock stability problem?  Is the part muting per SLES177B-APRIL-2006 Rev August 2015 Paragraph 7.3.3?

Tried a second breakout board.  Always zero on the DOUT line pin9.  Vref, Pin 1 measures 0 volts.  DC voltage at input pins is 0.

With power off the resistance from Pin 1 to ground is about 10 megaohms, so board trace is not shorted to ground.

Does the 0 volt Vref indicate that the second part faulty? 

I have two more boards coming within a few days.  Would like to know what DC voltage should appear input pins

when input is not driven by any external connection.  Any other advice or precautions?

  • Hi Graham,

    Ill sit down with an EVM and see the status of VREF when no clocks are supplied. As I understand VREF is voltage divided from VCC, If there is no VREF this could indicate damage to the device. 

    Ill get back to you by the end of the week

    Regards,

    Arthur

  • Hi Graham,

    I tested your timings with MD0=MD1=1 and FMT = 0 in slave mode, and it works as expected. 

    The only case where VREF=0 was when the SCLK was not applied. 

    when SCLK is applied VREF measures 2.56 V (half of my Vcc 5.12V)  and the input pins are biased at the same 2.56V

    Your input filters and input signal should be OK.

    And on this part if the device is active you will see switching at the DOUT even when no input is applied, so if you see no data I would suspect the device is muting itself or damaged.

    Can you also ensure that the SCLK amplitude is reaching valid TTL logic levels (2V high 0.8V low)

    Also please verify the connection of the MD0 and MD1 pins. for your case of SCLK = 256*FS they should both be "high"

    Regards,

    Arthur