This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

PCM5142EVM-U: not possible to write in registers, my code doesn't work

Part Number: PCM5142EVM-U
Other Parts Discussed in Thread: PCM5101, PCM5142

Hi Team, 

Good day. I am posting this inquiry on behalf of the customer.

A recent inquiry from the customer was posted in the link below.

Hello, I would like to have help with PCM5142EVM-U Evalboard I tried my code in the chip but nothing happen (it is not possible to write in registers) It will be great if someone can explain to me why my code doesn't work
So last inquiry was about the configuration of the registers, now it's configured
Today I received access to PurePath Studio but I only worked with CodecControl.
However, I generated a code(code.txt attached)
This code is mixed I started from the "PCM5101_USB Playback" database and modified it
My problem is after I've run the code registers haven't changed as you can see
The code works (I mean he is sent to PCM5142) and at the output, I have a sinewave
When I read the data all registers I modified are the same why?
Like register 25 (Hexa) is the same
the problem is in my code there is something that I don't change
Just add that I'm not using Pureath only write in registers
Normally, it will work with only coding registers
I mean it's what I guess

Please help to advise. Thank you for extending your support.

Kind regards,