This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Files generated by PPC3 V3.1.5 not usable

Part Number: TAS3251-SW
Other Parts Discussed in Thread: TAS3251, SRC4392, TAS3251EVM


I’m designing a TAS3251 Amp board with its on-board uC. I use PPC3 to design the configuration but I do not use an EVM.

Amp is running Ok, configuration of the TAS is OK, except DSP part, and it produce sound. What I can’t achieve is to design a DSP config in PPC3 and have it running on TAS. After several tests my current conclusion is that I may encounter an issue with PPC3. Please also take note that my on-board software consider the files coming from PPC3 made of two different parts:

  • First one related to general confit of the chip, of the serial audio port, the DAC and some housekeeping function. I’ve no issue with this part, everything is ok.
  • Second one is only related to the DSP, and exclusively deal with registers located in book 0x8C.

Please also note that I successfully design by hand basics DSP config. That should confirm that hardware is ok and my on-board uC software is ok as I the way this software interact with TAS3251.

The finding is that the .h files generated by PPC3 V.3.1.5 doesn’t produce any sound, and this is very likely due to the fact that most of the registers (DSP ones) are set to 0 rather than their default value. The same file generated by PPC V.3.1.1 produce sound and contain default value on most of relevant registers.

You’ll find attached the two files and a screenshot of a file compare which highlight the fact that V3.1.5 generate file with master volume to zero rather than 0x00800000, and this is only one of the many examples.

Parameters used to produce the file

Input : AIB @48k - Process Flow : Standard Processing 2.0 48k - then everything default : all modules Off except input mixer, Output crossbar, Volume 0dB gang and DAC Gain 0dB, 2V.
File creation menu : type :.h, Dump Mode : current state, Burst : 1


Could you please help me solve this issues; TAS3251 is a great product



  • Hi Chris,

    I just had a quick check on my bench. My PPC3 ver is v3.1.5, TAS3251 block ver is 3.0.1. Could you also check your TAS3251 block ver?

    I didn't encounter the problem in your description with ver 3.1.5

    Attached the .ppc3 file and header file. Could you give a try on this?




  • Hi Sam,

    My TAS3251 block ver is 3.0.1.

    Your is loaded without a hitch by my software and allows the TAS to produce sounds. It's ok, no suprise as it contains default values, not zeroes.

    Your ppc3 can also be loaded into ppc3 but generate a file with zero rather than default value.

    Please note that as I'm not using an EVM, I have to choose AIB connector in Audio I/O screen otherwise, for any other input (through the SRC4392), PPC3 will hang in the 'Check your speaker connection' screen at the 'Writing coefficient' Step, see picture.

    While using AIB connector, PPC3 go very fast trough the 'check your speaker connection' screen and produce no error, maybe it also doesn't' produce the coeffcients wich are missing in my .h files.

    It's looks like, but this is only an assumption, that PPC3 try to acess the EVM then hang. My PC has a fresh install W10, very few software installed.  There's,  however, one point noticeable : I've a Focusrite external sound card, which USB interface is an XMOS, same as EVM... Could PPC3 be fooled with Focusrite XMOS driver and try to communicate with EVM ? On status bar, bottom left of windows, TAS3251 appears Offline.



  • Hi Chris,

    For normal operation, the TAS3251 EVM should not show "TAS3251 - offline". This means the GUI is not really connected to the EVM, so all the commands you send by the GUI is not executed.

    To operate the device by GUI, you need something (like the XMOS, or TAS1020B with proper firmware) to translate the USB communications to I2C commands to device. Have you got a TAS3251EVM, or PPC3 motherboard for that?



  • Hello Sam,

    I have no EVM.

    I do not try to send command by the GUI and I know that an EVM is required to operate the device by GUI. I also do not expect PPC3 to show me TAS3251 Online.

    I only need PPC to produce the right files for me, which is currently not the case as shown in my first post.

    Thanks again,


  • Hi Chris,

    Thanks for the explanation.

    Although I can't duplicate your issue with the same PPC3 ver 3.1.5 + TAS3251 ver 3.0.1 and Win 10 OS, probably there is some unknown issue on the PPC3 on your PC. 

    I will transmit the information to software team who developed the GUI. 

    Could you use the good version on your PC to move forward on the development? 




  • Hi Sam,

    Things are getting worse :

    I've tried to uninstall / reinstall PPC3 and got the following issues :

    During installation :

    I answered Ignore than instllation terminated correctly.

    I then launched PPC3 which ask to upgrade platform, but without succes :

    Now I can't load TAS3251 plugin.

    Could you provide me some assistance?

    thanks and regards


  • I tried to download a fresh install file from TI web site and now PPC3 install correctly, but the TAS3251 app doesn't appear. This issue is the same as the one described n this case :

     Purepath console 3 isnt listed any EVM apps

    If I apply solution described in the case, I have a dedicated PPC3 installed with the TAS3251 APP. But this App has the same issue than my original : hang during write coefficient and produce .h file unusable.

    So, situation remains unchanged.




  • Hi Chris,

    Recently we met the issue that PPC3 platform shows no device apps. It's not an issue comes from your PC.

    Our software team is working on solving this problem. It should be fixed soon.

    BTW, the MCR is necessary for PPC3 running. Please follow below instructions and install MCR on your PC. Thanks!0243.MCR Verification.docx



  • Hi Sam,

    I have installed yesterday the fixed version and everything works fine !.

    thanks a lot