This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TLV320AIC3254EVM-K: TLV320AIC3254EVM-K - Control Software (v1.2.1) (Rev. D) – SLAC214D.ZIP Does not work with Windows 7 or 10

Part Number: TLV320AIC3254EVM-K


I have two TLV320AIC3254EVM-K evm's with the same results.  I have to use a Windows XP PC to load the evm firmware below: 

 Audio Converter Firmware (TAS1020B) V0304 (Rev. B) – SLAC563B.ZIP (684KB)

I can not load the evm firmware on a Windows 7 or 10 PC.

Once I have the the 3.04 Firmware loaded (using a Windows XP PC) I can connect the evm to a Windows 7 or 10 PC and run Control Software (v1.2.1) (Rev. D) and get the same result. See Below:

I'm assuming there is no communication to the I2C (AIC3254).  If I run the Control Software on a Windows XP PC it works correctly.  I get the same results with Evm Firmware 2.03.

The evm will work with Pure Path Studio v5.95 on Windows 7, I can connect and Download Code to the device on the evm.  The only issue is  Control Software (v1.2.1) (Rev. D).

What is my problem?  I need to be able to use the TLV320AIC3254EVM-K with newer OS's preferably Windows 10.  My company frowns on the use of Windows XP and they are getting scarce.


Brian Weir

  • Hello Brian,

    Sorry to hear you are facing issues. Is the USB-MODEVM being enumerated? Can you check the Sounds tab in the device manager?

    I would also recommend running the .exe as an administrator if you have not already. It seems as though you attached an image but I unfortunately cannot see it. Can you re-attach it using the Insert/Edit Media button?



  • Aaron,
    Thank you for your post.  It is a mute point that you could not see my attachment as your suggestion of running AIC3254_CS.exe as Administrator worked and I can run the Control Software on both my Windows 7 & 10 PC's.
    However, I still cannot load the EVM firmware on a Windows 7 or 10 PC.  It will load correctly on a Windows XP PC.  I tried loading the firmware on a Windows XP VM running on a Windows 7 PC.  It will load the DFU Driver (DFUEE.bin) and makes it through: A “Device was successfully reset” message will appear, and the USB device is enumerated.  But, it never makes it to:  A “Device Detach call succeeded” message will appear.  So, I cannot load the firmware image file (USB-AudioEVM0304_8KHZ.BIN).
    Is there another way to load the firmware image files using Windows 7 and/or 10? 
  • Hello Brian,

    I have attached a USB-MODEVM recovery document that provides steps on how to reprogram the USB-MODEVM. This is a more manual process than what is included in the GUI but it should work nonetheless. Please make sure the steps are followed exactly as shown in the document.