This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TLV320AIC3007: sound is not coming

Prodigy 135 points

Replies: 1

Views: 32

Part Number: TLV320AIC3007

Hi,

When i am playing audio with aplay command  blank screen is coming its not terminating it self until given ctrl+c.Please have a look on dump data of codec and log.

Please have a look on below log.

We got below dump data is  before aplay command in carrier board

root@rugged-board-a5d2x-sd1:~# i2cdump -f -y 0 0x18
      0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f 0123456789abcdef
00: 00 00 00 10 04 00 00 00 00 00 00 01 00 00 00 80 ...??......?...?
10: 80 ff ff 78 78 78 78 78 78 02 00 fe 00 00 fe 00 ?..xxxxxx?.?..?.
20: 00 00 00 00 20 00 00 00 00 00 00 80 80 00 00 00    .... ......??...
30: 00 00 00 04 00 00 00 00 00 00 04 00 00 00 00 00 ...?......?.....
40: 00 04 00 00 00 00 00 00 04 00 00 00 00 00 00 00 .?......?.......
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
60: 00 02 00 00 00 00 02 00 00 00 00 00 00 00 00 00 .?....?.........
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
80: 00 00 00 10 04 00 00 00 00 00 00 01 00 00 00 80 ...??......?...?
90: 80 ff ff 78 78 78 78 78 78 02 00 fe 00 00 fe 00 ?..xxxxxx?.?..?.
a0: 00 00 00 00 20 00 00 00 00 00 00 80 80 00 00 00    .... ......??...
b0: 00 00 00 04 00 00 00 00 00 00 04 00 00 00 00 00 ...?......?.....
c0: 00 04 00 00 00 00 00 00 04 00 00 00 00 00 00 00 .?......?.......
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
e0: 00 02 00 00 00 00 02 00 00 00 00 00 00 00 00 00 .?....?.........
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

Below data is after aplay command:

root@rugged-board-a5d2x-sd1:~# i2cdump -f -y 0 0x18
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f    0123456789abcdef
00: 00 00 aa 91 dc 00 00 0a c0 00 00 00 00 00 00 20    ..???..??......
10: 20 ff ff 00 78 78 00 78 78 02 00 fe 00 00 fe 00     ...xx.xx?.?..?.
20: 00 00 00 00 20 c0 00 00 40 00 00 af af 2f 2f af    .... ?..@..??//?
30: 00 00 00 0f 2f 2f af 00 00 00 0f 00 00 00 2f 2f    ...?//?...?...//
40: af 0f 00 00 00 2f 2f af 0f 04 00 00 00 00 00 00    ??...//???......
50: 2f 2f af 00 00 00 0b 00 00 00 2f 2f af 0b de 0c    //?...?...//????
60: 00 02 00 00 00 00 02 00 00 00 00 00 00 00 00 00    .?....?.........
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................
80: 00 00 aa 91 dc 00 00 0a c0 00 00 00 00 00 00 20    ..???..??......
90: 20 ff ff 00 78 78 00 78 78 02 00 fe 00 00 fe 00     ...xx.xx?.?..?.
a0: 00 00 00 00 20 c0 00 00 40 00 00 af af 2f 2f af    .... ?..@..??//?
b0: 00 00 00 0f 2f 2f af 00 00 00 0f 00 00 00 2f 2f    ...?//?...?...//
c0: af 0f 00 00 00 2f 2f af 0f 04 00 00 00 00 00 00    ??...//???......
d0: 2f 2f af 00 00 00 0b 00 00 00 2f 2f af 0b de 0c    //?...?...//????
e0: 00 02 00 00 00 00 02 00 00 00 00 00 00 00 00 00    .?....?.........
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................

 


root@rugged-board-a5d2x-sd1:/mnt# aplay -r 44100 CHIKKAHOSAHALLI.MP3
Playing raw data 'CHIKKAHOSAHALLI.MP3' : Unsigned 8 bit, Rate 44100 Hz, Mono

 



^CAborted by signal Interrupt...
aplay: pcm_write:2051: write error: Interrupted system call
root@rugged-board-a5d2x-sd1:/mnt# aplay -r 44100 CHIKKAHOSAHALLI.MP3 -v
Playing raw data 'CHIKKAHOSAHALLI.MP3' : Unsigned 8 bit, Rate 44100 Hz, Mono
Plug PCM: Route conversion PCM (sformat=S16_LE)
   Transformation table:
     0 <- 0
     1 <- 0
Its setup is:
   stream       : PLAYBACK
   access       : RW_INTERLEAVED
   format       : U8
   subformat    : STD
   channels     : 1
   rate         : 44100
   exact rate   : 44100 (44100/1)
   msbits       : 8
   buffer_size  : 22052
   period_size  : 5513
   period_time  : 125011
   tstamp_mode  : NONE
   tstamp_type  : MONOTONIC
   period_step  : 1
   avail_min    : 5513
   period_event : 0
   start_threshold  : 22052
   stop_threshold   : 22052
   silence_threshold: 0
   silence_size : 0
   boundary     : 1445199872
Slave: Hardware PCM card 0 'Simple Audio' device 0 subdevice 0
Its setup is:
   stream       : PLAYBACK
   access       : MMAP_INTERLEAVED
   format       : S16_LE
   subformat    : STD
   channels     : 2
   rate         : 44100
   exact rate   : 44100 (44100/1) +-----------------------------+
   msbits       : 16 |                             |
   buffer_size  : 22052                                      | Cannot
open /dev/ttyUSB0!  |
   period_size  : 5513 |                             |
   period_time  : 125011 +-----------------------------+
   tstamp_mode  : NONE
   tstamp_type  : MONOTONIC
   period_step  : 1
   avail_min    : 5513
   period_event : 0
   start_threshold  : 22052
   stop_threshold   : 22052
   silence_threshold: 0
   silence_size : 0
   boundary     : 1445199872
   appl_ptr     : 0
   hw_ptr       : 0

  • Hello,

    This seems to be related to a previous post that we are currently working. Is this the case? If so, I will close this thread and continue working on the other. 

    Regards,

    Aaron

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.